• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL] LineageOS 14.1 for SM-T113NU

Search This thread

pstglia

Member
Apr 21, 2019
37
45
This is a custom ROM build to run on Samsung Galaxy Tab E (SM-T113NU).

This work was based on Remilia Scarlet/Nguyễn Diệp Quỳnh code for SM-G360H phone (which uses Spredtrum sc8830, just like this tablet)

Working
Wi-FI
Bluetooth (file transfer tested only)
Sound
Rotation

Not working:
Camera
Offline charging

Prerequisites:


  • Galaxy Tab E SM-T113NU (reported by some users that works on T116 models, but this is not guaranteed)


Download links and source:
Please check my github (pstglia, repository local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO)
  • Download link for compiled ROM can be found on README file.
  • All repositories are mapped on local manifest (core33g.xml )
  • branch used for all repositories is "T113NU_COM_A_MAO_NO_BOLSO"

Latest Image build:
https://drive.google.com/file/d/1xEq9lttRw752KqIwXnk5ccUFmLJe4BSJ/view

Source links:

# Local manifest
https://github.com/pstglia/local_manifests/tree/T113NU_COM_A_MAO_NO_BOLSO

# Framework-native
https://github.com/pstglia/frameworks-native/tree/T113NU_COM_A_MAO_NO_BOLSO

# Kernel
https://github.com/pstglia/linux/tree/T113NU_COM_A_MAO_NO_BOLSO

# device/vendor
https://github.com/pstglia/android_device_samsung_scx35-common/tree/T113NU_COM_A_MAO_NO_BOLSO
https://github.com/pstglia/android_vendor_samsung_scx30g-common/tree/T113NU_COM_A_MAO_NO_BOLSO
https://github.com/pstglia/android_device_samsung_scx30g-common/tree/T113NU_COM_A_MAO_NO_BOLSO
https://github.com/pstglia/android_vendor_samsung_core33g/tree/T113NU_COM_A_MAO_NO_BOLSO
https://github.com/pstglia/android_device_samsung_core33g/tree/T113NU_COM_A_MAO_NO_BOLSO

# frameworks/base (the commit that hacks camera count return to 0 is here)
https://github.com/pstglia/platform_frameworks_base/tree/T113NU_COM_A_MAO_NO_BOLSO

Credits:
The LineageOS Team
Remilia Scarlet/Nguyễn Diệp Quỳnh for SM-G360H work
Fabio Júnior Chaves da Silva (lend his device, even knowing it might become a paperweight)
(My first post on xda, so used one of your posts as reference :D )
Anyone i forgot to mention

Note 1:
This version of TWRP does not populate ro.build.product, blocking a generated package to be installed
So, if you compile from source "brunch core33g", you can apply the following workaround for you generated installation package:

  1. Unpack generated package into a blank directory
    Code:
    mkdir /tmp/lineage-pkg
    cd /tmp/lineage-pkg
    last_gen_pkg=$(ls -tr ${OUT}/lineage-14.1-????????-UNOFFICIAL-core33g.zip | tail -1)
    jar xvf ${last_gen_pkg}
  2. Edit META-INF/com/google/android/updater-script and replace this:
    Code:
    getprop("ro.build.product") == "core33gdx"
    by this:
    Code:
    getprop("ro.build.product") != "core33gdx"
  3. Create a new "patched" package
    Code:
    cd /tmp/lineage-pkg
    jar cvf lineage-14.1-patched-UNOFFICIAL-core33g.zip *

Note 2:

If you face a bootloop, you can try formatting your efs partition as described bellow (AT YOUR OWN RISK!)
https://forum.xda-developers.com/showpost.php?p=79995765&postcount=42

Version Information:
ROM OS Version: Android 7.1.2 Nougat
Kernel Version: Linux 3.10.17
 

Attachments

  • IMG_20190420_103645974.jpg
    IMG_20190420_103645974.jpg
    51.7 KB · Views: 6,935
  • IMG_20190420_103617514_home.jpg
    IMG_20190420_103617514_home.jpg
    43 KB · Views: 6,943
Last edited by a moderator:

MrLinDowsMac

New member
May 21, 2019
2
1
What do you need to get a working camera? I have an actual Samsung SM-T113NU

This is a custom ROM build to run on Samsung Galaxy Tab E (SM-T113NU).

This work was based on Remilia Scarlet/Nguyễn Diệp Quỳnh code for SM-G360H phone (which uses Spredtrum sc8830, just like this tablet)

Working
Wi-FI
Bluetooth (file transfer tested only)
Sound
Rotation

Not working:
Camera

Prerequisites:

  • TWRP version 3.0.2

  • Galaxy Tab E SM-T113NU (similar models were not tested)


Download links and source:
Please check my github (pstglia, repository local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO)
  • Download link for compiled ROM can be found on README file.
  • All repositories are mapped on local manifest (core33g.xml )
  • branch used for all repositories is "T113NU_COM_A_MAO_NO_BOLSO"


Will update this thread with links when my user reaches the required points (new on xda)


Credits:
The LineageOS Team
Remilia Scarlet/Nguyễn Diệp Quỳnh for SM-G360H work
Fabio Júnior Chaves da Silva (lend his device, even knowing it might become a paperweight)
stephenpump (My first post on xda, so used one of your posts as reference :D )
Anyone i forgot to mention

Note:
This version of TWRP does not populate ro.build.product, blocking a generated package to be installed
So, if you compile from source "brunch core33g", you can apply the following workaround for you generated installation package:

  1. Unpack generated package into a blank directory
    Code:
    mkdir /tmp/lineage-pkg
    cd /tmp/lineage-pkg
    last_gen_pkg=$(ls -tr ${OUT}/lineage-14.1-????????-UNOFFICIAL-core33g.zip | tail -1)
    jar xvf ${last_gen_pkg}
  2. Edit META-INF/com/google/android/updater-script and replace this:
    Code:
    getprop("ro.build.product") == "core33gdx"
    by this:
    Code:
    getprop("ro.build.product") != "core33gdx"
  3. Create a new "patched" package
    Code:
    cd /tmp/lineage-pkg
    jar cvf lineage-14.1-patched-UNOFFICIAL-core33g.zip *

Version Information:
ROM OS Version: Android 7.1.2 Nougat
Kernel Version: Linux 3.10.17

bWuzKtH5ixmCwokf8

Z2Vyx3baWrcY7e2K7
 
  • Haha
Reactions: TheMadScientist

pstglia

Member
Apr 21, 2019
37
45
What do you need to get a working camera? I have an actual Samsung SM-T113NU

Hi,

1) I'd need spare time to find a way to make it work.

2) more knowledge would be needed. To build this image, I had basically to adapt Samsung kernel to met 7.1 requirements (I basically cherry-picked commits from remilia15 - SM-G360H) and some other minor changes.
Camera probably requires advanced coding, which is a bit far from my current skills. Enabling it causes crashes during components startup (see bellow):


Code:
04-19 22:37:01.036   227   769 I SprdCameraHardware: getPropertyAtv:0
04-19 22:37:01.036   227   769 I SprdCameraHardware: getNumberOfCameras:2
04-19 22:37:01.036   227   769 I CameraService: disconnect: Disconnected client for camera 0 for PID 227
04-19 22:37:01.036   227   769 E CameraService: initializeShimMetadata: Error initializing shim metadata: Status(-8): '3: connectHelper:928: Illegal argument to HAL module for camera "0"'
04-19 22:37:01.038   585   585 E System  : ******************************************
04-19 22:37:01.038   227   909 E isp-video: ISP_RAW: id:0x00, 00927 line, ispserver_thread : ISP_TOOL:isp-video server version 1.0
04-19 22:37:01.039   227   909 E isp-video: ISP_RAW: id:0x00, 00965 line, ispserver_thread : ISP_TOOL:log server waiting client dail in...
04-19 22:37:01.040   585   585 E System  : ************ Failure starting system services
04-19 22:37:01.040   585   585 E System  : java.lang.RuntimeException: Failed to boot service com.android.server.retaildemo.RetailDemoModeService: onBootPhase threw an exception during phase 600
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServiceManager.startBootPhase(SystemServiceManager.java:145)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServer$2.run(SystemServer.java:1538)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.am.ActivityManagerService.systemReady(ActivityManagerService.java:13591)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServer.startOtherServices(SystemServer.java:1466)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServer.run(SystemServer.java:368)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServer.main(SystemServer.java:237)
04-19 22:37:01.040   585   585 E System  :      at java.lang.reflect.Method.invoke(Native Method)
04-19 22:37:01.040   585   585 E System  :      at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:889)
04-19 22:37:01.040   585   585 E System  :      at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:779)
04-19 22:37:01.040   585   585 E System  : Caused by: java.lang.IllegalArgumentException: connectHelper:928: Illegal argument to HAL module for camera "0"
04-19 22:37:01.040   585   585 E System  :      at android.hardware.camera2.CameraManager.throwAsPublicException(CameraManager.java:694)
04-19 22:37:01.040   585   585 E System  :      at android.hardware.camera2.CameraManager.getOrCreateDeviceIdListLocked(CameraManager.java:778)
04-19 22:37:01.040   585   585 E System  :      at android.hardware.camera2.CameraManager.getCameraIdList(CameraManager.java:140)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.retaildemo.RetailDemoModeService.getCameraIdsWithFlash(RetailDemoModeService.java:492)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.retaildemo.RetailDemoModeService.onBootPhase(RetailDemoModeService.java:569)
04-19 22:37:01.040   585   585 E System  :      at com.android.server.SystemServiceManager.startBootPhase(SystemServiceManager.java:143)
04-19 22:37:01.040   585   585 E System  :      ... 8 more
04-19 22:37:01.040   585   585 E System  : Caused by: android.os.ServiceSpecificException: connectHelper:928: Illegal argument to HAL module for camera "0"
04-19 22:37:01.040   585   585 E System  :      at android.os.Parcel.readException(Parcel.java:1706)
04-19 22:37:01.040   585   585 E System  :      at android.os.Parcel.readException(Parcel.java:1645)
04-19 22:37:01.040   585   585 E System  :      at android.hardware.ICameraService$Stub$Proxy.getCameraCharacteristics(ICameraService.java:404)
04-19 22:37:01.040   585   585 E System  :      at android.hardware.camera2.CameraManager.getOrCreateDeviceIdListLocked(CameraManager.java:765)

Maybe sources under hardware/sprd/libcamera should be changed in order to make it work...

3) A device to test. The one I was using was borrowed from a friend, but already returned.

In any case, all source code I changed is available on github (check for pstglia on github - repository "local_manifests" maps all the changes (except platform_frameworks_base, which requires the last 2 commits from branch "T113NU_COM_A_MAO_NO_BOLSO".
 
  • Like
Reactions: Kvothe1810

Renanfpan

New member
Jan 10, 2017
1
1
Muito obrigado pela ROM

Falei com vc lá pelo YouTube e agradeço novamente pela rom. O tablet ficou novo em folha. Continue com seu ótimo trabalho ?
 
  • Like
Reactions: pstglia

YggH

New member
Mar 18, 2019
3
0
Heyyy, how you've made this custom rom?

I'm trying to build that for my sm-t280, and all instructions doesn't ever exist. if you gimme instructions to build, you'll doing a huge help. :)

email: [email protected]

This is a custom ROM build to run on Samsung Galaxy Tab E (SM-T113NU).

This work was based on Remilia Scarlet/Nguyễn Diệp Quỳnh code for SM-G360H phone (which uses Spredtrum sc8830, just like this tablet)

Working
Wi-FI
Bluetooth (file transfer tested only)
Sound
Rotation

Not working:
Camera

Prerequisites:

  • TWRP version 3.0.2

  • Galaxy Tab E SM-T113NU (similar models were not tested)


Download links and source:
Please check my github (pstglia, repository local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO)
  • Download link for compiled ROM can be found on README file.
  • All repositories are mapped on local manifest (core33g.xml )
  • branch used for all repositories is "T113NU_COM_A_MAO_NO_BOLSO"


Will update this thread with links when my user reaches the required points (new on xda)


Credits:
The LineageOS Team
Remilia Scarlet/Nguyễn Diệp Quỳnh for SM-G360H work
Fabio Júnior Chaves da Silva (lend his device, even knowing it might become a paperweight)
stephenpump (My first post on xda, so used one of your posts as reference :D )
Anyone i forgot to mention

Note:
This version of TWRP does not populate ro.build.product, blocking a generated package to be installed
So, if you compile from source "brunch core33g", you can apply the following workaround for you generated installation package:

  1. Unpack generated package into a blank directory
    Code:
    mkdir /tmp/lineage-pkg
    cd /tmp/lineage-pkg
    last_gen_pkg=$(ls -tr ${OUT}/lineage-14.1-????????-UNOFFICIAL-core33g.zip | tail -1)
    jar xvf ${last_gen_pkg}
  2. Edit META-INF/com/google/android/updater-script and replace this:
    Code:
    getprop("ro.build.product") == "core33gdx"
    by this:
    Code:
    getprop("ro.build.product") != "core33gdx"
  3. Create a new "patched" package
    Code:
    cd /tmp/lineage-pkg
    jar cvf lineage-14.1-patched-UNOFFICIAL-core33g.zip *

Version Information:
ROM OS Version: Android 7.1.2 Nougat
Kernel Version: Linux 3.10.17

bWuzKtH5ixmCwokf8

Z2Vyx3baWrcY7e2K7
 

pstglia

Member
Apr 21, 2019
37
45
I'm trying to build that for my sm-t280, and all instructions doesn't ever exist. if you gimme instructions to build, you'll doing a huge help. :)

email: [email protected]

Hi,

Tried to write a simplified procedure to compile the custom ROM for T113NU. See the 8 steps bellow:

I) Assuming you already have a build environment set up (see [1] as reference), download lineage sources using repo commands (repo init, repo sync)
Note: Use branch cm-14.1 (nougat)

II) After syncing, download core33g.xml from my github ( repo local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO) and copy to .repo/local_manifests (create it if doesn't exists)

III) execute "repo sync" again. The files/sources I modified will be downloaded and updated on source tree

IV) Edit vendor/cm/vendorsetup.sh and add this lunch combo:

Code:
add_lunch_combo lineage_core33g-userdebug

This will allow you to select a target compatible with T113NU when running "brunch"

V) As pointed previous posts, camera was avoiding Android to start. To allow booting, cameras were disabled (forced returned number of cameras to 0).
So, for T113NU, commit "0acc7879a9794aacdff85ef1563807d051114917 - frameworks/base - HACK - Disable cameras" will be needed. This commit is on my github, repository platform_frameworks_base, branch T113NU_COM_A_MAO_NO_BOLSO)

VI) Before compiling, export these environment variables:

Code:
export USE_CCACHE=1
ccache -M 50G
export ANDROID_JACK_VM_ARGS="-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx4G"
export JACK_SERVER_VM_ARGUMENTS="-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx4G"
export LC_ALL=C

I suggest you to include these on a file in your home dir (ex: ~/.android_profile) and include it every time you want to create a new build:

Code:
source ~/.android_profile

VII) Include build/envsetup.sh to config Android environment

Code:
source build/envsetup.sh

VIII) Compile the ISO using brunch (select lineage_core33g-userdebug option)



This should do it.
For your device (T280) you'll probably want to replace kernel by the one provided by samsung opensource.
Download it from Samsung Opensource Release Center (see [2]) and unpack it to kernel/samsung/core33g (clean previous files first)
Also:
A) After unpacking, cd to kernel/samsung/core33g and execute a "make mrproper" to remove any temp files under the source tree;
B) cd to kernel/samsung/core33g/arch/arm/configs and rename/copy one of the config files there to "cyanogen_core33g_defconfig" (select one that matches your device - in my case was goyavewifi-dt_hw04_defconfig)
C) You'll probably will need commits to make your kernel compatible with Android 7.1. Try cherry-picking the commits I used, starting from 8c97f3624701f53843b7b2da40185cdcd1c7a422


Play around with config/fw files and have lots of pacience. Creating a working image is not always a funny (consumes lots of time and requires much pacience, logging/debugging )


Good luck!

[1] - https wiki DOT lineageos DOT org/devices /bacon/buildcon/build
[2] - opensource DOT samsung DOT com

ps: Does your device uses Spreadtrum SOC, right?
ps2: Except for kernel, most of changes were minor. Most of this commits were based on remilia15 work. Kudos for who really deserve it!
 
Last edited:

Shreyas.ĒXĒ

Member
Jul 21, 2019
25
4
This is a custom ROM build to run on Samsung Galaxy Tab E (SM-T113NU).

This work was based on Remilia Scarlet/Nguyễn Diệp Quỳnh code for SM-G360H phone (which uses Spredtrum sc8830, just like this tablet)

Working
Wi-FI
Bluetooth (file transfer tested only)
Sound
Rotation

Not working:
Camera

Prerequisites:

  • TWRP version 3.0.2

  • Galaxy Tab E SM-T113NU (similar models were not tested)


Download links and source:
Please check my github (pstglia, repository local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO)
  • Download link for compiled ROM can be found on README file.
  • All repositories are mapped on local manifest (core33g.xml )
  • branch used for all repositories is "T113NU_COM_A_MAO_NO_BOLSO"


Will update this thread with links when my user reaches the required points (new on xda)


Credits:
The LineageOS Team
Remilia Scarlet/Nguyễn Diệp Quỳnh for SM-G360H work
Fabio Júnior Chaves da Silva (lend his device, even knowing it might become a paperweight)
stephenpump (My first post on xda, so used one of your posts as reference :D )
Anyone i forgot to mention

Note:
This version of TWRP does not populate ro.build.product, blocking a generated package to be installed
So, if you compile from source "brunch core33g", you can apply the following workaround for you generated installation package:

  1. Unpack generated package into a blank directory
    Code:
    mkdir /tmp/lineage-pkg
    cd /tmp/lineage-pkg
    last_gen_pkg=$(ls -tr ${OUT}/lineage-14.1-????????-UNOFFICIAL-core33g.zip | tail -1)
    jar xvf ${last_gen_pkg}
  2. Edit META-INF/com/google/android/updater-script and replace this:
    Code:
    getprop("ro.build.product") == "core33gdx"
    by this:
    Code:
    getprop("ro.build.product") != "core33gdx"
  3. Create a new "patched" package
    Code:
    cd /tmp/lineage-pkg
    jar cvf lineage-14.1-patched-UNOFFICIAL-core33g.zip *

Version Information:
ROM OS Version: Android 7.1.2 Nougat
Kernel Version: Linux 3.10.17

bWuzKtH5ixmCwokf8

Z2Vyx3baWrcY7e2K7

Bro I installed twrp 3.0.2 and Wiped Data, Chache,Dalvik and system..And I flashed the ROM.. It showed "Unknown Command [log]" BUT FLASHING WAS SUCCESSFUL..So I Botted the tab and now it's showing the Lineage OS boot animation from 15 mins..Ik it takes a hell lot of time for the first boot but 15 mins?!??
I'll update if something happens..
 

pstglia

Member
Apr 21, 2019
37
45
Bro I installed twrp 3.0.2 and Wiped Data, Chache,Dalvik and system..And I flashed the ROM.. It showed "Unknown Command [log]" BUT FLASHING WAS SUCCESSFUL..So I Botted the tab and now it's showing the Lineage OS boot animation from 15 mins..Ik it takes a hell lot of time for the first boot but 15 mins?!
I'll update if something happens..

Hi

5 minutes is the maximum time. 15 minutes can be threated as a bootloop.
Some users reported this on youtube (for T113NU models).

Try pluging USB and check if you have adb connection. If so, check logcat/dmesg
 
  • Like
Reactions: Shreyas.ĒXĒ

pstglia

Member
Apr 21, 2019
37
45
Going to fix camera gimme sources

---------- Post added at 10:04 AM ---------- Previous post was at 09:58 AM ----------

Also pm me on Telegram @sasi2006166

Hi, this manifest has all the repositories changed (except framework-native, which also can be pushed from my github, branch T113NU_COM_A_MAO_NO_BOLSO)

# Local manifest
https://github.com/pstglia/local_manifests/tree/T113NU_COM_A_MAO_NO_BOLSO

# Framework-Native
https://github.com/pstglia/frameworks-native/tree/T113NU_COM_A_MAO_NO_BOLSO
 
Last edited:

Shreyas.ĒXĒ

Member
Jul 21, 2019
25
4
Hi

5 minutes is the maximum time. 15 minutes can be threated as a bootloop.
Some users reported this on youtube (for T113NU models).

Try pluging USB and check if you have adb connection. If so, check logcat/dmesg
I took a Logcat file.But I am not able to attach it to this post it's showing"Bad Request"I think you are right my Tab is Bootlooped..Any solutions??☺️

Edit: I have uploaded a Google drive link for the logcat.log file..pls see it..

https://drive.google.com/file/d/15491N45mEhIb-MZU72ef83VESCEK_WGi/view?usp=drivesdk
 
Last edited:

Kvothe1810

Member
Sep 13, 2018
10
3
Thanks for the rom! I am using this ROM whit gapps pico and works everything so good! !!


Enviado desde mi Nexus 5X mediante Tapatalk
 
Hey man, I think something is wrong, T116NY and T116BU are identical. Here's what I've done:
- Made a Nandroid backup
- Downloaded Opengapps 7.1 ARM Pico
- Downloaded the ROM
- Downloaded TWRP 3.0.2 from dl.twrp.me/goyave
- Wiped System, Data, Cache and Dalvik
- Flashed the ROM, OpenGApps, then TWRP, in this order.
You should try it this way.

---------- Post added at 08:51 PM ---------- Previous post was at 08:47 PM ----------


If it still doesn't work, check if your using the correct version of TWRP (3.0.2) Download it at the link I gave you.

---------- Post added at 08:57 PM ---------- Previous post was at 08:51 PM ----------

PS: I wasn't able to reply the private message :p

---------- Post added at 09:38 PM ---------- Previous post was at 08:57 PM ----------

When I flashed the ROM, I noticed that it was running on a lower resolution than the normal (480p instead of 720p). If anyone else have this issue, just go to build.prop and change lcd_density to stock value (In my case is 160). Hope this helps!
 
  • Like
Reactions: Kvothe1810

pstglia

Member
Apr 21, 2019
37
45
I took a Logcat file.But I am not able to attach it to this post it's showing"Bad Request"I think you are right my Tab is Bootlooped..Any solutions?

Edit: I have uploaded a Google drive link for the logcat.log file..pls see it..

https://drive.google.com/file/d/15491N45mEhIb-MZU72ef83VESCEK_WGi/view?usp=drivesdk

Hi,

Unfortunatelly couldn't get any clue by logcat output. Can you post dmesg as well?
@All
Anyone with experience in LineageOS ROMS could give a clue?
Some user with identical device models I had in hand (T113NU) reported the same issue. In these cases, logcat stops logging at the beginning and I couldn't figure out any related message on dmesg?
I'm discarding hw failure because stock ROM works in these cases (based on reports from users)

Regards
pstglia
 

Shreyas.ĒXĒ

Member
Jul 21, 2019
25
4
Hi,

Unfortunatelly couldn't get any clue by logcat output. Can you post dmesg as well?

@All
Anyone with experience in LineageOS ROMS could give a clue?
Some user with identical device models I had in hand (T113NU) reported the same issue. In these cases, logcat stops logging at the beginning and I couldn't figure out any related message on dmesg?
I'm discarding hw failure because stock ROM works in these cases (based on reports from users)

Regards
pstglia
Sorry lol..I forgot to add dmesg..
I have given the LATEST logcat and Dmesg file in the link below..pls see it..:D

https://drive.google.com/folderview?id=1-8xJgzLeSE8TJxv5gh_ZXTLyXbB-0IcK

---------- Post added at 05:24 AM ---------- Previous post was at 05:21 AM ----------

Hey man, I think something is wrong, T116NY and T116BU are identical. Here's what I've done:
- Made a Nandroid backup
- Downloaded Opengapps 7.1 ARM Pico
- Downloaded the ROM
- Downloaded TWRP 3.0.2 from dl.twrp.me/goyave
- Wiped System, Data, Cache and Dalvik
- Flashed the ROM, OpenGApps, then TWRP, in this order.
You should try it this way.

---------- Post added at 08:51 PM ---------- Previous post was at 08:47 PM ----------



If it still doesn't work, check if your using the correct version of TWRP (3.0.2) Download it at the link I gave you.

---------- Post added at 08:57 PM ---------- Previous post was at 08:51 PM ----------

PS: I wasn't able to reply the private message :p

---------- Post added at 09:38 PM ---------- Previous post was at 08:57 PM ----------

When I flashed the ROM, I noticed that it was running on a lower resolution than the normal (480p instead of 720p). If anyone else have this issue, just go to build.prop and change lcd_density to stock value (In my case is 160). Hope this helps!
Bro I tried your method but still It's Bootlooping(stuck on Lineage OS boot animation)
P.s: I have already installed Twrp version (3.0.2)..:rolleyes:
 
Sorry lol..I forgot to add dmesg..
I have given the LATEST logcat and Dmesg file in the link below..pls see it..:D

https://drive.google.com/folderview?id=1-8xJgzLeSE8TJxv5gh_ZXTLyXbB-0IcK

---------- Post added at 05:24 AM ---------- Previous post was at 05:21 AM ----------


Bro I tried your method but still It's Bootlooping(stuck on Lineage OS boot animation)
P.s: I have already installed Twrp version (3.0.2)..:rolleyes:
Huh, thats weird. T116BU working.
 

Attachments

  • Screenshot_20190725-095213.jpg
    Screenshot_20190725-095213.jpg
    72.3 KB · Views: 655
  • Like
Reactions: Shreyas.ĒXĒ

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    This is a custom ROM build to run on Samsung Galaxy Tab E (SM-T113NU).

    This work was based on Remilia Scarlet/Nguyễn Diệp Quỳnh code for SM-G360H phone (which uses Spredtrum sc8830, just like this tablet)

    Working
    Wi-FI
    Bluetooth (file transfer tested only)
    Sound
    Rotation

    Not working:
    Camera
    Offline charging

    Prerequisites:


    • Galaxy Tab E SM-T113NU (reported by some users that works on T116 models, but this is not guaranteed)


    Download links and source:
    Please check my github (pstglia, repository local_manifests, branch T113NU_COM_A_MAO_NO_BOLSO)
    • Download link for compiled ROM can be found on README file.
    • All repositories are mapped on local manifest (core33g.xml )
    • branch used for all repositories is "T113NU_COM_A_MAO_NO_BOLSO"

    Latest Image build:
    https://drive.google.com/file/d/1xEq9lttRw752KqIwXnk5ccUFmLJe4BSJ/view

    Source links:

    # Local manifest
    https://github.com/pstglia/local_manifests/tree/T113NU_COM_A_MAO_NO_BOLSO

    # Framework-native
    https://github.com/pstglia/frameworks-native/tree/T113NU_COM_A_MAO_NO_BOLSO

    # Kernel
    https://github.com/pstglia/linux/tree/T113NU_COM_A_MAO_NO_BOLSO

    # device/vendor
    https://github.com/pstglia/android_device_samsung_scx35-common/tree/T113NU_COM_A_MAO_NO_BOLSO
    https://github.com/pstglia/android_vendor_samsung_scx30g-common/tree/T113NU_COM_A_MAO_NO_BOLSO
    https://github.com/pstglia/android_device_samsung_scx30g-common/tree/T113NU_COM_A_MAO_NO_BOLSO
    https://github.com/pstglia/android_vendor_samsung_core33g/tree/T113NU_COM_A_MAO_NO_BOLSO
    https://github.com/pstglia/android_device_samsung_core33g/tree/T113NU_COM_A_MAO_NO_BOLSO

    # frameworks/base (the commit that hacks camera count return to 0 is here)
    https://github.com/pstglia/platform_frameworks_base/tree/T113NU_COM_A_MAO_NO_BOLSO

    Credits:
    The LineageOS Team
    Remilia Scarlet/Nguyễn Diệp Quỳnh for SM-G360H work
    Fabio Júnior Chaves da Silva (lend his device, even knowing it might become a paperweight)
    (My first post on xda, so used one of your posts as reference :D )
    Anyone i forgot to mention

    Note 1:
    This version of TWRP does not populate ro.build.product, blocking a generated package to be installed
    So, if you compile from source "brunch core33g", you can apply the following workaround for you generated installation package:

    1. Unpack generated package into a blank directory
      Code:
      mkdir /tmp/lineage-pkg
      cd /tmp/lineage-pkg
      last_gen_pkg=$(ls -tr ${OUT}/lineage-14.1-????????-UNOFFICIAL-core33g.zip | tail -1)
      jar xvf ${last_gen_pkg}
    2. Edit META-INF/com/google/android/updater-script and replace this:
      Code:
      getprop("ro.build.product") == "core33gdx"
      by this:
      Code:
      getprop("ro.build.product") != "core33gdx"
    3. Create a new "patched" package
      Code:
      cd /tmp/lineage-pkg
      jar cvf lineage-14.1-patched-UNOFFICIAL-core33g.zip *

    Note 2:

    If you face a bootloop, you can try formatting your efs partition as described bellow (AT YOUR OWN RISK!)
    https://forum.xda-developers.com/showpost.php?p=79995765&postcount=42

    Version Information:
    ROM OS Version: Android 7.1.2 Nougat
    Kernel Version: Linux 3.10.17
    3
    Those who want transparent navbar ,statusbar,lock screen,etc just got to system/bulid.prop and change ro.config.low_ram=false.
    3
    Succes on sm t116 nu. But sim not detect. Please help me

    This is expected. This image targeted T113NU, which is a wifi-device only.

    In order to enable SIM, you'll need to change a few things and rebuild the image... Some I'm aware of:

    1) On device/samsumg/core33g, commit 4b9bfeea95c1b61ddaa42ec97884290c698311b5, revert this:

    Code:
    -$(call inherit-product, vendor/cm/config/common_full_phone.mk)
    +$(call inherit-product, vendor/cm/config/common_mini_tablet_wifionly.mk)
    
    -PRODUCT_CHARACTERISTICS := phone
    +PRODUCT_CHARACTERISTICS := tablet
    
     # RIL
    -bin/rild
    -bin/modemd
    -bin/nvitemd
    -bin/phoneserver
    -bin/ext_data.sh
    -bin/ext_kill.sh
    -bin/ext_symlink.sh
    -bin/prepare_param.sh
    -lib/libril.so
    -lib/libreference-ril_sp.so
    -lib/libsecril-client.so
    -lib/libsecnativefeature.so
    +#bin/rild
    +#bin/modemd
    +#bin/nvitemd
    +#bin/phoneserver
    +#bin/ext_data.sh
    +#bin/ext_kill.sh
    +#bin/ext_symlink.sh
    +#bin/prepare_param.sh
    +#lib/libril.so
    +#lib/libreference-ril_sp.so
    +#lib/libsecril-client.so
    +#lib/libsecnativefeature.so

    2) On device/samsung/scx30g-common, commit 836dcac836c967c01afd184728035f1396878f12, revert this:

    Code:
    -BOARD_RIL_CLASS += ../../../device/samsung/scx30g-common/ril
    +#BOARD_RIL_CLASS += ../../../device/samsung/scx30g-common/ril
    
    # RIL
    -ro.com.android.dataroaming=false
    -ro.msms.phone_count=2
    -persist.msms.phone_count=2
    -persist.msms.phone_default=0
    -persist.msmslt=0
    -ro.modem.w.count=2
    -persist.sys.modem.diag=,gser
    -sys.usb.gser.count=4
    +#ro.com.android.dataroaming=false
    +#ro.msms.phone_count=2
    +#persist.msms.phone_count=2
    +#persist.msms.phone_default=0
    +#persist.msmslt=0
    +#ro.modem.w.count=2
    +#persist.sys.modem.diag=,gser
    +#sys.usb.gser.count=4
     ro.ril.hsxpa=1
     ro.ril.gprsclass=10
    -ro.telephony.ril_class=SC7730SRIL
    -ro.telephony.ril.config=setPrefNwTypeOnUnsolConnected,sim2gsmonly
    -ro.telephony.ril.socket_name=rild,rild1,rild2
    -ro.ril.telephony.mqanelements=6
    -persist.sys.sprd.modemreset=0
    -persist.sys.sprd.wcnreset=1
    +#ro.telephony.ril_class=SC7730SRIL
    +#ro.telephony.ril.config=setPrefNwTypeOnUnsolConnected,sim2gsmonly
    +#ro.telephony.ril.socket_name=rild,rild1,rild2
    +#ro.ril.telephony.mqanelements=6
    +#persist.sys.sprd.modemreset=0
    +#persist.sys.sprd.wcnreset=1

    3) On device/samsung/scx35-common, commits 196c486aa6d920605b1a4380b7e74e3ef2dc9c60 and aca63492df0dd40d170a44dee834fdaf96f33013, revert this:

    Code:
    -       modem_control.rc \
    -       modemd.rc \
    +       #modem_control.rc \
    +       #modemd.rc \

    Probably kernel config will have to be changed in order to enable some modem/radio support...
    3
    i have published this rom on the galaxy tab 3 lite community
    link : https://forum.xda-developers.com/ga...-lineageos-t4110137/post82747923#post82747923
    its just an update to fix these bugs
    im also working on fixing the camera and sim


    ---------- Post added at 11:41 AM ---------- Previous post was at 11:35 AM ----------

    the bluetooth issue comes from the build prop

    # Bluetooth OPP low speed for save power
    debug.bt.lowspeed=true
    this value needs to be set to false for the bluetooth to work normaly

    ---------- Post added at 11:43 AM ---------- Previous post was at 11:41 AM ----------

    i have published this rom on the galaxy tab 3 lite community
    link : https://forum.xda-developers.com/ga...-lineageos-t4110137/post82747923#post82747923
    its just an update to fix these bugs
    im also working on fixing the camera and sim


    ---------- Post added at 11:41 AM ---------- Previous post was at 11:35 AM ----------

    the bluetooth issue comes from the build prop

    # Bluetooth OPP low speed for save power
    debug.bt.lowspeed=true
    this value needs to be set to false for the bluetooth to work normaly
    this is gonna fix bluetooth sound
    for the camera im still doing my research