• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][UNOFFICIAL]LineageOS-15.1[Albus][Moto Z2 Play][Discontinued]

Search This thread

Anbusm

New member
Aug 28, 2018
1
0
Problem advanced settings stopped

Hi, I have a problem and it is that when I finish installing and starting I get that advanced settings stopped and it does not let me do anything until it restarts again to the twrp someone knows what to do thanks :mad::mad:
 

naasking

Member
Aug 28, 2012
9
0
I've installed the latest ROM 15.1-20190811 from the google drive on my Z2 play XT1710-01, but it appears that it doesn't recognize when a SIM card is inserted. When the stock ROM was on there the SIM card was detected, so I'm certain it's not a hardware issue. Any thoughts on what might be wrong?
 

clydedarren

New member
Jan 8, 2015
1
0
Camera and Root not fully functional

So I installed the ROM...works fine, except I can't use the camera and I don't get apps only option for the Root Access
 
Oct 13, 2017
2
0
Having troubles with this

Hey guys,

I have a Moto Z2 Play XT1710-01. Using the instructions on this thread, as well as the ones here and here I have gotten most of the way through the process for installing Lineage on my device. However, once I reach step 7 of the instructions here I do not have access to my device from my command line in Win10. When I run "adb devices" there are no devices shown. So I am unable to transfer GAPPS and Lineage OS to the SD card. This isn't my first root, but I'm not a pro at this. Please help!

---------- Post added at 10:12 PM ---------- Previous post was at 09:18 PM ----------

Hey guys,

I have a Moto Z2 Play XT1710-01. Using the instructions on this thread, as well as the ones here and here I have gotten most of the way through the process for installing Lineage on my device. However, once I reach step 7 of the instructions here I do not have access to my device from my command line in Win10. When I run "adb devices" there are no devices shown. So I am unable to transfer GAPPS and Lineage OS to the SD card. This isn't my first root, but I'm not a pro at this. Please help!

So, by uninstalling the Win10 driver that it was using and repairing the Moto Device Manager software I was able to push the zip files for lineage and gapps to the phone, but now when I try to install the zip for lineage I get the following error:
"Checking for digest file....
Skipping Digest check: no Digest file found
Update process ended with ERROR: 255
Error installing zip file '/sdcard/lineage.zip'"

I can see from this post that the cause is likely me needing a 64-bit TWRP. Where can I get that please? The thread on the home page for the Z2 Play has a broken link, and I can't seem to find a 64-bit TWRP anywhere else.

---------- Post added at 11:07 PM ---------- Previous post was at 10:12 PM ----------

Hey guys,

I have a Moto Z2 Play XT1710-01. Using the instructions on this thread, as well as the ones here and here I have gotten most of the way through the process for installing Lineage on my device. However, once I reach step 7 of the instructions here I do not have access to my device from my command line in Win10. When I run "adb devices" there are no devices shown. So I am unable to transfer GAPPS and Lineage OS to the SD card. This isn't my first root, but I'm not a pro at this. Please help!

---------- Post added at 10:12 PM ---------- Previous post was at 09:18 PM ----------



So, by uninstalling the Win10 driver that it was using and repairing the Moto Device Manager software I was able to push the zip files for lineage and gapps to the phone, but now when I try to install the zip for lineage I get the following error:
"Checking for digest file....
Skipping Digest check: no Digest file found
Update process ended with ERROR: 255
Error installing zip file '/sdcard/lineage.zip'"

I can see from this post that the cause is likely me needing a 64-bit TWRP. Where can I get that please? The thread on the home page for the Z2 Play has a broken link, and I can't seem to find a 64-bit TWRP anywhere else.

Ok I found a 64-bit version of TWRP that seems to have worked for me. It can be found here. After re-downloading the 8.1 GAPPS and installing that, it looks like I'm good to go, my phone is rebooting now. Fingers crossed!!
 
Last edited:

meelten

Member
Nov 21, 2018
49
11
This ROM has not been updated for quite some. Please also look at this new ROM

https://forum.xda-developers.com/z2-play/how-to/rom-aospextended-v5-8-albus-t3951952

It works great and has tons of features.

Only feature that does not seem to work is the fingerprint nav. Everything else seems to work.

This ROM is updated quite regularly, last version is from August. Only dev is not announcing it here so people might not be even aware (I myself discovered it accidentally). All builds are here: https://drive.google.com/drive/folders/1szOod4UvFf7S2AnQQUo7eLRIcgcxQHrc

I wonder if there is any chance for Lineage 16 for Z2 Play? @HeltonMax
 
  • Like
Reactions: wsemi

HeltonMax

Senior Member
Oct 10, 2012
184
134
Pimenta Bueno
New Build

Hello guys I compiled again, the new build is already in the Google Drive folder and for those who play Pokemon GO it works normally and the Security Patch is October
 

Attachments

  • Screenshot_20191105-034143_SafetyNet_Test.png
    Screenshot_20191105-034143_SafetyNet_Test.png
    125.8 KB · Views: 519
Last edited:

HeltonMax

Senior Member
Oct 10, 2012
184
134
Pimenta Bueno
No Developer currently working on Z2 play

Thanks Helton for new build, good job as always.


Uh, so that means chances for LOS 16 don't look great at the moment?

Actually had to have a developer to redo the device tree from scratch, with the help of @Pranav Kumar who compiled RR 8.1 we tried to tweak it on the DTs that had it available on github but to no avail and have long had no news of it
 

Pranav Kumar

Senior Member
Feb 20, 2016
253
75
22
Secunderabad
Actually had to have a developer to redo the device tree from scratch, with the help of @Pranav Kumar who compiled RR 8.1 we tried to tweak it on the DTs that had it available on github but to no avail and have long had no news of it
I'm sorry to inform you that, I'll be releasing final RR 8.1 with updated security patch and few other tweaks(ezpz) and I can't continue development till Feb 2020 coz of my semester and other competitive exams, after Feb 2020 I'll be a free bird till March. In that month I'll try to contribute my best.
 
  • Like
Reactions: meelten

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    LineageOS-151.jpg
    LIneageOS is a free, community built, after-market firmware distribution of Android re-branded CyanogeMod, which is designed to increase performance and reliability over stock Android for your device.
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    LineageOS is based on the Android Open Source Project and CyanogenMod with extra contributions from many people within the Android community. All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS please visit Gerrit Code Review.

    Warning!!!


    • BackUp EFS partition before installing. .If you lose IMEI , use this backup to retrieve it in future.


    Installation

    First time LineageOS installation on your Moto Z2 Play:



    • Unlock your bootloader if you haven't done so already
    • Flash a custom recovery via Fastboot (64 bit TWRP is needed)
    • Copy Gapps (64 bit) and Lineage OS flash files to sdcard
    • Boot into Recovery
    • Format Internal Memory . I repeat Format.. (Not Wipe) (after format reboot to recovery)
    • Flash the LineageOS zip from SD card
    • Flash GApps from SD card
    • Reboot

    Upgrading from earlier version of LineageOS :


    • Push the new LineageOS zip to your SD card
    • Boot into Recovery (64 bit TWRP)
    • Flash the LineageOS zip from SD card
    • Flash the most recent GApps (64 bit) for 8.x
    • Reboot

    Downloads

    - LineageOS : Builds
    - Google Apps (arm64) : GApps

    Bugs


    • You tell me


    Reporting bugs


    • DO NOT report bugs if you're running a custom kernel
    • DO NOT report bugs if you've modifies system files
    • DO NOT report bugs if you've installed xposed and/or other mods
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    Code:
    adb logcat > logcat.txt

    Code:
    adb shell dmesg > dmesg.txt


    • If it is a random reboot, grab kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Code:
    adb shell cat /sys/fs/pstore/console-ramoops


    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log


    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues or bugs reported in the lastest 5 pages of this thread. Any bug not reported in the bug report format below may be ignored.
    Code:
    Phone Informations
    * LineageOS version
    * Gapps version
    What you did:
    * Wipe data: y/n
    * Upgrade from previous official cm build: y/n
    * Restore with titanium backup: y/n
    You're using (if yes write which one) :
    * Task killer
    * Phone cleaner / Battery enhancer apps
    * Non-stock kernel
    * Modified kernel settings
    * Other mods
    Bug info:
    * Last version it worked on
    * Repro steps
    F.A.Q.


    • ROOT! ROOT! Give me root or i'll die!!! Where root is???
    • First of all DO NOT flash any SuperSu/SuperUser/SuperMan zip package to get root. Go to Settings>Developement Settings>Root access and select "Apps Only"
    • Why no nightly today?
    • Build failed. Check again tomorrow
    • When do I have to wipe data?
    • You must wipe data only when you're switching from another rom or migrating to Snapshot branch from Nightly and vice versa. You don't need to wipe data when you update in the same release channe (this applies to 13.0 -> 14.1 upgrades too)
    • Will you add <insert awesome feature here>?
    • I won't. If you write it, submit a commit to gerrit, where it will be reviewed.


    The LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    Kernel Source : Here
    Device Tree: Here


    XDA:DevDB Information
    LineageOS, ROM for the Moto Z2 Play

    Contributors
    HeltonMax, rahulsnair, vache, brunorochaa00
    Source Code: https://github.com/LineageOS

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2019-03-17
    Stable Release Date: 2020-02-11
    Current Beta Version: 2018-01-13

    Created 2019-03-20
    Last Updated 2020-01-03
    5
    New Build

    Hello guys I compiled again, the new build is already in the Google Drive folder and for those who play Pokemon GO it works normally and the Security Patch is October
    2
    I have the ROM installed but the fingerprint button doesn't work and there are no on-screen buttons. How do you navigate the interface?

    The on-screen buttons can be restored by adding "qemu.hw.mainkeys=0" to the build.prop file. You can use the "BuildProp Editor" app for example to do this.
    1
    The JBL snap is fully functional?

    Neither of the two JBL MOD snap models works