[ROM][UNOFFICIAL] LineageOS 15.1 for the Essential PH-1 (mata)

makbomb

Senior Member
Feb 23, 2014
118
39
0
New York City
Yes

Also phone app has vvm works. OMG just fot that I'll never go back to stock.
I'm debating between Magisk and that suinstaller. I'd love to be able to use Android Pay if possible, but it's not..."Essential" LOL

---------- Post added at 10:38 AM ---------- Previous post was at 10:01 AM ----------

@invisiblek @strictlyphat I'm up and running!!
Just got my PH-1, and that was under the impression that ROM development was DEFINITELY not a given. To be sitting here just a few days later with Lineage and TWRP is absolutely incredible. Thank you SO much for your hard work and help! SO excited.
 

DaveHTC200

Senior Member
Oct 2, 2008
1,635
421
0
Is anyone able to post some pictures of settings etc, I've not been on a Lineage ROM since the CM days and can't really just go to test but interested none the less.

I know it's a pain lol
Thank you in advance
 
  • Like
Reactions: CRasH180

NaterTots

Senior Member
Feb 7, 2012
1,472
758
143
CT
Is anyone able to post some pictures of settings etc, I've not been on a Lineage ROM since the CM days and can't really just go to test but interested none the less.

I know it's a pain lol
Thank you in advance
Just look for a YouTube video of any lineage Oreo build on the Pixel or XL.
Those will give you an idea of the settings screen and wherever else is in there
 
  • Like
Reactions: DaveHTC200

ZooBaAr

Senior Member
Apr 30, 2011
270
106
63
Venus
wow, this ROM makes this phone the Reel Deel !
Restore backup from cloud worked a treat so everything automagicked into place.
Setup did not ask me which wifi I wanted to use it auto connected, interesting.
I'm just playing around with it now. Putting the clock center is a bad idea lol, doesn't recognize the cam cutout, left clock it is.
Only thing that is odd, I use Nova Prime and restoring from backup, no matter which one, I cannot create widget, touching the place holder would normally just put the correct one there but not now. No biggie.
All thats left to do is magisk and AdAway .
I've been running Darkrom ( lineage based on my 6p which is now retired. ) So everything is where I would expect it.
Terrific work invisiblek so, get off the table mable, the ten bucks is for the Beer!
Cheers
Zo0
 
  • Like
Reactions: nicoconepala

DaveHTC200

Senior Member
Oct 2, 2008
1,635
421
0
The issue you had with the twrp was it was called mata_6 not mate_6 and if you use the tab key when entering a filename it should automatically fill it for you!

Great video though!
Thanks
 
Last edited by a moderator:

Saundersmtt

Member
Dec 3, 2014
11
2
0
Tampa
Same issue as you, when following your solution I now don't have a fingerprint

I have lost my fingerprint scanner after using the new build of twrp from your link.
Is this something that you encountered? Can you send more specific instructions on how you resolved your issue?

Following the instructions posted, wifi stops working after flashing twrp and rebooting back into LOS. I flashed addonsu-14.1-arm64-signed.zip to enable App access to root. It worked, but wifi is broken on reboot. It turns itself off immediately after turning on.

Replication steps:
1. Follow steps in OP.
2. Reboot to bootloader (adb reboot-bootloader)
3. Flash twrp_mata-6.img (fastboot flash boot twrp.img)
4. adb push addonsu-14.1-arm64.zip /sdcard/
5. Install .zip in TWRP
6. Reboot

Anybody else getting this issue? The only way I've been able to fix it is to re-flash LOS.

EDIT: Thanks to @bmg1001, this issue is resolved (for me at least) by using this build of TWRP... Sorry, I can't post links yet! Can someone link this please?

https:// drive.google. com/file/d/1Pp9Hep-EEGNHLl6I_ob7ugihpKfrAcWm/view?usp=sharing

Note that flashing this TWRP build will allow you to reboot to recovery at any time without having to reflash TWRP, as mentioned in the OP.
 
Last edited:
  • Like
Reactions: m3lover1

artiemon

Senior Member
May 25, 2004
264
81
0
Colorado
Thank you for this custom ROM! So far I am loving it. The only thing I have noticed so far is "fast charging" does not not display on the screen. Haven't charged it long enough to know if it is slow charging or just doesn't say "fast charging". Also, I can't restore the Essential Accessory app in Titanium. I was hoping that would get my 360 camera working. :)

Edit: WIFI calling on T-Mobile doesn't appear to work for me.
 
Last edited:

adinkwok

Retired Forum Moderator / Inactive Recognized Deve
May 28, 2013
2,712
10,116
0
6ix
adin.dev