• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL] LineageOS 15.1 for the Essential PH-1 (mata)

Search This thread

makbomb

Senior Member
Feb 23, 2014
118
39
New York City
The one in bmg1001 thread worked. But have to click mirror.

---------- Post added at 02:54 PM ---------- Previous post was at 02:54 PM ----------

If u do get it installed let me know about signal. Mine taking big hit.

Sorry @strictlyphat , but where is bmg's thread exactly? Apologize, still haven't had coffee ;) Do you mean bmg's magisk thread?
 
Last edited:

makbomb

Senior Member
Feb 23, 2014
118
39
New York City
Yes

Also phone app has vvm works. OMG just fot that I'll never go back to stock.

I'm debating between Magisk and that suinstaller. I'd love to be able to use Android Pay if possible, but it's not..."Essential" LOL

---------- Post added at 10:38 AM ---------- Previous post was at 10:01 AM ----------

@invisiblek @strictlyphat I'm up and running!!
Just got my PH-1, and that was under the impression that ROM development was DEFINITELY not a given. To be sitting here just a few days later with Lineage and TWRP is absolutely incredible. Thank you SO much for your hard work and help! SO excited.
 

DaveHTC200

Senior Member
Oct 2, 2008
1,635
423
Is anyone able to post some pictures of settings etc, I've not been on a Lineage ROM since the CM days and can't really just go to test but interested none the less.

I know it's a pain lol
Thank you in advance
 
  • Like
Reactions: CRasH180

socali

Senior Member
Aug 7, 2009
371
718
Thank you @invisiblek and @bmg1001 for all your great work!
I just bought this phone after seeing you got fully working TWRP and Magisk. I assumed LOS would take a while longer, but wow was that fast! :)
 
  • Like
Reactions: CRasH180

NaterTots

Senior Member
Feb 7, 2012
1,486
761
CT
OnePlus 5
OnePlus 7T
Is anyone able to post some pictures of settings etc, I've not been on a Lineage ROM since the CM days and can't really just go to test but interested none the less.

I know it's a pain lol
Thank you in advance

Just look for a YouTube video of any lineage Oreo build on the Pixel or XL.
Those will give you an idea of the settings screen and wherever else is in there
 
  • Like
Reactions: DaveHTC200

ZooBaAr

Senior Member
Apr 30, 2011
279
111
Venus
wow, this ROM makes this phone the Reel Deel !
Restore backup from cloud worked a treat so everything automagicked into place.
Setup did not ask me which wifi I wanted to use it auto connected, interesting.
I'm just playing around with it now. Putting the clock center is a bad idea lol, doesn't recognize the cam cutout, left clock it is.
Only thing that is odd, I use Nova Prime and restoring from backup, no matter which one, I cannot create widget, touching the place holder would normally just put the correct one there but not now. No biggie.
All thats left to do is magisk and AdAway .
I've been running Darkrom ( lineage based on my 6p which is now retired. ) So everything is where I would expect it.
Terrific work invisiblek so, get off the table mable, the ten bucks is for the Beer!
Cheers
Zo0
 
  • Like
Reactions: nicoconepala

DaveHTC200

Senior Member
Oct 2, 2008
1,635
423
The issue you had with the twrp was it was called mata_6 not mate_6 and if you use the tab key when entering a filename it should automatically fill it for you!

Great video though!
Thanks
 
Last edited by a moderator:

Saundersmtt

Member
Dec 3, 2014
11
2
Tampa
Same issue as you, when following your solution I now don't have a fingerprint

I have lost my fingerprint scanner after using the new build of twrp from your link.
Is this something that you encountered? Can you send more specific instructions on how you resolved your issue?

Following the instructions posted, wifi stops working after flashing twrp and rebooting back into LOS. I flashed addonsu-14.1-arm64-signed.zip to enable App access to root. It worked, but wifi is broken on reboot. It turns itself off immediately after turning on.

Replication steps:
1. Follow steps in OP.
2. Reboot to bootloader (adb reboot-bootloader)
3. Flash twrp_mata-6.img (fastboot flash boot twrp.img)
4. adb push addonsu-14.1-arm64.zip /sdcard/
5. Install .zip in TWRP
6. Reboot

Anybody else getting this issue? The only way I've been able to fix it is to re-flash LOS.

EDIT: Thanks to @bmg1001, this issue is resolved (for me at least) by using this build of TWRP... Sorry, I can't post links yet! Can someone link this please?

https:// drive.google. com/file/d/1Pp9Hep-EEGNHLl6I_ob7ugihpKfrAcWm/view?usp=sharing

Note that flashing this TWRP build will allow you to reboot to recovery at any time without having to reflash TWRP, as mentioned in the OP.
 
Last edited:
  • Like
Reactions: m3lover1

dospaquetes

New member
Nov 12, 2017
3
0
Hey guys, can this be rooted the same way as with the stock essential OS or is there anything different to do?
 

artiemon

Senior Member
May 25, 2004
264
81
Colorado
Thank you for this custom ROM! So far I am loving it. The only thing I have noticed so far is "fast charging" does not not display on the screen. Haven't charged it long enough to know if it is slow charging or just doesn't say "fast charging". Also, I can't restore the Essential Accessory app in Titanium. I was hoping that would get my 360 camera working. :)

Edit: WIFI calling on T-Mobile doesn't appear to work for me.
 
Last edited:

mstrblueskys

Senior Member
Aug 27, 2012
171
36
St. Paul, MN
Anyone else having microphone issues? Distortion is a thing for me today.

Edit: in calls only so far. Video recording seems normal. It's a bit scratchy and muffled.
 
Last edited:

adinkwok

Retired Forum Mod / Inactive Recognized Developer
May 28, 2013
2,712
10,116
6ix
adin.dev

Top Liked Posts

  • There are no posts matching your filters.
  • 109
    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    It should go without saying, but do not lock your bootloader with this installed. You must be 100% stock, I'd suggest on both slots, in order to re-lock your bootloader. Doing otherwise will likely lead to a brick that Essential really shouldn't warranty.

    Code:
    #include <std_disclaimer.h>
    
    /*
     * Your warranty is now void.
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.

    Unofficial LineageOS Builds
    Essential PH-1 (mata): https://updater.invisiblek.org/mata

    Google apps
    Google apps (opengapps nano) are baked in to these builds. This is due to the A/B partition layout and complications backing up/restoring gapps between builds. This is not ideal, and is the major road block to getting this device in to official status with Lineage. At this time I do not plan to release non-gapps builds. Users who require this will have to build their own.

    Source
    Device | Kernel
    Here's a local_manifest for those who want to build at home.

    Prerequisites
    • Unlocked bootloader
    • OPM1.180104.092 firmware - even if you were on this build, you should flash this firmware package to ensure the firmware is on BOTH slots.
    • Fastboot and ADB set up (use your google-fu to figure this out)

    Installation
    This device is different than what most people are familiar with due to the A/B partition layout. If you're familiar with Pixel devices, then you already know what this means. This thread isn't really designed to explain how it all works, that should be handled somewhere else. Instead, I'll assume you can either follow directions or do some research on your own. Additionally I have a discord set up where there are several people who may be able to help if you run in to a snag.

    The initial install should go rather smooth, and future updates can be taken through the built-in Lineage updater app (yes, the are the seamless updates you may have heard about). Due to A/B, the recovery's ramdisk is actually on the boot.img partition (the rom's ramdisk is on the system partition now). What this means is once you flash the rom, it essentially (lol) replaces the TWRP that you have installed. This shouldn't be a problem since with the seamless updates, you shouldn't have to ever go into recovery. If you find yourself needing recovery, you'll have to re-flash TWRP to get there.

    Phew, now some instructions.

    • See the prerequisites. You really do need these or things aren't going to work for you.
    • Boot into bootloader mode and wipe data with:
      Code:
      fastboot -w
    • Download twrp (mirror) and flash it with this command:
      Code:
      fastboot flash boot twrp-mata_11.img
      (no, this isn't a typo, you are flashing twrp to the boot partition)
    • While still in bootloader mode, use vol down to select "Recovery mode" and hit the power button. This should boot you in to TWRP. Enter your previous lock screen password or pin (if it asks) to decrypt your data partition.
    • Put the device in sideload mode with:
      Code:
      adb shell twrp sideload
    • Install the zip via adb sideload with:
      Code:
      adb sideload <zip name here>
    • When finished, reboot.
    • Profit!

    The LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    XDA:DevDB Information
    [ROM][UNOFFICIAL] LineageOS 15.1 for the Essential PH-1 (mata), ROM for the Essential Phone

    Contributors
    invisiblek
    Source Code: [url]https://github.com/LineageOS[/URL]

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2017-11-12
    Last Updated 2017-11-11
    29
    • Q: What is broken?
      A: Nothing I'm aware of
    • Q: Can I use the stock Essential camera app?
      A: Yes
    • Q: Does the 360 cam work?
      A: No.
    • Q: Is this rooted?
      A: No. You're on your own for that.
    • Q: Does this pass SafetyNet?
      A: Yes. Android pay, Pokemon Go, etc work fine. If you root, depending on your root method, you may lose this ability. But the ROM itself does pass SafetyNet.
    • 2017-11-20 FAQ rollup: https://forum.xda-developers.com/showpost.php?p=74580036&postcount=189
    • FAQ site with some more info (be gentle with the terrible, or should i say complete lack of, css)
    28
    Here's a bunch of answers to a bunch of questions and things I've seen asked about. I'll link this in post 2 so it can be found again easily.

    Halp! My wifi doesn't work!
    Why: This is due to the boot.img being replaced either by flashing TWRP again or some root methods. In fact, it's not even that the boot.img is replaced, but the kernel inside it has been replaced. The problem here is that the kernel you have flashed is checking the wifi module when it tries to load it and determining that it wasn't built alongside this kernel. This patch must be included in order for the kernel to ignore this check.
    Solution: Re-flash the ROM and don't flash any other stuff afterward. Do this to make sure wifi works initially. After that try flashing your mods and see what causes it to break.

    How do I wipe cache/dalvik cache?
    Answer: You don't. Don't worry about this. You don't have to do it. I promise.

    Halp again! My fingerprint reader isn't working!
    Why: Your firmware is not the same version as the blobs included with the rom. Fingerprint reader uses some lower level firmware than what's included with the rom. Make sure you have the same firmware as mentioned in the OP. Firmware available here. You can just download and flash the appropriate "Firmware Package", you don't need a "Full Dump" for this unless you intend to go all the way back to the stock ROM.

    Is there a changelog?
    Answer: No, because I'm a lazy piece of sh!t. You're better off looking at the github history. I realize not everyone understands what a lot of it means, but that's a good excuse to learn something ;)

    Sup with this not getting official LineageOS support?
    Answer: Just a quick response to this. If I felt this ROM was in a state to give it official status at Lineage, I could turn that on at any point. I won't though, due to the A/B layout and retaining gapps/root/etc (addon.d/backuptool) between rom flashes. I touch on this in the OP too, there's just no really great solution for this right now. The same reason my Pixel builds never went official: official Lineage builds can't, and never will, include gapps. My current best solution would be to roll a supported gapps package that would work with the A/B stuff that I had worked on earlier this year. Opengapps won't work with this without a bunch of hackery to their installation scripts. The biggest problem with all this is if you flashed an update that didn't have gapps over one that did, and forgot to re-flash the gapps zip on top of it, android will get super pissed at you. Rebooting to recovery in this state and flashing gapps after having booted without them wont fix it. Its messy and will cause a lot of problems for users. That's the real reason I haven't made a push for official Lineage on Pixel or PH-1. Rest assured, I've been with the CM/Lineage team for many years (if you didn't know this already). This going to get about as close to official builds as you can get without actually being official.

    More stuff:
    - Double tap to wake is not going to happen here. If people want to roll their own kernels/ROMs with this functionality, that's on them. The hacks to enable this on devices that don't support it at a touchscreen firmware level are detrimental to battery life.
    - I'm not kanging oneplus 3teabag whatever device's drivers. If someone wants to roll their own kernel or ROM with stuff like that, have at it.
    - lineage-15.0 is in the works
    - 360 cam still doesn't work. Got closer with some proxy debugging, but haven't nailed it down yet.
    - Built in updater still needs some work. If it appears to hang, it's probably still installing or finished (it does all this in the background) but somewhere along the line stopped updating the notification. I need to track this down still.
    13
    Here are the steps I developed to install LOS and then correctly root it with Magisk.
    I just tried it with the latest 1130 build and it worked perfectly.

    NO NO NO
    Don't ever give out `dd` commands. You will brick people because people have fat fingers and will mistype. At the very least use by-name partitions and not numeric partition numbers. (I've removed the comment, this is a really bad thing to do)

    If you need magisk, flash this after flashing your rom: https://download.invisiblek.org/magisk_14.3_invisiblekhax.zip
    That zip will flash magisk to the opposite slot you're booted to. So you shouldn't have to deal with this reflashing twrp and swapping slots business.
    11
    How to Successfully Install LOS over Stock

    Is LOS 1205 compatible with firmware NMJ51B?
    Thats a good question has anybody confirmed this?

    Yes, LOS 1205 is working perfectly fine when flashing over either NMJ32F or NMJ51B.
    It is very important to back up all your data and then wipe the phone with fastboot before installing LOS when coming from stock. I believe that most of the weird issues people are reporting here after installing LOS is because they did not wipe the phone first.
    Another set of issues is when people try to flash twrp after installing LOS in order to root or flash other things. Since the new A/B system does not have recovery partition like before, flashing TWRP again messes up the kernel!

    Here are the steps for getting phone with stock rom (NMJ32F or NMJ51B) to LOS 1205:
    1) Backup all your data, including documents, photos, downloads etc.
    2) Wipe phone This is important!:
    Code:
    fastboot -w
    3) Flash twrp:
    Code:
    fastboot flash boot twrp-mata_6.img
    4) Flash LOS 1205 zip from within twrp (copy zip to phone and install)
    5) If you want root, from twrp go to Reboot -> Bootloader, then flash the rooted boot image:
    Code:
    fastboot flash boot boot-LOS1205-magisk1437.img
    6) Boot system as normal

    Notes:
    * Rooted boot image: boot-LOS1205-magisk143.zip UNZIP before flashing
    * You will not have TWRP after this process. Installing TWRP again could break LOS.
    * If rooted, you will need to get Magisk Manager apk from magisk thread and install as a regular app (no flashing)