[ROM] Unofficial LineageOS 16.0 PQ3A.190801.002] for ZTE Blade S6 (P839F30)

Search This thread

lightwars

Senior Member
Oct 19, 2010
240
220
Wuppertal
Sorry for the misunderstanding.
My device still rebooting to system. Because I flash the boot.img to recovery partition.
I am still trying to flash the twrp.img and I cant.
I am using a terminal app but I cant. permission denied.

---------- Post added at 01:29 PM ---------- Previous post was at 01:14 PM ----------


this what i get

C:\Users>cd..

C:\>cd adb

C:\adb>adb shell
Blade-S6:/ $ su
/system/bin/sh: su: not found
torage/E8BC-034B/twrp.img of=/dev/block/bootdevice/by-name/recovery <
dd: /dev/block/bootdevice/by-name/recovery: Permission denied
1|Blade-S6:/ $ adb shell
/system/bin/sh: adb: not found
127|Blade-S6:/ $ adb devices
/system/bin/sh: adb: not found
127|Blade-S6:/ $ dd if=/dev/zero of=/dev/block/bootdevice/by-name/misc
dd: /dev/block/bootdevice/by-name/misc: Permission denied
1|Blade-S6:/ $
OK, I thought you were able to get back into twrp and wanted to get the system booted.
Have you activated the root access for adb in the developer options?
Otherwise the su command and all succeeding commands will fail. If it is already enabled and the command will fail nevertheless, then I have no idea at the moment.
 

lagos911

Senior Member
  • Jan 25, 2009
    214
    18
    Its okay man I install aploite for the apps.
    Hard reset its not working as well. Maybe because the recovery is missing.
    I will try to root the device again. I try some apps but nothing happend.
     

    cd492

    Senior Member
    Oct 20, 2010
    337
    53
    I'm coming from LineageOS 14.0 and need help.

    I installed the latest TWRP but can't find the img file in my Download folder. I don't see it in TWRP I only see it in Windows.
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    I'm coming from LineageOS 14.0 and need help.

    I installed the latest TWRP but can't find the img file in my Download folder. I don't see it in TWRP I only see it in Windows.

    You want to install twrp or you have already installed it??
    If you want to flash and img file with twrp, you are going into install and then click the button which changes to show img files at the bottom of the screen, select the img file and push install.
     

    fm663

    New member
    Jun 18, 2009
    1
    0
    Phone

    Hi, my ZTE Blade S6 Plus, after switching on i get white screen, then after a while reboots again and again. What do I need to do to fix it and then install the latest new ROM? Thanks
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    Hi, my ZTE Blade S6 Plus, after switching on i get white screen, then after a while reboots again and again. What do I need to do to fix it and then install the latest new ROM? Thanks
    This is probably bootloop, but you didn't state what you have done. So if you flashed a boot.img with a device tree missing for your variant this could happen, but it could be something else.
    Get into recovery, backup you device and flash again, if it is right for your device. Or just install the newest rom, like state in the OP. Remeber that this thread is for the ZTE Blade S6, so thing might not work correctly.
     

    dstruan

    New member
    Dec 30, 2020
    4
    0
    Dear all,

    unfortunately i need some expert support from you ;-)

    Many thanks for the new 16 release ... great work

    I tested the latest version yesterday on my old phone ... mainly just for interest.

    I had the latest official ZTE Android 5 version installed on my S6 and after some struggle i was able to flash the Lineage OS 16 release using Kingroot and TWRP all with latest version i found on internet, and yes i did backups of Boot and Recovery with TWRP ...

    After flasing i was able to boot my phone successfully and i was able to do the post configuration and all seems to work fine. Next i wanted to install google apps ...

    But now my problems starts ... Kingroot is not able to root the device anymore (and Dr. Fon either) ... and when i want to use recovery mode i'm only getting ZTE recovery mode, not TWRP recovery console.

    In ZTE recovery console i tested nearly everything to get a recovery installed or package installed, even with adb sideboard installation ... but nothing is accepted even my original boot and recovery images are not recognize by process. In ZTE recovery console I'm able to get a connection via adb. ">adb devices" is working ...

    Futhermore i recognize that it looks like i not have fastboot installed/available on phone.

    Everytime when i try to enter bootloader mode I only see blank screen ... and from computer i'm not able to connect via platform tools - fastboot to my phone to do recovery ...

    I try to enter bootloader mode on phone by ZTE recovery console (Reboot fo bootloader), but without any success ... Switch on with Power on + Buttom up for 8 sec. will open ZTE recovery console

    I'm frustrated ... any chance or advice ???
     

    Attachments

    • IMG_20201230_112333 800px.jpg
      IMG_20201230_112333 800px.jpg
      124.7 KB · Views: 11
    Last edited:

    dstruan

    New member
    Dec 30, 2020
    4
    0
    No solution ??
    No advices ??
    No hints ??
    Whats up ??

    I not understand why it is not possible to activate root-modus on a custom rom

    Sorry for complaining
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    No solution ??
    No advices ??
    No hints ??
    Whats up ??

    I not understand why it is not possible to activate root-modus on a custom rom

    Sorry for complaining
    How about reading what is stated in the OP about root or inform yourself about lineage os and their addon for root. You could also use Magisk, which I do.
    To your main problem, it seems you have installed the lineage rom but kept the original zte recovery. So with this recovery you can only flash zte signed roms.
     

    dstruan

    New member
    Dec 30, 2020
    4
    0
    How about reading what is stated in the OP about root or inform yourself about lineage os and their addon for root. You could also use Magisk, which I do.
    To your main problem, it seems you have installed the lineage rom but kept the original zte recovery. So with this recovery you can only flash zte signed roms.
    Thanks lightwars for your reply, but instead to blame somebody how is running into an issue it would be better to help them to fix the issue.
    First of all ... I read the treat and more, but maybe I missed a thing, second to run the Lineage OS installation I did it from a custom recovery, otherwise it was not possible, third I tried Magisk on the Lineage OS installation right now, but without success providing me root access and unfortunately fourth, with the ZTE recovery I was not able to recover my backup image or any other ZTE Image that I downloaded for whatever reason.

    Nevertheless thanks
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    Thanks lightwars for your reply, but instead to blame somebody how is running into an issue it would be better to help them to fix the issue.
    First of all ... I read the treat and more, but maybe I missed a thing, second to run the Lineage OS installation I did it from a custom recovery, otherwise it was not possible, third I tried Magisk on the Lineage OS installation right now, but without success providing me root access and unfortunately fourth, with the ZTE recovery I was not able to recover my backup image or any other ZTE Image that I downloaded for whatever reason.

    Nevertheless thanks
    I did not want to blame you, it is just I wrote that for root there is an extra package to flash and this is not new to lineage os, that the roms comes without root and they provide the su addon.
    To my knowledge if all went well you shouldn't have the zte recovery, but it is on your phone. The recovery indicates that you have a german device variant, so it will just accepts roms for this variant, so eu roms might also not work. I havn't seen any de rom.
    Nevertheless I understand that you might want to use lineage, so please try this "Then go into settings and about device, click there multiple times on the build number until you unlocked the developer options. Go to developer options and look for root access." There should be still the option to give adb root access.

    If it is there and you can active it and have a pc/notebook. Install adb xda-how-to-install-adb, if you havn't.
    Connect your phone to the pc open the command prompt and type
    Code:
    adb root
    adb shell
    If twrp is on your sdcard you can flash it like this:
    Code:
    dd if=/storage/XXXX-XXXX/twrp.img of=/dev/block/bootdevice/by-name/recovery
    XXXX-XXXX should be numbers and letters representing your card, maybe use
    Less:
    ls /storage
    beforehand to see it.

    Let me know how it works.
     
    Last edited:

    dstruan

    New member
    Dec 30, 2020
    4
    0
    H
    I did not want to blame you, it is just I wrote that for root there is an extra package to flash and this is not new to lineage os, that the roms comes without root and they provide the su addon.
    To my knowledge if all went well you shouldn't have the zte recovery, but it is on your phone. The recovery indicates that you have a german device variant, so it will just accepts roms for this variant, so eu roms might also not work. I havn't seen any de rom.
    Nevertheless I understand that you might want to use lineage, so please try this "Then go into settings and about device, click there multiple times on the build number until you unlocked the developer options. Go to developer options and look for root access." There should be still the option to give adb root access.

    If it is there and you can active it and have a pc/notebook. Install adb xda-how-to-install-adb, if you havn't.
    Connect your phone to the pc open the command prompt and type
    Code:
    adb shell
    su
    Now on the phone a message sould appear to grant root access. If twrp is on your sdcard you can flash it like this:
    Code:
    dd if=/storage/XXXX-XXXX/twrp.img of=/dev/block/bootdevice/by-name/recovery
    XXXX-XXXX should be numbers and letters representing your card, maybe use
    Less:
    ls /storage
    beforehand to see it.

    Let me know how it works.
    Hi lightwars, sorry for the late reply and thanks for you guide ...

    adb was already installed on my Laptop and I was able to connect to my phone ... Android debugging is activated and Root Access is open for ADB.
    When i connect to adb on my ZTE S6 it gives me the ability to browse the filesystem .. But unfortunately i'm not able to do the "su" command ... same for "sudo" i got ... "/system/bin/sh: su: not found"

    hmmm

    Any ideas ??
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    H

    Hi lightwars, sorry for the late reply and thanks for you guide ...

    adb was already installed on my Laptop and I was able to connect to my phone ... Android debugging is activated and Root Access is open for ADB.
    When i connect to adb on my ZTE S6 it gives me the ability to browse the filesystem .. But unfortunately i'm not able to do the "su" command ... same for "sudo" i got ... "/system/bin/sh: su: not found"

    hmmm

    Any ideas ??
    There is of course the qualcomm hs-dloader mode, which can be also used to unbrick the device, unluckily I had to used it at the beginning of my lineage-17.1 test, because my recovery was erased. This was due some update settings. This is maybe the last to try.
    What if you install the latest magisk.apk, what can magisk do? Maybe give me sometime, so I can prepare my device, cause it is my daily driver, to see what can be done.
     

    lightwars

    Senior Member
    Oct 19, 2010
    240
    220
    Wuppertal
    H

    Hi lightwars, sorry for the late reply and thanks for you guide ...

    adb was already installed on my Laptop and I was able to connect to my phone ... Android debugging is activated and Root Access is open for ADB.
    When i connect to adb on my ZTE S6 it gives me the ability to browse the filesystem .. But unfortunately i'm not able to do the "su" command ... same for "sudo" i got ... "/system/bin/sh: su: not found"

    hmmm

    Any ideas ??
    I have updated the instruction above. Before typing "adb shell" in the command prompt type "adb root". If you then enter "adb shell" you should see the # instead of the $ sign in the adb shell.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 2
      Code:
      [I]DISCLAIMER[/I]
      [COLOR="red"]Do not mirror my builds![/COLOR] Please post a link to this thread instead.
      
      All information and files — both in source and compiled form — are provided on an as is basis.
      No guarantees or warranties are given or implied. The user assumes all risks of any damages
      that may occur, including but not limited to loss of data, damages to hardware, or loss of
      business profits. Please use at your own risk. Note that unless explicitly allowed by the
      warranty covering your device, it should be assumed that any warranty accompanying your
      device will be voided if you tamper with either the system software or the hardware.

      Introduction
      This is my unofficial build of LineageOS 16.0 for the ZTE Blade S6 aka P839f30.
      This is the first alpha release, so be aware that issues could arise.

      I have tested this version with my AS variant device. Other variants have to be tested.

      Features
      working:
      phone: calls, sms, data.
      wifi
      bluetooth
      sensors
      gps: mostly I have used the energy saving mode
      sound
      camera: rear with flash and front.
      torch
      headphone detection
      swap back and menu button
      light: button backlight, brightness control and adaptive brightness, breath light (notification and/or battery)



      not working:
      SELinux is permissive.
      We have to test to find out.

      Installation instructions
      It is best to have installed the latest stock rom beforehand, so modem and all other vendor stuff is up to date.
      If you like you can use this mod to have a unified data partition, please proceed with caution.
      You will need TWRP or any other custom recovery.
      • Reboot into recovery and do a nand backup.
      • Do a factory format.
      • Download Rom and put it on your phone or use adb sideload.
      • Install the rom and then clear cache and dalvik cache.
      • optional: install su and/or gapps (preferable pico).

      Changelog:
      25.05.2021 - new release:
      • los security patch level 05.05.2021
      • revert some kernel changes from the last release
      • add some cpu governors and cpu hotplug
      • now with Boeffla WakeLock Blocker and other things
      • wireguard kernel support
      22.12.2019 - 1st beta release:
      • los security patch level 05.12.
      • kernel supports EU device variant
      • add autosmp hotplug
      • add cpu governors blu_active, darkness, lionfish and relaxed
      • Revert CwMcu sensor driver from SU6 kernel release
      24.10.2019 - 2nd alpha release:
      • los security patch level 05.10.
      • CwMcu sensor driver from SU6 kernel release, with wake lock disabled
      • wifi mac is loaded anyway, remove the loading in the wifi driver
      • give bluetooth a null mac address, to overcome force close error
      • kang gps from oppo
      04.10.2019 - 1st alpha release:
      • los security patch level 05.09.
      • initial release of pie

      Downloads
      new release - 25.05.2021:
      Google Drive.

      first beta release - 22.12.2019:
      Google Drive or here.

      second alpha release - 24.10.2019:
      Google Drive or here.

      first alpha release - 04.10.2019:
      Google Drive or here.

      If you want root use the lineage addon package found here - download arm version.
      Install it after flashing the rom or download your favourite root package and install it.

      Sources

      FAQ
      Here you will find some answers to common question which could arise.
      Q: How to give root access to an app or adb?
      A: First install the su extra package from Lineage OS or any other su tool you like. Then go into settings and about device, click there multiple times on the build number until you unlocked the developer options. Go to developer options and look for root access.

      Q: I thing I found an issue, what to do now?
      A: Do a logcat or grab a dmesg while having the issue, otherwise we can't say what is happening. Report as much info as possible. Quote your stock rom your device shipped with or which device variant you possess.

      Thanks To/Credits
      Code:
      *aquaris-dev team
      *aymende7
      *PacMM79
      *LineageOS team
      *many others

      XDA:DevDB Information
      Unofficial LineageOS 16.0 [PQ3A.190801.002] P839F30, ROM for the ZTE Blade S6

      Contributors
      lightwars
      ROM OS Version: 9.x Pie
      ROM Kernel: Linux 3.10.x
      Based On: LineageOS 16.0

      Version Information
      Status:
      Beta
      Current Beta Version: 20191213
      Beta Release Date: 2019-12-22

      Created 2019-10-04
      Last Updated 2019-12-22
      1
      @Kurt Krummbein
      Here is my latest build or just grab the boot.img from the attachment. Which has a dtb for msm8929 build from source.
      Maybe this will boot without any bootloop.