• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL] LineageOS 17.1 for Asus Zenfone 4 Max [Q][ZC520KL][ZC554KL]

Status
Not open for further replies.
Search This thread
Oct 6, 2017
6
1
NYC
Lineage OS follow up.



Just an update - Still on the same install for about 6 weeks now, no real complaints for this ROM - the Battery Life on this phone lasts me almost 2-3 days with normal use. I do use another phone for work during the week days. Call quality (T-Mobile) and usability has been everything I hoped for and more. I do get some occasional dropped calls while driving or talking from home, but this may be Carrier Related only.

My original issues with system message from my carriers voicemail was mostly resolved with this ROM, I only get the notification of a carrier voicemail every 2 hrs on stock, Now I only get the message on restarts and during signal loss (say entering a tunnel or going into the subway/metro).

I seem to have a small problem with saving pictures or video on to my Micro SD card. Im just using the stock camera app and when I change the storage location from internal to external SD card, the pictures/video do not save and are lost. No issues saving to the internal storage so far. Has anyone else experienced this or can someone else test this for me? I am using a 128GB micro sd card from Micro Center.

Otherwise, I've been loving this Rom anyways, despite any minor gripes!!! I was hoping to pick up the Zenphone 7, but it is not available in the USA at this time. So Zenfone 4 Max is still with me.

Just another update.

Still using this ROM and loving it for nearly 3 mos now. I mostly have problems with media on my internal or external storage. I am still unable to save pictures or video to my sd card, I can only save to the internal storage. I have about 50 downloaded podcasts on my internal storage to listen to at work. After finishing with the podcasts (USING AIMP3 player) I have troubles deleting the files from my internal storage. Anyone else have trouble deleting files / sycning data from Windows 10 or moving files between internal storage and external micro sd cards??
Once again, many thanks to the ROM creator, my comments are mostly minor and the problems I describe do not effect my day to day use.
 

Jaud029

New member
Jan 10, 2021
2
0
Hi,
i installed your stock Android Pie beta on my Asus Zenfone 4 Max ZC520KL X00HD via TWRP, and it works great, thanks !
Now, i'm trying to install LineageOS 17.1.
But, now, when i try to boot TWRP, the screen turn to "Powered by Andoid" and nothing happens. So i'm not able to flash the rom.
There is no error message in my shell.
I re-flashed TWRP, with no changes.
Do you have any idea to help me, please ?
 

Mexicain93

New member
Jan 27, 2021
2
0
Hi,
i installed your stock Android Pie beta on my Asus Zenfone 4 Max ZC520KL X00HD via TWRP, and it works great, thanks !
Now, i'm trying to install LineageOS 17.1.
But, now, when i try to boot TWRP, the screen turn to "Powered by Andoid" and nothing happens. So i'm not able to flash the rom.
There is no error message in my shell.
I re-flashed TWRP, with no changes.
Do you have any idea to help me, please ?

Hello Jaud029,

Where did you find the beta version of Android Pie for Asus Zenfone 4 Max ZC520KL X00HD? And the link https://forum.xda-developers.com/t/...ne-4-max-x00hd-zc520kl-x00id-zc554kl.4124547/ is more active...

Could you please give me the links to finally update my Zenfone.

Thank you so much.
 

Jaud029

New member
Jan 10, 2021
2
0

slyce95

New member
Apr 10, 2013
3
0
Dear,
the link to the downloads aren't working anymore. I decided to reset my phone settings (From lineageOS settings) before selling it, now each time I start it I'm back to TWRP. After asking me the mount passord, I was also able to wipe cache and data, and fortmat data (no more password asked), but even... always back to TWRP, no wait to boot to LineageOS.
Is there another link to download the firmwares again ?
 

5thjunior

Member
Feb 12, 2012
22
1
Seremban
This rom is good and working properly. I hope you will continue your work in making custom rom for this phone and i would like to see you porting others custom rom like resurrection remix, arrow os, it will be great. Thank you SebaUbuntu.
 

GhostYoung

New member
Dec 19, 2020
3
0
I apologize if there is any spelling mistake, I am using a translator, when I install the rom and start it does not recognize the sim or the imei, I tried to fix it but I occupy the baseband, will you know where to get it?
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    2okPze5.png


    Note: Android 10 is not supported anymore, please use this

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10.0 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Namings
    Asus Zenfone 4 Max, ZC520KL or also called X00HD, is referred as X00H
    Asus Zenfone 4 Max, ZC554KL or also called X00ID, is referred as X00I
    Asus Zenfone 4 Max Pro, ZC554KL or also called X00ID, is referred as X00I

    THIS ROM REQUIRES PIE FW. OREO AND NOUGAT FW WON'T BOOT!

    Flashing instructions

    Note: You must be on stock Android Oreo or Android Pie beta!
    - Unlock bootloader (Asus unlock tool is in their website)
    - Flash TWRP
    - Format data (and not wipe)
    - Wipe cache
    - Flash the custom ROM
    - Flash additional zips, like Gapps or Magisk
    - Reboot and wait

    What's not working
    - Fingerprint needs to be tested

    What firmware do you need?
    - Pie firmware

    Don't for whatever reason disable force encryption, camera won't work if you do so (my TWRP supports data decryption)

    Downloads

    X00H
    X00I

    Changelogs are on #2 post
    Telegram channel for updates: Here
    Telegram group for support: Here

    Sources:
    Common device tree
    X00H device tree
    X00I device tree
    Common kernel sources
    Common vendor blobs

    Happy modding!
    3
    Changelog:
    08/31/2020
    Common:
    - August 2020 SPs
    - Kernel sources has been unified, also supporting X00P (2018 phone)
    - Added a check that will abort flashing if Pie FW isn't installed
    - Building a custom fingerprint HIDL, this will definitely fix fingerprint :p
    - Back and recents key will now vibrate when touched

    Needs to be tested:
    - Goodix on X00H, FPC and Goodix on X00I

    Old changelogs:
    07/29/2020
    Common:
    - Fixed fingerprint as home button for some variants (tested on X00H, cdfinger sensor)
    - Fixed WFD and Miracast
    - Updated all blobs from daisy
    - Fixed FM Radio
    - Fixed power-off alarm
    - Fixed wide-angle camera on Snap

    X00I:
    - Rebased X00I kernel to latest CAF tag (no need anymore to flash external boot image)
    - Fixed Wi-Fi on X00I

    Bugs:
    - X00H: Probably goodix not working, but the rest is rock solid
    - X00I: Fingerprint not working yet

    07/15/2020
    - From now on devices codenames have the final D removed, following other Asus devices examples, you can still flash ROMs w/o issues
    - July 2020 security patch
    - Kernel has been rebased to CAF LA.UM.8.6.r1 tag (thanks to KudProject for the base kernel)
    - Kernel upstreamed to 3.18.140 + Google ASB changes
    - Camera has been fixed
    - Fingerprint has been fixed
    - Notification LED has been fixed
    - Fixed heating issue
    - ROM will now force encryption by default (needed for camera, DON'T DISABLE IT, support for TWRP decryption will come soon)

    Bugs:
    - Fingerprint doesn't act as home key (I've enabled software navbar as a workaround for now)
    - FM radio

    06/01/2020
    - Fixed Wi-Fi
    - Imported prima stuff to kernel

    Not working
    - Camera
    - Fingerprint
    - Power-off alarm

    05/27/2020:
    - May security patches
    - RIL (calling, mobile data, SMS and maybe also VoLTE) working
    - Bluetooth fully fixed
    - No more random bootloops and restarts
    - Media OMX issue solved

    04/27/2020
    - Initial build
    2
    I'm very happy to announce that I booted Linux kernel version 4.9 on X00H! (screenshot attached)
    With 4.9 we will have longer kernel updates and EAS, so better temperatures and such
    August Security patches build will be skipped, so I can work on fixing 4.9, and release it
    attachment.php
    2
    New update is out
    Check post #2 for infos
    2
    New update is out!
    See #2 post for changelog, a lot of stuff has been fixed
    Remember, now X00HD is "called" X00H and X00ID is now X00I, so don't ask what zip you need to flash
    If you can't find X00I update, please wait a little and check later, I'm fixing booting issues
    I can now consider this custom ROM as daily driver ready