[ROM][UNOFFICIAL] LineageOS 17.1 for castor/castor_windy

Anton Yuminov

New member
Jan 24, 2021
2
1
13
Hi guys

Thank you for this ROM. I like it. Everything seems work fine. But I have to root it too like MaujuDroid. My device has very weak battery. My case - is to use tablet always plugged in. But it is often drain battery in case of heavy load, so battery often charges and discharges. I want to install "Battery Charge Limit" app to prevent battery from dying within couple of weeks. But I can't install root: both magisk and Lineage OS root tool are not working. Magisk seems installed successfully but when boot no root is present

Guys, have somebody positive experience in rooting our tablet? Any help would be appreciated. Thanks!
 

Attachments

Anton Yuminov

New member
Jan 24, 2021
2
1
13
  • Like
Reactions: MaujuDroid
Nov 5, 2017
17
2
3
Rennes
Hi there,
With my Castor Windy: coming from AICP14, I flashed TWRP 3.4 + AICP15 boot image + LoS 17.1 ROM + Magisk 20.4 (no Gapps)
Everything is OK except Bluetooth permanent force closes and double tap wake up.
 

MaujuDroid

Member
Oct 28, 2017
16
2
3

qsnc

Senior Member
Feb 26, 2013
270
1,366
123
Salzburg
www.vware.at
I have tried this rom, but tablet would not boot. When I flashed the boot.img from the aicp rom, I could get it to boot.

I am not really familiar with installing custom roms. Could using a boot.img from a different rom disable the sensors?

What could be the reason that my tablet is not booting with your default lineage boot.img?
could you please describe exactly what happened? did it hang at the boot animation? seems you are not the only one with this problem, but i can not reproduce it for some reason. which device are you on?
Oh God, Finally !!!
Let me thank you 1 milion times man.
I try all the custom roms made for the SGP521, but no one had work.
Every rom goes random reboot when the tablet goes deep sleep.
Till now the only one that work for me was the stock 6.0.1 - 23.5.A.1.291.
Finally with this one the problem seems to be gone.

Am not used the rom deeply but till now I can say that, am on castor, Gapps Pico installed, no reboot, Wifi, GPS, NFC and other work without issue. Bluetooth keep crashing, no MAC Address.

Automatic screen rotation does not work in lock screen, when unlocked is ok.
Can't access system when open the settings, everytime the tablet came back at home screen.

The rom start with AICP 15 boot.img.
With the original from lineage the tablet doesn't start, led flash red and tablet reboot.

Can't install magisk either in recovery (TWRP 3.4.0 from spiritcroc) that in Magisk manager, the message is "unsupported/unknow image format" after boot unpacking. Tryed almost every versions either in stable that in canary chanel with patched boot.img.

Make my donation minutes ago. Wish for a more stable release. Thank you for keep our tablet alive !
i will take a look at it, had to rebuild my build system...


Anybody succesfully root the rom? If yes could explain how? Thank you.
Flash Magisk from the recovery, reboot, install Magisk app -- that's basically it.
 

qsnc

Senior Member
Feb 26, 2013
270
1,366
123
Salzburg
www.vware.at
New builds are up. Bluetooth tested again, works fine. Please, if you experience any kind of problem: try to give as much info as possible (device, what happened, LOGS).
Can only test castor myself, so this one is sure to work.
 
  • Like
Reactions: MaujuDroid

MaujuDroid

Member
Oct 28, 2017
16
2
3
New builds are up. Bluetooth tested again, works fine. Please, if you experience any kind of problem: try to give as much info as possible (device, what happened, LOGS).
Can only test castor myself, so this one is sure to work.
Thank you qsnc 🤘 downloading now, give you feedback soon after some tests.
 

MaujuDroid

Member
Oct 28, 2017
16
2
3
could you please describe exactly what happened? did it hang at the boot animation? seems you are not the only one with this problem, but i can not reproduce it for some reason. which device are you on?

i will take a look at it, had to rebuild my build system...



Flash Magisk from the recovery, reboot, install Magisk app -- that's basically it. } Done 20.4 with 8.0. 7 manager is workin'.
 

qsnc

Senior Member
Feb 26, 2013
270
1,366
123
Salzburg
www.vware.at
for everyone on castor_windy (!! not castor !!) having boot problems: please try the attached boot.img (in twrp, select "flash image" and flash it as boot image). let me know if that improves your situation... without logs and no access to an actual device it's a wild guess, but anyways.



Yes, I can do that. Where can I find the necessary log files.
go for "adb logcat > log.txt" to capture a log while booting, there are plenty of guides for that on xda.
 

Attachments

SirBoss1st

Member
Oct 25, 2009
18
23
33
So the boot.img did not work. I have attached 2 logfiles. I hope they help a little. But I could start the log only after the device had booted completely. So I have no log from the boot process.
 

Attachments

qsnc

Senior Member
Feb 26, 2013
270
1,366
123
Salzburg
www.vware.at
the boot.img didnt work, but you logged after booting? i am confused, sorry :)
guys, please try to describe what exactly happened. you flashed, rebooted, and it didnt work? can you get logs from the failed boot? how do you get to finish the boot, with the aicp boot.img? then i wouldnt be surprised bluetooth (and other stuff) doesnt work.
what we (well i) am trying to do is fix the boot problem we have on the lineage boot.img - not a combination of lineage system and aicp boot, that is bound to fail somewhere.
so please, if you could: flash the lineage zip, reboot, log. no shenanigans please ;)

also, i would like to hear from castor users, they should not experience any problems at all.
 

SirBoss1st

Member
Oct 25, 2009
18
23
33
Ok, here's the long version. I downloaded the imge. Then I booted into TWRP 3.4.0-sc-1. I wanted to start the log from here, unfortunately only one error message came up (/../sh: logcat not found or similar). I then installed the boot image (without a log). After the restart, the screen just stayed black. So, as usual, I reinstalled the old working image via Fastboot. After the tablet started, I was able to start recording with logcat without an error message.
 

MaujuDroid

Member
Oct 28, 2017
16
2
3
the boot.img didnt work, but you logged after booting? i am confused, sorry :)
guys, please try to describe what exactly happened. you flashed, rebooted, and it didnt work? can you get logs from the failed boot? how do you get to finish the boot, with the aicp boot.img? then i wouldnt be surprised bluetooth (and other stuff) doesnt work.
what we (well i) am trying to do is fix the boot problem we have on the lineage boot.img - not a combination of lineage system and aicp boot, that is bound to fail somewhere.
so please, if you could: flash the lineage zip, reboot, log. no shenanigans please ;)

also, i would like to hear from castor users, they should not experience any problems at all.
1) you flashed, rebooted, and it didnt work?

» Yes, tablet vibrate but the screen doesn't switch on, remains black.

2) can you get logs from the failed boot?

» No because I can't see when the entire boot process is ended, I can feel the vibrate but can't see from the screen, in any case, I wait some minutes try to connect usb cable from tablet to pc but nothing happen.

3) how do you get to finish the boot, with the aicp boot.img?

» Yes with aicp boot.img the tablet boot without issue, screen switch on and tablet usable.

4) then i wouldnt be surprised bluetooth (and other stuff) doesnt work.

» Surely the aicp boot cause the issues.

5) what we (well i) am trying to do is fix the boot problem we have on the lineage boot.img - not a combination of lineage system and aicp boot, that is bound to fail somewhere.

» Ok.

6) so please, if you could: flash the lineage zip, reboot, log. no shenanigans please.

» No I can't because 1 - 2 reply was my problem.

7) also, i would like to hear from castor users, they should not experience any problems at all.

Am on castor SGP521 LTE as you can see in the Pics of the (#35) post.

Many thanks for you hard work qsnc.
 

MaujuDroid

Member
Oct 28, 2017
16
2
3
1) you flashed, rebooted, and it didnt work?

» Yes, tablet vibrate but the screen doesn't switch on, remains black.

2) can you get logs from the failed boot?

» No because I can't see when the entire boot process is ended, I can feel the vibrate but can't see from the screen, in any case, I wait some minutes try to connect usb cable from tablet to pc but nothing happen.

3) how do you get to finish the boot, with the aicp boot.img?

» Yes with aicp boot.img the tablet boot without issue, screen switch on and tablet usable.

4) then i wouldnt be surprised bluetooth (and other stuff) doesnt work.

» Surely the aicp boot cause the issues.

5) what we (well i) am trying to do is fix the boot problem we have on the lineage boot.img - not a combination of lineage system and aicp boot, that is bound to fail somewhere.

» Ok.

6) so please, if you could: flash the lineage zip, reboot, log. no shenanigans please.

» No I can't because 1 - 2 reply was my problem.

7) also, i would like to hear from castor users, they should not experience any problems at all.

Am on castor SGP521 LTE as you can see in the Pics of the (#35) post.

Many thanks for you hard work qsnc