• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][matisse][millet] crDroid 7.13 [Beta]

Search This thread

IamTheBRAVE

Senior Member
for battery problem, IMHO I think is a bug on crDroid..
I've resumed a matisselte SM-T535 with crDroid 2.2 which have the same problem.. percentage battery works fine when up to 50% more or less, then collapse to 1%...
this evening I'll update tablet with version 7.12 downloaded here and I can send some feedback (y)
I've had that battery problem with my T531 for years now. Started around android 7 and happening on all custom roms. Battery % is reported incorrectly. Sometimes tab just powers off unexpectedly around 50%. Capacity (mAh) is still there. Recharging leads to overcharge.
I found the only way when it powers off, is to reboot into recovery. It shows actual battery percent (it needs to be unplugged before it finish loading) If it shows battery is empty, you can charge it for 5% or so. Unplg and reboot. It should stay the same. Then you can continue charge in system.
Hope i explained it well...
 

crazydrive22

Senior Member
battery problem still here.. I'm trying to investigate..
but I have a big problem using Magisk and LSposed, roms have incorrect SELinux rules that cause Riru not load correctly.. here more info with probabily fix: Riru repo
About the battery:
I've also faced a dropping but never from 50%.
I'll ask the crDroid-Devs.

About Riru:
I asked @matteo0026, who is managing the Device Sources. He told me, that this rule
(allow init system_file:dir relabelfrom)
isn't defined in our sources.
 

BoGnY

Senior Member
Aug 29, 2014
67
19
32
Treviso
Samsung Galaxy Tab 4
OnePlus 6T
I've had that battery problem with my T531 for years now. Started around android 7 and happening on all custom roms. Battery % is reported incorrectly. Sometimes tab just powers off unexpectedly around 50%. Capacity (mAh) is still there. Recharging leads to overcharge.
I found the only way when it powers off, is to reboot into recovery. It shows actual battery percent (it needs to be unplugged before it finish loading) If it shows battery is empty, you can charge it for 5% or so. Unplg and reboot. It should stay the same. Then you can continue charge in system.
Hope i explained it well...
yes, I've tested more roms yesterday, crDroid, Dirty Unicorns, LineageOS, with Android version 6 up to 11... Starting from Android 7 battery % is displayed incorrectly... maybe a bug on kernel source?

About the battery:
I've also faced a dropping but never from 50%.
I'll ask the crDroid-Devs.

About Riru:
I asked @matteo0026, who is managing the Device Sources. He told me, that this rule
(allow init system_file:dir relabelfrom)
isn't defined in our sources.
it's strange, but after some reboot Riru start working corrrectly 🤷‍♂️:ROFLMAO:
 

jirido

Member
Dec 3, 2021
8
0
Suomi
Hi I just installed and now it works fine. I do not know if it is crDroid or the gapps but I was forced to do some face recognition.. that was a bit traumatic and felt enforced as it not let me skip but just threw me back to gsettings over and over again. Maybe it was because I chose gapps nano and not pico. Also after whipng my /data I had no /data/data and had to format to ext2 and back to ext4 again to get /data populated.. That was a bit scary for me but it probably was my own fault also. Thanks
 

crazydrive22

Senior Member
Hi I just installed and now it works fine. I do not know if it is crDroid or the gapps but I was forced to do some face recognition.. that was a bit traumatic and felt enforced as it not let me skip but just threw me back to gsettings over and over again. Maybe it was because I chose gapps nano and not pico. Also after whipng my /data I had no /data/data and had to format to ext2 and back to ext4 again to get /data populated.. That was a bit scary for me but it probably was my own fault also. Thanks
Ah yes, Face recognition is a little buggy bc of the bad camera. You need propper light to get your Face scanned correctly. Formating /data is the best thing to do before the installation of a new ROM. You cannot damage the tablet with it but all your Data is gone, of course. A full and actual backup would be a good idea.
 

Exepan95

New member
Dec 4, 2020
4
0
Ukraine
vk.com
I can't download anything the error gives out
Безымянный.png
 

vitosulla

New member
Jan 28, 2019
1
0
Hi crazydrive22, thanks again for the great job.
I installed the new ROM with Gapps nano.
Google Play Services won't install me updates with memory full error. I have 6.9 GB available. I have already tried cleaning cache and data but to no avail.
Really strange ...
 

Nebuzaradan70

Member
Mar 6, 2021
12
2
Hi crazydrive22, thanks again for the great job.
I installed the new ROM with Gapps nano.
Google Play Services won't install me updates with memory full error. I have 6.9 GB available. I have already tried cleaning cache and data but to no avail.
Really strange ...
I confirm the same problem of blocking Play Services updates for full memory
 

crazydrive22

Senior Member
Hi crazydrive22, thanks again for the great job.
I installed the new ROM with Gapps nano.
Google Play Services won't install me updates with memory full error. I have 6.9 GB available. I have already tried cleaning cache and data but to no avail.
Really strange ...

I confirm the same problem of blocking Play Services updates for full memory
:oops: Dafuq?
I don't have that issue.
Please try to do a clean install and restore /data only, after you have booted it once.
Maybe this happend while dirty flashing
If it's not working, try a different GAPPS-Package to sort it out.
What Devices do you use?
 

Nebuzaradan70

Member
Mar 6, 2021
12
2
:oops: Dafuq?
I don't have that issue.
Please try to do a clean install and restore /data only, after you have booted it once.
Maybe this happend while dirty flashing
If it's not working, try a different GAPPS-Package to sort it out.
What Devices do you use?
Device: millet
I've already done everything you wrote before posting and twice.
I could at most try to use Gapp pico ...
 

Nebuzaradan70

Member
Mar 6, 2021
12
2
Reinstalled the ROM from scratch, I used Gapps Pico. Every problem solved.
The problem would appear to be somehow related to the Gapps Nano / Mini
 

redL1nE_87

Member
Feb 10, 2008
13
3
Hello everyone, I tried all firmware on 10-11, there is a problem with LiveDisplay everywhere, it stops working after turning off/on the screen, you have to activate it again in the settings. Reading mode does not work at all.Does anyone have these issues?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4

    crDroid is a LineageOS-based CustomRom.
    This one is based on LOS 18.1.
    Special Thanks to matteo0026, who is maintaining the device sources and TWRP.

    Disclaimer
    I am not responsible for lost data, identity theft, lost money, security vulnerabilities, bricked devices or any other hardware or software malfunctions or a nuclear war that comes as a result of flashing this ROM. Please make also be sure that you have always a full backup ready. Best to use: Nandroid Backup via TWRP


    Installation instructions :
    • Be sure to have installed the latest TWRP recovery (you can find it in downloads)
    • Download the latest build and GApps (ARM, 9.0, I advice pico package) and copy it to your external SD-Card
    • Make a full Backup of your Data and copy it to your external SD-Card or USB-OTG
    • Boot to recovery mode
    • Wipe > Advanced wipe > Select system, data, cache and dalvik/art cache (and, if you want to clean more, select even internal storage, which deletes all the content in /sdcard) and do swipe to wipe. Format /data. When it's finished go to home page
    • Install > select ROM zip file > swipe to flash and when it's finished go to home page
    • Do the same thing to flash GApps and Root (if needed)
    • Reboot > System
    Update instructions :
    • Be sure to have installed latest TWRP build
    • Download the latest build
    • Boot to recovery mode
    • Install > select ROM zip file > swipe to flash and, when it's finished go to home page
    • Reboot > System
    Known issues :
    • This ROM is [BETA] atm, but if you find anything, please tell me
    • SIM is not working for 3G-Variants (no fix so far)
    • Maybe Uplink to Chromecast not working
    Downloads :
    Other Stuff
    Contributors:
    crazydrive22, matteo0026 and all the S3NEO devs that provided the base for developing Pie on Tab 4

    Source Code:

    Thread started at 2021-06-13
    Thread updated at 2021-12-15
    4
    Well, well, well!

    Finally all new Builds are updated und uploaded.

    There could be an error with casting to Chromecast.
    If you have a Chromecast please try it and give me a short Feedback. Thx.



    Changelog:
    -July Security Patch
    -updated to crDroid 7.8
    -synced with LOS-Source
    -some changes under the Hood by @matteo0026
    3
    Heck me! Now crDroid updated to 7.8, after i am done with my monthly builds. :/

    Well, i'll update my builds, too and give you a ping as soon as they're ready.
    3
    New Builds with July Security Patch are up.
    2
    About battery, I need to use it more to confirm that mine works fine. I'll tell you more in the next days. I don't have that much time to use tab actually