• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][matisse][millet] LineageOS 18.1

Search This thread

Achsel

Senior Member
Jan 17, 2007
54
28
For testing purposes I installed the ACC Magisk module and the ACCA app on a Tab 4 (SM-T530) and set the charge limit to 80% in the settings. The charging indicator goes out, but charging continues anyway. I finished the test at 85%. On a Galaxy S4 phone with LineageOS 18.1, however, the charging process is correctly terminated at 80%.
 

matteo0026

Senior Member
Jul 1, 2015
1,363
776
21
Treviso
Lenovo P2
BQ Aquaris X Pro
For testing purposes I installed the ACC Magisk module and the ACCA app on a Tab 4 (SM-T530) and set the charge limit to 80% in the settings. The charging indicator goes out, but charging continues anyway. I finished the test at 85%. On a Galaxy S4 phone with LineageOS 18.1, however, the charging process is correctly terminated at 80%.
Ok, alright, then something should have be fixed in the kernel sources. I don't know what, by the way
 

rodunks

New member
Sep 6, 2021
1
0
Samsung Galaxy Tab 4
Moto G6
Incredible upgrading from Android 5 to 11.. no problems with opengapps. Only thing that may or may not be a relevant issue is Onedrive says it cant connect, even though browser works. Not going to worry about it though, just happy to see it hasn't slowed down at all and the ram usage is less than 1gb.
 

Donzi84

Member
May 2, 2020
21
0
I've never tested ACC in Tab 4. As I said before, I've never used these apps. By the way, you can control the charging in pretty every possible way. And to help yourself to setup the environment, use the app ACCA
I've testet ACC in Tab 4 8" and works fine. Charging stopped at 80% automatic. A question: when I push home button the tablet wake up in the desktop page closing the old app opening. Do you a method to push home button and wake up the tablet without going to desktop page?

God bless you
STefano
 

matteo0026

Senior Member
Jul 1, 2015
1,363
776
21
Treviso
Lenovo P2
BQ Aquaris X Pro
I've testet ACC in Tab 4 8" and works fine. Charging stopped at 80% automatic. A question: when I push home button the tablet wake up in the desktop page closing the old app opening. Do you a method to push home button and wake up the tablet without going to desktop page?

God bless you
STefano
I don't think there's a way to do it. You can simply wake up the tablet with power button and you won't go to the home page
 

Achsel

Senior Member
Jan 17, 2007
54
28
I've testet ACC in Tab 4 8" and works fine. Charging stopped at 80% automatic. A question: when I push home button the tablet wake up in the desktop page closing the old app opening. Do you a method to push home button and wake up the tablet without going to desktop page?

God bless you
STefano
@Donzi84
As already described in my Post 82, the ACCA app switches off the charging symbol in the display on my Tab 4 with 10", when reaching the 80% limit, but the charging is not stopped with connected charger as it is on my S4 phone. Can you leave your Tab 4 with 8"on the charger for longer after reaching the 80% limit to test whether charging is really stopped completely?

It greets you
Axel
 

Donzi84

Member
May 2, 2020
21
0
@Donzi84
As already described in my Post 82, the ACCA app switches off the charging symbol in the display on my Tab 4 with 10", when reaching the 80% limit, but the charging is not stopped with connected charger as it is on my S4 phone. Can you leave your Tab 4 with 8"on the charger for longer after reaching the 80% limit to test whether charging is really stopped completely?

It greets you
Axel
You have right. The charge doesn't stoped. Have you a solution? With the original ROM I've used battery charge limit app e it was working.

Thanks
Stefano
 

Achsel

Senior Member
Jan 17, 2007
54
28
As matteo0026 wrote in Post 83, something in the kernel sources should have to be fixed, perhaps a missing driver for battery charging in the deconfig file or something else. However, I do not have the knowledge to do this. Here is the link to the deconfig file from the Samsung Galaxy S4 phone with LineageOS 18.1, with which ACC/ACCA works.

https://github.com/LineageOS/androi...-18.1/arch/arm/configs/lineageos_jf_defconfig

It would be even better to compare the kernel sources from Android 5.0.2 ROM with those from LineageOS 18.1 regarding battery and charging, which would involve a lot of effort. So I don't think there is a simple solution for automatically turning off the charging function at 80% for the Tab 4 (for example: SM-T335 and SM-T530).
 

matteo0026

Senior Member
Jul 1, 2015
1,363
776
21
Treviso
Lenovo P2
BQ Aquaris X Pro
Hi Matteo, I've tested better Acc and it doesn't stop charge on tab 4 sm t335. Could you please test Acc acca on your tablet e let us know if it works fine? Keep your device in charge for long period after percentage you set.

God bless you
I'll inform you about this.
As matteo0026 wrote in Post 83, something in the kernel sources should have to be fixed, perhaps a missing driver for battery charging in the deconfig file or something else. However, I do not have the knowledge to do this. Here is the link to the deconfig file from the Samsung Galaxy S4 phone with LineageOS 18.1, with which ACC/ACCA works.

https://github.com/LineageOS/androi...-18.1/arch/arm/configs/lineageos_jf_defconfig

It would be even better to compare the kernel sources from Android 5.0.2 ROM with those from LineageOS 18.1 regarding battery and charging, which would involve a lot of effort. So I don't think there is a simple solution for automatically turning off the charging function at 80% for the Tab 4 (for example: SM-T335 and SM-T530).
I didn't remove any charger drivers, and I can't make a comparison between Tab 4 and S4 because they have completely different hardware. The best thing is to do a research on ACC and understanding what is needed to make this controller working properly.


This issue can explain even how to make this controller working if in kernel there isn't a support for charging status.
 

Achsel

Senior Member
Jan 17, 2007
54
28
@matteo0026
Thank you for the link:

https://github.com/VR-25/acc/issues/114

@Donzi84
Installation ACC ZIP file via Magisk:

Copy the ZIP file into the "/storage/emulated/0/Download folder", start Magisk, click on module symbol, then on "Installation from storage" in the top and choose the ZIP file. I tested these two versions, but it doesn't stop charging at 80%.

acc_v2021.8.4_.202108040.zip (Tip from kevin01523 in the first post)

acc_v2021.9.12_(202109120).zip

So I'm waiting for the new build from VR-25.
 

Donzi84

Member
May 2, 2020
21
0
@matteo0026
Thank you for the link:

https://github.com/VR-25/acc/issues/114

@Donzi84
Installation ACC ZIP file via Magisk:

Copy the ZIP file into the "/storage/emulated/0/Download folder", start Magisk, click on module symbol, then on "Installation from storage" in the top and choose the ZIP file. I tested these two versions, but it doesn't stop charging at 80%.

acc_v2021.8.4_.202108040.zip (Tip from kevin01523 in the first post)

acc_v2021.9.12_(202109120).zip

So I'm waiting for the new build from VR-25.
Hi Achsel,

did you try acc_v2021.9.13_(202109130).zip? does it work with Samsung tablet? Does it stop the charge?

Thanks
Stefano
 

Achsel

Senior Member
Jan 17, 2007
54
28
Even with this version the charging of the Tab 4 with 10.1" is not stopped at 80%. So I wait to see if VR-25 finds an issue in your log file and can fix it.

Thanks
Axel
 
  • Like
Reactions: Donzi84

Achsel

Senior Member
Jan 17, 2007
54
28
@Donzi84
Even with the versions 16.1 – 16.4 the charging of the Tab 4 with 10.1" is not stopped at 80%. As a result, I no longer have much hope, that VR-25 can fix the issue. He hasn't even commented on your log file.
 

FailSafeNow

Senior Member
Apr 3, 2020
78
13
I was out on the road today, and I was trying some GPS applications. They couldn't find anything. They had no clue where I was. Has anyone else had this problem? I want to rule out the rom before I go crazy with anything else.
 

matteo0026

Senior Member
Jul 1, 2015
1,363
776
21
Treviso
Lenovo P2
BQ Aquaris X Pro
I was out on the road today, and I was trying some GPS applications. They couldn't find anything. They had no clue where I was. Has anyone else had this problem? I want to rule out the rom before I go crazy with anything else.
GPS works fine. No doubts. I've just tested right now and I got as best precision 3 metres. The only thing is that you have to wait about 1 minute and it's better you are outdoor.
 

Donzi84

Member
May 2, 2020
21
0
I'll inform you about this.

I didn't remove any charger drivers, and I can't make a comparison between Tab 4 and S4 because they have completely different hardware. The best thing is to do a research on ACC and understanding what is needed to make this controller working properly.


This issue can explain even how to make this controller working if in kernel there isn't a support for charging status.
with VR-25 we are arrive to define a kernel problem. Is kernel in the lineage rom?

Thanks
STefano
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Update: I've gotten the phone to successfully find my location. I don't know whether it was just wrongly configured before, or what. I haven't yet been in a situation to see if it could actively track me, but it was able to find me initially, at least. I also don't know whether we fixed it, or it fixed itself. Still, thank you.
    1
    @Analogiker I saw you have done something with bluetooth while getting the logcat... I saw that 2 libs are missing, and one of those I've found online. Can you put the lib I put down below in /system/vendor/lib and get another logcat, always by repeating what you were doing with bluetooth? Of course, the zip file has to be extracted before. To put in that directory the library, I advice you to work in twrp file manager (by mounting system before).
    About wifi, I should do some tests, but I need a more direct contact with you. In this way, we can test things faster.
    Hi, I'm sorry for the delay. Had a on site meeting the last days (Without Internet :( ).

    When I came back home the wifi worked without problems. 5GH, 2.4GHz, roaming, restarting the device. Nothing breaks the Wifi Adapter. I really don't know what happened. I leaved the T530 at home and no one touched it. Really strange!!
    1
    I'm probably missing something obvious, but I haven't flashed any Samsung devices in years. Any help is appreciated.
    I'm getting a long hang at the LineageOS boot animation and eventually it just reboots into TWRP.

    What I've done:
    1. ODIN flash to "T530NUUEU1BQC1_T530NUXAR1BQC1_HOME"
    2. Boot up and save Bluetooth MAC address
    3. ODIN flash "twrp-3.5.2_9-0-matisse"
    4. Boot to TWRP, wipe all partitions, transfer Lineage and Gapps zips
    5. TWRP flash "lineage-18.1-20210923-UNOFFICIAL-matissewifi" and "open_gapps-arm-11.0-nano-20210929"
    6. Clear dalvik/cache and reboot
    Try the Gapps pico package. Were you on stock lollipop prior to this? You need to be on the latest stock rom (lollipop) for it to work.
    1
    Okay, next issue now that it's installed/working:
    When I try to update/install apps from the Play Store, I am told that I need to free up space.
    This is strange because there aren't any apps installed yet and I don't have anything on the internal storage and Settings > Storage shows over 11GB of free space. I'm assuming it's trying to install to the wrong partition or something like that.

    Also I found bluetooth was working fine after a clean install of Lineage with pico-build of OpenGapps so perhaps that bug has been fixed?
    Camera does not work, however.
    You have something wrong in your tablet, I guess, at firmware/partitions level. Restart from scratch by flashing stock lollipop with pit file. Bluetooth is working at 99% of cases, but in case bluetooth address is lost, I let the guide on how to recover it. I'm not sure if the issue is definetely fixed because I've never found the reason why it happened and, in case, how I fixed it.
    1
    Okay, next issue now that it's installed/working:
    When I try to update/install apps from the Play Store, I am told that I need to free up space.
    This is strange because there aren't any apps installed yet and I don't have anything on the internal storage and Settings > Storage shows over 11GB of free space. I'm assuming it's trying to install to the wrong partition or something like that.

    Also I found bluetooth was working fine after a clean install of Lineage with pico-build of OpenGapps so perhaps that bug has been fixed?
    Camera does not work, however.
    I just spent too much time with the same problem, multiple clean installs and "free up space" with no apps listed every time. Did you by any chance nuke the whole stock folder structure/ wipe internal memory?

    I had to flash the stock firmware again 5.1.1 which kept crashing at boot but still created the stock android folder structure in the internal memory, then I flashed TWRP using odin and LOS 18.1 and opengapps nano and finally was able to install apps after a clean install
  • 10
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Installation instructions :
    • Be sure to have installed latest TWRP recovery (you can find it in downloads) and latest Android Lollipop (5.0.2 for matisse, 5.1.1 for millet) firmware
    • Download the latest build and GApps (ARM) - if you'll go to wipe even internal storage, put them on a microSD or an USB OTG, or copy them after wiping it
    • Boot to recovery mode
    • Wipe > Advanced wipe > Select system, data, cache and dalvik/art cache (and, if you want to clean more, select even internal storage, which deletes all the content in /sdcard) and do swipe to wipe. When it finishes, go to home page
    • Install > select ROM zip file > swipe to flash and, when it finished, go to home page
    • Do the same thing to flash GApps
    • Reboot > System
    Update instructions :
    • Be sure to have installed latest TWRP build
    • Download the latest build
    • Boot to recovery mode
    • Install > select ROM zip file > swipe to flash and, when it finished, go to home page
    • Reboot > System
    Known issues :
    • Magnetic cover doesn't trigger magnetic sensor (it works, but it's too little sensible).
    • Some randomic minor issues with YouTube app (sometimes, after skipping ads in a video, you'll get just a grey screen - close and reopen video to fix the issue)
    • Some randomic issues with bluetooth MAC address (bluetooth app crashes always). To fix this, you need to get (take note!) the address by going to stock ROM and getting that from Settings > About tablet menu. Then, come back to LineageOS 18.1 and rewrite the file /efs/bluetooth/bt_addr by using root permissions and a root file explorer, or by using adb push/pull, better in TWRP.
    • In matisse3g and millet3g SIM isn't working
    Downloads :
    Contributors
    matteo0026, DJABHipHop, Alastor89, All the S3NEO devs that provided the base for developing Android 11 on Tab 4
    Source Code:
    3
    New build of LineageOS 18.1 is online!
    Changelog:
    - August 2021 security patches
    - For millet*: fixed inverted audio channels through jack
    3
    Lineage 18.1 on my Tab4, amazing!!
    Coming from 16, did a clean install.
    I updated TWRP within TWRP.
    Cleaned/cleared as per usual
    Installed latest 18.1 (millet)
    Installed open gapps pico-20210130-TEST
    Installed magisk 23 as zip.
    Waited a few minutes and boom! So far, runs as smooth as butter and fairly nippy considering the base specs and age.
    I've only run/tested the basics. Installed Firefox&ublock and Mixplorer.

    Thank you matteo0026 for keeping the device alive, really appreciate your efforts.
    2
    You can also use Nikgapps for LOS 18.1. The core package would be comparable to Gapps pico.


    @matteo0026 Thanks for LOS 18.1. As 17 seems stable, I'll be stick with that for now on my SM-T530NU.
    NikGapps is arm64-only.
    2
    Is gesture navigation available in the settings for you? It doesn’t show up for me, but I’m not sure if it’s because that’s just how the rom is or if it has something do to with what I’ve added on top of it.
    Probably, by using hardware buttons, those settings are disabled. To re-enable them, put in /system/build.prop file: qemu.hw.mainkeys=0 and software buttons and gestures settings should come up.