• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][MediapadM5][8.1] LineageOS 15.1

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 24

    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working :
    • Boots
    • Wifi
    • Bluetooth
    • Camera ( Videos And Photos )
    • Video Playback
    • Audio ( Record and Playback )
    • Sensors
    • GPS

    What's not working :
    • You tell me :)

    Instructions :
    • Make a Backup of your Internal Storage
    • Download the latest build and gapps
    • Flash my TWRP Build
    • Make a full Wipe if you coming from StockRom, then Format Data (Attention this will wipe your Internal Storage)
    • Reboot to recovery
    • Flash my Remove Encryption file: Download if you want to backup your data afterwards when you installed LineageOS
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][UNOFFICIAL][MediapadM5][8.1] LineageOS 15.1, ROM for the Huawei MediaPad M5

    ROM OS Version: 8.x Oreo

    Version Information
    Status: Beta

    Created 2018-07-08
    Last Updated 2018-07-08
    I was unable to get this ROM to work with SHT-W09 (8" WIFI only, EU model). It got stuck in a boot loop. So I had to reload the stock firmware (it was painful to find a method).

    I used the 'russian website' to find the link to the official Huawei firmware and downloaded from Huawei's servers. I took firmware (It was published at a later date than yet has a lower version number - wierd?) Double check that the firmware corresponds to your model SHT-W09/SHT-AL09 etc - I made this mistake. I guess that the region is also important - for EU I took C432.

    To recover to stock firmware I used the TWRP ROM in schwabe93's other post (https://forum.xda-developers.com/mediapad-m5/development/recovery-twrp-3-2-2-1-t3813825). To reload the stock firmware I followed the instructions in Tutorial 2 https://forum.xda-developers.com/p10/how-to/guide-manual-updgrade-to-update-oreo-t3758286. I copied the oreoupdater folder to an external SD card which was formatted as exFAT. In TWRP file manager I also copied from the external SD to the root of the internal SD.

    In TWRP I started the zip flash from the internal SD as per the tutorial 2 instructions. It rebooted and installed the 163 firmware.

    I can't remember exactly what I did after the update was completed, but it was something along the lines of: rebooting several times, using the built in EMUI recovery to low level format, then reboot then clear cache then wipe data then reboot a few more times.

    If the EMUI recovery doesn't work after installing the stock ROM then you can try using fastboot to reload the recovery from the img files that you extracted from the full firmware zip file i.e.:
    fastboot flash recovery_kernel RECOVERY_KERNEL.img
    fastboot flash recovery_ramdisk RECOVERY_RAMDISK.img
    fastboot flash recovery_vbmeta RECOVERY_VBMETA.img

    Hope this helps!

    Also for the benefit of others, it took me a while to work this out:

    Reboot - hold down the power button.
    Fastboot - As soon as it boots, and just before the mediapad screen, hold the volume down button WITH the USB cable connected.
    Recovery - Hold down the power button and volume up WITHOUT the USB cable connected.
    I thought so. That's the reason why I'll return my M5

    It really is a piece of trash, this tablet, and **** Huawei for being ignorant greedy pricks, taking our community's hard work, and then stealing our personal property through bootloader locks. It should be illegal under right-to-repair and personal property ownership legislation. But, I digress.

    You can fix the pixelation on the latest OmniROM builds by enabling "Disable HW overlays" in the developer options. Note the toggle isn't permanent; you'll need to do something with Magisk or use Tasker + Secure Settings (on boot) if you don't want to toggle it manually each time.

    Telegram Group for MediapadM5:
    Join :)
    Can you send me the link to the RR rom download page, thanks.


    It says beta but everything works and no crashing. This will work even with custom recovery even though the page instructions say use stock recovery