[ROM][UNOFFICIAL][montana][11] LineageOS 18.0

Lyra2108

New member
Dec 13, 2020
1
0
1
The build is working fine for me, the only thing i noticed that (for me randomly) the camera is unusable, some apps report someother app is using it, but i can not see any app running which would use the camera, the native camera app just keeps crashing.

The only way I could fix it sofar was rebooting the device.

If there is a way i can provide debug information, I would be glad to help :)
 

Hausemaster

Senior Member
Dec 2, 2020
189
56
38
Translation: Hello everyone in my 1974 g5s moto does not go
Do you mean that this rom is not working on your device?
If so, first make sure that you followed the instructions provided by the OP,
Secondly, try starting from stock ROM for best results,
Thirdly, make sure that you are using the latest version of TWRP,
if either of these do not work, I think @JarlPenguin will definitely help you.
Note: the developer, i.e @JarlPenguin mentioned that he won't be updating this rom until the Lineage OS 18.1 source is fully ready, if you find this ROM too buggy for daily use, then downgrade to Lineage OS 17.1, it's stable and also is built by @JarlPenguin...
 

saropoggi

Member
Dec 25, 2020
10
0
1
kind sir the rom works very well to two important problems the first is that the mobile internet does not work and then the obb folder I don't want to create but it tells me that it already exists I hope that I have explained myself
 

Hausemaster

Senior Member
Dec 2, 2020
189
56
38
if there is anyone who can correct this rom it would be wonderful
Lineage OS 18.1 source is not fully ready, and also, the developer of this rom mentioned that he will continue developing the rom after the source is fully ready, till then just report bugs if you find any, don't expect them to be solved immediately, as mentioned the development and active bug fixing will start after the source is fully ready, till then if this rom is too buggy use the Lineage OS 17.1 rom for now as it's stable...
 

Moto bari

Member
Dec 30, 2020
7
0
1

Code:
#include <std_disclaimer.h>

/*
* Your warranty is now void.
*
* We are not responsible for bricked devices, dead SD cards,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at us for messing up your device, we will laugh at you.
*
*/
LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

Instructions:
  • Download the latest build, official TWRP (3.3.1 and newer) and GApps (if you need them)
  • Flash the downloaded TWRP via fastboot
  • Boot to recovery
  • Format system, vendor, data, cache, and dalvik cache
  • Reboot to recovery
  • Flash the latest build
  • Flash GApps and any other necessary add-ons

Note: Long first boot times are normal due to forced encryption. Please do not reboot your device when it is booting up the first time, instead wait patiently. If it takes more than 10 minutes to boot then please notify me here with a logcat.

What's working:

  • WiFi
  • Camera
  • Bluetooth
  • Fingerprint - Oreo firmware required
  • GPS
  • OTG
  • Video Playback
  • Audio
  • RIL
  • VoLTE/VoWiFi
  • USB tethering/audio

Known issues:
  • Camcorder
  • FM Radio
  • NFC
  • SELinux: Permissive
  • You tell me

Downloads:
  • Unofficial build: GitHub
  • Recovery: Official TWRP
  • Google Apps: OpenGApps (nano package is advisable, but you definitely should avoid using stock/super packages)

Reporting Bugs
  • All bugs should be reported here: Issue Tracker
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:

Did you--
wipe:
restore with titanium backup:
reboot after having the issue:

Are you using--
a task killer:
a non-stock kernel:
other modifications:

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
Thanks to:
@GivFNZ for testing my builds
@wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
LineageOS team

Changelogs:

Code:
2020-10-13:
Initial release.


Source code:

XDA:DevDB Information
LineageOS 18.0 for Moto G5S, ROM for the Moto G5S

Contributors
JarlPenguin, electimon, wiktorek140, AsD Monio, karthick mostwanted, wh0dat
ROM OS Version: Android 10
ROM Kernel: Linux 3.x
ROM Firmware Required: Oreo
Based On: CyanogenMod/AOSP

Version Information
Status:
Alpha

Created 2020-10-13
Last Updated 2020-10-13
Bootloader is not unlocked what to do