[ROM][UNOFFICIAL][montana][9.0.0_r46] LineageOS 16.0

Search This thread

Rush

Senior Member
Apr 19, 2019
763
130
neuss
OnePlus 5T
TWRP 3.4 is definitely buggy...
I tried to flash EVA kernel, this time unmount was a success, but I got an error 1 no ramdisk found...

Edit : or maybe it is the zip that is not suitable for these builds ?
Yes
Current kernels aren't suited for newer builds yet

As soon as the "new format" aka SAR is finished and working just as fine as older builds, SAR Versions will probably be made
 
  • Like
Reactions: Dan Mornill

JarlPenguin

Recognized Developer
Oct 16, 2018
1,021
943
Earth
github.com
Moto G5S
Moto G7
TWRP 3.4 is definitely buggy...
I tried to flash EVA kernel, this time unmount was a success, but I got an error 1 no ramdisk found...

Edit : or maybe it is the zip that is not suitable for these builds ?
Ramdisk is not included in boot images of system-as-root builds, it was moved to /system
Hence the name system-as-root, before ramdisk in boot image was mounted at root, but now system has ramdisk and is mounted as root. This is why actual Android system path in SAR is /system/system (depending on mount point). Boot image only has kernel.
 
Last edited:

JarlPenguin

Recognized Developer
Oct 16, 2018
1,021
943
Earth
github.com
Moto G5S
Moto G7
https://build.twrp.me/twrp-3.4.0-0-montana.img - should fix most issues, forceencrypt disabler (if flashed) should always be flashed last after ROM and add-on flashing. GApps seems to persist, not definitely tested yet. Feedback appreciated.
Clean flash instructions:
Boot TWRP
Format system, data, vendor, cache, dalvik
Reboot to recovery
Flash LOS zip
Reboot to recovery
Flash any add-ons (if you want to)
Flash forceencrypt disabler (if you want to)
In order to get GApps to persist across dirty flashes (warning: not tested, probably only needs to be done once if you already had LOS installed before, if clean flashing this shouldn't be needed)
Boot to TWRP on existing SAR build with GApps installed
Dirty flash LOS SAR
Flash OpenGApps
Reboot to device
See if OpenGApps is there
Reboot to TWRP
Dirty flash LOS SAR
Reboot to device
--> GApps should still be there.

Update: GApps indeed does persist across dirty flashes. Please use the linked build.
Also, for anyone curious, a reboot to TWRP is required after flashing LOS in a clean flash to flash other add-ons so that TWRP can apply needed changes after recognizing the system as Android 9 SAR (since before flashing system partition is empty and therefore detection of installed system is impossible).
 
Last edited:

JarlPenguin

Recognized Developer
Oct 16, 2018
1,021
943
Earth
github.com
Moto G5S
Moto G7
A new update is available (in case you haven't noticed). The changelog and downloads are in the OP, as always. Thanks for using this ROM.

Since this is the first stable release, I'd like to thank @karthick mostwanted and @wh0dat for the excellent trees, @wiktorek140 for helping me with the kernel, and last but not least @GivFNZ for testing the majority of my test builds.
 

Dan Mornill

Senior Member
May 7, 2019
102
11
SELinux: Enforcing ?

Edit : just dirty flashed it, apart from the same first boot that doesn't complete, all is fine ?
 
Last edited:

Dan93.

New member
May 29, 2019
3
0
Yesterday I flashed newest version of img (beta 1.0), and after third reboot my smartphone comes to bootloop. Today i did latest twrp 3.4.0.1 and again flashed same latest img. I do 5 times reboot and have no problem, but when i did some changes in user interface and again did reboot, smartphone comes in bootloop. I think there is problem. Sorry for my bad english, im not a native speaker.

The same thing happens to me, my phone froze, it did not start again.
 

Remaxz

New member
Aug 28, 2020
1
0
Anyone can compile the rom, kernel with USB driver ch341 arch64 please? I try to compile and haver no sucess
 

sakaaz1

Member
Aug 28, 2020
5
0
Hi thank you JarlPenguin for your work.
I tried to flash your last LOS 1.0 with no success, I'm stuck in bootloop. I'm waiting more than 20 minutes still stuck at loading starting page.
I wipe everything, tried to adb sideload nothing success.
 

Dan Mornill

Senior Member
May 7, 2019
102
11
Have you got bootloop or are you stuck on first boot ?
It's not the same.

For a reason I do not know, SAR builds cannot complete first boot properly after clean flash, you need to force a reboot in order to use it. Bur after it works very well.
 

sakaaz1

Member
Aug 28, 2020
5
0
Have you got bootloop or are you stuck on first boot ?
It's not the same.

For a reason I do not know, SAR builds cannot complete first boot properly after clean flash, you need to force a reboot in order to use it. Bur after it works very well.

I'm stuck on my first boot.
I already try to force a reboot multiple time but still stuck my device won't boot.
 

JarlPenguin

Recognized Developer
Oct 16, 2018
1,021
943
Earth
github.com
Moto G5S
Moto G7
Hello, unfortunately this issue is quite hard to debug, so if you can assist me by providing logcats, that would be helpful. It would also help if you could figure out if the problem disappears after forcing SELinux into permissive mode.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    
    /*
     * Your warranty is now void.
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Instructions:
    • Download the latest build, official TWRP (3.4.0 and newer) and GApps (if you need them)
    • Flash the downloaded TWRP via fastboot
    • Boot to recovery
    • Format system, vendor, data, cache, and dalvik cache
    • Reboot to recovery
    • Flash the latest build
    • Reboot to recovery
    • Flash GApps and any other necessary add-ons

    Note: Long first boot times are normal due to forced encryption. Please do not reboot your device when it is booting up the first time, instead wait patiently. If it takes more than 10 minutes to boot then please notify me here with a logcat.

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE/VoWiFi
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • You tell me

    Downloads:
    • Unofficial builds: GitHub
    • Recovery: Official TWRP
    • Google Apps: OpenGApps (nano package is advisable, but you definitely should avoid using stock/super packages)

    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team

    Changelogs:

    Code:
    2020-09-18:
    Added support for Color profiles (Settings > Display > Colors)
    Fixed an issue where you couldn't connect to certain Wi-Fi networks
    Fixed offline charging
    Fixed bootloop when enabling secure startup
    Fixed dual SIM menu not appearing
    Mobile data settings now only displays 3 modes (LTE, 3G and 2G)
    September security patch
    
    2020-08-24:
    First stable release of LineageOS 16.0
    SELinux: Enforcing
    Widevine level is now L1
    OTA updates
    Minor tweaks and bug fixes
    
    2020-08-17:
    Fixed an issue where the navigation bar would not disable respective to the toggle in Settings
    
    2020-08-16:
    Fixed an issue where some applications on the Google Play Store were listed as incompatible with the device
    Fixed an issue where Moto Camera was unable to be updated from the Google Play Store
    August security patches
    
    2020-06-24:
    Improved overall stability and performance
    Updated blobs from deen_sprout (Moto One) and tissot_sprout (Xiaomi Mi A1)
    Fixed a crash that happened while taking photos when recording videos
    Included Moto Camera instead of Snap - has slow-motion, supports front flash properly
    Updated camera and fingerprint blobs from stock OPPS28.65-37-7-12
    Now we are mounting system as root (/system at /)
    Now we verify vendor, so make sure not to tamper with it
    Updated kernel with recent CAF tags merged
    June security patches
    
    2020-01-24:
    Enforced VNDK linker namespace isolation.
    
    2020-01-16:
    January security patch
    
    2020-01-01:
    Fixed NFC on XT1793/4 (thanks to @CypherNoodle for helping me)
    Fixed compass on XT1790/1
    Fixed "There's a problem with your device." error (thanks to @wiktorek140)
    Fixed MTP (thanks to @Sohamlad7)
    
    Thanks to @Giv314, @CypherNoodle and @wiktorek140 for testing this build!
    
    2019-12-05:
    New tree
    Updated lots of blobs
    Fixed encryption
    November security patch
    
    2019-08-12:
    August security patch
    New tree
    Updated offline charging blobs
    Updated fingerprint blobs
    Updated perf configs
    Disabled OTA
    Added vector icons for Ambient Display and Fingerprint gestures in Moto Actions
    Enabled vibrating for "Flip for DND" action
    Made default Hotspot name "Moto G5S"
    Enforced privileged apps permissions
    Kernel upstreamed to match some changes at CAF
    
    If you're coming from an update before v0.11, please flash https://github.com/MontanaDevelopment/releases/releases/download/LOS16-12/lineage-migration-unsigned.zip before booting this update.
    
    2019-07-07:
    July security patch (for real).
    Fixed Hotspot.
    
    2019-07-05:
    Project Treble support! Thanks a lot to [user=6879971]@AsD Monio[/user] for his commits
    July security patch
    Other LineageOS source updates
    
    2019-06-27:
    June security patch.
    LineageOS source updates.
    Updated device sources from CAF.
    Removed useless blobs.
    Fixed VoLTE.
    Added zram support for Moto G5S' with 4GB of RAM.
    Fixed video recording on Snap and switched to Snap.
    Lowered minimum brightness.
    Some audio optimizations.
    Fixed call recording.
    Kernel compiled with clang.
    Smoothened vibrations.
    Updated media configs.
    Enforced Oreo bootloader.
    
    2019-06-02:
    Fixed Wi-Fi Display (Miracast).
    Removed NFC stuff on XT1795s.
    Upstreamed kernel to 3.18.140.
    Fixed Moto Actions crash (only affects select handsets).
    Removed DTV (Digital TV) as none of our handsets support it (as far as I am aware of).
    Addressed some denials.
    
    2019-05-16:
    Fixed encryption.
    May security patch.
    Changed from LTE icon to 4G.
    Device model now includes Moto G5S.
    Fixed some SEPolicies (thanks [user=6879971]@AsD Monio[/user]).
    Upstreamed kernel to 3.18.139.
    Android 9.0.0_r35 --> Android 9.0.0_r37.
    
    2019-04-29:
    First signed build.
    Fixed low audio bug
    Fixed navigation bar toggle (is now there in Settings > System > Buttons)
    Add correct HAL1 packagelist for fixing certain apps with HAL3 enabled
    Updated blobs
    OTA updates should work now.
    
    Use [url]https://github.com/montanadevelopment/releases/releases/download/LOS16-6/lineage-migration-signed.zip[/url] to migrate from unsigned to signed builds (flash after flashing ROM)
    
    2019-04-24:
    Fixed front flash & USB tethering. Thanks to @wiktorek140
    
    2019-04-17:
    Bundled Open Camera instead of Snap.
    Disabled Camera2 API (HAL3) and EIS by default.
    These changes fix video recording, once and for all.
    Native support for repaired "tianma" kernels.
    
    2019-04-13:
    Upstreamed kernel to 3.18.138 from 3.18.113
    Updated GPS, DRM, encryption blobs
    Support for LiveDisplay 2.0
    WiFi calling in supported countries
    Oh and April security patch ofc
    
    2019-03-16:
    Fix broken recording on stock camera.
    Enabled Camera2 API and EIS by default. Blacklisted stock and Moto Camera app for compatibility.
    
    2019-03-15:
    Initial release.


    Source code:

    XDA:DevDB Information
    LineageOS 16.0 for Moto G5S, ROM for the Moto G5S

    Contributors
    JarlPenguin, AsD Monio, wiktorek140, GivFNZ, karthick mostwanted, wh0dat, rajatgupta1998
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.x
    ROM Firmware Required: Oreo
    Based On: CyanogenMod/AOSP

    Version Information
    Status: Stable
    Current Stable Version: 1.1
    Stable Release Date: 2020-08-24
    Current Beta Version: 1.0b3
    Beta Release Date: 2019-03-15

    Created 2019-03-15
    Last Updated 2020-09-18
    11
    Hello,

    New LineageOS 16.0 build avaiable here (https://sourceforge.net/projects/mo...16.0-20200502-UNOFFICIAL-montana.zip/download)

    CHANGELOG:
    - default kernel included (radium compatibility)
    - fixed error in AudioFX
    - April security patches
    - Minor tweaks
    - fixed "Internal error" on eva kernel

    INSTALLATION:
    - Make a backup
    - flash rom zip via recovery
    - Optional instalation step
    - install additional mods (magisk, gapps, audio mod etc.)
    - reboot to system

    WARNING! First boot may take ~10 min!

    ADDITIONALS:
    - Prebuilded ProjektEva kernel here (https://sourceforge.net/projects/montana/files/3.18/ProjektEva/boot-projekteva-20200503.img/download - !!!MAGISK PREFLASHED!!!)
    Optional instalation step:
    - Install boot-projektEva-2020-05-02.img as image into BOOT partition
    9
    If anyone is wondering what happened, I've been really busy these past few weeks, so that is why no updates have been launched.

    On the other hand, sneak peek into next update:
    Fixed video recording in Snap, Moto Camera, etc. (Partly thanks to @AsD Monio)
    Project Treble (Team effort of me and @AsD Monio)
    Fixed time resetting on reboot
    Updated lots of blobs
    And more
    7
    Hello, everyone! I have good news! Wi-Fi is FIXED! Thanks a lot to @wiktorek140 (for reading & helping me with logs) and @GiovaniFNZ (for testing all of my builds) on Telegram. Now all that is left is fixing Moto Actions, which is pretty much a piece of cake.