• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][UNOFFICIAL] Omnirom for zenfone8 [Android-11]

Search This thread

micky387

Senior Member
Sep 9, 2011
2,778
2,741
Lyon
omnirom_logo-big_layout_transparent-e1381615771697.png


What is Omnirom ?


Selinux Status:
Enforcing

Instructions :
Follow this Steps by steps

You need to be on lastest stock firmware Please.

Knows isues:

Somtimes, FOD is weird...
FOD on AOD not working for the moment

* Remove all Security pwd/pin/pattern on you current Rom
* Download the ROM (see Dl section)

************************************************************
For the first install.
************************************************************
- reboot to fastboot (fastboot reboot fastboot or adb reboot fastboot, depend if you're on running system or bootloader)
- fastboot flash procedure (Use this flash cmd with the stock boot.img):

fastboot flash boot boot.img
fastboot flash dtbo dtbo.img
fastboot flash system system.img
fastboot flash system_ext system_ext.img
fastboot flash product product.img
fastboot flash vbmeta vbmeta.img

fastboot flash vbmeta_system vbmeta_system.img

- reboot recovery and wipe userdata ( make an save of your videos/pictures before, you will loose all your data)
- reboot system
- profite :)


************************************************************
Update Rom
************************************************************
- Go to settings -> system --> system updates --> (enable local flash) select the zip file and flash --> reboot

if u did something else. we dont need/wanna know about it in the thread


Device Maintainers
@micky387


What's not working ?
Smartkey didn't work for the moment...

ROM OS Version: Android 11
ROM Kernel: Linux 5.4


Download:
First install - Package zipped with all partitions (GAPPS)
First install - Package zipped with all partitions (MicroG)

Telegram Group:
What's our MicroG version ?
OmniROM zenfone8 chat
Official OmniROM Community

Source Code
Omnirom
Omnirom gerrit

XDA:DevDB Information
Omnirom for zenfone8, ROM for the ASUS zenfone8, Rom Asuszenfone8

Contributors

micky387
ROM OS Version: Android 11
ROM Kernel: Linux 5.4
ROM Firmware Required: Lastest stock Asus Official website for the firmware

Version Information
Status:
Stable

Created 2021-06-26
Last Updated 2021-06-26
 
Last edited:

DerSteppo

Senior Member
Aug 10, 2017
202
52
Frankfurt
ASUS ZenFone 8
Nice work, thanks a lot!

I just noticed; On the OmniROM website, it says that the version for ZenFone 8 is official. Also, there is a picture of the ZenFone 6. Maybe you can bring this up with the maintainer of the website. :)
 
  • Like
Reactions: michelinoO
Using the ROM in the original post is great. Do we report bugs here?

SIM 1 doesn't work. It'll show your carrier but won't work. I tried with 1 and 2 SIMs at once. Only SIM 2 will work.
When you select the option to hide the nav bar (which is great because then it pushes the keyboard down), even if you're using gesture navigation, the back gesture stops working. Hiding the pill isn't as good because the keyboard and some apps leave a huge gap at the bottom.

Not necessarily a bug, but it looks like the GAPPs version can't get system updates? What's the best way to have Google apps but also utilize the system updates feature. (I know there probably aren't any updates available at the moment.)
 

assasss

Member
Jun 14, 2012
44
12
ASUS ZenFone 8
I would really appreciate if someone who is anyway gonna try this ROM and use it to post some kind of short review. I am mostly interested in stability, battery life and camera (as usually on custom ROMs camera quality is way worse compared to stock)
 

randman2011

Senior Member
Mar 25, 2013
212
120
Cincinnati
OnePlus 5
ASUS ZenFone 8
I don't know if this is coincidence or ROM-related, but has anyone else had adb and fastboot problems? Since flashing the June version of OmniROM I can't get my computer to recognize my phone in fastboot or recovery ADB. Nothing shows up in Device Manager at all.

Everything works fine from within Android, but once I get into recovery it's just silence. Same symptoms on my Win10 desktop, Win10 laptop, and terminal on OnePlus 5. As far as I'm aware I can't update the ROM, restore factory firmware, or root the phone without fastboot and/or ADB.

EDIT: I tried several other Windows, Linux, and Android devices and none would even acknowledge that I had plugged something in, but yesterday I tried my mom's ASUS laptop and my phone showed up in Device Manager without even needing drivers. I was able to fastboot flash TWRP and update the ROM. I still have no explanation for why so many devices didn't work or why this one did, but at least all of that is behind me.
 
Last edited:

Top Liked Posts