[ROM][UNOFFICIAL][RAMDISK][11] LineageOS 18.1 for Galaxy S10e/S10/S10+/S10 5G Exynos

Search This thread


Jan 22, 2019
Extract dtb.img from my latest LineageOS build, pack it into a .tar flash that (I think for making Odin flash it you will need to rename it to dt.img and then pack it into a tar archive), should resolve that issue.
thanks again for your help. I did it, flashed with odin ap. Now, the message changed to Check Fail. Device: 11, Binary:8 (DTBO)

I flashed you DTBO too, now i can access the lineageos recovery :D


Jan 22, 2019
Do the same thing with dtbo.img from lineage zip (just that you don't need to rename it in this case)
flashed you DTBO too, now i can access the lineageos recovery :D. In recovery, i formated data like descripted, at the moment, i am flashing. Is there a possibility to sponsor you a coffee? Greetings


Senior Member
Hello, On no, it stopped with 47% serving on cmd, (for 10 minutes no change), on mobile there is writen "Restoring Google Services Framework". Any idea? Thank you very much.
That 47% thing is a common "bug" when using sideload (also on other devices) but it's not really a problem, the output on device's display is what really matters
Where do you get that message? For sure that's not from recovery


Jan 22, 2019
That 47% thing is a common "bug" when using sideload (also on other devices) but it's not really a problem, the output on device's display is what really matters
Where do you get that message? For sure that's not from recovery
I don't know what i did wrong, i repeated whiping and installing, now LinageOS bootscreen apppears correctly and system boots
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I managed to patch the system in order to enable signature spoofing for MicroG by following this guide. Here is a zip file I created for my s10e with a patched services.jar one must flash via Magisk.

    With the latest update of the ROM I get stuck on loading lineage screen with this module activated in Magisk maybe need an update

    @flortsch Do you have the same problem ?

    If you have same problem you can try this version I just made based on @flortsch linked tuto

    And it works fine for me :)
    Well this just got weird. It seems that youtube music (vanced) is removed (as in uninstalled/gone) after such a reboot happens. This does not happen if i manually reboot.

    The reset reason is also system_server...

    The first would hint at a root/vanced issue, but the latter more LOS. Weird stuff. Anyone got some thoughts on this?

    Edit: appears that this is a known bug that should've been fixed, but the fix probably didn't account for this type of reboot. Also happens without vanced installed. I'm just going to hope it doesn't happen when I get a call...
    Instead of youtube/vanced you can give NewPipe a try - from FDroid store. It offers a lot of good OSS stuff.
    @Linux4 Would you be so kind to post your roomservice.xml? I'd like to use your repository to try building LOS18 myself. Thank you!
    <project name="LineageOS/android_device_samsung_slsi_sepolicy" path="device/samsung_slsi/sepolicy" remote="github" revision="lineage-18.1" />
    <project name="LineageOS/android_hardware_samsung" path="hardware/samsung" remote="github" revision="lineage-18.1" />
    <project name="LineageOS/android_hardware_samsung_nfc" path="hardware/samsung/nfc" remote="github" revision="lineage-18.1" />
    <project name="exynos9820-dev/android_device_samsung_beyond1lte" path="device/samsung/beyond1lte"  remote="github" revision="lineage-18.1" />
    <project name="exynos9820-dev/android_device_samsung_exynos9820-common" path="device/samsung/exynos9820-common" remote="github" revision="lineage-18.1" />
    <project name="exynos9820-dev/android_kernel_samsung_exynos9820" path="kernel/samsung/exynos9820" remote="github" revision="lineage-18.1" />

    Thank you! Question: How do you include vendor files from android_vendor_samsung_exynos9820-common? I dont want to pull those files from the phone but from the repository instead. Any idea on that?

    Just add add the vendor repos for the devices you need to the roomservice.xml like this:
        <project name="exynos9820-dev/android_vendor_samsung_beyond1lte" path="vendor/samsung/beyond1lte" remote="github" revision="lineage-18.1" />
        <project name="exynos9820-dev/android_vendor_samsung_exynos9820-common" path="vendor/samsung/exynos9820-common" remote="github" revision="lineage-18.1" />
    i was using S10+ stock with root and magisk and twrp for the last years. Today i flashed Lineago OS recorvery like descripted, but i can't access recovery with Volume up, power and bixby. it just shows the red message. So i flashed https://androidfilehost.com/?w=files&flid=315865 in the hope to make it work, and reflashed LineageOS recorvery like descripted here. Now it's just staring over and over again. Any help possible?

    Edit: in the top left corner there is writen in a text box:
    Rev. Check Fail. Device: 8, Binary:2 (DTBO)
    You were on Pie firmware before by any chance?
    Also on download page there's a link "Firmware update" you could try with this
  • 31

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    • Follow the instructions here


    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • DO NOT Report bugs if you're using TWRP
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Telegram group

    Source Code: https://github.com/exynos9820-dev

    • SELinux enforcing
    • AES-256-XTS FBE encryption
    • Latest Linux 4.14.x kernel
    • All cameras are working
    • Ramdisk is working

    Known issues

    • Miracast not working (Google removed it in AOSP Pie)
    • VoLTE/VoWiFi
    • You tell me
    • Any Q or R based firmware installed on your device.

    Pre-Install Instructions

    Warning: The following instructions will unlock the bootloader and wipe all userdata on the device.

    1. Connect the device to a Wi-Fi network.
    2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
      • From within the Developer options menu, enable OEM unlock.
    3. Power off the device, and boot it into download mode:
      • With the device powered off, hold Volume Down + Bixby and connect USB cable to PC.
      • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”.
    4. Your device will reboot, you may now unplug the USB cable from your device.
    5. The device will demand you format userdata, please follow the onscreen instructions to do so.
    6. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
    7. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu.

    Installing LineageOS for the first time
    1. Flash lineage recovery and a disabled vbmeta image
      Only the provided lineage recovery will be supported,
      using TWRP might result in a possible data loss!!

      If using Odin rename the lineage recovery image for your model to recovery.img and add it to a .tar archive using e.g 7zip
      together with a disabled vbmeta image.
      If using Heimdall use: heimdall flash --RECOVERY recovery.img --VBMETA vbmeta.img --no-reboot
      You can find a disabled vbmeta image attached to this post.
    2. Boot lineage recovery
      IMPORTANT: Do not boot into system again before booting recovery, or system will restore stock recovery!
      If using Odin untick auto-reboot before flashing.
      After flashing reboot by pressing Volume Down and Power for approximately 7 seconds,
      immediately hold Volume Up, Bixby and Power to boot recovery
      IMPORTANT: As of OneUI 3 your device needs to be connected to a PC via USB cable in order to be able to
      boot recovery via Volume Up, Bixby and Power.
    3. Factory reset using Factory reset -> Format data/factory reset
      Warning: Unlike TWRP this will also erase internal storage!
    4. Sideload LineageOS by enabling sideload via Apply Update -> Apply from ADB
      Then run adb sideload <path to your lineage.zip> on your PC
    5. Sideload GApps and magisk by repeating above step
      with their zip/apk

    As this ROM has a working ramdisk sideloading the magisk apk is enough, just as it is
    on every other device, no bootimage with magisk included or installing to recovery is needed!
    LOS 18.1 for our S10 device? SELinux enforcing? FBE? Open-source device tree? Where can I donate for this awesome work?
    Update on feedback on the ROM, its been a couple of days, and this is easily my daily driver. Only issue I encountered was through Gapps not having the dialer app set as the default. Bizarrely the dialer was still semi functional. The finger print sensor is now fixed as well.

    This is a an easy successor to ModPunks great work, and I hope that Linux4 finds the time to become a maintainer for our device. Thanks for the great work