[ROM][UNOFFICIAL][s5neolte][SM-G903F][10.0] LineageOS 17.1

Search This thread

arthur073

New member
Apr 10, 2009
2
1
Hi,

I have been testing the ROM for a week, and no issue so far except for the sensors one.
@stricked: is there a way to fix the sensors issue without flashing the new ROM version? Like a file to manually modify with adb or else?

Thanks a lot for this great work!
 

sekret1

Senior Member
Jul 25, 2015
67
22
Dunno why LOL
Simple: Because he fixed it. Or why are you wondering?!

---------- Post added at 20:55 ---------- Previous post was at 20:50 ----------

Currently it's not my main phone, because the bad mic audio quality still bothers me. Is there any chance that this could be improved? Less noise and a larger / wider frequency range? The camera is really good, too bad videos sound so bad. I know you'd need to reverse engineer stuff, which sounds very difficult, but it's really bothering me, so I thought I'd ask politely.

Everything else seems great, very snappy! Going official soon?
 

cggraciel

Member
Aug 21, 2018
41
2
La Habana
I just installed the ROM. At the moment it works perfectly. A great job from developers. I only have one problem: The starting and I wish I had a face unlock.

Now I use Pixel Launcher
 

Attachments

  • Screenshot_20200423-192259_Servicios_de_Google_Play.png
    Screenshot_20200423-192259_Servicios_de_Google_Play.png
    95.9 KB · Views: 268
  • Screenshot_20200423-191737_Trebuchet.png
    Screenshot_20200423-191737_Trebuchet.png
    255.3 KB · Views: 274
Last edited:

PacAtHome

New member
Apr 24, 2020
4
0
For what it's worth, I switched from 16 to 17.1 and using my phone as a daily driver.
Hi, quick question: how did you do the update from 16 to 17.1, just a dirty installation in TWRP over the existing 16?
And a big "Thank you" to the developers for the terrific work on this project!!
 

cggraciel

Member
Aug 21, 2018
41
2
La Habana
In this new ROM, the microphone works much better in audio recordings than in LineageOS 16.0. very good work. I have been testing it for three days and very good performance or battery life.
 

0LDST4R

Senior Member
May 2, 2018
269
197
if i use the nano does it work well?

Ok. The micro package does include the Pixel launcher, this caused some fc's in trebuchet in my experience. If you've flashed nano, so everything should be ok, maybe you should try to redownload the package, OR use an older version, OR try the pico package. GApps are not ever bugfree. You can install all wanted Google apps trough the play store.
 
  • Like
Reactions: cggraciel

Reiner55Sch

Member
Oct 29, 2018
8
3
NFC not working on 22.Apr. release at all?

Hello I just installed the version from 22.April yesterday.
All seems fine except NFC doesn't seem to work even NFC-Check says its there.
Tested it with two NFC-enabled Batteries and my german ID-card.
The NFC-Chip on that recognized and read on earlier Android-Versions without problems, now it is not seen at all any more.
Works however with an S3 (i9300), so the RFID-Chip itself must be ok.

regards

Reiner
 
Last edited:

Ant_b81

New member
Apr 30, 2020
4
0
I downloaded this earlier and flashed it. It's quality stuff as my long search is now over, after trying to get a few ROM's working with Virgin UK. This works and I haven't had any problems.

As a general noob to all this and I haven't installed any Google apps (As i don't want any), I've noticed some apk's won't install. I've been getting them from apkpure. Whatsapp installed but i can't get Vivaldi browser to install. Is there a work around to getting certain apps to install? I've tried apk editor but to no avail.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I forgot to respond. The setting was just in a different place to where I thought it was.

    It should be under lock screen settings? At least it is on my devices.
    Thanks for the hint. I re-enabled this, at last.
  • 17
    2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 17.1 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    What's working :
    • Boots
    • Wifi
    • NFC
    • Bluetooth
    • Camera
    • Video Playback
    • Audio
    • Sensors
    • GPS
    • HWC

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot

    Downloads :

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    XDA:DevDB Information
    [ROM][UNOFFICIAL][s5neolte][SM-G903F][10.0] LineageOS 17.1, ROM for the Samsung Galaxy S5 Neo

    Contributors
    Stricted, danwood76
    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 3.10.x
    Based On: LineageOS

    Version Information
    Status: Testing

    Created 2020-04-13
    Last Updated 2020-04-22
    6
    Where to donate? Pm me. Thanks. Incredible.
    my paypal donation link is https://www.paypal.me/Stricted


    Looks like some sensors aren't working, see my screenshot.


    Not entirely, unfortunately :(

    yea sealinux striked again
    here is a new build with working sensors https://mega.nz/file/cFoFUZgB#pKQeaWXcVcauPKdRb3S7i1A87djDoVspvlts0lUDw1I
    5
    Hi
    is it planned that the ROM will get the official status?

    Yes
    4
    Logcat generated and sended by PM to you.

    How long can this be, before its fixed? Otherwise i will switch to other working rom.

    Please switch to another ROM. Asking for an ETA is just rude.
    4
    my paypal donation link is https://www.paypal.me/Stricted




    yea sealinux striked again
    here is a new build with working sensors https://mega.nz/file/cFoFUZgB#pKQeaWXcVcauPKdRb3S7i1A87djDoVspvlts0lUDw1I


    Allready found it in your and @danwood76 signature. ;)

    Donated a few bucks for more coffee. ;)

    Any plans to go official? And if so, would it be possible to switch dirty from the unofficial builds? I'm very happy with the official LOS 16 atm, using my S5Neo as business device.

    Greetz,

    0LDST4R
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone