[ROM][UNOFFICIAL][SM-T580][8.1.0_r20] LineageOS 15.1 [01.05.2018]

Search This thread

xpdragon

Senior Member
Feb 16, 2006
205
64
Xiaomi Mi Pad 4
OnePlus 7 Pro
The latest build works as expected except the known issues as @tank0412 mentioned. Magisk 14.0 works fine with this ROM, but the newer Magisk verisons would cause bootloop. For anyone having installation issue with Magisk 14.0, try the following
1. Extract the boot.img from the zip and flash it in TWRP
2. Flash the Magisk 14.0
3. Flash universal-safetynet-fix-v2-beta-5-magisk-v14.zip to pass SafetyNet check.
 
  • Like
Reactions: tank0412

Asrael00md

Member
Jan 20, 2018
10
5
WLAN issues after installation

Hi all,
I do have an issue with not working WLAN. after the installation.
No matter if I install the ROM provided by #tank only or if I add open_gapps,or even reinstall Magisk, the WLAN cannot be switched on. The slider moves, but reverts to off immediately.
I'm starting from a LineageOS version 14.x with Magisk 16 running.
Any idea what could be the issue?

Marc
 

ps_minky16

Senior Member
Sep 6, 2015
1,029
1,447
28
New Delhi
Hi all,
I do have an issue with not working WLAN. after the installation.
No matter if I install the ROM provided by #tank only or if I add open_gapps,or even reinstall Magisk, the WLAN cannot be switched on. The slider moves, but reverts to off immediately.
I'm starting from a LineageOS version 14.x with Magisk 16 running.
Any idea what could be the issue?

Marc


The rom is pre rooted (includes lineage root) so please dont flash any other root method.
 

Freedomsi

Member
Feb 20, 2018
12
0
I install it again today everything working perfectly!!!
Lineage 15.1 feel faster than the lineage 14.1 I was using before. Keep updating and hope for android P that coming in next few months.

---------- Post added at 05:11 PM ---------- Previous post was at 05:08 PM ----------

I am disagree with you. I can not reproduce your issues,
ROM installed fine without any errors.
On my tablet Google play store works fine.
Also apk files install is fine too.
Some proofes:
Working perfectly man! :) thanks
 

RayMcGrath

Inactive Recognized Contributor
Aug 29, 2012
2,500
3,555
Pacific Northwest
New build is released.
Changelog:
Sync LOS 15.1 sources so March stagefright patch is there
Push some changes in device tree

Download:
https://drive.google.com/open?id=1S1G6PXCxX6YfKtwMXUYH30jqr1ON0Gdo
I could not get this to boot via flashing in twrp. . It was stuck in bootloop. I'm new to Samsung just bought this tablet yesterday. I'm currently running Los 14.1. I wanted to try this ROM out! Forgive me but what do you mean by in fastboot? Is that something Odin has to handle? I know how to fastboot Flash my Nexus devices.
 

tank0412

Senior Member
May 24, 2014
2,831
5,468
Saint Petersburg
I could not get this to boot via flashing in twrp. . It was stuck in bootloop. I'm new to Samsung just bought this tablet yesterday. I'm currently running Los 14.1. I wanted to try this ROM out! Forgive me but what do you mean by in fastboot? Is that something Odin has to handle? I know how to fastboot Flash my Nexus devices.
I always test my ROM builds before publising it.
OP had a typo: i mean flash it with TWRP, not fastboot. (Sorry for this)
Just flash this los15.1 build with TWRP and try to wipe data+cache. (I did not wipe data/cache this time because i came from old Lineageos 15.1 build but i think it can be needed when come from LineageOS 14.1 build)
 
  • Like
Reactions: RayMcGrath

Intelli69

Senior Member
Jan 22, 2018
79
11
@tank0412 I have one small odd problem, I always clean flash any ROM, but when I try but yours or the RR-OS ones make my soft and hard nav keys go dead. Only the back button works. But when I flash back to Valera's 585 15.1 or 14.1 even, all my buttons work again. Any idea what the cause is? Thanks
 

tank0412

Senior Member
May 24, 2014
2,831
5,468
Saint Petersburg
@tank0412 I have one small odd problem, I always clean flash any ROM, but when I try but yours or the RR-OS ones make my soft and hard nav keys go dead. Only the back button works. But when I flash back to Valera's 585 15.1 or 14.1 even, all my buttons work again. Any idea what the cause is? Thanks
I do not have this issue but i guess it is a fault of changes in device tree.
Can you attach logcat and dmesg?
 

Asrael00md

Member
Jan 20, 2018
10
5
Bluetooth question/remark

Working fine after clean install (wipe system, cache & data).
It's stable and works flawless.
Hope you can fix the bluetooth situation too.
@tank0412 pls. let me know, in case I can support testing.

If I understood the post here https://forum.xda-developers.com/galaxy-tab-a/development/rom-lineageos-15-1-android-8-1-20171223-t3723952
correct, the Bluetooth issue was fixed for SM-T 585 (the device with mobile services).
How can I support porting the solution to SM-T 580 (my developing and testing days are some times ago :cyclops:)?
 
Jun 16, 2012
99
37
Hello and thank you for this nice piece of Oreo for my T580!

I'm still on lineage-15.1-20180220-UNOFFICIAL-gtaxlwifi and want to leave some feedback after I got everything running.

  • Camera is working, but not with the stock app (closes just after start). Using "Manual Camera" is ok.
  • Could not read anything about GPS, but can say: it is not working for me. No satellites found.
  • Volume keys primary afffect ringtone volume - should be media, I think.
  • No issues with SD-Card
  • Bluetooth still untested ...

Appreciate your work and looking forward to future builds.
 
Last edited:

safariking

Senior Member
Jan 4, 2012
4,820
4,936
Lelystad
Why am i getting this error i have T580
 

Attachments

  • 20180317_105915.jpg
    20180317_105915.jpg
    255.5 KB · Views: 275

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    14kbsk9.jpg
    Code:
     * Your warranty is now void.
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */
    What is working:
    • Wi-Fi
    • Audio
    • Sensors
    • Software video decoding
    • Hardware video decoding
    • Flashlight
    • Camera photo taking
    • Bluetooth
    What is NOT working:
    • Camera video recording
    • 1080p 60 fps videos on Youtube lags
    • Ambient Display is broken
    • You tell me
    Download
    New build:
    https://drive.google.com/open?id=16ylBoF2Dqh_hGQRfZ9KX19g5iQLKMbkq
    Old build:
    https://drive.google.com/file/d/1S1G6PXCxX6YfKtwMXUYH30jqr1ON0Gdo/view
    Another old build:
    https://drive.google.com/open?id=1wR__Ro7m1B39mfr0u-ZgFq0W-SUBcA_e
    Checksum:
    lineage-15.1-20180309-UNOFFICIAL-gtaxlwifi.zip
    md5: ef68237e93dc3ec048123ccf046db19b
    lineage-15.1-20180405-UNOFFICIAL-gtaxlwifi.zip
    md5: abfbeb6f30f58ded89c9ba9f69ce96ab
    lineage-15.1-20180501-UNOFFICIAL-gtaxlwifi.zip
    md5: 9c2fe066468242d269dad078bddc284b
    Installation Instructions:
    - Download ROM
    - Flash it with TWRP
    - Wipe cache and data

    Workaround for Ambient Display bug :
    Go to Settings -> Battery and disable Ambient Display there.

    Credits:
    Valera1978 for first Oreo bring up
    Exynos7870 team for hardware decoding fix
    Followmsi for his fixes

    XDA:DevDB Information
    LOS15.1 for T580, ROM for the Samsung Galaxy Tab A series

    Contributors
    tank0412, tank0412
    Source Code: https://github.com/tank0412/android_device_samsung_gtaxlwifi

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.x
    Based On: LOS

    Version Information
    Status: Testing

    Created 2018-02-18
    Last Updated 2018-05-01
    7
    Hi, there.
    New LineageOS 15.1 build is released.
    Changelog:
    Merge all changes by @followmsi like:
    Fixed bluetooth
    Security patches in kernel
    Etc
    Sync LOS 15.1 sources

    Download:
    https://drive.google.com/open?id=16ylBoF2Dqh_hGQRfZ9KX19g5iQLKMbkq

    P.S. Unfortunatly i am very busy in my university so thats all what i can do. Sorry for this.
    4
    New LIneageOS 15.1 build is released.
    Changelog:
    Revert "gtaxlwifi: push changes for wifi"
    Switch to bionic from Exynos7870 org so:
    Fix flashlight
    Fix camera photo taking
    Revert "gtaxlwifi: shim missing symbol for camera"
    Sync LOS15.1 sources

    Download:
    https://drive.google.com/open?id=1Opx1SokzITzhSOc-o3Um0ooFovNTnGnL
    3
    Can you please provide checksums for the zip?
    lineage-15.1-20180309-UNOFFICIAL-gtaxlwifi.zip
    md5: ef68237e93dc3ec048123ccf046db19b
    2
    Install it after hours of errors on twrp. Installed opengapps Google play store was not loading I reinstall it 3 times and nothing. I was not able to install apk files too! This ROM at this time suck big time! I download 14.1 from this forum and its working perfectly.
    I am disagree with you. I can not reproduce your issues,
    ROM installed fine without any errors.
    On my tablet Google play store works fine.
    Also apk files install is fine too.
    Some proofes:
    142buxu.jpg

    2ldkod4.jpg

    346t5kp.jpg