• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][UNOFFICIAL][T710][8.1] LineageOS 15.1

Search This thread

ripee

Recognized Developer / Recognized Contributor
I don't have wifi with this rom

That's because the wifi, video recording, and adb fixes are in bonuzzz's common repo as patches that need to be applied manually. I just applied them to forks of the corresponding repos, making it easier for others to apply those fixes by simply building with my forks rather than the lineage original repos.

Anyway, see tripLr's links for the latest builds.
 
  • Like
Reactions: tripLr

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    http%3A%2F%2Fi.imgur.com%2F2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working :
    • Boots
    • USB OTG
    • Rotation
    • Key backlights
    • Video/Audio playback on mxplayer/vlc for now

    What's NOT working :
    • Everything Else

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Donations :
    You don't have to but if you want so...
    [email protected]

    Contributors
    Ather
    Source Code:
    android_vendor_samsung_gts28wifi
    android_vendor_samsung_gts2-common
    android_device_samsung_gts28wifi
    android_device_samsung_gts2-common
    android_kernel_samsung_exynos5433
    local_manifest

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.10.x
    Based On: LineageOS

    Version Information
    Status: Testing

    Created 2018-04-05
    Last Updated 2018-04-05
    7
    to addition to previous post
    all this time I cant understand only one thing. I'm not a perfect and usually leave some mistakes in config, useless parameters, experiment stuff... So why do you have all of that in your rom if you didn't use my device tree?

    This attack really needs to stop. It's getting old. You've done it now with both 14 and 15 Lineages. I don't understand why it is that you keep posting you have something working, yet refuse to release it to the public here on XDA.
    At least Ather has released something for people to use and work with. You did, then withdrew, while still posting how wrong, others did it.

    If you want recognition, you've got it for both of you're Lineages. And if that's all your looking for, then please just ask for it. Stop pointing out your supposed work that you won't post here on XDA.
    We've ALL APRECIATED the work that you have posted here!!! And would appreciate it even more if you would keep releasing.

    Google- open source, Android- open source, GitHub- open source, XDA- open source-with permission. You might want to look up what open source means. Basically, if it's in any of these places, then it's open to all to modify, release, create, etc

    I really tried to support you with 14. But now with 15, you just seem to want to attack peoples work. Claiming you have something that no one else does. (15) Then when its posted, claiming its all your work.

    So please, just stop attacking and either ask for some recognition, or release your own work

    XDA is a collaboration, so please use it that way. Anything posted on XDA has to have source with it. (Some of your past work has not) And it's helps EVERYONE if they can replicate and build your work and make fixes. That's the idea behind XDA and Open sources.

    In my 10 years+ on XDA, I've seen this happen quite a bit and it's usually solved by just asking for credit if credit is deserved. I've also been in this same predicament.

    Edit Another option is to NOT post your source anywhere its openly available, or make it private so no one can use your work. But then, it won't be allowed on XDA. Also, some of my explanations are general, and not literal.
    I'm having flashbacks of FreeGee, Bump, Open Bump and jcase wars of the past and really don't want to see these happen again.
    6
    First of all, i'm no thief or a kanger, the only thing i used from you was your kernel modified for oreo , the rest of the sources were initiated by raymanfx BUT they wouldnt compile, and anan is witness to that because i sent him the files to test aswell, the kernel by lineageOS had sepolicy errors which i tried very hard to fix but they woudnt boot with it, FYI before you initiated Oreo commits to your kernel, i already had added my fixes to it, like the missin zimage type, min/max errors, you can ask matt about that, then when i finally got to bootloop it was ueventd error which remi told me about, after that i was missing manifest which by help of matt i generated for gts2 by looking at his. the sources that were upped had problems which i fixed so i pushed them with them included minus the orignal author thats my bad i agree, but please dont call me a kanger atleast i deserve that much respect. this is not a competition to become famous, you withheld souces and the rom from others before aswell and when i always asked you for help you simply gave meaningless answers, rayman never replied, the lineage irc channel is full of dickheads so i did all of it on my own with help from Matt and remy.

    i'll add your forked kernel in OP, and also releasing the bare minimum version was because so others could help me fix it not for becoming famous, i've been on xda since windows mobile days and have made my share of custom roms,apps so i dont need to be famous
    4
    What is the benefit of this new lineage over PoseidonROM 1.1?
    This is pure Android from Google as opposed to Samsung's modifications, this is the latest android version (8.1.x) where as Samsung stopped at 7.0 for our t710 model, this has the latest security patch as of yesterday April 5th,whilst our TouchWiz rom has from January

    Sure this Rom will have bugs but hopefully we'll fix them
    3
    complete sources are added to OP