• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][T719][9] LineageOS 16.0

Search This thread


Senior Member
Oct 13, 2016
When I try to flash this build in twrp on my sm-t719 lte version this message appears [E3004: This package is for device: gts28velte: this device is gts28vewifi.] plz help me out guys sorry for my bad English..


Senior Member
Jan 18, 2008
Just download the correct release and try again. It seems that your device is not the LTE version. If it's indeed the LTE version then try to wipe everything but the internal storage and flash again.

Top Liked Posts

  • There are no posts matching your filters.
  • 21

    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • Incall audio
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][UNOFFICIAL][T719][9] LineageOS 16.0, ROM for the Samsung Galaxy Tab S2

    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2018-09-05
    Last Updated 2019-02-16
    Ok, found the problem with my daily build script with regards to the broken mobile data issue.

    The most recent build there now should be good, since there's only been a handful of builds there and most didn't work with mobile data I've removed them.

    Merry Christmas!
    T719Y gts28velte ROM update


    I was looking to upgrade my Tab S2 SM-T719Y to something more modern than what Samsung was providing and found this thread. I noticed that the there hasn't been an updated build here for a while so I went and figured out how to do it myself. I've shared the ROM here:


    Sorry, because I'm new here I can't create new threads or provide clickable links in the posting otherwise I would. If there's enough interest, i'll look at automating those builds so they can be available regularly.



    1) I'd don't know if its a requirement to wipe the tablet before installing, in my case I did.
    2) I'm using TWRP 3.3.1-0 to flash if that matters.
    3) Seems like I'm having trouble with getting on mobile network with this build - Wifi is OK, but don't install this if you require mobile sim working, i'm going to look into fixing that.
    T719Y gts28velte ROM update

    Ok, got it sorted out - ran into @LuK1337 on irc and he pointed me in the right direction on how to resolve the mobile data issue and it seems I got it sorted out.

    An updated ROM has now been uploaded to that same location now:


    Does it need a clean flash or is it possibile a dirty flash over last @LuK1337 release?

    As a test, I just did this:

    1 ) A complete full wipe (everything all caches, full meal deal)
    2) Installed lineage-16.0-20190713_165030-UNOFFICIAL-gts28velte.zip (Luk1337's build) from top of this thread
    3) Then installed lineage-16.0-20191217-UNOFFICIAL-gts28velte.zip (my build) over that

    Everything seemed to go smoothly and it booted up normally, no idea if any other side effects will appear. I personally would do a full wipe "just in case".