• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][woods] darklineage-14.1-20200913 [MOD of lineageOS]

Search This thread

Zumairmhd

Member
Oct 3, 2017
25
19
Matara
attachment.php

Hi guys, I have been working on this rom from corona vacation due to some other works, I couldn't push the stable version of this rom. Today I'm releasing my modified rom of lineage as darklineage.

Key features

  • Full OMS support
  • Signature spoofing support
  • Pixel animated navbar (with on/off switch)
  • Pulse Notification LED Works (notification & Charging) [ Can be customize led notification light for apps]
  • Wifi hotspot client counts
  • Pixel accent colors
  • Rounded icons
  • LiveDisplay with Color Calibration
  • Ambient display (default - pulse notification) [ can be enabled to work with the proximity sensor (Reboot Required)]
  • Custom Headers (Added New Header images)
  • Quick unlock with Fingerprint After reboot
  • Change navbar height
  • USB Tethering tile
  • Separate ring and notification volume
  • Choose Ambient display brightness
  • Dynamic navbar color (changes color to the same of the status bar)
  • Quick Magisk Manager & Substratum dashboard launcher (Fixed magisk launcher error)
  • Two Column Dashboard
  • Memory bar on recent
  • immersive recent
  • enable/disable clear all button


SafetyNet
Install Hidden Core module from Xposed to pass SafetyNet.

Installation
If You are on custom rom with a working fingerprint than no pre-requirements just clean flash this rom. If not you are on a stock rom with the latest version (NMA.26.42-169) than downgrade your Rom with Spflash tool (Flash NMA26.42-113 / NMA26.42-75) rom and come to this rom otherwise the Fingerprint not work correctly.

- Backup first... always backup first
- Wipe system, data, cache, and Dalvik cache
- Install darklineage
Optional
- Install GAPPS / MicroG ( NanoDroid zip)
- Install root package of your choice (I recommend Magisk)
Enjoy!

Donations
I added a Donation Button in Settings → about. Please consider small support for me. Thanks in Advance. :good:

Screenshots
Check It in screenshot tile.

Download

darklineage-14.1-20200913-UNOFFICIAL-woods.zip

Motorola_Moto_E4_XT1762_MT6737M_WOODS_NMA26.42_75_04082017_7.0.zip

Support
join on Telegram Group : Moto_E4_Plus_Custom_Roms

XDA:DevDB Information
Dark Lineage, ROM for the Moto E4

Contributors
Zumairmhd, Dark_Eyes_, iykeDROID™ , @vishalk17 , @SamarV-121 , @RebelLion_ , @manjuyashu & Many others
Source Code: https://github.com/mhdzumair

ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.x
ROM Firmware Required: <= NMA.26.42-113
Based On: lineageOS

Version Information
Status:
Stable
Current Stable Version: 14.1-20200913
Stable Release Date: 2020-09-13

Created 2020-09-13
Last Updated 2020-09-13
 
Last edited:

Zumairmhd

Member
Oct 3, 2017
25
19
Matara
Is VoLTE working sucessfully on this build?
also does it has edge lighting support?..
I'll try this after exams

I don't sure volte working or not. I added some of the volte wanted vendor blobs need to test by jio users.
Secondthing, you earlier also mention about this light. But in my device i have white led in the front of the phone (near to front camera). I mentioned in my post as notification led. So in this build That is work perfectly for battery charging, low batter and notifications.
 

hitman72

Senior Member
May 22, 2008
133
26
ortona
I have installed to xt1761 (standard "moto e"), sorry I don't know about volte. previously I had installed a rom from this forum with always a kernel present here, the phone was laggy like hell... about these kernels... guys don't use zram in your kernels! zram is the absolute evil for an android smartphone
 

allrightlite

Senior Member
Oct 18, 2016
1,623
341
Where can I download the 113 firmware? Which part of it is exactly needed for the working fingerprint?

Edit: Found the thread with the backup of 113. We will see...

Ok, fingerprint not working anymore, even with this 113 twrp backup. Original 113 firmware not available anymore, just the latest for the SP flash tool. Not important, my mother don't like the fingerprint scanner, so it doesn't matter. Original IMEIs back with Toolhero has worked perfectly, just the serial number is wrong and this is not fixable and maybe not important like the right imei numbers.

There is one bug, safety menu in settings is not opening and seems to crash. That's because fingerprint is not working here, for sure. Or, all fine so far for mother.

And I have changed the bootanimation for her ;)

Edit: Now she got a new battery. Hope the phone is not going down anymore around 75% :cowboy:
 
Last edited:

MarioRomain

New member
Jan 7, 2021
1
0
I have installed it on my Moto e4 XT1762 (2017), and my camera and gallery are not working... When I try to acces one of this futures, the phone stops and reboot.
It's there something to do with it?
Thx
 

Ueufi9

New member
Feb 10, 2015
4
0
mumbai
Notification Lights are working perfectly which is blinking lights that were disabled in stock rom and in all custom ROM :).

This is the only ROM that has enabled blinking notification lights for each added apps the pulse and speed of blinking.

Notification lights are white only & not RGB colors.

Wifi Calling also enabled and is supported by my carrier.

Screenshots below August 2020 security patch.

If all restored userapp icons dissapear like as if it was formatted, just clear Dalvik and cache.
 

Attachments

  • Screenshot_20210108-174631.png
    Screenshot_20210108-174631.png
    75.5 KB · Views: 97
  • Screenshot_20210108-174954.png
    Screenshot_20210108-174954.png
    60.8 KB · Views: 95
  • Screenshot_20210108-175017.png
    Screenshot_20210108-175017.png
    65.2 KB · Views: 91
  • Screenshot_20210108-175039.png
    Screenshot_20210108-175039.png
    86.9 KB · Views: 88

poptart_boi

New member
May 21, 2021
2
1
Hi everyone!!

Must say an awesome ROM. The dark theme was the selling point for me tbh and the fact that its based off LineageOS sealed the deal. Thus, an amazing ROM overall in terms of performance, stability and battery life (the 3 things that someone wants out of a ROM :p )

But one issue that I am consistently facing is whenever I go into Settings and tap on either "Security" or "Set up Fingerprint" the Settings app either freezes or crashes entirely.

I currently have LineagOS 14.1 Dark installed on my Moto E4 XT1762 "Woods" MediaTek variant
LineageOS version is 14.1-20200913-UNOFFICIAL-woods
kernel version 3.18
Build Number being lineage_woods-userdebug 7.1.2 NJH47F 0b5190fbeb test-keys

I also Magisk version 23.0 installed for root.

Troubleshooting steps that I have taken till yet:
  • Restarted the device numerous times
  • Wiped the Cache/Dalvik Cache from Recovery
  • Signed up using Google Email
  • Deleted Google's application cache and restarted
  • Signed up using a new user (that time it just froze on the boot animation until I manually restarted it)
None of the steps work and still whenever I tap on Security or Fingerprint, its like my devices just tells me to eff off and not play around with the security settings. If this is something that the developer intended or locked, I would love to know any way to unlock it :p

I have also googled the issue quite significantly. However, for my specific device, I was unable to find any good information thus I decided to post on my own. I have tried a couple of different fixes that worked on other devices with similar issues but the same ROM. However, none of them have worked so far.

Otherwise, I must say I have been using this ROM as my daily driver for like 2 weeks and have yet to come across any other issues. All my required apps work seamlessly and its like my 3 yrs old mobile got a new life. Just this one issue is bugging me, and would love if I get some guidance regarding how to resolve this!

Thank you once again !! Y'all are awesome!! :D
 
  • Love
Reactions: Zumairmhd

Zumairmhd

Member
Oct 3, 2017
25
19
Matara
Hi everyone!!

Must say an awesome ROM. The dark theme was the selling point for me tbh and the fact that its based off LineageOS sealed the deal. Thus, an amazing ROM overall in terms of performance, stability and battery life (the 3 things that someone wants out of a ROM :p )

But one issue that I am consistently facing is whenever I go into Settings and tap on either "Security" or "Set up Fingerprint" the Settings app either freezes or crashes entirely.

I currently have LineagOS 14.1 Dark installed on my Moto E4 XT1762 "Woods" MediaTek variant
LineageOS version is 14.1-20200913-UNOFFICIAL-woods
kernel version 3.18
Build Number being lineage_woods-userdebug 7.1.2 NJH47F 0b5190fbeb test-keys

I also Magisk version 23.0 installed for root.

Troubleshooting steps that I have taken till yet:
  • Restarted the device numerous times
  • Wiped the Cache/Dalvik Cache from Recovery
  • Signed up using Google Email
  • Deleted Google's application cache and restarted
  • Signed up using a new user (that time it just froze on the boot animation until I manually restarted it)
None of the steps work and still whenever I tap on Security or Fingerprint, its like my devices just tells me to eff off and not play around with the security settings. If this is something that the developer intended or locked, I would love to know any way to unlock it :p

I have also googled the issue quite significantly. However, for my specific device, I was unable to find any good information thus I decided to post on my own. I have tried a couple of different fixes that worked on other devices with similar issues but the same ROM. However, none of them have worked so far.

Otherwise, I must say I have been using this ROM as my daily driver for like 2 weeks and have yet to come across any other issues. All my required apps work seamlessly and its like my 3 yrs old mobile got a new life. Just this one issue is bugging me, and would love if I get some guidance regarding how to resolve this!

Thank you once again !! Y'all are awesome!! :D

Thank you for your kind review. in my installation guide i was strictly said before use this rom you need to flash NMA26.42-75 firmware using spflash tool to work the fingerprint. i'll provide the firmware rom link. you need to flash the rom and then come back here. if you need any guides or help please join in our telegram group.
Thanks.
 

poptart_boi

New member
May 21, 2021
2
1
Thank you for your kind review. in my installation guide i was strictly said before use this rom you need to flash NMA26.42-75 firmware using spflash tool to work the fingerprint. i'll provide the firmware rom link. you need to flash the rom and then come back here. if you need any guides or help please join in our telegram group.
Thanks.
Most welcomee!!

Plus, regarding the NMA ROM I must have missed that part. I am still a n00b when it comes to rooting/installing custom ROMs, thus pls excuse my silly mistake.

Please do share the link of the NMA ROM, plus if there is any guide to do the installation of the NMA ROM and then this ROM, please do share that as well. Although you have already mentioned that you flash the NMA ROM and then flash this one and the fingerprint should work fine, so not a strict requirement, but would be nice to have if possible :)

Plus, pls pls pls do share the telegram group link. Tbh after flashing the ROM I have gotten interested in learning about custom ROM development, plus, if I encounter any bugs I can get quicker responses from the OG devs like you, so would greatly appreciate the share !! ^_^

Thanks once again!! Awesome ROM!! :)
 

Zumairmhd

Member
Oct 3, 2017
25
19
Matara
Most welcomee!!

Plus, regarding the NMA ROM I must have missed that part. I am still a n00b when it comes to rooting/installing custom ROMs, thus pls excuse my silly mistake.

Please do share the link of the NMA ROM, plus if there is any guide to do the installation of the NMA ROM and then this ROM, please do share that as well. Although you have already mentioned that you flash the NMA ROM and then flash this one and the fingerprint should work fine, so not a strict requirement, but would be nice to have if possible :)

Plus, pls pls pls do share the telegram group link. Tbh after flashing the ROM I have gotten interested in learning about custom ROM development, plus, if I encounter any bugs I can get quicker responses from the OG devs like you, so would greatly appreciate the share !! ^_^

Thanks once again!! Awesome ROM!! :)
Here is the telegram link: Moto_E4_Plus_Custom_Roms
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi everyone!!

    Must say an awesome ROM. The dark theme was the selling point for me tbh and the fact that its based off LineageOS sealed the deal. Thus, an amazing ROM overall in terms of performance, stability and battery life (the 3 things that someone wants out of a ROM :p )

    But one issue that I am consistently facing is whenever I go into Settings and tap on either "Security" or "Set up Fingerprint" the Settings app either freezes or crashes entirely.

    I currently have LineagOS 14.1 Dark installed on my Moto E4 XT1762 "Woods" MediaTek variant
    LineageOS version is 14.1-20200913-UNOFFICIAL-woods
    kernel version 3.18
    Build Number being lineage_woods-userdebug 7.1.2 NJH47F 0b5190fbeb test-keys

    I also Magisk version 23.0 installed for root.

    Troubleshooting steps that I have taken till yet:
    • Restarted the device numerous times
    • Wiped the Cache/Dalvik Cache from Recovery
    • Signed up using Google Email
    • Deleted Google's application cache and restarted
    • Signed up using a new user (that time it just froze on the boot animation until I manually restarted it)
    None of the steps work and still whenever I tap on Security or Fingerprint, its like my devices just tells me to eff off and not play around with the security settings. If this is something that the developer intended or locked, I would love to know any way to unlock it :p

    I have also googled the issue quite significantly. However, for my specific device, I was unable to find any good information thus I decided to post on my own. I have tried a couple of different fixes that worked on other devices with similar issues but the same ROM. However, none of them have worked so far.

    Otherwise, I must say I have been using this ROM as my daily driver for like 2 weeks and have yet to come across any other issues. All my required apps work seamlessly and its like my 3 yrs old mobile got a new life. Just this one issue is bugging me, and would love if I get some guidance regarding how to resolve this!

    Thank you once again !! Y'all are awesome!! :D