• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.

[ROM UPDATED NOV 11 [UB] DirtyUnicorns Lollipop 5.1.1 r29 Unofficial

optimumpro

Senior Member
Jan 18, 2013
6,265
13,594
0
Okay running smoothly sofar.
I did flash after Factory reset.. Tried wipe cache only first, but google play store and services fc'ed . 1 thing I came across... OP says that ROM now shows 4g instead of lte, but mine still shows lte:(
Als there seems to be a (small) lag when I press the power button tot screen on and wiping to unlock. Other than these minor things ROM is great!!!:D
Battery seems to be okay too.

Great work @optimumpro
That's true about 4g, as opposed to LTE not showing, but that was in DU chanelog. I can confirm, though, that the icon can be changed in gravity box. Both icons are already in framework-res.apk, so, all you need to do is to address the 4g icon in a java file. Gravity hooks into framework and allows you to change icons without making permanent changes. Gravity does not burden system/battery, unless you use its smart radio feature, which I don't use.. It also provides additional features, which are not part of DU. So, I recommend to use gravity box.. Both xposed framework and gravity are pretty stable...
 

bossie1975

New member
Oct 31, 2008
153
7
0
Spijkenisse
That's true about 4g, as opposed to LTE not showing, but that was in DU chanelog. I can confirm, though, that the icon can be changed in gravity box. Both icons are already in framework-res.apk, so, all you need to do is to address the 4g icon in a java file. Gravity hooks into framework and allows you to change icons without making permanent changes. Gravity does not burden system/battery, unless you use its smart radio feature, which I don't use.. It also provides additional features, which are not part of DU. So, I recommend to use gravity box.. Both xposed framework and gravity are pretty stable...

Done! thanks once again for the hard work!
 
Last edited:

calage1234

New member
Mar 28, 2011
163
46
0
Brasília
Screen freeze

Hello guys, i'm using Resurrection Remix and i'm getting a lot of screen freeze. When i turn on and use some app like whatsapp the screen doesn't recognize my touches... Can you tell me if this rom has this problem? Has someone faced that?
 
  • Like
Reactions: AlmostIdiot

moneydeep

New member
May 31, 2009
19
2
0
Hello guys, i'm using Resurrection Remix and i'm getting a lot of screen freeze. When i turn on and use some app like whatsapp the screen doesn't recognize my touches... Can you tell me if this rom has this problem? Has someone faced that?
Yes I was getting screen freeze with ressurection remix.
That doesnt happen with this. Maybe once in like a long time.
The only problem I noticed with this is that some apps the task switcher button doesnt work and I have to press home button twice to get out of the app.
Everything else is working perfectly.
 
  • Like
Reactions: AlmostIdiot

kentexcitebot

New member
Mar 30, 2014
575
481
0
Moorpark
Any chance of porting the little arrows under the Bluetooth and Wifi signal indicators back into Android? I use them quite a bit and it's an Android 5.1 feature, not sure why DU chose to remove it for CAF devices.
 

olokos

Recognized Developer
Oct 16, 2011
2,939
2,477
0
Warsaw
I tried your rom, two versions back it was all perfect, but now:
I get NO notifications, although the LED blinks.
You cannot expand QS unless you enable smart expand
Home button doesn't work at all, be it navbar or LMT. Just nothing happens after you tap it, well, it vibrates...
Your rom was awesome 2 versions back, but now it got all of those bugs which kind of puzzles me.
Also, after I disabled navbar in DU Tweaks interface FC'd.
Waking phone with power button doesn't work on a single press, you have to press it multiple times to wake up the screen.
Adding more buttons to power menu doesn't work. It's just power and reboot, doesn't matter if you enable everything under power menu, it will only stay on power off and reboot...

Hope you could get that resolved.
Thanks man!
 
Last edited:
  • Like
Reactions: AlmostIdiot

optimumpro

Senior Member
Jan 18, 2013
6,265
13,594
0
I tried your rom, two versions back it was all perfect, but now:
I get NO notifications, although the LED blinks.
You cannot expand QS unless you enable smart expand
Home button doesn't work at all, be it navbar or LMT. Just nothing happens after you tap it, well, it vibrates...
Your rom was awesome 2 versions back, but now it got all of those bugs which kind of puzzles me.
Also, after I disabled navbar in DU Tweaks interface FC'd.
Waking phone with power button doesn't work on a single press, you have to press it multiple times to wake up the screen.
Adding more buttons to power menu doesn't work. It's just power and reboot, doesn't matter if you enable everything under power menu, it will only stay on power off and reboot...

Hope you could get that resolved.
Thanks man!
I have been running this rom non stop and have none of this. Can anyone else confirm similar bugs? Absent logcat, I can only imagine that you didn't do fresh install (wiping system/cache/data and factory reset) before upgrading. I have also noticed that TWRP does not always get rid of all partitions unless you also do factory reset where the interface asks you to enter "yes" before reset. A few times, after doing system/data/cache erasing only, I would have a screen pin from the previous rom.. Also, because our Z1 does not have a separate internal storage, i.e., internal SD card is emulated on the same disk where the system sits, it is important to also erase internal SD card where most android apps poop, so you will have remnants from previous roms interfering with the new one.

Again, unless someone else can repeat your issues and get a logcat, there is nothing, unfortunately, I can do. Sorry.....
 
Last edited:
  • Like
Reactions: kinjal

kinjal

New member
Oct 11, 2008
187
26
0
I have been running this rom non stop and have none of this. Can anyone else confirm similar bugs? Absent logcat, I can only imagine that you didn't do fresh install (wiping system/cache/data and factory reset) before upgrading. I have also noticed that TWRP does not always get to fully erase all partitions unless you also do factory reset where the interface asks you to enter "yes" before reset. A few times, after doing system/data/cache erasing only, I would have a screen pin from the previous rom....

Again, unless someone else can repeat your issues and get a logcat, there is nothing, unfortunately, I can do. Sorry.....
No similar bugs. Home botton is working, power menu too.

Wysłane z mojego Xperia Z1 przy użyciu Tapatalka
 
  • Like
Reactions: optimumpro

bossie1975

New member
Oct 31, 2008
153
7
0
Spijkenisse
New build is up. Most overheating issues resolved. See OP for description and download link.
First impresions are good! One thing is that I can't seem to find the kill all apps in recents... Anyone? I am using xposed with gravity box...

One more thing. In lock screen it shows 'no service' all the time.
 
Last edited:

optimumpro

Senior Member
Jan 18, 2013
6,265
13,594
0
First impresions are good! One thing is that I can't seem to find the kill all apps in recents... Anyone? I am using xposed with gravity box...

One more thing. In lock screen it shows 'no service' all the time.

DirtyTweaks/system/recents, as well as in Gravity, but you can't have it if you use slim recents.