• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][WIP]AOSP 5.1.0 Stable v1.0 | Lollipop for Xperia Z1 [14-04-2015]

Search This thread

prjakate

New member
Dec 26, 2012
4
0
Mobile Data not working?

1) Flashed v2.5
2) Wiped data, cache, dalvik.
3) Flashed v3.0
4) Didn't wipe anything

Pros:
Wifi etc working

Con:
NO NETWORK SIGNAL BARS ARE SHOWN. WHEN TRY TO SEARCH FOR NETWORK PROVIDERS, OR CALLING GET THIS ERROR "No SIM or SIM error".
IF YOU KNOW HOW TO MAKE MOBILE DATA WORK., THEN PLEASE REPLY.
Thanks.
 

mr_tawan

Member
Jun 6, 2010
19
3
Bangkok
If you're using C6903 then you have to flash the modem file as well (download it somewhere in the thread and do the adb sideload in recovery).

1) Flashed v2.5
2) Wiped data, cache, dalvik.
3) Flashed v3.0
4) Didn't wipe anything

Pros:
Wifi etc working

Con:
NO NETWORK SIGNAL BARS ARE SHOWN. WHEN TRY TO SEARCH FOR NETWORK PROVIDERS, OR CALLING GET THIS ERROR "No SIM or SIM error".
IF YOU KNOW HOW TO MAKE MOBILE DATA WORK., THEN PLEASE REPLY.
Thanks.
 
  • Like
Reactions: paksUK and prjakate

hlaube

Senior Member
Feb 20, 2011
136
21
Hi

I think I found the reason why wifi is not working in v3.

The following is in the wrong locaion:
Code:
/etc/firmware/wlan/prima/WCNSS_qcom_wlan_nv.bin

The wlan.ko modules is looking for it hear:
Code:
/data/misc/wifi/prima

The easy way to fix is:
Code:
adb shell
cp -r /etc/firmware/wlan/prima/ /data/misc/wifi/
adb reboot

Wifi is now working for me on v3 when going directly to v3

Ciao

Nar
I can confirm this steps on an fresh install strait to v3
 
  • Like
Reactions: pranii23

hlaube

Senior Member
Feb 20, 2011
136
21
I'm working on an update at the moment :)

Sent from my Xperia Z1 (AOSP) using XDA Free mobile app

I am looking forward :)

Another small point: I am a fan of Daydream, one of the options in the Display section. :angel:

I have set it up to run while charging the phone (one of the options). It does not start while loading. I can start it manually, but it misses the push to run while loading.

UPDATE:
=======
I do not now how and why, but today daydream works as it should. I did a reboot, may be it fixed something.
 
Last edited:

hlaube

Senior Member
Feb 20, 2011
136
21
I have another point.

I do not get a location found. I have not tried GPS up till now, but location by wlan/radio does not result in anything.

Sent from my Xperia Z1 (AOSP) using XDA Free mobile app
 

hlaube

Senior Member
Feb 20, 2011
136
21
I have another point.

I do not get a location found. I have not tried GPS up till now, but location by wlan/radio does not result in anything.

Sent from my Xperia Z1 (AOSP) using XDA Free mobile app

Ok, back home here the section of logcat switching from Energi saving mode to high precision:
_______________________________________________________________________________________________________________
W/ContextImpl(15112): Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1335 android.content.ContextWrapper.sendBroadcast:381 com.android.settings.location.LocationSettingsBase.setLocationMode:110 com.android.settings.location.LocationMode.onRadioButtonClicked:104 com.android.settings.location.RadioButtonPreference.onClick:64
D/audio_hw_primary( 444): out_set_parameters: enter: usecase(1: low-latency-playback) kvpairs: routing=2
D/audio_hw_primary( 444): select_devices: out_snd_device(2: speaker) in_snd_device(0: none)
D/audio_hw_primary( 444): enable_snd_device: snd_device(2: speaker)
D/audio_hw_primary( 444): enable_audio_route: apply and update mixer path: low-latency-playback
D/GpsNetInitiatedHandler( 849): location enabled :true
E/LocSvc_eng( 849): I/===> int loc_eng_init(loc_eng_data_s_type&, LocCallbacks*, LOC_API_ADAPTER_EVENT_MASK_T, loc_core::ContextBase*) line 1572
E/LocSvc_eng( 849): E/int loc_eng_init(loc_eng_data_s_type&, LocCallbacks*, LOC_API_ADAPTER_EVENT_MASK_T, loc_core::ContextBase*): log_eng state error: instance already initialized
E/ ( 849): E/open failed: /dev/mdm: No such file or directory
E/LocSvc_eng( 849): I/===> void loc_eng_agps_init(loc_eng_data_s_type&, AGpsExtCallbacks*) line 2144
E/LocSvc_eng( 849): E/void loc_eng_agps_init(loc_eng_data_s_type&, AGpsExtCallbacks*): log_eng state error: agps instance already initialized
E/LocSvc_eng( 849): I/===> void loc_eng_ni_init(loc_eng_data_s_type&, GpsNiExtCallbacks*) line 327
E/LocSvc_eng( 849): I/===> int loc_eng_set_server_proxy(loc_eng_data_s_type&, LocServerType, const char*, int) line 2443
I/LocationSettingsBase(15112): Location mode has been changed
I/LocationSettingsBase(15112): Location mode has been changed
I/GCoreUlr( 1712): Starting service, intent=Intent { act=com.google.android.location.reporting.ACTION_UPDATE_WORLD cmp=com.google.android.gms/com.google.android.location.reporting.service.DispatchingService (has extras) }, extras=Bundle[{receiverAction=android.location.PROVIDERS_CHANGED}]
I/GCoreUlr( 1712): WorldUpdater received intent Intent { act=com.google.android.location.reporting.ACTION_UPDATE_WORLD cmp=com.google.android.gms/com.google.android.location.reporting.service.DispatchingService (has extras) } with receiverAction android.location.PROVIDERS_CHANGED
I/GCoreUlr( 1712): No GCM registration ID
I/GcoreUlrLong( 1712): account#17#: reporting activated:LocationDisabled
I/GCoreUlr( 1712): Ensuring that reporting is active for [account#17#]
I/GCoreUlr( 1712): Starting service, intent=Intent { act=com.google.android.location.reporting.ACTION_LOCATION_STATUS cmp=com.google.android.gms/com.google.android.location.reporting.service.DispatchingService (has extras) }, extras=Bundle[{status=LocationStatus[cell status: STATUS_UNKNOWN, wifi status: STATUS_UNKNOWN, elapsed realtime ns: 0]}]
I/GCoreUlr( 1712): GMS FLP location and AR updates requested: {"sampleReason":"default","description":"default","timestampMs":1416852583394,"samplePeriodMs":60000,"sampleSource":"internal"}
__________________________________________________________________________________________________________________________


The Error
E/ ( 849): E/open failed: /dev/mdm: No such file or directory
I verified, there is no mdm-device.

I also cheched: I do not find any satelites, where I normaly get at least 5-8 ones.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 138
    Hello everyone,

    I present to you Android 5.1 AOSP for Xperia Z1. This is for the people that can't wait to see how lollipop looks like on Z1.

    == Project status ==
    Working:
    - Bluetooth
    - Wifi
    - NFC
    - LED
    - Offline Charging
    - Texting
    - Video Playback
    - Calling
    - Mobile Data
    - Sound
    - Sensors
    - Auto-Brightness
    - Vibration
    - Video playback
    - Screen/Touch
    - SELinux
    - GPS
    - everything that's not in the "not working list"

    Not working:
    - Camera
    - ....

    == Updates ==
    I'm working on fixing bugs and making this rom a daily driver. This might take some time though.

    == Download ==
    Download all files from the correct device folder, system and kernel are in the version directories :)
    - Rom: Xperia Z1 AOSP 5.1 Stable
    - Gapps can be found in the main directory ;)

    == Already on this rom?? ==
    No need to wipe data unless I tell it in the thread :)
    - Just flash system.img and boot.img using fastboot.
    - You can flash gapps in another kernel's embedded recovery.

    == Installation instructions: ==
    - Boot into recovery, wipe data, dalvik and cache :)
    - flash boot.img and system.img using fastboot
    - You can flash gapps in another kernel's embedded recovery.
    Don't try this roms when you don't know what you are doing!!

    == Changelog ==
    Code:
    [QUOTE][B]== Stable v1.0 ==[/B]
    - Android 5.1.0_r5
    - Everything except camera should be functional
    - New 3.10 kernel
    - Mobile data is working.
    - More bug fixes[/QUOTE]
    
    [B]== Beta v4.0 ==[/B]
    - Android 5.1
    - Video playback fixed
    - A lot better battery life
    - Mobile data doesn't function for now.
    - More bug fixes
    
    [B]== Beta v4.0 ==[/B]
    - More open source soundfx stuff
    - Mobile data is fully fixed
    - Overall more stable rom
    - Android 5.0.2_r1
    
    [B]== Beta v3.5 ==[/B]
    - Mic is fixed
    - Mobile data might not work
    - Screen flickering is gone (or at least a lot less)
    - Wifi works with clean install
    - Android 5.0.1_r1
    
    [B]== Beta v3.0 ==[/B]
    - Mic is still not working while calling
    - Mobile data is fixed
    
    [B]== Beta v2.5 ==[/B]
    - Z2, Z3 and Z3c have working modem etc and have same status as Z1 etc??
    - Recovery added: TWRP for Z1, ZU, Z1c, Z2 & CWM for Z3 and Z3c
    
     [B]== Beta v2 ==[/B]
    - Sensors are fixed
    - first Z1 compact, Z2, Z3 and Z3 compact release
    - Latest 3.5.2.2 kernel
    - Auto-brightness fixed
    - Rotation is working
    
    [B]== Beta v1.1 ==[/B]
    - Wifi is a lot more stable
    - Updated kernel
    - charging-LED is working now
    - Rom is more stable and supersmooth
    
    [B]== Beta v1.0 ==[/B]
    - Bluetooth
    - Wifi
    - LED
    - Texting
    - Calling
    - Sound
    - Brightness Slider (autobrightness doesn't work yet, turn it off to make slider working)
    - Vibration
    - Screen/Touch

    == Credits ==
    - Big thanks to Sony and all coopoerating devs with the unified kernel: https://github.com/sonyxperiadev/kernel
    - Unified kernel thread: Unified kernel xda thread
    == Screenshots ==
    In the screenshot part of devdb project are more screenshots ;)

    attachment.php


    attachment.php


    attachment.php


    XDA:DevDB Information
    [ROM][WIP]AOSP 5.1.0 Stable v1.0 | Lollipop for Xperia Z1 [14-04-2015], ROM for the Sony Xperia Z1

    Contributors
    krabappel2548
    Source Code: https://github.com/xperia-aosp-project?tab=repositories

    ROM OS Version: 5.1.x Lollipop
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Unlocked bootloader
    Based On: AOSP

    Version Information
    Status: Beta
    Current Stable Version: 1.0
    Stable Release Date: 2015-04-14

    Created 2014-11-06
    Last Updated 2015-04-14
    44
    Camera HAL gets fully loaded, still an error when opening camera app, but I'm getting closer to make it work ;)

    Sent from my SGP611 using XDA Free mobile app
    41
    I have a fix for wifi and camera ready :) but I'm not home yet, but New version will be compiled today when I'm home ;)

    Sent from my C6903 using XDA Free mobile app
    33
    Ok, I'm gonna try some other stuff, yesterday wasn't too productive and bugs remain. But camera can take pictures now probably and nfc is back ;) will test tonight :)

    Sent from my C6903 using XDA Free mobile app
    31
    I probably almost have working camera. But it can also still not work. But kernel is almost ready I think :)

    Sent from my SGP611 using XDA Free mobile app