[ROM][X00TD][8.1.0] LineageOS 15.1 [OFFICIAL][NIGHTLY]

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 86

     * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
     * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
     * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
     * Your warranty will be void if you tamper with any part of your device / software.
     * Same statement for XDA.

    LineageOS is a free, community built, aftermarket firmware distribution of Android 8 (oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

    What's working :
    • Boots
    • RIL (Calls, SMS, Data)
    • Fingerprint
    • Wi-Fi
    • Bluetooth
    • Camera
    • Camcorder
    • Video Playback
    • Audio
    • Sensors
    • Flash
    • LED
    • GPS

    Known issues:
    • You Tell me

    Instructions :
    • Download the latest build and GApps
    • Reboot to recovery
    • Flash the latest build and GApps
    • Reboot

    Download Official build
    Unofficial builds (AFH)

    Kernel Source

    XDA:DevDB Information
    [ROM][X00TD] LineageOS 15.1 [OFFICIAL], ROM for the Asus ZenFone Max Pro M1

    Shivam Kumar Jha, SagarMakhar
    Source Code: https://github.com/lineageos

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Latest firmware + Unlocked bootloader + TWRP
    Based On: LineageOS

    Version Information
    Status: Stable

    Created 2018-05-24
    Last Updated 2018-08-28
    [Q] Does it work on 4GB or 6GB variant?

    [Q] Is this GSI ?
    This is a ROM with device specific system, vendor & kernel.

    [Q] Is this port ROM?
    Built from source.

    [Q] Is camera2 API enabled?

    [Q] Do I need to flash mod to disable force encryption?

    Changelog (Official builds) - LINK
    Changelog (Unofficial builds):
    1. 20180523: Initial build
    2. 20180606: Here
    3. 20180609: Here
    4. 20180610: Here
    5. 20180615: Here
    6. 20180622: Here
    7. 20180702: Here
    8. 20180706: Here
    9. 20180712: Here
    10. 20180721: Here
    11. 20180723: Here
    12. 20180730: Here
    13. 20180824: Here
    14. 20180905: Here

    • OTA 316 sync (ASUS you dont let me rest continuously for a week :p)
    • Fixed low media volume
    • Fixed FM
    • Fixed NFC (ZB602KL users confirm this?)
    • Upstream changes

    About official lineage status,
    I got added in Lineage slack group ~3 weeks back & also got Sagar added later as we plan to co-maintain.
    Device trees have already been imported by lineage team. We are waiting for some patches to get merged & then official builds will initiate.

    I've also updated my stock camera port to 316.
    Official build starts

    Download official build

    Make sure to clean flash!
    Also remember to flash decrypt.zip if you are on unencrypted /data & would like to stay so.

    does it support GSIs.
    Yes the lineage vendor supports GSI. VoLTE will work too without flashing any additional patch :p
    I tried to make a user build for myself with the code. I ran into some sepolicy issues. These arent specific to this device but also showed up with another device I tried. Looks like a bug in lineage.
    libsepol.report_failure: neverallow on line 416 of system/sepolicy/public/domain.te (or line 8819 of policy.conf) violated by allow update_engine rootfs:file { write create setattr relabelto append unlink rename };
    libsepol.report_failure: neverallow on line 413 of system/sepolicy/public/domain.te (or line 8816 of policy.conf) violated by allow recovery system_file:dir { mounton };
    libsepol.report_failure: neverallow on line 260 of system/sepolicy/public/domain.te (or line 8663 of policy.conf) violated by allow update_engine update_engine:capability { sys_rawio };
    libsepol.check_assertions: 3 neverallow failures occurred
    Error while expanding policy
    When I look at the domain.te file, I see these lines at the mentioned line numbers -
    # Nothing should be writing to files in the rootfs.
    neverallow { domain userdebug_or_eng(`-recovery -update_engine') } rootfs:file { create write setattr relabelto append unlink link rename };
    # Don't allow mounting on top of /system files or directories
    neverallow * exec_type:dir_file_class_set mounton;
    neverallow { domain -init userdebug_or_eng(`-recovery') } { system_file vendor_file_type }:dir_file_class_set mounton;
    # Limit raw I/O to these whitelisted domains. Do not apply to debug builds.
    neverallow {
    } self:capability sys_rawio;
    Looks like there are exceptions being made for eng and userdebug builds, and hence it doesnt work with user builds.

    I could track down the recovery issue to device/lineage/sepolicy/common/private/recovery.te. I think its the following line. There is also an update_engine.te file that might be having the other troubled policies
    allow recovery system_file:dir mounton;
    I could probably get rid of the offending lines from the recovery.te and update_engine.te files, but just wanted to make sure thats the best way to move forward with this.

    X00TD has no build errors with device tree given in lineage-15.1 or we wouldn't have official build :eek:

    • OTA 311 sync
    • SeLinux: Permissive->Enforcing thanks to @SagarMakhar
    • Kernel: Merge 4.4.139
    • Upstream changes

    pending work
    1.fm radio doesn't work
    2.dual 4g (vodafone & jio)
    3.auto-rotate issue
    4. selinux - change to enforcing
    5. notification led will u change red to green because of its couldn't able to identified low battery level or any notification
    6.add night light option
    1. cool, will check
    2. yea known
    3. minor. fixed now, give feedback (clean flash)
    4. done
    5. dont know what you meant , led is fine totally
    6. livedisplay exists
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone