[ROM][X52x][OFFICIAL][9.0.0][s2] LineageOS 16.0

Rk585

Senior Member
Jan 8, 2017
153
756
113
Thiruvanathapuram
rk585.wtf


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.



What's working :
  • RIL (Calls, SMS, Data)
  • Fingerprint
  • IR Blaster
  • Wi-Fi
  • Bluetooth
  • Camera
  • Camcorder
  • Video Playback
  • Audio
  • Sensors
  • Flash
  • LED
  • GPS
  • Volte

Known issues:
  • Encryption

Instructions :
  • Download the latest build and GApps
  • Reboot to recovery
  • Flash the latest build and GApps
  • Reboot

Downloads :

XDA:DevDB Information
Lineage OS 16.0, ROM for the LeEco Le 2

Contributors
Rk585, The_Mard
Source Code: https://github.com/rk779/android_kernel_leeco_msm8976

ROM OS Version: 9.x Pie
ROM Kernel: Linux 3.10.x
ROM Firmware Required: Latest TWRP

Version Information
Status: Stable
Current Stable Version: 16.0
Stable Release Date: 2018-10-02

Created 2018-10-02
Last Updated 2020-01-04
 
Last edited:

[email protected]

Senior Member
Jun 10, 2012
137
34
58
kwebstore.k-touch.cn
Thanks for working on the ROM.
Do we need to flash a root solution?

Edit - installed magisk, and it works.

Noticed a couple of bugs -
1) the root option in system settings does nothing.
2) the network traffic monitor isn't working.
 
Last edited:

yash_ghar

Member
Jul 16, 2015
13
8
0
Hi @Rk585,

Phone was running lineage 15.1 20180811 build with no issues.

I clean flashed the lineage 16 20181002 build with open gapps pico .
On this build , microphone, speaker/ earpiece does not work for calls.

Only way to get audio in calls in lineage 16 is to use the provided type c to 3.5mm adapter with an earphone.
This was using Airtel and Vodafone sims.

I reverted to the prior 15.1 build (clean flash) and calls work with the microphone, speaker/ earpiece.

Only change was the lineage os.

My phone is indian le 2, with 19s bootloader.
TWRP was 3.2.3 IIRC.

If you get the time, please look into it.
 

[email protected]

Senior Member
Jun 10, 2012
137
34
58
kwebstore.k-touch.cn
It's been about 12 hours since I flashed it, and so far most things seem to work fine, though there are a few bugs.

Calling works fine for me.
I've been having problems with my primary Airtel number for some time, and can't hear the other person if I'm in one of the back rooms of my house. But if I go to a different area and toggle airplane mode it works fine. I've got a secondary Vodafone SIM too, and that hasn't given me any problems.

The camera gave me a little trouble. The stock camera app doesn't work well. On 15.1 Footej was slow, but stable. Last night I tried using it on 16, but after working for a few minutes it kept FC'ing. Resetting the app didn't help. This morning I reinstalled it, and now it's working again. The only change in my settings is that I didn't enable stabilization this time.

For me restarting the phone is iffy. Sometimes it restarts, sometimes it hangs, sometimes it just stays off. But if I power off, and then reboot there's no problem. I had a similar problem with 15.1, which I used for about 2 days before installing this.
I'm using the latest magisk. Also since I'm not using GAPPS, I've had to make the UnifiedNLP app a system app to get navigation to work. Maybe that's what's causing the reboot issue.

Getting a GPS lock was really slow in 15.1 and used to take about 10-15 minutes. It's improved a lot in 16, and takes only a couple of minutes. But, it was almost instantaneous in Lineage 13.

There were a couple of times the phone stopped responding. It hadn't hung, and the hardware buttons still registered touches, but I couldn't exit the app. This happened with the Footej gallery app and the KORE remote for Kodi. Sorry, I don't have the log files for them as I couldn't reproduce the issue.

Battery backup seems to be really good. On 15.1, and this ROM there was hardly any overnight drain. But for me the battery percentage began varying a lot between restarts, showing 4% at one reboot, and then, without charging, showing 50% at the next reboot. I've wiped all my caches, so I'm not sure what the problem is. BatteryBot Pro says my battery is healthy, and it lasts me more than a day with about 4 hours SOT.
Fast charging seems to work too. As does the hotspot.

Thanks @Rk585 for this ROM.
 
Last edited:

Yamel

Senior Member
Apr 14, 2015
100
19
38
Dark and black theme not working, can't scan codes, camera blurry, force closed on settings until duly sign up on Google play store before stable, no Sim deactivation or toggle as it was call
 

Atif Raini

Member
Jul 6, 2018
37
8
0
It's been about 12 hours since I flashed it, and so far most things seem to work fine, though there are a few bugs.

Calling works fine for me.
I've been having problems with my primary Airtel number for some time, and can't hear the other person if I'm in one of the back rooms of my house. But if I go to a different area and toggle airplane mode it works fine. I've got a secondary Vodafone SIM too, and that hasn't given me any problems.

The camera gave me a little trouble. The stock camera app doesn't work well. On 15.1 Footej was slow, but stable. Last night I tried using it on 16, but after working for a few minutes it kept FC'ing. Resetting the app didn't help. This morning I reinstalled it, and now it's working again. The only change in my settings is that I didn't enable stabilization this time.

For me restarting the phone is iffy. Sometimes it restarts, sometimes it hangs, sometimes it just stays off. But if I power off, and then reboot there's no problem. I had a similar problem with 15.1, which I used for about 2 days before installing this.
I'm using the latest magisk. Also since I'm not using GAPPS, I've had to make the UnifiedNLP app a system app to get navigation to work. Maybe that's what's causing the reboot issue.

Getting a GPS lock was really slow in 15.1 and used to take about 10-15 minutes. It's improved a lot in 16, and takes only a couple of minutes. But, it was almost instantaneous in Lineage 13.

There were a couple of times the phone stopped responding. It hadn't hung, and the hardware buttons still registered touches, but I couldn't exit the app. This happened with the Footej gallery app and the KORE remote for Kodi. Sorry, I don't have the log files for them as I couldn't reproduce the issue.

Battery backup seems to be really good. On 15.1, and this ROM there was hardly any overnight drain. But for me the battery percentage began varying a lot between restarts, showing 4% at one reboot, and then, without charging, showing 50% at the next reboot. I've wiped all my caches, so I'm not sure what the problem is. BatteryBot Pro says my battery is healthy, and it lasts me more than a day with about 4 hours SOT.
Fast charging seems to work too. As does the hotspot.

Thanks @Rk585 for this ROM.
Did you play any music ..
Music from speaker does not work fine
Only one time a song played that too from retro music player then when it stopped no sound came
Ringtones work incoming call works
No issue of network stability
I tried graphene kernel it works fine but music issue was still there
 

[email protected]

Senior Member
Jun 10, 2012
137
34
58
kwebstore.k-touch.cn
Music works fine for me, as does bluetooth. I connected to my cars audio, and could use it to make calls.
I think the problem I had earlier with the hardware buttons not responding has to do with system profiles. The recent apps button would stop responding randomly, and even a restart wouldn't fix it. I disabled profiles about 7-8 hours back, and the problem hasn't cropped up again. I use profiles to keep the phone unlocked when I connect to my home wifi, so maybe it's a permissions thing.

Also, I changed my GPS backend, and now I get a fix instantly.
And it's still showing negligible idle battery drain. I'm not using GAPPS, or any social networking apps, so that may be why.

The only issues I have now are with apps not being Pie ready. My banking app says my version of Android is too new, and to wait for an update. Keepass2 FC's if I try to use fingerprints to unlock the database. And Lawnchair launcher isn't very smooth.