[ROM][XC][P][9.0][WEEKLY]OmniROM

oshmoun

Senior Member
Aug 29, 2012
1,397
1,458
153
¯\_(ツ)_/¯
XC/KUGO/F5321 OmniROM BUILDS

PIE 9.0

DOWNLOAD WEEKLY

REQUIREMENTS TO SUCCESSFULLY FLASH OMNIROM:
1. The device has the latest stock ftf
2. The device has an unlocked bootloader
3. The ODM image zip (version 9) has been downloaded from HERE, and the ODM image has been extracted from it
4. The WEEKLY zip file has been downloaded and copied to the device

INSTALLATION INSTRUCTIONS:

1. Reboot device to fastboot mode, and flash the ODM image with this command
Code:
fastboot flash oem <ODM image>
2. Reboot device to TWRP and flash the WEEKLY zip file
3. (If coming from an 8.1 ROM) Fix /dsp SELinux labels with the dsp-label-fixer.zip
4. (Optional) Flash a gapps package
5. Reboot device to system

CURRENT ISSUES ON OFFICIAL:

1. Device crashes and reboots (mostly happens on demanding tasks)
2. Camera quality is suboptimal

KERNEL SOURCE: https://github.com/omnirom/android_kernel_sony_msm/tree/android-9.0

BUG REPORTS

REPORT BUGS ONLY:

- AFTER A CLEAN INSTALL
- USING STOCK OMNI KERNEL
- NO MODS OF ANY SORT

OMNI GERRIT REVIEW

https://gerrit.omnirom.org/

DISCLAIMER:

No one is responsible for any damage done to your device but YOU. You've been warned.

XDA:DevDB Information
[ROM][XC][P][9.0][WEEKLY]OmniROM, ROM for the Sony Xperia X Compact

Contributors
oshmoun, humberos
ROM OS Version: 9.x Pie
ROM Kernel: Linux 4.x
ROM Firmware Required: latest stock ftf

Version Information
Status: Beta

Created 2019-06-16
Last Updated 2019-06-16
 

Kianush

Senior Member
Jan 4, 2014
686
96
48
so are the micro lags fixed or still happening? there were slow downs and microlags on on games like clash royale etc... not as smooth as stock
 

spy_owl2

Senior Member
Feb 2, 2009
62
3
0
This is excellent news! For those of us coming from 8.1 should we dirty flash (along with dsp-label-fixer) or is full data wipe required?
 

Bluestar01

Senior Member
Jan 24, 2013
225
57
48
Tried already but not booting completely.

I came from Omni 9 homemade.
Installed this one and restartet and waited about 20 minutes, but only the omni sign visible with wobbly feelers.

Then restored backup.

Need to do complete clean install?
 

oshmoun

Senior Member
Aug 29, 2012
1,397
1,458
153
¯\_(ツ)_/¯
Tried already but not booting completely.

I came from Omni 9 homemade.
Installed this one and restartet and waited about 20 minutes, but only the omni sign visible with wobbly feelers.

Then restored backup.

Need to do complete clean install?
yes
official builds are signed and hence not really compatible with homemade
 

ardylemon

New member
Nov 19, 2016
4
0
0
Great work! thanks for taking time to upgrade this ROM to Pie.

Is GPS working? I have just installed the ROM with binaries v9 and GPS detects satellites, but cannot lock onto any. (I previously had harry's ROM with the same problem as well, I guess it's poor implementation from the AOSP end)

EDIT: GPS works
EDIT 2: GPS has a mind of its own and will not work except for the time when it does, currently investigating (probably something wrong with my phone)
 
Last edited:

droncheg

Senior Member
Aug 18, 2016
75
79
0
Krasnodar
Is GPS working? I have just installed the ROM with binaries v9 and GPS detects satellites, but cannot lock onto any. (I previously had harry's ROM with the same problem as well, I guess it's poor implementation from the AOSP end)
Just tried in GPSTest - locking works. Omnirom 9 official, v9 OEM. Clear field would be best test area =)
 
Last edited:

ardylemon

New member
Nov 19, 2016
4
0
0
Just tried in GPSTest - locking works. Omnirom 9 official, v9 OEM. Clear field would be best test area =)
Thank you, I also got it to work after waiting a while, enabling mobile data as well as derping around with A-GPS settings in the process appears to have worked (not sure which, though). For future reference, my phone locked in after detecting at least 8 satellites with ~20% signal.
 

badbatlinux

New member
Jun 19, 2019
1
0
0
All seems work (camera, fingerprint...) but an important things don't work. The phone conversation don't work (micro and audio), I can't received and emit sound. BUT the contact can received the sound of phone numbering ?!?!!
I specify that the sound and the microphone works perfectly.
So it's unusable.
I return to => Omnirom 8.1
 

Pergin

Member
Jan 17, 2016
21
0
21
All seems work (camera, fingerprint...) but an important things don't work. The phone conversation don't work (micro and audio), I can't received and emit sound. BUT the contact can received the sound of phone numbering ?!?!!
I specify that the sound and the microphone works perfectly.
So it's unusable.
I return to => Omnirom 8.1
I've not this problem, for me all is working well and smooth (the only problem is quickswitch magisk module not working).
 

Matej101

Member
Oct 5, 2016
32
6
0
All seems work (camera, fingerprint...) but an important things don't work. The phone conversation don't work (micro and audio), I can't received and emit sound. BUT the contact can received the sound of phone numbering ?!?!!
I specify that the sound and the microphone works perfectly.
So it's unusable.
I return to => Omnirom 8.1
The Unofficial version of OmniROM by HarryHarryHarry had a similar issue, the fix was to first flash the latest stock ftf image (ends with .118), flash twrp and do a clean install of the rom. I would think this fix is going to work for this version too.
 

yanom

Member
Jun 17, 2012
39
1
0
I'm currently running the Omnirom 8.1, and I just got a pushed message from OpenDelta on the phone itself:

Update ready to download
omni-9-20190616-kugo-WEEKLY
Can I update to Omnirom 9 from the phone itself by running that? Or must I download the rom on my computer and install it the normal way?
 

mase76

Senior Member
Aug 26, 2011
333
54
58
After updating to the latest weekly today, some apps got uninstalled again. I dad this behaviour also with the test builds before.