[ROM][XZ][P][9.0][WEEKLY]OmniROM

Search This thread

oshmoun

Senior Member
Aug 29, 2012
1,397
1,459
¯\_(ツ)_/¯
XZ/KAGURA/F8331 OmniROM BUILDS

PIE 9.0

DOWNLOAD WEEKLY

REQUIREMENTS TO SUCCESSFULLY FLASH OMNIROM:
1. The device has the latest stock ftf
2. The device has an unlocked bootloader
3. The ODM image zip (version 9) has been downloaded from HERE, and the ODM image has been extracted from it
4. The WEEKLY zip file has been downloaded and copied to the device

INSTALLATION INSTRUCTIONS:

1. Reboot device to fastboot mode, and flash the ODM image with this command
Code:
fastboot flash oem <ODM image>
2. Reboot device to TWRP and flash the WEEKLY zip file
3. (If coming from an 8.1 ROM) Fix /dsp SELinux labels with the dsp-label-fixer.zip
4. (Optional) Flash a gapps package
5. Reboot device to system

CURRENT ISSUES ON OFFICIAL:

1. Device wakes up by itself every 5 seconds, reason unknown
2. Camera quality is suboptimal

KERNEL SOURCE: https://github.com/omnirom/android_kernel_sony_msm/tree/android-9.0

BUG REPORTS

REPORT BUGS ONLY:

- AFTER A CLEAN INSTALL
- USING STOCK OMNI KERNEL
- NO MODS OF ANY SORT

OMNI GERRIT REVIEW

https://gerrit.omnirom.org/

DISCLAIMER:

No one is responsible for any damage done to your device but YOU. You've been warned.

XDA:DevDB Information
[ROM][XZ][P][9.0][WEEKLY]OmniROM, ROM for the Sony Xperia XZ

Contributors
oshmoun, humberos, local__hero
Source Code: https://github.com/omnirom

ROM OS Version: 9.x Pie
ROM Kernel: Linux 4.x
ROM Firmware Required: latest stock ftf

Version Information
Status: Beta

Created 2019-03-17
Last Updated 2019-05-31
 

KikiGames

Senior Member
Feb 17, 2019
52
3
Thank you for the separate this from the other pie roms.
I will flash it after I arrive home.
Thank you all for the hard work!

Sent from my kagura using XDA Labs
 

XxperexX

Senior Member
Jul 19, 2017
123
10
Finally flashed! been using it for less than an hour, i can say that its definitely good for daily use. Camera seems better and hasnt crashed yet (like it use to), mic actually picks up audio properly, brightness slider is finally proportional to the brightness level, and its pie :D

however, the stereo speaker seems to muffle at high volumes (especially with the ringtones and less with youtube, but still a little prevelent), app opening times seem a little longer than 8.1, and 120HZ still doesnt work :(

im also curious why the linked odm isnt the latest one (im pretty sure the latest is 1st march not feb)

anyways, thanks dev! (may be editing this thread after more use for battery etc)
 
Last edited:

sinivalas23

Member
Dec 16, 2011
23
5
however, the stereo speaker seems to muffle at high volumes (especially with the ringtones and less with youtube, but still a little prevelent)

Could it be this kernel bug: https://github.com/sonyxperiadev/bug_tracker/issues/336 ? Looks like the sonyxperiadev team is working on it.

im also curious why the linked odm isnt the latest one (im pretty sure the latest is 1st march not feb)

The March 1 release says "Android 8.1", the linked one looks like the latest for Pie.
 

bloodey

Member
Mar 30, 2018
10
0
I saw this version from delta updater (using 8.1 omni) and immediately downloaded flashed oem for pie and downloaded omni 9 but it stucked new omni animated logo. Waited like 10 minutes but nothing happened then rebooted phone but same thing happened. Should i wait more or something went wrong?
 

KikiGames

Senior Member
Feb 17, 2019
52
3
Im here with OmniROM freshly flashed trough Open Delta.
I have some problems. First boot never ends, BUT restart worked for me but I have another problem.
Now I need 10 min to unlock the phone when Im lucky.
I unlock with the code and then its instantly relock and it say I cant use fingerprint for first unlock, so I use code again and not work again and still can't use fingerprint.
I do this A LOT OF TIME before I can use my phone. Sometimes it helps sometimes not if I not unlock my phone but use corner dial icon first and then if its ask for code i use it and then I got SystemUI crash error again and again and again.
As I said I try to repeat this methods for like 10 min after every restart. I tried to delete some maybe not compatible apps with this new update but still nothing. Now I will remove some Magisk modules. I will write again.
 

oshmoun

Senior Member
Aug 29, 2012
1,397
1,459
¯\_(ツ)_/¯
Im here with OmniROM freshly flashed trough Open Delta.
I have some problems. First boot never ends, BUT restart worked for me but I have another problem.
Now I need 10 min to unlock the phone when Im lucky.
I unlock with the code and then its instantly relock and it say I cant use fingerprint for first unlock, so I use code again and not work again and still can't use fingerprint.
I do this A LOT OF TIME before I can use my phone. Sometimes it helps sometimes not if I not unlock my phone but use corner dial icon first and then if its ask for code i use it and then I got SystemUI crash error again and again and again.
As I said I try to repeat this methods for like 10 min after every restart. I tried to delete some maybe not compatible apps with this new update but still nothing. Now I will remove some Magisk modules. I will write again.
you need to do a full wipe before upgrading to p
 
  • Like
Reactions: fallingandroid

AJMeisterXD

Member
Mar 22, 2017
29
9
Newcastle upon Tyne
Just as @oshmoun said; before flashing new ROMs, it's imperative to do full wipe (if you don't want to lose all your data, then do a full backup in TWRP), as flashing without full wiping can cause TONS of problems. Don't be lazy and follow the instructions properly.
 

ouiski

Member
Apr 14, 2013
7
2
Hello !

It's cool to see our XZ is alive !

I have some problems with this rom after a full wipe and update to oem V6 :

- no sounds during calls, no mic, no earphone, no sounds on speaker
- Magisk 18.1 not working
- With official camera app, while using the flash, only the autofocus led is lit, the second and much powerful led is never triggered resulting on dark shots

For now that's all

Thx
 

Layns

Senior Member
Nov 29, 2016
113
20
Performance is somewhat distressed and the camera does not work for the sound is not working after restarting the device is improving
 
Mar 20, 2017
42
0
Moto G Power (2021)
Flashed data, cache and dalvik, factory reset. And installed latest nightly with gapps and magisk 18.1.
Only reason I did it this way is because I was on a unofficial build on Omni. Everything is working as it should. Very snappy and no lag. Still have to see how the ROM handles after it's settled for a couple day, but right off the bat it's amazing. Thank you very much Dev, and happy to see you back on XDA. :)
 

KikiGames

Senior Member
Feb 17, 2019
52
3
you cant do that. its pretty misleading having it available on that opendelta ota thingy. you have to follow the instructions in this thread

:(
Why this ROM showed up as an update then? :(
I just don't understand it.
Nevermind this is my main and only phone and I work 4 days straight before I can use my PC so I need to use this ROM buggy for me. :/
 
Mar 20, 2017
42
0
Moto G Power (2021)
:(
Why this ROM showed up as an update then? :(
I just don't understand it.
Nevermind this is my main and only phone and I work 4 days straight before I can use my PC so I need to use this ROM buggy for me. :/


You need a PC to flash this. Follow all steps in order and it'll work. Always remember, unless you have a messaging app that backups texts, you will lose them flashing a cfw. Always always backup anything you don't want to lose.

---------- Post added at 12:56 AM ---------- Previous post was at 12:28 AM ----------

I've had a reoccurring issue on the unofficial and official builds so far. I do not have the option to use my phone when calling unless speaker phone or a Bluetooth headset. I cannot put the phone to my head and use normally. Is there any kind of option to fix this nuisance. Any feedback is truly appreciated
 
Mar 20, 2017
42
0
Moto G Power (2021)
Every 9.0 ROM I ever flash, I always seem to have the same problem. Whether its dirty flashing, or starting with flashtool, to CMD, and then to TWRP, the same problem seems to happen. After the ROM has settled, audio quality through calls becomes a huge problem. I'm not sure if I'm doing something wrong, but it has been a persistent bug, next chance I get for the next nightly ill send a logcat, kinda cant not since back on stock. I need good call quality for work lol. Either way, thank you for bringing OMNI to 9.0 official
 

XxperexX

Senior Member
Jul 19, 2017
123
10
anyone having problems with video playback? videos dont play on instagram, youtube or snapchat. using magisk 18.1 and latest omni 9 rom

edit: nvm, found out that the Google camera fix module for magisk was the problem :(
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    XZ/KAGURA/F8331 OmniROM BUILDS

    PIE 9.0

    DOWNLOAD WEEKLY

    REQUIREMENTS TO SUCCESSFULLY FLASH OMNIROM:
    1. The device has the latest stock ftf
    2. The device has an unlocked bootloader
    3. The ODM image zip (version 9) has been downloaded from HERE, and the ODM image has been extracted from it
    4. The WEEKLY zip file has been downloaded and copied to the device

    INSTALLATION INSTRUCTIONS:

    1. Reboot device to fastboot mode, and flash the ODM image with this command
    Code:
    fastboot flash oem <ODM image>
    2. Reboot device to TWRP and flash the WEEKLY zip file
    3. (If coming from an 8.1 ROM) Fix /dsp SELinux labels with the dsp-label-fixer.zip
    4. (Optional) Flash a gapps package
    5. Reboot device to system

    CURRENT ISSUES ON OFFICIAL:

    1. Device wakes up by itself every 5 seconds, reason unknown
    2. Camera quality is suboptimal

    KERNEL SOURCE: https://github.com/omnirom/android_kernel_sony_msm/tree/android-9.0

    BUG REPORTS

    REPORT BUGS ONLY:

    - AFTER A CLEAN INSTALL
    - USING STOCK OMNI KERNEL
    - NO MODS OF ANY SORT

    OMNI GERRIT REVIEW

    https://gerrit.omnirom.org/

    DISCLAIMER:

    No one is responsible for any damage done to your device but YOU. You've been warned.

    XDA:DevDB Information
    [ROM][XZ][P][9.0][WEEKLY]OmniROM, ROM for the Sony Xperia XZ

    Contributors
    oshmoun, humberos, local__hero
    Source Code: https://github.com/omnirom

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    ROM Firmware Required: latest stock ftf

    Version Information
    Status: Beta

    Created 2019-03-17
    Last Updated 2019-05-31
    4
    Does anyone experience random reboots?
    4
    i cant see any improvements anywhere sadly. i test the compatibility with the v8 and v7 oem images myself just by flashing it manually. on both, the sim cards arent recognised.

    It'd be cool if OP gave us a changelog or something, but hes probably busy or something :p
    there's a changelog app just for that :)
    but concerning the changes between odm versions, i don't have the ability to know what changes there beyond what Sony publishes on their page.

    so now, just updated the trees to the latest from upstream.
    starting from next weekly, you all MUST flash v8 odm.
    4
    I'm sorry to say but until we have found the root cause of these stability issues, I'd recommend Stock for newcomers as well.
    There was a regression introduced within the last month or so and we're hard at work tracking it down.

    ---------- Post added at 22:38 ---------- Previous post was at 22:31 ----------

    How to install oreo??
    Please ask in the Q&A section, don't clutter this thread.

    I think its better switch to aosp. Past few days i experienced random reboots, overheating, freezes and no deep sleep issue on latest omni pie
    OmniROM is built from the same sources as my AOSP builds. Same kernel, same binaries, Omni just has a changed framework and more customization options.
    So you will experience the same issues.

    any news on development ?
    im waiting for the new weekly rom
    Asking for ETA is a quick way to get banned... just don't do it. We're all spending our precious free time for your benefit, please respect that.

    Omni itself is great but has too many issues (overheating, random reboots and freezes). After flashing AOSP i spotted one huge problem: screen freeze and touch is not working after some time.
    I'll turn off double-tap-to-wake entirely in the next builds. Because it's unstable (the errors you experienced are a side effect), I offered it as an opt-in experiment for advanced users, but seems regular users will turn it on regardless.
    3
    Just updated to the new weekly version and still testing, now using oem v8, don't know what the effect of the oem update, mic still not working, not sure what else fixed
    you need to flash stock before flashing omni.
    it's mentioned in OP as part of the requirements.