[ROM] [ z2_plus ] AICP 13.1 | Oreo 8.1.0 | OFFICIAL | Treble | WEEKLY

Not open for further replies.
Search This thread
Nov 1, 2015
Just dirty flashed aicp 13.1 weekly 20181005, stuck at boot logo forever. Didn't took backup of previous build, which was September build I guess(the stable one). Now I'm running on may build, which has the USB tethering bug and I can't find builds after May and before October. Any links would be appreciated to September build. Anyone else facing this problem? I tried flashing custom kernal and then the weekly, doesn't work. Will be clean flashing soon to October weekly to see if that works. Any thoughts?
Just dirty flashed aicp 13.1 weekly 20181005, stuck at boot logo forever. Didn't took backup of previous build, which was September build I guess(the stable one). Now I'm running on may build, which has the USB tethering bug and I can't find builds after May and before October. Any links would be appreciated to September build. Anyone else facing this problem? I tried flashing custom kernal and then the weekly, doesn't work. Will be clean flashing soon to October weekly to see if that works. Any thoughts?

First flash ROM and then custom kernel.
  • Like
Reactions: [email protected]
Yup! That's what I did after seeing a old post about it and it worked, anyways thanks. And will it be OK if I flash another kernal? I first flashed nameless r18 before flashing weekly. And now I have faiz rebase kernal which I flashed after flashing weekly which worked. Now, I want to flash r18 again.

Check other posts for flashing other kernels.. although nameless treble shld work coz I used it in treble ROMs. Try and share reviews


Senior Member
Jan 7, 2018
Currently I'm in AICP 13.1 and I want to update my baseband how can i do it??
Actually the VOLTE performance and signal reception performance is reduced that ZUI rom.
Is there any way to impose it??
Last edited:
I'm trying to solve the problem of gps. I read in some post that it might be related to baseband.So I trying to update it.
This is indian baseband.. so should pose no problems.. but if u want to change. Then u can go for 1.70.. that's Chinese.. either flash baseband through twrp.. search forums or go official way by flashing zui 1.9 and upgrade to latest.
  • Like
Reactions: awesomeRj


Senior Member
Jan 7, 2018
I have installed factory2vendor.zip for treble. And Installed treble AICP version. Everything is working fine but voice is not working during call. I can not hear the other person and other person cant not hear my voice. Although Whatsapp call is working properly.
Can someone know about this issue. Please help. I really screwed up.


Senior Member
Jan 7, 2018
Anyone else facing problem of "failed to mount system (invalid argument)" after flashing 19 oct 2018 weekly build of AICP 8.1?


Senior Member
Dec 26, 2013
When i try to flash this rom i can't öpen my phone. Always bootloop. I tried magisk 17.1 and 16.3 but always same. First i try to clean flash over toxyc OS and after that tried after zui 4.0 but same. Always bootloop. Problem is magisk?


Senior Member
Jan 7, 2018
Anyone else having problem of "failed to mount system (invalid argument) " after flashing weekly biuld of 19 oct 2018 of AICP 8.1 ??


Senior Member
May 20, 2018
I am on 20180629.zip build.(Stable build)
1 Should i update ? & 2 Why??
Want kernel too
3 Suggest some(I know you will suggest nameless )
4 Will this nameless will perfect for my 20180629 build? :confused:
Thanks in advance
Uses :- Right now normal(watching video,e.t.c)
NO PUBG(5 can this help me in pubg in future kernel??)


  • Screenshot_AICP_OTA_20181027-205415.png
    155.2 KB · Views: 1,426
Last edited:

Vaibhav K

Sep 12, 2016
Redmi Note 10 Pro
Anyone else having problem of "failed to mount system (invalid argument) " after flashing weekly build of 19 oct 2018 of AICP 8.1 ??
This is happening because this ROM is a Project Treble ROM.
Treble - where /factory partition is renamed into /vendor partition
Non-Treble - where we were mounting /factory as /vendor directly
To solve this issue please refer the below-mentioned thread

---------- Post added at 02:38 AM ---------- Previous post was at 02:28 AM ----------


You tell... :p

so here i tell you-

Are there any bugs in the latest build i.e. "October 26,th 2018" such as USB Tethering or Volte or Agps ??
  • Like
Reactions: awesomeRj


Senior Member
Jan 7, 2018
In all music player the player is automatically playing next song without completing previous song? Anyone having/had this bug?


Jan 11, 2018
Yes, I'd same issue.
What helped me was :
1. Wipe the System, Cache, Data and ART/Dalvik cache.
2. Reboot

However, I have same issues regarding calls but for me even whatsapp call is not working :(
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 63


    Android Ice Cold Project

    AICP is known by everyone as the "Ice Cold Project" that started on a Desire HD years ago (2012) and since then has evolved into a mature ROM with the BEST community that you can find!!!

    Until Lollipop, the Rom has always been based on AOKP. Unfortunately, since AOKP stopped development (but made a comeback later), we changed our base to CM.
    With the re-brand of CM to LineageOS (LAOS) we are now LAOS based with some tweaks from AOSP.

    If there are any bugs, either we will sort them out or the LAOS team will if it concerns their code base. This rom isn't LAOS supported, so no need to report errors/bugs to them!!

    #include <std_disclaimer.h>
     * Your warranty is now void.
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you. Hard & a lot.


    Feature list (rough Overview)


    In the beginning we would like to thank:

    LineageOS & CM (R.I.P.) team
    @Maxwen and the rest of the OmniRom team
    DU team
    SlimRoms team
    Resurrection Remix team


    @LorD ClockaN
    plus the rest of the crazy bunch that we call "team"


    We are paying for servers that build nightlies/weeklies and everything that comes with it, so EVERY DONATION will really be appreciated and be used to cover those expenses.
    Thank you!!


    Latest Stable Release Version 13.1

    Download link: http://dwnld.aicp-rom.com/?device=z2_plus

    Official builds will be deleted from our servers every month due to maintenance services.
    We advise everyone to keep at least the latest or best working build on their device as a backup.
    Maybe copy it to a cloud service or USB too.

    Archived build will goes to this link AFH


    Full Changelog link: http://dwnld.aicp-rom.com/

    Google Apps:
    we're recommending you guys to use beansgapps bcuz it's stabiltiy https://drive.google.com/file/d/1CyUh99f8893eYHxYkPgZHvr1caH8z9Sc/view


    using GZR Gapps
    small, fast, and blazing


    • USB Tethering

    Before using the ROM:
    Q. Can I have an ETA for the next build?
    A. Yes, just look in the OP to see if your device is built on a nightly or weekly schedule.

    Q. Does this ROM support custom kernels?
    A. No. You can still use them, but discussion should go in the thread of the respective kernel. We don't offer support for bugs you might encounter while using them!

    Q. Why doesn't this ROM support Xposed?
    A. Xposed is a hack that is geared towards AOSP, custom ROM's modify the framework a lot, so Xposed can cause a ton of issues on custom ROM's. Now it might work for you, however it is not to be discussed in this thread, and you should refrain from posting bug reports.

    Q. Alright, but I still want to flash Xposed, so which version do I need to install?
    A. Xposed is not yet available for Oreo.

    Flashing the ROM:
    Q. What do I need to know before flashing?
    A. Check the install instructions in the first post...

    Q. Can the builds be dirty flashed over each other?
    A. Yes, however make a nandroid backup first as there is a chance of getting a bootloop or encountering bugs. Also bugs may only be reported on a clean flash.

    Q. How do I dirty flash builds?
    A. Wipe the System, Cache and ART/Dalvik cache. Flash the ROM, GApps (only needed if you wipe the system), your preferred root solution and reboot. Or just use the OTA app to preform that task for you.

    Q. How do I flash kernel builds?
    A1. If it's a .img file, boot into TWRP and go to the install page in TWRP, in the bottom right corner select "install image", select the desired kernel, then select "boot", then swipe to flash, then go back to the install screen and install your root method again, if you don't want to loose root and reboot.
    A2. If it's a flashable ZIP, you can flash it together with a ROM update or separately. Go to the install page in TWRP, choose the kernel zip (or add it to the flash queue right after the ROM zip). Then add your root method to the queue if you don't want to loose root. Now swipe to flash, and then reboot.

    Using the ROM:
    Q. How do I enable software buttons?
    A. Go to Aicp Extras/Navigation bar, and enable it.

    Q. I installed a bad theme and now I'm getting a bootloop, how do I fix it?
    A. In TWRP, flash the substratum rescue zip that's in the substratum folder on the internal storage.

    Q. I keep losing root with Magisk, how do I fix it?
    A. Check this out. If that doesn't work for you, ask for help in this thread, read or ask in the Magisk thread on XDA or just re-flash Magisk!

    Q. I'm having issues with WhatsApp, how do I fix it?
    A. Read this

    Q. Do I need to provide a logcat if I'm reporting a bug?
    A. If you want it to be fixed faster (or at all) then yes, you should definitely provide a logcat. (Note: Please just link the logcat from your GDrive, Dropbox, etc. and do not post the content here. Thanks.

    Q. How do I get a logcat, what type should I get and more questions that can conveniently be answered by my pre-determined answer?
    A1. Read this thoroughly. Also, here's a good app for getting logs: https://play.google.com/store/apps/details?id=com.tortel.syslog (Root needed).
    A2. If you are already rooted, you can use the built-in feature to make a logcat and provide that. Just look into the root section in the AICP Extras menu.


    The ROM should contain everything you need to enjoy Android Oreo. You don't need to install any Add-on's, simply download the latest ROM, GApps, flash it and go!
    If you want the device to run the ROM "rooted", you can flash a root solution of your choice after the ROM Zipfile.

    It is STRONGLY recommended to fully wipe your device before flashing and please avoid restoring system apps and system data with Titanium Backup as this can cause stability issues that are very hard to debug.
    If you believe you know what you're doing - then fine, go ahead, but please don't complain if you experience any strange behavior.
    How to flash:
    (Again: Don't do it if you don't know it!)

    1. Download the ROM and GApps and transfer them to your device.
    2. Boot to recovery (TWRP recommended).
    3. Wipe the System, Cache, Data and ART/Dalvik cache.
    4. Flash the ROM Zipfile.
    5. Flash the GApps (optional, needed for e.g. Google Playstore to work).
    6. Flash the root solution of your choice (optional).
    7. Reboot your device.
    The ROM has GApps persistence in between dirty flashes, so you only have to flash them once!
    The root solution should be flashed together with every OTA update (= ROM Update) as long as the instructions of your
    root solution do not state something else (="persistence on dirty flashing") !

    Currently Supported Root Solutions:

    Magisk v16.3-factory

    The kernel in this ROM follows LAOS source with custom additions.

    To be able to flash using the built-in OTA app, TWRP recovery is needed.
    You can still use the LAOS recovery and OTA app, but you will need to download the zip file and flash it manually from within your recovery. The Zipfile gets saved in the "aicp_ota" folder on your internal storage.
    Please be sure that you are on the latest TWRP recovery. Keep in mind that this could also be an unofficial version!

    If you want to contribute to the AICP or want see what is being worked on/merged, feel free to visit our Gerrit code review system. (Link is at the bottom!!!)


    Kernel source:

    ROM & Additional links:
    AICP Gerrit Code Review
    AICP on Github

    AICP G+ community

    (mention all the devs who have contributed to your device tree, kernel, vendor, etc,
    only mention the main ones though, probably the top four or so, otherwise this list will be a mile long unless if you're a huge kanger xD)

    ROM OS Version: 8.x.x Oreo
    Kernel: Linux 3.18.y

    Version Information:
    Release Date: dd-mm-yyyy

    You want to see a "normal" night at the "DEV office", click here!!

    XDA:DevDB Information
    AICP 13.1 z2_plus, ROM for the Lenovo ZUK Z2 (Plus)

    faizauthar12, zipsnet
    Source Code: https://github.com/AICP

    ROM OS Version: 8.x Oreo
    ROM Firmware Required: ZUI 3.5
    Based On: LineageOS 15.1

    Version Information
    Status: Stable

    Created 2017-10-15
    Last Updated 2018-04-15

    Reporting Bugs

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.

    Frequently Asked Questions:
    Q)Why is this UNOFFICIAL?

    Q) Where are Developer options?
    A) Go to Settings > About phone, and press five times on Build number.

    Q) How can I enable root access?
    A) Go to Settings > Developer options > Root access, and enable it for apps, adb or both.

    Q) How do I update GApps? (Also useful if you have GApps related problems).
    A) Reboot to recovery. Wipe System, Cache and Dalvik Cache. Install ROM + GApps. (Yes, without rebooting). Reboot.

    Q: i got an error 7, vendor whatever it is
    A: please head over to this thread https://forum.xda-developers.com/lenovo-zuk-z2/how-to/z2plus-treble-roms-flashing-reverting-t3778287 and please use factory2vendor ( this rom has Full treble support )

    Thread cleaned
    attacks on other members will not be tolerated and will be treated severely
    Racist remarks merit immediate removal from this private site
    Either report bugs properly with logs or use something else
    If you feel you can do better, please build your own
    Developers do this for free and as a hobby
    Complain to the people you actually paid for the software, Google and your manufacturer!
    Now this thread will remain within the forum rules going forward, right? :)
    Thank you for your cooperation :good:
    Friendly Neighborhood Moderator
    Thanks for your attention guys

    Finally jenkins build isn't fail anymore
    You are safe to go with ota
    It have a working OTG , and VoLTE

    Enjoy the weekly build from now on!!

    Sent from my z2_plus using XDA Labs
    Weeklies updates!!


    Highlight changelog :

    • full treble support
    • substratum OMS integration
    • April security patch updates!

    from now on please flash a custom Magisk attached below
    and for more updates please subscribe to z2 plus portal channel at telegram http://t.me/zukz2plusportal