• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][Z3TC] LineageOS 18.1 SGP621 [UNOFFICIAL]

Search This thread
I've successfully installed LineageOS and pbrp recovery (On SGP611) but installing Magisk doesn't work. I tried installing the Magisk mod from post #1 several times and I constantly have the same problem as MaX.


I also tried this, installing from the github but instead with Magisk 23, it didn't work. I either gets stuck on the Xperia logo on boot or it installs the app but inside the app it says that Magisk isn't installed.


I have installed it using this method, so the problem is not the way it is installed. I guess.

And I have not installed any Gapps, I don't know if that's a problem or not.

Any help on fixing this bug would be highly appreciated.

I was also wondering that only if Magisk really doesn't work, could SuperSU be used instead of Magisk? Especially since it has been discontinued quiet a while ago.
For the ones having this issue I had, I've found a solution. If magisk is having a package error, install magisk 22.1 from their website and install the apk. After that, return to the recovery menu and flash the magisk mod zip again. It works after that.
 

bbiwy

Member
Nov 4, 2021
6
0
SGP621 LTE

Hi evil-god,
it seems it is not possible to join an encrypted hotspot (e.g. hotspot provided from my laptop).

I tried with a clean install, no Magisk, no firewall, just flashed the rom from #2. I could enter the password to the network, but I got no connection to the hotspot.

Access to an unsecured/unencrypted hotspot, however, works fine. Just with encrpytion it is not possible.

Access to any WLAN works fine also without complication.

When I try with your LineageOS 15.1 it works perfect, no problems.

Maybe you can check if there is something wrong, please.

Thx,
bbiwy.

Nobody else facing problems connecting to a computer-hotspot?

I using a computer-hotspot to get the Z3tc to the internet.
So it worked fine so far as I was on Lineage15.1. But when I changed to Lineage18.1 it won't work anymore.

Testing results:
1) computer-hotspot is working with my tablet and Lineage 15.1
2) computer-hotspot is working with a Samsung S8 and Android 11
3) computer-hotspot is NOT WORKING with my tablet and Lineage 18.1. It looks like that the tablet is not able to contain the IP-address(?)
4) strange, a hotspot provided by any mobile phone will work with Lineage 18.1

Any idea?
 

Attachments

  • Lineage15_hotspot.jpg
    Lineage15_hotspot.jpg
    124.8 KB · Views: 30
  • Lineage18_hotspot.jpg
    Lineage18_hotspot.jpg
    146.3 KB · Views: 30

getchaosde

New member
Feb 25, 2009
3
0
Amazing...never have flashed any device before, but my SGP611 recently became totally useless with the official 6.0 Android on board.

Didn't really need a new tablet, because i rather use my 6,7 inch phone and my laptop. But it was still useful for stuff like chords for my Ukulele. Except that i couldn't install any apps anymore because of Android 6.

Had to read and test stuff out for a few hours before finally getting through trial and error to install everything. But now it works like a charm. Thanks so much.

Hopefully this gets a few more years out of this trusted device!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Any skilled tester here? i make a build for the SGP611, now i need some brave tester, you should know how to collect debug data like "adb logcat > boot01.log".

    ROM IS UNTESTED, IF YOU DONT KNOW HOW BRING IT BACK TO LIFE FROM A BOOTLOOP, DONT WRITE ME!

    write me a message to get a download link.
    see #2 for download
    4
    Thank you Evil-god for making a new build for us SGP611 Users. (y)(y)(y)(y)(y)
    I really appreciate that.
    I tried to install the new build but i got an error like siphyn mentioned before. (error: 3004).
    How can I rename the device?

    You're going to want to use a program like peazip or 7zip or an archive utility of your choice. Open up the rom zip file you downloaded and navigate to META-INF/com/google/android/

    If you're in the correct folder you should see update-binary and a updater-script file. Open up the updater-script file with notepad or a text editor. Delete everything above the line beginning with ui_print and then save and repack the zip file. At this point this bypasses the device ID check when flashing the rom in recovery. Make sure you double check you're using the correct rom either wifi or cellular depending on what model you have because there is no device check at this point in the script.

    On another note, I just decided to wipe the device using emma and, even once I did that and updated the device back up to 23.5.A.1.291, avoiding any custom roms, the device identifies as a z3tc in both TWRP 3.0.2 and in the provided Orange Fox recovery. So, if you have a SGP611 or SGP612 and you're running into issues, you may have to do the above to get the rom to flash. Other than that, this rom has been pretty solid.
    2
    Hello evil-good,

    it is very nice to see, that you update the SGP621 build so regularly. But the SGP611 build from joschi1979 unfortunately has not been updated since May. :(
    I think he is no longer maintaining it.
    Is there a possibility that you could also create a updated build for the SGP611 users?
    I think many SGP611 users including me would be very thankfull.
    And don't forget Christmas is not far away. ;)

    Best wishes from Styria
    2
    Hey thanks for the update. I installed this earlier today on my SGP612 32GB. So far I can confirm the following works:

    Notification LED
    Camera both front and back
    Gyro and compass
    Power management (tablet charges rapidly when using a qc2.0 adapter) battery saver seems to work well for standby.
    Volume control both via hardware buttons and on screen.
    Auto brightness.
    No issues with video playback.
    NFC. I tested logging in using my yubikey just fine.
    Sdcard and adoptable storage function normal.
    Wifi and Bluetooth.
    Haptic feedback
    Power button and tap to wake/sleep
    3.5mm audio and speaker audio.
    Microphone input.

    If there is anything you'd like to test let me know.

    Edit: one last thing is I had to edit the install script. In recovery I received a script aborted E3004: this package is for device: z3tcw, scorpion_windy, SGP611, SGP612; this device is z3tc.error: 3004

    I don't think there should be a w at the end of z3tc and so I just deleted the requirement in the script and forced it to install.
    thank you for testing!
    the "problem" with the install script is only if you come from joschi's rom, he rename the device for some strange reason...
    1
    No I want to do the contrary. Making my tablet compatible with .zip without having to remove assert.
    I read joschi rom have broken something how to correct that ?
    the correct way is to build a recovery for SGP611, as i say, delete the first line is a workaround, not the final solution.
  • 25
    lineage-logo.png

    LineageOS
    Sony Xperia Z3 Compact Tablet SGP621 & SGP611

    In the beginning credits goes to:

    the AICP rom team
    LineageOS & CM (R.I.P.) team
    Community


    Bugs:

    • wifi 5ghz not working in some countries, 2.4ghz working fine.
    • Magisk dont work, dont patch boot.img manually, workaround unzip this modded apk and rename apk to zip, the flash via recovery


    It is STRONGLY recommended to fully wipe your device before flashing!
    If you believe you know what you're doing and do a "dirty" flash - then fine, go ahead, but please don't complain if you experience any strange behavior.


    How to flash for the first time:
    (Again: Don't do it if you don't know it!)

    1. Download the ROM, (optional GApps) and transfer them to your device(or sideload via adb)
    2. Boot to recovery.
    3. Wipe the System, Cache, Data and ART/Dalvik cache.
    4. Flash the ROM Zipfile.
    5. Flash the GApps (optional, needed for e.g. Google Playstore to work) or Magisk, use this mod
    6. Reboot and set up your device.

    Sources:
    Gitlab
    16
    DOWNLOADS

    Recovery (Pitchblack Recovery Project, pbrp)

    SGP621 LTE <- as of 14.11.2021 recovery is not loading, if you face this problem, try lineage-recovery

    SGP611 WIFI <- maybe the same problem like the recovery for SGP621, waiting for reporting

    ROM

    SGP621 LTE, legacy tested OrangeFox-Recovery, not fully tested pbrp see above
    build 20211114 november patch level
    lineage recovery (no touch, use volume up/down and power)

    SGP611 WIFI
    build 20211114 november patch level
    lineage recovery (no touch, use volume up/down and power)
    11
    Updated SGP611 build: sensors and camera fixed
    download
    8
    Hello, a SGP611 updated build would be appreciated. If a developer reads my prayer, please help :)
    8
    Any skilled tester here? i make a build for the SGP611, now i need some brave tester, you should know how to collect debug data like "adb logcat > boot01.log".

    ROM IS UNTESTED, IF YOU DONT KNOW HOW BRING IT BACK TO LIFE FROM A BOOTLOOP, DONT WRITE ME!

    write me a message to get a download link.
    see #2 for download