[ROM][Z3TC] LineageOS 18.1 SGP621 [UNOFFICIAL]

Search This thread

orjanraberg

Senior Member
Jul 22, 2006
60
18
Xperia XZ2
OnePlus 8T
I came directly from LOS 15.1 (didn't install Stock first) and I had some problems but eventually managed to install LOS 18.1 and GApps on my SGP611. I tried a lot of different things so I am not sure what made it work in the end but I think it was this:
1. Extract boot.img from LOS 18.1 zip and flash with command fastboot flash:raw boot boot.img
2. Flash recovery: fastboot flash FOTAKernel pbrp_9.0_z3tcw.img
3. Boot to recovery (a bit tricky on this device but Power + spamming Volume Up normally works)
4. Flash LOS 18.1. I couldn't flash GApps at this point since it told me my Android version was wrong
5. Boot to system and then to recovery again
6. Flash LOS 18.1 and GApps Arm (32-bit)
7. Boot to system and configure device

I had TWRP 3.0.2.0 installed before and tried to install LOS with it but it didn't work.

Thanks a lot @evil-god for this rom!!!
 
Last edited:

zuiffon

Member
May 5, 2021
21
5
I came directly from LOS 15.1 (didn't install Stock first) and I had some problems but eventually managed to install LOS 18.1 and GApps on my SGP611. I tried a lot of different things so I am not sure what made it work in the end but I think it was this:
1. Extract boot.img from LOS 18.1 zip and flash with command fastboot flash:raw boot boot.img
2. Flash recovery: fastboot flash FOTAKernel pbrp_9.0_z3tcw.img
3. Boot to recovery (a bit tricky on this device but Power + spamming Volume Up normally works)
4. Flash LOS 18.1. I couldn't flash GApps at this point since it told me my Android version was wrong
5. Boot to system and then to recovery again
6. Flash LOS 18.1 and GApps Arm (32-bit)
7. Boot to system and configure device

I had TWRP 3.0.2.0 installed before and tried to install LOS with it but it didn't work.

Thanks a lot @evil-god for this rom!!!
TWRP is not compatible, you must use Orangefox.
 
  • Like
Reactions: orjanraberg

zhuanyi

Senior Member
Jan 19, 2008
197
55
Garrhhh...think I must have done something stupid...now when I powered on the device with Pwr + Vol Up all I hear is 3 vibrates and nothing happens, fastboot devices is also not returning anything.

Using a SPG621

I was on stock marshmallow, and this is what I have done:

Code:
fastboot flash:raw boot boot.img
Sending 'boot' (7858 KB)                           OKAY [  0.249s]
Writing 'boot'                                     OKAY [  0.523s]
Finished. Total time: 0.850s


fastboot flash FOTAKernel pbrp_9.0_z3tc.img
Sending 'FOTAKernel' (14874 KB)                    OKAY [  0.468s]
Writing 'FOTAKernel'                               OKAY [  0.996s]
Finished. Total time: 1.481s

And this didn't work, when holding pwr + vol down all I heard was a vibrate and then another one like a second after, and after I let go of the buttons nothing happens.

Code:
fastboot flash FOTAKernel OF-recovery.img
Sending 'FOTAKernel' (15948 KB)                    OKAY [  0.502s]
Writing 'FOTAKernel'                               OKAY [  1.059s]
Finished. Total time: 1.578s

then I tried this and the same thing as before, so I think here is where I made the bad mistake:

Code:
fastboot flash recovery recovery.img
Sending 'recovery' (14310 KB)                      OKAY [  0.452s]
Writing 'recovery'                                 OKAY [  0.954s]
Finished. Total time: 1.421s

fastboot reboot recovery
Rebooting into recovery                            OKAY [  0.003s]
Finished. Total time: 0.004s

And now when I do fastboot (Pwr+Vol Up) the device doesn't even show up anymore...

Code:
>fastboot devices

>fastboot devices

>fastboot devices

>fastboot devices

>fastboot devices

Any idea what might have happened?

UPDATE: Made some progress, after 3 vibrates for some reason I am in fastboot again (indicator light flashed blue and fastboot devices is showing).

So I tried to run the FOTAKernel line again and then press Pwr + Vol Down and now nothing happens (I only know it was powered on because my computer made that USB connected sound). The screen is blank and no indicator light.

Also I used flash:raw rather than flash when flashing boot img, not sure if that would cause any issue there.

So I am stuck again...please help.
 
Last edited:

zhuanyi

Senior Member
Jan 19, 2008
197
55
@RedSimply : Done, gerne.

to all: I am only repeating what I have written several times in this thread for SGP621.

First be sure to be on last stock MarshMallow with kernel 23.5.A.1.291
Unlock bootloader and flash boot.img from withing LOS 18.1 ZIP:
fastboot flash boot boot.img

Then flash OF-recovery:
fastboot flash FOTAKernel OF-recovery.img
(exactly as written!)

Start SGP621 with vol - and pwr button simultaneously pressed. After a short time OF-recovery launches and you can flash LOS 18.1.

Last: Enjoy your new tablet and thanks to our dev evil-god!

Question...when you do vol down + pwr did you have the tablet plugged into computer via USB?
 

zhuanyi

Senior Member
Jan 19, 2008
197
55
@zhuanyi : You only need to download the linked ROM when using flashtool.
EDIT3:

All good! Running on Lineage OS 18 now, thanks for all the good work OP and thanks for the valuable helps I received from tommes_d.

Few things I want to mention which I think might help others:

1. My Z3TC used to have bootloader unlockable no. Thanks to this thread I was able to get it unlocked.

2. On Lineage I think the battery runs pretty fast, but this could also be because the system was just initialized and so on. My battery went from 78% to 49% in an afternoon of very light usage (with SIM card plugged in but using Wifi signal).

3. Part of the reason for 2 I think is because Wifi seems to be weaker on Lineage, but my Wifi is set up to use same SSID between 2.4G and 5G so that could be a reason (given some earlier posters seems to suggest Wifi on 5GHz doesn't work so well).

4. One thing I didn't do was I kept my microSD card in the whole time, and after Lineage is installed I found out my card becomes "read-only" (it wasn't read-only before since I was moving stuff to the card before unlocking the tablet), I am not accusing Lineage for making it read only but probably safer to pop the microSD card out when factory unlocking. (And I was using a USB microSD card reader so it wasn't because the adapter had the read-only lock on). Fortunately I have a few microSD lying around so not too much of an issue. Seems this is related to Lineage 11 in general and a long discussion can be found here (no fix from what I can see unfortunately).

5. Had some trouble directly installing apks saved to Download folder, turns out you just need to move the apks to outside of Download and it would work (using Lineage's built-in Files app).



EDIT2:

Success!


After some trial and error using the Flashtool from flashtool.net I was able to reflash the factory version (in Windows 11 I had to use admin mode).

Followed the steps in post #135 again and now I am in OrangeFox!

Thanks @tommes_d for your help and super-fast response!


EDIT:
Sorry I guess you meant this one: http://www.flashtool.net/downloads.php

Mmm...interesting, I downloaded and installed the flash tool from Sony (from here) but this one doesn't really give me the option to use my own firmware and the ones showing on the tool seems to be of older version than what you have sent me...am I using the wrong flash tool?

2022-01-16_12-14-27.jpg
 
Last edited:
  • Like
Reactions: tommes_d

exis_tenz

Senior Member
Oct 14, 2013
223
38
OnePlus Nord 2 5G
I am using the ROM since a week or two and I am super excited about it. I made one mistake though, which I would like get rid of. I've installed GAPPS (Pico or Nano) but actually I want the tablet de-googled.

Question: if I wipe SYSTEM (only system) in recovery (I use OrangeFox Recovery) and then re-flash the rom, should that do the job (get rid of GAPPS)?

Furthermore, before I ruine things, did anyone test making a Nandroid with OrangeFox and actually put it back (all worked)? Hope someone can share some thoughts!
 

Max8719

Member
May 14, 2018
38
27
Thank you evil-god, for updating the security patch level of the builds so regularly. I really appreciate that. (y)
 

Henry48

Member
Apr 4, 2021
8
6
Thank you very much for keeping our devices in good shape. I wish you much success and good health. Best wishes.
 

belrik

Senior Member
Nov 25, 2010
467
108
Testing on SGP-611. Neither pbrp_9.0_z3tcw.img or recovery.img are bootable. The LED flashes red but the screen will not initialise.

I tried flashing the SGP-611 image from TWRP 3.0.2.0 - needed to edit the update script to remove the device check but that also failed to boot with a flashing red LED. So something is not setup correctly on SGP-611 builds. Was on the lineage 15 build prior to this.

Tried flashing to FOTAKernel partition also - and pushing the boot.img from the ROM.

Now tablet won't even get into fastboot. Suspect the battery is starting to die so its 10x more difficult than it needs to be. :-(
 
Last edited:

phil_87

Senior Member
May 2, 2010
50
1
Good day,
I have unfortunately the following problem with the current Rom for SGP621 and SanDisk extreme 128GB card.
Since I absolutely need my SD card for APPS I have formatted this as internal memory. As soon as I outsource apps and these are on the SD card comes in the current operation or even when restarting the error SD card damaged or missing.
I hope someone here can fix this problem and offer a solution in a timely manner. After restarting the device, this problem occurs again.
In addition, still the volume bug with the display and button operation and max volume is not as high as in the original.

Many greetings and thanks for the editing (members and developers)
 

Ermann123

Senior Member
Apr 30, 2020
100
16
Hello!
Did anyone manage to update to Magisk v24 successfully? Former update from 22.1_sony to v23 was always possible... v24 failed somehow. On other devices it went fine.
 

rik_eudisch

New member
Dec 4, 2020
1
0
Would it be possible to share your build commands?
Having a SGP611 as well and I am just learning LineageOS-Builds (this is my first post :) ) - any starting points would be really appreciated.

Thank you very much for your efforts in making this!!!

i have two questions for you guys

1st:
@joschi1984 and @evil-god can you please post the build commands you used for this build. i know the repo is here: gitlab but don't know how to build it. i tried a combination of official lineageOS build instructions and the gitlab repo but ended up with a ninja error i could not resolve.

2nd:
@evil-god: is it possible to move your scorpion repo to the offical LineageOS org at github?

Thank you again very much for your work!!
Regards Rudi
 

evil-god

Senior Member
Thank you very much for your efforts in making this!!!

i have two questions for you guys

1st:
@joschi1984 and @evil-god can you please post the build commands you used for this build. i know the repo is here: gitlab but don't know how to build it. i tried a combination of official lineageOS build instructions and the gitlab repo but ended up with a ninja error i could not resolve.

2nd:
@evil-god: is it possible to move your scorpion repo to the offical LineageOS org at github?

Thank you again very much for your work!!
Regards Rudi
hi, please forget the linked gitlab repo from joschi1984, its outdated!
use the repo linked in post #1 under sources.
pm me and lets see how far you are.
 
Managed to revive my SGP611 after having it in cupboard for 2 months. It was soft or hardbricked and totally unresponsive whatsoever.
But I guess letting the battery drain over the past few months did the trick. Got it working and into Fastboot mode again, managed to flash everything and now up and running with latest rom.
Everything seems to be working except Location.
No problem with audio, camera or Wifi 5 ghz.
 
Last edited:

Top Liked Posts

  • 1
    Its not possible to download from Playstore, but no problem installing the APK if you download it from Apkmirror.com. Audio is nice and loud.
    I´m on the latest update for Wifi-version with May Security Patch.
    Thanks! I'll give it a try then. I mean I like 15.1, works perfectly, but still I'm curious :) I have the LTE version, so we'll see.
    I'll do a system backup first in case I have to revert.
  • 1
    Its not possible to download from Playstore, but no problem installing the APK if you download it from Apkmirror.com. Audio is nice and loud.
    I´m on the latest update for Wifi-version with May Security Patch.
    Thanks! I'll give it a try then. I mean I like 15.1, works perfectly, but still I'm curious :) I have the LTE version, so we'll see.
    I'll do a system backup first in case I have to revert.
  • 34
    lineage-logo.png

    LineageOS
    Sony Xperia Z3 Compact Tablet SGP621 & SGP611

    In the beginning credits goes to:

    the AICP rom team
    LineageOS & CM (R.I.P.) team
    Community


    Bugs:

    • wifi 5ghz not working in some countries, 2.4ghz working fine.
    • Magisk dont work, dont patch boot.img manually, workaround unzip this modded apk and rename apk to zip, the flash via recovery


    It is STRONGLY recommended to fully wipe your device before flashing!
    If you believe you know what you're doing and do a "dirty" flash - then fine, go ahead, but please don't complain if you experience any strange behavior.


    How to flash for the first time:
    (Again: Don't do it if you don't know it!)

    1. Download the ROM, (optional GApps) and transfer them to your device(or sideload via adb)
    2. Boot to recovery.
    3. Wipe the System, Cache, Data and ART/Dalvik cache.
    4. Flash the ROM Zipfile.
    5. Flash the GApps (optional, needed for e.g. Google Playstore to work) or Magisk, use this mod
    6. Reboot and set up your device.

    Sources:
    Gitlab
    23
    DOWNLOADS

    Recovery (Pitchblack Recovery Project, pbrp)

    SGP621 LTE

    SGP611 WIFI

    ROM

    SGP621 LTE, legacy tested OrangeFox-Recovery, pbrp see above
    build 20220514 may patch level
    optional lineage recovery (no touch, use volume up/down and power)

    SGP611 WIFI
    build 20220514 may patch level
    optional lineage recovery (no touch, use volume up/down and power)
    11
    Updated SGP611 build: sensors and camera fixed
    download
    8
    Hello, a SGP611 updated build would be appreciated. If a developer reads my prayer, please help :)
    8
    Any skilled tester here? i make a build for the SGP611, now i need some brave tester, you should know how to collect debug data like "adb logcat > boot01.log".

    ROM IS UNTESTED, IF YOU DONT KNOW HOW BRING IT BACK TO LIFE FROM A BOOTLOOP, DONT WRITE ME!

    write me a message to get a download link.
    see #2 for download