[ROM][Z3TC] LineageOS 18.1 SGP621 [UNOFFICIAL]

Search This thread
Last edited:
  • Like
Reactions: mind.inc

meksis

Member
May 14, 2013
41
6
Oryol
Installed the firmware on sgp611, everything started fine. I decided to try to install magisk. Tried different versions and all without success unfortunately. (((If anyone finds a working method to get root rights on this beautiful firmware, please share. Thanks. I had to roll back to Floko Rom ((((
 

madxxcow

Member
Jan 30, 2005
21
2
Installed the firmware on sgp611, everything started fine. I decided to try to install magisk. Tried different versions and all without success unfortunately. (((If anyone finds a working method to get root rights on this beautiful firmware, please share. Thanks. I had to roll back to Floko Rom ((((
As for now there is no root method, see #1
 

madxxcow

Member
Jan 30, 2005
21
2
Hello, I have SGP611, I have downloaded recovery from #2, I have typed :

fastboot flash FOTAKernel OF-recovery.img

Sending 'FOTAKernel' (15948 KB) OKAY [ 0.508s]
Writing 'FOTAKernel' OKAY [ 1.063s]
Finished. Total time: 1.720s

But when I type :

adb reboot recovery

There's no recovery.

Is there something else to do ?
I had a similar situation some years ago, coming from a quite old firmware. In order to make a more recent recovery working I had to first go through a bootloader update. This is done by flashing the latest official firmware 23.5.A.1.291. Then you flash recovery, then lineageos 18.1
 

zuiffon

Member
May 5, 2021
7
1
In fact to boot to recovery, I must power on with "the standard method to power on the tablet" without any volume button and when the led become blue quickly press volume down alone.
 
So, for all the SGP611 users that are still struggling to install this, I did the following and got it working:

1) flashed latest stock to start fresh with flashtool from androxyde version 0.9.18.6 (only version working for me)
2) extracted boot.img from the rom zip itself
3) flashed the following via fastboot:

fastboot flash recovery OF-recovery.img
fastboot flash FOTAKernel OF-recovery.img
fastboot flash boot boot.img

4) unplug and restart device. When you see the LED starting to show up, just press and hold VOL down.
5) flash rom and gapps (optional)
6) reboot and that's it.

Thanks to @evil-god and @joschi1979 and all other participants for providing informations.
Hope that this will help others to get their SGP611 running LOS18.1 too.
 
Last edited:
  • Like
Reactions: zuiffon and flouli

flouli

Member
  • Apr 13, 2021
    14
    4
    Düsseldorf
    www.nmr.hhu.de
    So, for all the SGP611 users that are still struggling to install this, I did the following and got it working:

    1) flashed latest stock to start fresh with flashtool from androxyde version 0.9.18.6 (only version working for me)
    2) extracted boot.img from the rom zip itself
    3) flashed the following via fastboot:

    fastboot flash recovery OF-recovery.img
    fastboot flash FOTAKernel OF-recovery.img
    fastboot flash boot boot.img

    4) unplug and restart device. When you see the LED starting to show up, just press and hold VOL down.
    5) flash rom and gapps (optional)
    6) reboot and that's it.

    Thanks to @evil-god and @joschi1979 and all other participants for providing informations.
    Hope that this will help others to get their SGP611 running LOS18.1 too.
    Just to be on the safe side: From which rom zip did you extract the boot image? Many thanks for this detailed instruction!
     

    zuiffon

    Member
    May 5, 2021
    7
    1
    If you have the message "error - the bundle does not match the connected device" when you try to flash latest stock with Flashtool you can use "Emma" from Sony.
     

    corb06

    Senior Member
    Installed the firmware on sgp611, everything started fine. I decided to try to install magisk. Tried different versions and all without success unfortunately. (((If anyone finds a working method to get root rights on this beautiful firmware, please share. Thanks. I had to roll back to Floko Rom ((((
    I have SPG6111 with Floko Rom at the moment using recovery TWRP_scorpion_windy_3.3.0-0_201905.img.

    Can I just boot into recovery and flash the this rom?
     
    1 month of daily usage and I faced 2 problems with LOS 18.1.:
    - navigation bar sometimes disappears when starting an app. I got fullscreen mode with no chance getting back to homescreen or switching to another app. Only restart helps. This happened 5-6 times.
    - Yesterday suddenly the WiFi-Icon in the status bar disappeared. Tried to switch WiFi off an on again, but no reaction when clicking on the quick settings icon. Even the network settings section in system settings could not be opened.
    Tried to restart the device, no reaction. Had to hard reset it.
     

    meksis

    Member
    May 14, 2013
    41
    6
    Oryol
    I have SPG6111 with Floko Rom at the moment using recovery TWRP_scorpion_windy_3.3.0-0_201905.img.

    Can I just boot into recovery and flash the this rom?
    Unfortunately, it won't work. I already tried it, the error appears. The firmware was installed only on Recovery, which is in the topic header.
     

    corb06

    Senior Member
    Unfortunately, it won't work. I already tried it, the error appears. The firmware was installed only on Recovery, which is in the topic header.
    Yeah! I went ahead and tried as well, lots of e: fstab errors. Barley managed to flash back the Floko Rom, kept getting errors there also for a while. Had to mount and dismount the system and data many times.
     

    suuperboom

    Member
    Jun 10, 2019
    16
    7
    I just got this running on my SGP611. Thanks @evil-god & @joschi1979 !

    Couple of issues -
    1) disappearing navbar sometimes as mentioned in #73
    2) audio in youtube particularly is going funky, sometimes really loud for a few secs then drops back to normal volume. But in either case audio does not sound as "smooth" as on stock MM, sounds very harsh/sharp at louder volumes. I tried adjusting in AudioFX app, but whatever is changed in there doesn't really seem to have an effect?
    Without root/magisk no way of getting Viper4Android or Xperia Audio Enhancement onto the tablet.

    Anyone having same issues or any suggestions about the audio issue?

    Was trying to get lineage 15 on it, but cannot find the TWRP required for lineage 15 anywhere.
    If anyone has TWRP 3.2.1 / recovery for lineage 15 for SGP611 - Please PM me! or post it up please!!! @evil-god mabye?
     

    flouli

    Member
  • Apr 13, 2021
    14
    4
    Düsseldorf
    www.nmr.hhu.de
    I followed #67 and got it also running on my SGP611 - many thanks to all of you!

    When flashing the boot image, I got 'fastboot: error: Couldn't parse partition size '0x'' but could easily fix this with 'fastboot flash:raw boot boot.img'. Thereafter, everything went smoothly. Up to now only one issue: The camera seems to work, but after pressing the shutter button, the camera freezes and does not store the image to the disk. I checked the permissions of the app, but they were OK. Any ideas how to resolve this?

    @suuperboom: Lineage 15 can be installed with the official TWRP twrp-3.0.2-0-scorpion_windy following this thread - at least this worked for me.
     

    suuperboom

    Member
    Jun 10, 2019
    16
    7
    @flouli - how did you get the official TWRP to boot? I couldn't get it working (flash to recovery and fota, but it hangs after pushing vol down and LED changing color). I thought it needed higher than 3.0.2, but if it works with that I'll gonna give it a shot.

    Camera is completely stuffed for me in 18 - not a big deal to me, but just for your reference. perhaps its generally buggy. it doesn't focus, and pushing button does nothing. Button is also half off the screen
     

    roey787

    New member
    May 2, 2021
    1
    0
    SGP611: My device booted to recovery, but the screen would not turn on. I used this Guide to install @joschi1979: rom with the help of TWRP recovery:
    1. flashed the latest stock to start fresh with the flashtool from Sony (23.5.A.1.291)
    2. adb reboot bootloader
    3. fastboot devices -> device should be listed
    4. fastboot reboot bootloader (optional?)
    5. fastboot flash recovery twrp.img (I used 2.8.7. 3.0.2 should be tested. This step might be optional)
    6. fastboot boot twrp.img (2.8.7)

      <phone will reboot, the screen will be black>
      <wait to Windows new device sound>

    7. adb devices -> device should be listed
    8. Type: adb shell
      twrp wipe cache
      twrp wipe dalvik
      twrp wipe system (<- I got an error on this on)
      twrp wipe data <- NOW YOUR DATA WILL BE REMOVED, SO MAKE A BACKUP BEFORE!
      twrp sideload

    9. adb sideload <location_of_your_ROM.zip>, e.g. adb sideload C:\Havoc.zip
      When the installation is completed you will see "Total xfer X.XXx".

    10. fastboot reboot > LineageOS should start up.
     

    flouli

    Member
  • Apr 13, 2021
    14
    4
    Düsseldorf
    www.nmr.hhu.de
    @flouli - how did you get the official TWRP to boot? I couldn't get it working (flash to recovery and fota, but it hangs after pushing vol down and LED changing color). I thought it needed higher than 3.0.2, but if it works with that I'll gonna give it a shot.
    Well, that was a little longer ago. When I remember correctly, I came from stock (23.5.A.1.291) and had to additionally flash a modified boot.img - the solution should be somewhere in this older thread on lineage 15. Good luck with this!
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 2
      Have the same error, could you please share, how you solved it?
      So the question was about the not working install of the Magisk Manager after flashing the modded zip.
      I just uninstalled the magisk icon and then went back to recovery and flashed the standard magisk v23, and it worked out.
      1
      Question: as long I tried it with 6.0.1 boot img and OF-Recovery it didn't work. What happens if I use for the procedere the boot image from Lineageos 18.1 and OF-Recovery; will it brick the tablet?
      No, exactly this will do the job - see #67 + #69. I flashed it this way and it is now running stable for more than two weeks.

      Once again many thanks to @evil-god & @joschi1979!

      @joschi1979: Is there any chance that the camera issue canbe fixed?
      1
      Worked! If the minor bugs (camera and sound) will be fixed, it could be a great tablet again! ;)
      1
      I can not confirm problems with GPS (#100) and Google Maps (#98) - for me both work perfectly on SGP611. Also Magisk can be updated to the current version (23) via the workaround described by @evil-god. The only problem is the camera, which is not a major issue but would be nice to work.
      1
      Hi, I installed it today and was very happy. I only have one small problem, when playing music or audio books the volume sometimes goes very low. I've tried all sorts of things, different media players - but I can't find the cause.
    • 17
      lineage-logo.png

      LineageOS
      Sony Xperia Z3 Compact Tablet SGP621

      SGP611 builds from joschi1979 see post #2 for download or on his profile.

      In the beginning credits goes to:
      the AICP rom team
      LineageOS & CM (R.I.P.) team
      Community


      Bugs:

      • wifi 5ghz not working in some countries, 2.4ghz working fine.
      • Magisk dont work, dont patch boot.img manually, workaround unzip this modded apk and rename apk to zip, the flash via recovery


      It is STRONGLY recommended to fully wipe your device before flashing!
      If you believe you know what you're doing and do a "dirty" flash - then fine, go ahead, but please don't complain if you experience any strange behavior.


      How to flash for the first time:
      (Again: Don't do it if you don't know it!)

      1. Download the ROM, (optional GApps) and transfer them to your device(or sideload via adb)
      2. Boot to recovery.
      3. Wipe the System, Cache, Data and ART/Dalvik cache.
      4. Flash the ROM Zipfile.
      5. Flash the GApps (optional, needed for e.g. Google Playstore to work) or Magisk, use this mod
      6. Reboot and set up your device.

      Sources:
      Gitlab
      8
      Updated SGP611 build: sensors and camera fixed
      download
      6
      Hello, I would like to build for my SGP611 myself. Can you point me to the source code of your Lineage 15.1 build for SGP611, so that I can figure out the differences? I think in the other thread you also only link the source of SGP621. Thanks!
      @evil-god Nevermind. Figured it out myself and have a working build for SGP611. I will upload it here, if you agree.
      5
      DOWNLOADS

      SGP621 LTE, tested recovery
      build 2021.05.08

      SGP611 WIFI build by joschi1979
      click thx for your work :cool:
      4
      do you think this rom could be flashed onto SGP611 (wifi only)?
      my guess is a device in bootloop, think about to make the rom compatible like dev on lenovo tablets do, init-script look for baseband(modem) or no baseband and set properties, works on my GF lenovo tablet. will play a little around maybe this weekend, until that there is no support for the SGP611 device, sorry