[ROOT][CWM RECOVERY] Onda V971 Quad-core | V972 | Allwinner A31

Search This thread

hariprasadiit

Senior Member
Jan 13, 2011
69
58
Bangalore
Was anyone else get an error when trying to install rom from external sdcard? I got, keep geting "error ext_sd can't mount"

I'm sorry for not being able to spend time to work on recovery as i'm really busy with serious problems in my job.whenever i find time i'll try to work on it.

BTW can you post partition info
Code:
cat /proc/mounts
and
Code:
mount
from shell?

i've Onda v971 16gb version and i dont have access to any other versions of Onda or any other A31 tablets.
 
  • Like
Reactions: tragidy

edd-1988

Senior Member
Oct 8, 2009
128
3
Hello everybody
i have two firmware for two Chinese tablets they have the same possessor ram all things is same ,just a camera and the screen is not the same ...
the first firmware ONDA (rom ) is good and much better than the original firmware for my android tablet .... and i try to install it and it s working well .. but i have two problems the camera and touch screen didn't work ....

so how can do to fix this problems .. ... what i should take from the original ROM to make it on the other ROM ?
or can you do it for me ?? i can send the two roms...
please tell me what i should do for any questions i am here to answer thanks ....
 

hitman33430

Member
Dec 10, 2010
22
1
Works with AMPE A10 Ultimate A31

Works perfectly with AMPE A10 Ultimate A31, which is a similar device to Sanei N10 Ultimate A31.

The instructions couldn't be easier to follow. The only mistake I made the first time was to download busybox from the market instead of using the one already installed on the system. Gave me all sorts of problems with the terminal.

Finally I can backup my rom for safe keeping. Thanks a lot man :good:
 

Naismith

Member
Aug 3, 2012
24
4
Hi!

I try to use this CWM in a TVbox MeLE A1000G A31

I can flash OK, boots ok... but dont have keyboard or mouse support to interact

Its possible to add this feature?

Thanks a lot
 

poemadevil

Member
Jun 3, 2012
29
1
This even works great on a chinese tablet called Airlio A108 which is a 10.1 1920x1200 tablet. Thanks!:good: Only proble I encountered was the message "sh applet not found" or something. Installed "Busybox installer" instead "Busybox" from playstore and this one worked just fine.

Hmm, not so much....stuck at bootlogo
 
Last edited:

wahabfun

New member
Feb 10, 2010
4
0
My tablet stuck at boot logo

Hi

Please help what I do. My Itek mini pad (All winner a31) stuck at boot logo after doing your steps. I can't able to go on the boot recovery mod. Please please help what I do.

Very thanks
 

gabontz

Senior Member
Jul 13, 2006
57
8
TM
www.smart-host.ro
Hi!

I try to use this CWM in a TVbox MeLE A1000G A31

I can flash OK, boots ok... but dont have keyboard or mouse support to interact

Its possible to add this feature?

Thanks a lot
Just installed this on my MeLe A1000G quad and is working like a charm.
The remote is unusable, but with a wireless keyboard/mouse kit, is more than you need.
 

blakegriplingph

Senior Member
May 13, 2011
966
146
Amazon Fire
Realme C3
How'd you cobble this one up? I tried to edit this one on Windows and replace the superuser.apk with an updated one, but regardless of what I do, I end up with an invalid package when I open the one I edited on the Allwinner update app.
 

Dom3616

Senior Member
May 7, 2013
909
574
Karachi
I'm using HP 7 Plus. It also runs on an Allwinner A31.
I don't have an update app that allows me to select the update locally. But I can boot into Recovery Menu fine.
The problem is that recovery fails to verify the root zip and aborts installation. Pls tell me how to fix this.
I'm an android dev myself but I have no experience with tablets.
 

Scorpion_D

Member
Oct 9, 2012
47
1
Faro
Hi, I'm sorry for this noob moment but..

When I type "busybox sh /sdcard/intall-recovery.sh" on adb terminal it give me error "can't open "sdcard/intall-recovery.sh"

Anyone?

33xdd8w.jpg


Cheers
 
Last edited:

dimpapadop

Member
Nov 20, 2006
8
0
help me (if it is possible)
i installed twrp, but made as i understand many things wrong!

1. after flashing twrp, i wiped everything within twrp (no os installed)

the problem is the tablet refuse to get recognized at all (win xp & win 10) - nothing not even a beep :)

onda v971 v3 quad
Also flashing with phoenix is not applicable since the home button, (insert otg mini us plug) and pressing 10 times (or more) the power while the home is pressed, still does not make the tablet get recognized.

Can i do anything else?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 43
    Hello everybody!

    Here is the ROOT and CWM Recovery for Onda v971 Allwinner A31 and Onda v972.


    CAUTION : I'm not responsible for any damage to your device.Use at your own risk



    Back up your data before you start doing anything

    Links :

    ROOT : ROOT Allwinner A31

    CWM RECOVERY : CWM Recovery Onda v971 and V972

    INSTRUCTIONS :

    ROOT :

    1.Download the root zip and put it on SD card.
    2.Open Update app, select Local update option.
    3.Now select "ROOT_Limpieza_Logo_V3.zip" from the file list then update.

    Update app checks the zip and flashes using stock recovery. After its done, device will automatically reboots.
    This ROOT zip removes all most all Chinese apps and installs NOVA Launcher. If you don't want NOVA launcher you can delete is using
    ES File explorer.
    This Root zip works for all Allwinner A31 tablets which has update app.

    RECOVERY : (ROOT required)

    1.Download the recovery zip and extract it to some folder on your computer.
    2.Copy all three files , extracted from the zip, to the SD card.
    3.Connect your device to the computer (enable "USB debugging" option in Developer Options), open terminal or command prompt and enter below commands.

    Code:
    adb shell
    Code:
    su
    Code:
    busybox sh /sdcard/install-recovery.sh

    Above command installs CWM recovery.To reboot into recovery run below command

    Code:
    busybox sh /sdcard/reboot-recovery.sh

    NOTE : Pressing power button for about 30 secs to 1 min while holding home button boots device into recovery.

    For Geeks :

    to flash the recovery, run from adb shell
    Code:
    cat '/sdcard/path to recovery img' > /dev/block/nandg
    to reboot into recovery
    Code:
    echo -n boot-recovery | busybox dd of=/dev/block/nandf count=1 conv=sync;sync;reboot
    Now your device boots into CWM recovery.
    NOTE : Use home button to navigate and power button to select, as touch controls are not working.

    If some thing goes wrong, you have to flash stock firmware using Phoenix suit.while upgrading you have to select "yes" to format the device to get it working again.

    CREDITS :

    Thanks to CyanogenMod for their great work
    Thanks to Koushik dutta for his great CLOCKWORKMOD Recovery
    Thanks to http://www.htcmania.com/member.php?u=463595 for root zip
    Thanks to everybody who helped me to understand and write this post and to port the CWM .
    7
    @Hariprasaditt,

    How much dev experience do you carry under you belt? There has been a few people here working hard trying to come up with something, yourself of course, and Arctablet. I've seen some others on androidtablet already coding somethings, but its for the Novo 9. I know the drivers for the screen is going to be different. They are almost finished with it already. Do you think any of their work would assist with us here? Also, I still haven't heard anything from Cyanogenmod, on my request. Thanks to everyone that supported it by the way :).

    I'm working on porting CM10 now.i'll get help from them in this process. I've already tried Novo 9 and you are right, the drivers are different and also some modules.
    2
    1. Do we need Busybox on our devices?
    2. Do we need to type the commands into a terminal app from the play store or on cmd of windows? (maybe a dumb question, because it looks Linux/Ubuntu-Like)

    Thank you, a huge step forward!
    I'm on V812

    Busybox is already installed on our devices.but its old version.so you can update it with busybox from market.

    if you use terminal app, you dont need to type first command.i.e "adb shell" .In command prompt in windows , you have to type adb shell to enter into android shell.
    2
    Does anyone tried to use on v812 also? really thanks.
    As I posted before, yes it works in v812.
    I've done a backup and restore without problems. So the other options should work too.

    Now we need only custom ROM to flash.
    Gamepad support and external bt would be fine.
    1
    1. Do we need Busybox on our devices?
    2. Do we need to type the commands into a terminal app from the play store or on cmd of windows? (maybe a dumb question, because it looks Linux/Ubuntu-Like)

    Thank you, a huge step forward!
    I'm on V812
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone