Root for SM-T290 (tab a 8.0 2019)

Search This thread


Senior Member
May 4, 2020
Good, also open that file in 7-Zip
wow, its a part file of a backup still it opened without errors
Screenshot 2023-05-19 220919.png
Last edited:
  • Like
Reactions: J.Michael
I dont know the location of those drm keys . Because of those drm keys only i viewed my video lectures. Otherwise i would have found it if it were normal unencrypted files lying in img files. Any hope of restoring these images on any android emulator? Or can we transfer drm keys from one device to another ?
If you know the location where you stored those keys, we can get them. Are they stored as files?
Yes for 1st question. Yes for 2nd question. The drm videos(on separate hard disk but encrypted) which i see are decrypted using the drm keys stored in this naandroid backup.
But we first need to know where they are. What software did you use to access your study files?
it was a coaching instiute's android app. Are we planning to find the location of those keys by reverse engineering the apk of the app?
That could be possible. Did you also make a backup of the internal storage partition? Also look in the data partition, and then search for the APP.
  • Love
Reactions: LUCID_DREE
those keys are different for diffrent companies. its actually those keys which proprietary media vendors use so that common public are unable to make unencrypted playable mp4 of their streamed media content, eg netflix , amazon prime, etc. so that we just stick to their platform.
Would those keys be in the data of each app or on the system? And how do you actually know that the app uses such keys?
  • Love
Reactions: LUCID_DREE


Senior Member
May 4, 2020
Would those keys be in the data of each app or on the system? And how do you actually know that the app uses such keys?
not each app. those keys are present either in that app only or among my android system files . i know because when i run the mp4 videos provided by the app on normal players like vlc or mx player they are unable to read it and show error while plays smoothly in the app. Also in the new app there is an option to use old drm sytem or new drm system which proves it. Also , i saw in the app data folder that it download videos and their audios as separate file. like mp4 with no audio and then a separate mp3 file . it then uses its drm keys to decrypt in timewise fashion as well as make a complete video with audio [deleted]
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Tried all versions of Magisk, including the version CANARY 20.4 (20303) | 7.5.2 (272) (7).
    But none of them work :(
    And to restore the device,it is enough to flash the current firmware, or even 3 files are enough: boot;recovery;vbmeta, pulling them out of the AP part of the firmware ...
    No one wants to deal with our device... :(

    I just rooted my SM-T290 with firmware version T290XXU2ASL3, using Magisk 20.3. It's been stable for a couple of days now. Here's a link to my patched Magiskmodpatched.tar file.

    Problems included a lot of links that led me to the wrong firmware, an SL4 version that was a Kids ROM for the SM-T290. Another thing that caused problems was zipping the whole .tar archive back up with the patched boot.img, recovery.img, and vbmeta.img files plus all the original extraneous little lz4 files. It didn't root successfully until I simplified the patched AP file to contain just the 3 compressed image files.
    Btw, where can I find twrp compatible with this tablet
    Somewhere laid out in the subject ...
    I will attach an option for installation via ODIN:
    I won't tell you about custom ... I prefer a rooted stock firmware with a slight modification ...
    I want to root this tab just so that I can provide signature level permissions to sideloaded apps to make them work (As this tablet has stupid One UI Core, no Good lock modules or Bixby apps work).
    Is there a way to provide them signature level permissions or convert them to system apps without root? Can we do that in Twrp by moving .apk files to /system privileged without root? If it is possible just by Twrp and works well then there is no reason for me to root my device.
    You can only install TWRP and not get Root rights. But you still need to change the bootloader to the one taken from android 9 and the patched vbmeta file ... You will also need to make format data and install the Fix_vendor_10 patch from TWRP to access memory ...
    The clarification! when installing TWRP, you must patch the stock kernel, because otherwise the built-in protection will not allow you to boot,there will be a bootloop :( For the kernel patch, you need to apply, that is, you will have to root it... ;)
    And most importantly, a quote from a knowledgeable user:Waseeam,:
    There are no solutions and no matter what was bought - a tablet or a phone, if it's a version of Core that is not one third-party app stock or modified will not work - ie after the installation of the system will be notified that the application is not compatible with the device and you can install only two apps not galaxy store and google play is a calculator and galaxy store and all other apps can be installed or upgraded only in galaxy store and google play.
    I have root on my SM-T295 A8 tablet!!

    Attached boot.tar file is for XXU2ASL3 only.


    Okay, after multiple failed attempts, I read about a method to root my T295. It did not work!! But, I decided to just use Magisk Manager on the boot.img file only. The resultant file would not flash - it will fail. The original boot.img file is 65,536K bytes. I had to take the Magisk modified boot.img and overlay it onto the original file. Then the file would flash successfully. The first thing after booting was to check Magisk Manager. It showed I have Magisk 20.3 installed. So, I tested this with Root Explorer. I did have root!!

    If you are going to try this, you need to unlock your boot loader, I think. I have not tried this with a locked bootloader.
    Ok i got twrp and magisk running on android 10. SMT290

    you need twrp file that @gcrutchr provided here and the abootvkT290XXS3ATF1 file @Talich52 provided
    1:boot to download mode
    2: flash the abootvk file @Talich52 provided
    4:boot to download mode
    5:inside odin go to options, and untick "auto reboot"
    6:flash the twrp file
    7: dont reboot or shut down
    8: after flashing twrp press and hold power + volume up
    9:when it goes to the "this tablets bootloader is unlocked screen" (it comes up every boot if you have unlocked bootloader, which is needed for rooting)
    press the power button once to dismiss the warning and press and hold power + volume up for two seconds then leave
    10: you should be in twrp now
    11:it is defaulted to russian language for some reason find the language button ( usually bottom right above the slide bar)
    you can use google translate on other phone to check for it
    12: now you can flash magisk that @gcrutchr provided in the post i mentioned above
    NOTE: if you reboot after flashing twrp without opening twrp for first time, it will be removed and you'll have to flash again.
    (sorry for bad english, im not good with explaining things)