How To Guide ROOT GAINED !!!!

Search This thread


Aug 20, 2022
can you give the detail please?, im having hard time to pass the safetynet, and because of that, i cant use the banking app
i can't rn but i can give u ss of what i have if u like then after all try reboot your phone I'm using ALPHA magisk and it's bypassing for me


  • Screenshot_2023-01-24-07-45-15-036_y.zv.yjewamuluh.jpg
    328.5 KB · Views: 20
  • Screenshot_2023-01-24-07-45-29-637-edit_y.zv.yjewamuluh.jpg
    82.1 KB · Views: 21
  • Screenshot_2023-01-24-07-45-40-215_y.zv.yjewamuluh.jpg
    298.6 KB · Views: 19
  • Screenshot_2023-01-24-07-45-49-019_y.zv.yjewamuluh.jpg
    380 KB · Views: 15
  • Screenshot_2023-01-24-07-45-54-780_y.zv.yjewamuluh.jpg
    358.6 KB · Views: 13
  • Screenshot_2023-01-24-07-45-57-790_y.zv.yjewamuluh.jpg
    356.7 KB · Views: 18


New member
May 26, 2019
Whatever I do Magisk just doesnt install. I patched the boot.img with 7 different versions of magisk, I even downloaded the image posted by someone here, and it just doesnt install.
I'm on SKSEUXM,bootloader unlocked.
my fastboot commands are:
adb reboot bootloader
fastboot --disable-verity --disable-verification flash vbmeta_a vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_b vbmeta.img
fastboot flash boot_a magisk_patch.img
fastboot flash boot_b magisk_patch.img
fastboot reboot.

It doesn't install :( Can anyone help?
It's my mom's phone and it had root before the MIUI 13 update, so I tried the payload.bin method too but it didnt work.


Senior Member
Jun 14, 2015
Whatever I do Magisk just doesnt install.
I see the same problem. I used patched EU boot.img and magisk 25.2 does not see it. I patched original boot.img by this 25.2 version and result is binary the same with publiced on this forum. I do not know, why magisk does not see it is installed ...
Is something preventing the : fastboot flash , but without information about error ?

It can happend, if previous installation of magisk app was hidden with changed name and was not unhiden before upgrade of ROM. Uninstall new magisk app, uninstall renamed magisk app and install new one again.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    THIS METHOD WORKS on both:
    POCO M3 Pro / Redmi Note 10 5G

    hey guys.. wonderful news.. been trying here and there and IT WORKS FINALLY i gained root of POCO m3 Pro 5G !
    i'll write in steps how it works and post all files i've been using

    DISCLAIMER as always.. " do it at your OWN risk , i won't be responsible if anything goes wrong, you might risk to brick your phone "

    that said :

    1 - unlock your bootloader .. it'll take 168 hours so the earlier the best
    if you don't know how to do it check XIAOMI bootloader unlock on xda

    2 - download your rom ( get exactly the one you are on ) with this i mean YOU have to DOWNLOAD exactly the ROM you have in this moment installed on your smartphone, you can simply check your rom in settings!

    3 - from the zip file extract boot.img

    4 - get magisk ( i've used 22.1 and it worked.. you might try with the most recent but since it worked for me i suggest to use 22.1)
    now you need to patch original boot.img ( keep a copy of the original one )

    5 - copy the patched boot.img you got from magisk and copy it to your pc

    6 - VERY IMPORTANT get this "empty " vbmeta.img ( link at bottom of this post)

    7 - now reboot your Smartphone in fastboot , you can do it in 2 ways:
    adb reboot bootloader
    turn off poco and then keep pressed VOLUM DOWN and POWER

    8 - fastboot commands:
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img

    (you should get this response)
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img Sending 'vbmeta_a' (4 KB) OKAY [ 0.016s] Writing 'vbmeta_a' OKAY [ 0.000s]

    now send patched boot.img ( rename it just like so )
    fastboot flash boot boot.img
    fastboot flash boot boot.img Sending 'boot_a' (65536 KB) OKAY [ 1.524s] Writing 'boot_a' OKAY [ 0.224s]
    and finally :

    fastboot reboot

    you will NOT get any

    Dm-VERITY corruption on boot

    you will get your POCO rooted as i show in the pictures!
    IF you have any questions ask.. i'm gonna upload PATCHED boot.img for MIUI Global EEA 12.0.8 stable ( so you get already a pacthed boot.img )
    i upload also ORIGINAL stock boot.img always from MIUI Global EEA 12.0.8 stable
    and i upload vbmeta.img empty !

    enjoy it !!!

    FILES : magisk_patched-22100_WInEw.img rename it to boot.img

    [EDIT] added on 25 AUGUST 2021 BOOT.img and already MAGISK patched BOOT.img V12.0.10.0.RKSEUXM

    AVOID auto firmware UPDATE by Xiaomi

    follow this post:

    with one exception, in point 8 I used this command:
    fastboot flash vbmeta vbmeta.img
    This is know issue. You have "lite" version of adb/fastboot. The version with bigger files will support all parameters.
    Another week passed and I was finally able to root my Redmi note 10 5g from UK Vodafone. First I flashed the EEA latest rom V12.0.8.0.RKSEUXM. Than I followed the tutorial from the first page, with one exception, in point 8 I used this command:
    fastboot flash vbmeta vbmeta.img
    As the command provided was not recognized.
    And I used the newest Magisk v23
    Hello! Do You know how to fix "dm verity is corrupt"?
    The correct flashing vbmeta.img should fix this problem.
    GOOGLE PAY WORKS... another good news 👍👍👍 @Kwiato