• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROOT]How to get root Moto G 2015 With Android Marshmallow 6.0 (worked in XT1541)

Search This thread

acejavelin

Recognized Contributor
Sep 3, 2009
6,835
3,322
Lincoln, ND
[/COLOR]
thanks for your reply and the warning.
I think maybe I've misunderstood something because in the past ive been able to go to: settings, storage and usb, internal storage, apps. and then when I tap some of the pre installed apps (or bloatware I assume its called?) I cannot see an option to un install, but there is a button called "clear data". this does not remove the app, but it frees a small amount of useable space. I feel like I must have misunderstood something. the apps im talking about are things such as: hangouts, google play music, talkback, fm radio, google play movies and tv, gmail, etc... some of these apps I can see the use for, such as keyboard apps and camera. but others I have never used and I assume arnt necessary for the device to work correctly (therefore I assumed they fitted the definition of bloatware).
when I have used "clear data" I get usable space for apps of my choice, so im assuming that these apps arnt part of the system memory you mentioned?
Those are all system apps, they reside in system protected space like /system/app and that space is not usable even cleared... These system apps store their data in usable space, which would be regained but only minimally. There is no uninstall option because they reside in the system partition and are part of the firmware.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 44
    :fingers-crossed:
    How to get root Moto G 2015 With Stock Android Marshmallow 6.0 (XT1541)

    Hi guys. Now I have a Moto G 2015 XT1541 with previously unlocked bootloader (following Motorola Guide described here, be careful unlocking bootloader wipes everything!) with recently installed Europe Retail Stock ROM MM 6.0, but i was having some issues trying to install TWRP 3.0 and SuperSU 2.65....until now.

    With latest SuperSU you will get bootloop, and probably you need to reinstall the stock rom completely.........but... ....This method works fine!

    Try it yourself on XT1540, XT1542, XT1543, XT1544 and XT14548 variants

    So, I have used TWRP twrp-osprey-2.8.7-r7.img for the recovery and Super SU Beta 2.62 (BETA-SuperSU-v2.62-3-20151211162651.zip) to get root on my device.

    Get TWRP recovery and ROOT

    Step 0: enter to developer options (tap 7 times the build number) and select Allowing USB debubbing and Allow OEM unlock options

    Step 1: install TWRP 2.8.7-r7 entering to bootloader mode

    Turn off the device, press power and volume down and wait for two seconds. device will show bootloader mode in black screen, connect it to the pc through usb cable

    Step 2: Paste twrp2.8.7-r7.img file into folder \Android\sdk\platform-tools and rename it to recovery.img (this requires previously installed Android SDK Tools, but you can do the same with MinimalADB

    open cmd in windows, navigate to the platform-tools folder location and write this line:

    Code:
    fastboot boot recovery.img
    Wait until ok message appears in cmd

    TWRP will appear, and press reboot System. Enter bootloader mode again and type in CMD the following:

    Code:
    fastboot flash recovery recovery.img

    Wait until ok message appears in cmd. After that, press in bootloader mode the recovery option, you will enter to twrp and now new recovery becomes permanent, press Reboot system.

    Step 3: copy BETA-SuperSU-v2.62-3-20151211162651.zip file into the device and after that, disconnect it from usb

    Step 4: turn off the device, enter bootloader mode as stated in step 1, and select the recovery option with the volume up and down , press power button to enter to recovery and twrp will appear instead of original recovery.

    Step 5: in twrp press install, select location of the Beta SuperSu File, select beta Super SU zip file and allow installation swipping to the right side and wait until it finish.

    Step 5.1: after flash Super SU, wipe dalvik and cache through twrp, pressing the wipe dalvik/cache button located in left side.

    Step 6: in twrp press button reboot now.
    Wait a little while android rebuild the cache.
    The device will enter to the home screen. check that super su app is installed

    yBcVLRM.png


    Note: if twrp offers to you install SuperSu dont let it. That causes a bug.

    Step 7: Install Root checker and check if you are root.

    inJL01K.png


    Thats all folks!!

    -------------------------------------------------------------------------------------------

    Plus 1 - If something goes wrong you can reinstall Stock as described in this repair guides. Check here the firmware and here the reinstall instructions

    Plus 2 - How to delete the Motorola annoying unlock bootloader message:

    Step 0: connect the device to the pc, copy unlocked_logo.zip file into the device and after that, disconnect from usb

    Step 1:
    Turn off the device, press power and volume down and wait for two seconds. device will show bootloader mode in black screen

    Step 2: In bootloader mode select with the volume up and down the recovery option, press power button to enter and twrp will appear

    Step 3: in twrp press install, select location of the unlocked_logo.zip File, select that file and allow installation swipping to the right

    Step 4: in twrp press reboot now. The device will boot without nagging window.
    5
    Excellent instructions. First time I saw detail to flash TWRP in a manner that does not revert back to stock recovery.

    One recommendation, after the first boot to recovery, make a clean (pre-root, pre-cutom recovery) TWRP back up to your SD Card. If anything goes wrong, just flash this backup.
    3
    [emoji2] detailed!!! Ty

    Sent from my MotoG3 using Tapatalk

    Instead of quoting the whole first post to say "Ty", just click the Like or Thanks button on the post... It is better for the OP and keeps the rest of us from having to scroll through the whole post.

    Sent from my MotoG3 using Tapatalk
    3
    I found an updated supersu around: BETA-SuperSU-v2.66-20160103015024.zip, is it better to use this or the original older one, BETA-SuperSU-v2.62-3-20151211162651.zip?

    Thanks!

    You can install any recent version, but before flashing the zip you need to enter in TWRP terminal this "echo SYSTEMLESS=true>>/data/.supersu". This force the systemless installation, the only one that works in stock MM.
    2
    Suggestions please. I'm missing something simple here.

    XT 1541 brand new. Marshmallow 6.
    Unlocked but still with annoying ' Warning Bootloader Unlocked ' warning screen.

    I've installed on W7, via minimal adb & fastboot, twrp-osprey-3.0.2-r1.img. Recovery seems to work just fine......but....

    When I install ANY of these SuperSU images

    - UPDATE-SuperSU-v2.46.zip
    - UPDATE-SuperSU-v2.65-20151226141550.zip
    - BETA-SuperSU-v2.74-2-20160519174328.zip


    Tried Data Wipe\No Data Wipe. Makes no difference with TWRP before Reboot.

    The device appears to become soft-bricked and sticks at the ' Warning Bootloader Unlocked' screen.

    I've reinstalled stock firmware XT1541_OSPREY_RETEU_6.0_MPI24.65-33.1_cid7_subsidy-DEFAULT_CFC__v2.xml.zip .....twice.

    Loosing the will to live. Any ideas what I'm doing wrong please ?

    Thank you

    Muppet The Wonder Dog

    (None of my Samsungs were this tricksy.)
    In the TWRP terminal enter:

    echo SYSTEMLESS=true>>/data/.supersu

    Then flash current SuperSU zip. SuperSU doesn't always recognize it needs to use systemless, this forces it.

    Sent from my MotoG3 using Tapatalk