[Root] [KitKat] How to Disable Knock On

Search This thread

meyerweb

Senior Member
Jun 19, 2010
2,407
1,141
I love knock on, and it works great for me. But some people apparently have a problem with the phone turning on in their pocket. The Sprint ZV6 update supposedly has some changes included to address this problem, but how effective it will be is anyone's guess. I was recently involved in a discussion elsewhere as to whether it would be possible to use Tasker to prevent knock-on from working in your pocket, but I don't think it is.

I did discover another approach, though, that will work. Verified on the LS990 with BarRin v2, but it should work on any rooted G3 with a stock-based kernel. ( IF you have an AT&T or T-Mobile version, you can probably find this setting in HiddenMenu without using the Shortcut Master app, by entering the dialer codes as in this thread: http://forum.xda-developers.com/lg-g3/general/mod-root-rid-lag-g3-t2819365)

Note that this will turn off both knock on and knock OFF. If you still want to use knock off, you'll need to use one of the many screen off apps in the play store, in combination with an alternate launcher like Nova or Apex.

1. Download and install Shortcut Master: https://play.google.com/store/apps/details?id=org.vndnguyen.shortcutmaster.lite
2. Open the app and select Search from the menu. Enter hiddenmenu in the search field, and press search.
Screenshot_2014-12-05-17-15-07.png


3. Scroll down and find the row for com.lge.hiddenmenu.settings.LgSrvKnockonSetting
QuickMemo%2B_2014-12-05-17-15-54.png


4. Tap that row, and then tap on "Launch"
QuickMemo%2B_2014-12-05-17-16-53.png


5. Change the toggle from On to Off, then back out of Shortcut Master.
QuickMemo%2B_2014-12-05-17-16-35.png


You can repeat the steps to turn it back on.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    I love knock on, and it works great for me. But some people apparently have a problem with the phone turning on in their pocket. The Sprint ZV6 update supposedly has some changes included to address this problem, but how effective it will be is anyone's guess. I was recently involved in a discussion elsewhere as to whether it would be possible to use Tasker to prevent knock-on from working in your pocket, but I don't think it is.

    I did discover another approach, though, that will work. Verified on the LS990 with BarRin v2, but it should work on any rooted G3 with a stock-based kernel. ( IF you have an AT&T or T-Mobile version, you can probably find this setting in HiddenMenu without using the Shortcut Master app, by entering the dialer codes as in this thread: http://forum.xda-developers.com/lg-g3/general/mod-root-rid-lag-g3-t2819365)

    Note that this will turn off both knock on and knock OFF. If you still want to use knock off, you'll need to use one of the many screen off apps in the play store, in combination with an alternate launcher like Nova or Apex.

    1. Download and install Shortcut Master: https://play.google.com/store/apps/details?id=org.vndnguyen.shortcutmaster.lite
    2. Open the app and select Search from the menu. Enter hiddenmenu in the search field, and press search.
    Screenshot_2014-12-05-17-15-07.png


    3. Scroll down and find the row for com.lge.hiddenmenu.settings.LgSrvKnockonSetting
    QuickMemo%2B_2014-12-05-17-15-54.png


    4. Tap that row, and then tap on "Launch"
    QuickMemo%2B_2014-12-05-17-16-53.png


    5. Change the toggle from On to Off, then back out of Shortcut Master.
    QuickMemo%2B_2014-12-05-17-16-35.png


    You can repeat the steps to turn it back on.
    1
    Does it save for battery if i turn this feature off?

    Marginally, yes but barely noticeable. Unless it was constantly going off in your pocket, thats a big battery waster, lol.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone