Root OOS 10.0.1

Search This thread

ViperCDX

Senior Member
Jul 25, 2013
359
48
0
Kolkata
Hello, i was on android 10 open beta 2 with root
But while upgrading i ran into some complications and now i am on OOS 10.0.1 but dont have root
I tried to install twrp but after pushing through adb the screen says "fastboot mode" and stays there. And after typing fastboot reboot the phone reboots into home screen
I also tried to patch boot image of oos 10.0.1 but it enters into fastboot loop
Any way i can get root?
 

redpoint73

Recognized Contributor
Oct 24, 2007
15,259
6,949
113
I tried to install twrp but after pushing through adb the screen says "fastboot mode" and stays there. And after typing fastboot reboot the phone reboots into home screen
Your description sounds a bit suspicious, like you aren't doing the right method. Or maybe you are not just using the right (precise) terminology. There is a lot of confusion by folks on how to boot/install TWRP properly on this device, so that is why I am pointing this out, and hope you can clarify more specifically so we can then help you.

You don't need to adb push the TWRP.img file to boot TWRP, and you don't "install" TWRP.img using fastboot either. You should be trying to fastboot boot twrp.img, with that img file on your computer.

You do need the Magisk zip on the phone (and adb push is one way); as well as the TWRP installer zip if you intend to install (not just boot) TWRP to the phone. The TWRP installer zip not completely necessary, if you want to just flash Magisk and achieve root (not have TWRP installed on the phone).

Also, are any error messages showing up on your command prompt on the computer, and if so what does it day exactly?

Might be best if you cut/paste your fastboot commands, or post a screenshot of your PC, so we can see exactly what commands you used, error messages, etc.
 
Last edited:

ViperCDX

Senior Member
Jul 25, 2013
359
48
0
Kolkata
Your description sounds a bit suspicious, like you aren't doing the right method. Or maybe you are not just using the right (precise) terminology. There is a lot of confusion by folks on how to boot/install TWRP properly on this device, so that is why I am pointing this out, and hope you can clarify more specifically so we can then help you.

You don't need to adb push the TWRP.img file to boot TWRP, and you don't "install" TWRP.img using fastboot either. You should be trying to fastboot boot twrp.img, with that img file on your computer.

You do need the Magisk zip on the phone (and adb push is one way); as well as the TWRP installer zip if you intend to install (not just boot) TWRP to the phone. The TWRP installer zip not completely necessary, if you want to just flash Magisk and achieve root (not have TWRP installed on the phone).

Also, are any error messages showing up on your command prompt on the computer, and if so what does it day exactly?

Might be best if you cut/paste your fastboot commands, or post a screenshot of your PC, so we can see exactly what commands you used, error messages, etc.

ok let me try to be as specific as possible.
First i put the "twrp-3.3.1-4-guacamole.img" file in the adb folder and "twrp-3.3.1-4-guacamole.zip" in the internal storage of my phone
Then i switched off my phone, pressed vol up and vol down and power button to enter fastboot mode
i connected my phone to my pc
opened cmd window in the adb folder
typed "fastboot devices" to check if connected
then "fastboot boot twrp-3.3.1-4-guacamole.img"
on pressing enter , i get the 2 ok messages on cmd window and at that point my phones screen goes completely black with "Fastboot mode" written in the center
And stays there that way
now if i type "fastboot reboot" the phone reboots to the home screen
Hope i made it a bit clear
Sorry cant post screenshots at this moment, i am on vacation and dont have my laptop with me
 

kgs1992

Senior Member
May 8, 2012
1,482
1,884
0
Bangalore
You're using the wrong twrp image. You have to use the one for android q. Unofficial build of twrp for android q is available on the development section. Get that image, fastboot boot twrp.img and then install magisk 20. You don't need to install the twrp zip. You can just boot the image from fastboot whenever you need a custom recovery.
If you absolutely want the recovery, then you can flash it (remember to get the zip for android q) from magisk and then do direct install of magisk then reboot.
 
Last edited:
  • Like
Reactions: redpoint73

ViperCDX

Senior Member
Jul 25, 2013
359
48
0
Kolkata
You're using the wrong twrp image. You have to use the one for android q. Unofficial build of twrp for android q is available on the development section. Get that image, fastboot boot twrp.img and then install magisk 20. You don't need to install the twrp zip. You can just boot the image from fastboot whenever you need a custom recovery.
If you absolutely want the recovery, then you can flash it (remember to get the zip for android q) from magisk and then do direct install of magisk then reboot.
Oh damn, didnt realise that, so silly of me
Will try the android q version and report back
 

ViperCDX

Senior Member
Jul 25, 2013
359
48
0
Kolkata
Good catch by the previous user, that you need to use an updated TWRP version.

Unofficial version -70 from the following thread is what you want (if you haven't found it already): https://forum.xda-developers.com/on...nt/recovery-unofficial-twrp-recovery-t3931322

Yeah i pushed the .70 version through fastboot then flashed the installer
And now i have twrp
However when i try to flash magisk zip through twrp, the phone enters into fastboot mode and does not enter home screen
I have to fastboot boot image to get out of it
I have tried magisk 20.1,20 and 19.4
Kindly help
 

iceman1177

Member
Jan 21, 2016
38
15
0
Hello guys please help me if you know what is this? What can I do? it's bug in Android 10.0.1 or something wrong that show me every minute this error?Show me in every minute this Don't want communicate with E4:5F:8D:9C:06:1A.Wait your answer,thanks.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    What happens when you're in fastboot and boot the twrp file?

    The whole screen turns black with the words "fastboot mode" in the center
    1
    You're using the wrong twrp image. You have to use the one for android q. Unofficial build of twrp for android q is available on the development section. Get that image, fastboot boot twrp.img and then install magisk 20. You don't need to install the twrp zip. You can just boot the image from fastboot whenever you need a custom recovery.
    If you absolutely want the recovery, then you can flash it (remember to get the zip for android q) from magisk and then do direct install of magisk then reboot.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone