[ROOT/RECOVERY] Root and CWM for the Lenovo Yoga 10 HD+ (b8080-h)

Search This thread

zyrill

Senior Member
May 6, 2010
102
56
I'd appreciate help porting CWM and Cyanogenmod! Please post, fork, request merges etc...

I've managed to compile CWM for the Lenovo Yoga 10 HD+

My repository is here: https://github.com/zyrill/android_device_lenovo_b8080h

And the CWM recovery image is attached. Use towelroot by geohot to root your tablet.

Before attempting to flash, you should:
  • make sure you know what you're doing!
  • double check that you're flashing the right partition!
If you flash the wrong partition, you'll brick your tablet!

You can check your partition layout with
Code:
$ ls -al /dev/block/platform/msm_sdcc.1/by-name/

Once rooted, you can flash the image as follows:
Code:
$ adb push recovery.img /storage/sdcard0/recovery.img
$ adb shell
$ dd if=/storage/sdcard0/recovery.img of=/dev/block/mmcblk0p21

Enjoy!

Changelog:

v 0.1: Initial version. Known issue: can't yet mount /sdcard and external cards
v 0.2: Backup is operative! Known issues: no option to backup to external storage, no option to skip backing up of external storage, date is not set correctly
 

Attachments

  • recovery.zip
    9.2 MB · Views: 7,367
Last edited:

Bringer1

Senior Member
Dec 3, 2008
84
4
Very nice @zyrill!!!! :good:

Thank you so much! :)

Did anyone tested it yet?

Regards,
Asmaron

Yep! I´ve done! TowelRoot works.
And It works fast and without problems. I have used the tr.apk with date 04.07.2014 and done on the
B8080 with Firmware B8080_S102202_140716_ROW_3GData

Needs 2-3 Seconds and now I have root! But don´t forget to install SuperSu!
 
Last edited:
  • Like
Reactions: asmaron

B5Pilot

Member
Nov 16, 2007
8
0
Most Excellent

Well don't worry, I've got it running on my tablet for all that time now and of course it works, else I wouldn't have posted it. :) If I find some more time, I'll start porting CM as well, but that might be a while, I'm a bit busy right now.

I installed this and it seems to be working. I backed up my current configuration but have not yet tried to restore anything. The backup did take a while though. I was a little worried at first that it was stuck.

zyrill, you need a donate button somewhere. I'm willing to donate to have cwm running on my tablet. CM 11 would be nice too but I'm just happy to be able to run Exposed and back everything up.

Mark
 

B5Pilot

Member
Nov 16, 2007
8
0
Oh Yeah

Oh yeah, I forgot to mention that I've got the WiFi only version. That's the 8080-f hardware version. The recovery block is the same.


I installed this and it seems to be working. I backed up my current configuration but have not yet tried to restore anything. The backup did take a while though. I was a little worried at first that it was stuck.

zyrill, you need a donate button somewhere. I'm willing to donate to have cwm running on my tablet. CM 11 would be nice too but I'm just happy to be able to run Exposed and back everything up.

Mark
 

tdklaus

Member
Aug 17, 2007
31
5
I tried the CWM recovery, and it didn't work for me. (Wifi-only HD+)

flashing worked fine, and I was able to boot into CWM

tried to run a backup, the display stopped changing at (quoting from memory here) "backing up sd-ext" - I have no ext-partition on my sdcard (64GB)...

1st try, switched off after ca. 2 hours: a folder clockworkmod\backup was created on the sdcard, but was empty

2nd try: let it run overnight until the battery ran out. Result: corrupted filesystem on the sdcard, had to re-install from scratch.

Does anybody have the original recovery.img for me to flash it back?
 

B5Pilot

Member
Nov 16, 2007
8
0
I tried the CWM recovery, and it didn't work for me. (Wifi-only HD+)

flashing worked fine, and I was able to boot into CWM

tried to run a backup, the display stopped changing at (quoting from memory here) "backing up sd-ext" - I have no ext-partition on my sdcard (64GB)...

1st try, switched off after ca. 2 hours: a folder clockworkmod\backup was created on the sdcard, but was empty

2nd try: let it run overnight until the battery ran out. Result: corrupted filesystem on the sdcard, had to re-install from scratch.

Does anybody have the original recovery.img for me to flash it back?

I may have a little premature in my enthusiasm. My backup included a full copy of my SD card which nearly filled the remaining internal memory. I never did try to restore the backup so I can't guarantee that it would work correctly.

I've started the process of compiling a version of CWM for the WiFi only version but I'm new to the whole process and it will take me a while to begin to figure it out.

Unfortunately I wasn't careful and never extracted the stock recovery before I flashed this version. I was double stupid and never tried to capture the ota to 4.4. I suppose you could do a factory reset and start over. Sucks I know.


Mark
 

tdklaus

Member
Aug 17, 2007
31
5
Unfortunately I wasn't careful and never extracted the stock recovery before I flashed this version. I was double stupid and never tried to capture the ota to 4.4. I suppose you could do a factory reset and start over. Sucks I know. Mark

I have captured the OTA to 4.4, so if you tell me how, I could try to extract the original recovery from it.
 

mdy

Member
May 9, 2011
14
0
CM 11 would be great

Thanks for your attention to our HD+ tablets. I have B8080-F. Lenovo seems to be pretty slow in bringing new Android versions to this new tablet. It would be great to have CM 11 builds for this device. I have a Samsung Tab 2 7.0 that got new life after I installed CM 11 4.4.4..Just my encouragement to you folks who know how to build CM for the HD+.
 

AEkiz

Member
Jan 18, 2014
36
12
Edit:
4.4.2 firmware have WiFi problems,problems with some apps like weather and so on. I went back to 4.3
 
Last edited:

zyrill

Senior Member
May 6, 2010
102
56
Can anybody confirm the issues with the backup/restore process? It seemed to work fine for me. Maybe the exact steps to reproduce the mistaken behaviour will help us fix it. Also, I have the original recovery image, is it still needed?

Regarding CWM: I've just finished my PhD and am looking for a job. As soon as that's settled, I'll have time to work on other projects such as CM for our tablet. But in the meantime, if anybody makes any headway, simply issue a pull request and I'll include your work in our repository so everybody can benefit.

Cheers!
 

tdklaus

Member
Aug 17, 2007
31
5
Can anybody confirm the issues with the backup/restore process? It seemed to work fine for me. Maybe the exact steps to reproduce the mistaken behaviour will help us fix it. Also, I have the original recovery image, is it still needed?

thx, zyrill.
Well what cam I say, booted into recovery, chose backup/restore - backup and after a few messages the process seemingly stopped with "backing up /sd-ext" on the screen.
No ext-partition existed on the external sdcard, and there were about 10GB free on the internal and 27GB on the external, so wherever CMW tries to store it's files, I hope there was ample room.

I'd still very much appreciate the original recovery.img before I do any more experiments (it's the wife's tablet, after all ;)
 

tdklaus

Member
Aug 17, 2007
31
5
Also, I have the original recovery image, is it still needed?

Hi zyrill, I appreciate that you don#t have much time now, but could you still please upload the original recovery?

I managed to get through a backup process in CWM without error messages. Let's trade hostages :laugh:
 

zyrill

Senior Member
May 6, 2010
102
56
Hi zyrill, I appreciate that you don#t have much time now, but could you still please upload the original recovery?

I managed to get through a backup process in CWM without error messages. Let's trade hostages :laugh:

Sure, I'll upload the files once I get back to Germany next Tuesday. Am away and without access to something else than Android... I'll get right on it once I'm back.
 

DannyBiker

Senior Member
Jul 10, 2010
2,465
351
Brussels
I have rooted through towelroot, haven't touched the recovery. I got the "b8080_s101103_140715_row_wifi" update but it failed to apply because of the LenovoSafeCenter.apk being altered.

Any way to update ?

Edit : I tried to restore the factory settings. The update still won't install.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    I'd appreciate help porting CWM and Cyanogenmod! Please post, fork, request merges etc...

    I've managed to compile CWM for the Lenovo Yoga 10 HD+

    My repository is here: https://github.com/zyrill/android_device_lenovo_b8080h

    And the CWM recovery image is attached. Use towelroot by geohot to root your tablet.

    Before attempting to flash, you should:
    • make sure you know what you're doing!
    • double check that you're flashing the right partition!
    If you flash the wrong partition, you'll brick your tablet!

    You can check your partition layout with
    Code:
    $ ls -al /dev/block/platform/msm_sdcc.1/by-name/

    Once rooted, you can flash the image as follows:
    Code:
    $ adb push recovery.img /storage/sdcard0/recovery.img
    $ adb shell
    $ dd if=/storage/sdcard0/recovery.img of=/dev/block/mmcblk0p21

    Enjoy!

    Changelog:

    v 0.1: Initial version. Known issue: can't yet mount /sdcard and external cards
    v 0.2: Backup is operative! Known issues: no option to backup to external storage, no option to skip backing up of external storage, date is not set correctly
    3
    Alright, excuse my belated reply. But here we go: I have uploaded the original recovery.img - see the attachment.
    2
    (...)because of the LenovoSafeCenter.apk being altered.

    I don't think this has anything to do with towelroot as it doesn't alter any of your apk's. But anyway, for your convenience, here's an unaltered version of that file (see att.). Cheers!
    2
    Thanks! I'll give it a try later on! :)

    Well don't worry, I've got it running on my tablet for all that time now and of course it works, else I wouldn't have posted it. :) If I find some more time, I'll start porting CM as well, but that might be a while, I'm a bit busy right now.
    2
    Can anybody confirm the issues with the backup/restore process? It seemed to work fine for me. Maybe the exact steps to reproduce the mistaken behaviour will help us fix it. Also, I have the original recovery image, is it still needed?

    Regarding CWM: I've just finished my PhD and am looking for a job. As soon as that's settled, I'll have time to work on other projects such as CM for our tablet. But in the meantime, if anybody makes any headway, simply issue a pull request and I'll include your work in our repository so everybody can benefit.

    Cheers!