[Root] Root and TWRP for R

Search This thread


Senior Member
Jul 6, 2016
Stock Recovery

When I flash twrp, I'm unable to install any zip files and when I reboot, the recovery is back to stock recovery...

Any ideas?:confused:


Senior Member
Jul 6, 2016
I tried again but still no luck. This time I used the tool but no success either.. So, what do I do?

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    Disclaimer: If you are not comfortable with using Fastboot and ADB and editing system files than this guide might not be for you. At this point this is what I have to offer.

    Click here for the unofficial twrp image - Latest version as of 12/27/14

    So getting right into it.

    1. Turn on ADB mode on the watch by going to about and tapping the build info 7 times.

    2. Download ADB and Fastboot utilties

    3. Plug the watch into the computer and your phone should vibrate and ask you to accept the computers fingerprint, tick the check box to always allow and hit ok

    4. Open up a command prompt or terminal inside of where the ADB utilities are located and enter
    adb reboot bootloader

    This next step will wipe your data!

    5. Now you should be in fastboot, go ahead and on the terminal use the next code and follow prompts to unlock
    fastboot oem unlock

    6. Now after you re-set up your watch again you will need to do step 1 and 3 again.

    Please do not skip step 6!

    7. Go ahead and issue
    adb reboot bootloader

    8. Flash unofficial twrp, make sure the recovery image file is in the same location as fastboot than issue
    fastboot flash recovery YOURIMGNAMEHERE.img

    9. Upon successfully doing that you should have twrp installed

    10. Lots in one step here, download the latest supersu.zip flashable file and put it in the same folder as ADB use the proper name of what you downloaded. Issue
    adb push SUPERSUNAMEHERE.zip /sdcard/

    11. Issue
     adb reboot recovery

    12. than using the very tiny TWRP and somewhat messed up go ahead and use it to install the supersu.zip under the folder /sdcard

    13. Enjoy root and twrp.

    I will make this guide into a much easier Java program in the very near future to make it easier to use.

    This was typed up pretty fast and it is kinda hacky, I will work on a bat script and a shell script if we have enough osx users here. I'm sure someone will come along and make this better if I don't get around to it.

    Dees-Troy for his TWRP support for dory our fish brother device which worked on our device
    Chainfire for all his hard work these many years

    I'v just sideloaded the Marshmallow update and rooted it through TWRP:

    I used this TWRP image by rbox (I just booted it as I prefer stock recovery on my watch, but flashing should work too)
    and Chainfire's latest SuperSU v2.67 without the apk as described here

    thanks to all the people linked above!
    ah ok, the tools you are using arent packing the image correctly. the DTB.img isnt being packed properly. its similar to the ramdisk offset its soemthing you need to define and have it get packed in with the boot.img.

    edit: use https://github.com/xiaolu/mkbootimg_tools

    Yea that was it. I was using abootimg to create images which worked up until recently. I just copied some git repository and downloaded unmkbootimg and mkbootimg again and used that and now it works.

    Latest TWRP is in OP. Thanks to shabbypenguin for the latest theme which works pretty well.
    PLEASE BE CAREFUL FLASHING LOLLIPOP UPDATE! It flashes a new bootloader, TZ, kernel, and system.
    Q: ADB complains there is no device listed.
    A: Install universal ADB drivers and then go to device manager and under the device with a yellow warning icon go to update driver, Browse my computer, let me pick from list of device drivers, than Google ADB interface. If it still complains turn off debugging, than turn it back on, revoke authorization, then disable and re-enable again.