[ROOT] ROOT DROID RAZR XT910/XT912 [Win/Mac/Linux][2.3.6][ICS]

Search This thread


Senior Member
Oct 16, 2011
i never understood the whole "RSD Lite" and "Use the corresponding files" bit. no one really explains how to use RSD Lite very well, or even explain any of the terminology or what the process is doing. This is the single largest obstacle i face when futzing around with ROMs. I never know what to use. Fastboot Files (which i assume as the .zip ROM packages you download from the developer?) through RSD Lite, or Do i use Bootstrap recovery and install much like my HTC Incredible?

The Motorola for Newbies thread is terribly ineffective for informing a newcomer to Moto on what's what.

Yeah you and me both, I however found out how to do it. It's quite easy actually.

Download RSD Lite, install

Take the phone and hold the powerbutton and both volune button to getn inte the bootloader. Choose fastboot. (volume down is scrolling, volume up select)

Connect to PC and RSD should find the phone,

Now you need to find the right stock rom, download and put it in RSD and press start, thats all.


Senior Member
Apr 2, 2012
Thanks OP. Works like a charm! There could not be an easier way to do this for noobs. I am on stock (now rooted) AsiaRetail ICS.


Senior Member
Oct 17, 2010
I'm not sure what I'm doing wrong, I downloaded the files, I have the drivers installed. When I click on the windows file and click ok to start, it just sits at Rooting... and nothing is happening.

Edit: Nevermind, I tried a few more times and eventually everything worked fine.
Last edited:


Mar 3, 2011
The Download of downloadandroidrom.com/file/DroidRazr/rooting/motofail_windows.zip didnt work. Do you have a mirror for it?


Senior Member
Mar 26, 2012
Worked Flawlessly

I'm not sure what I'm doing wrong, I downloaded the files, I have the drivers installed. When I click on the windows file and click ok to start, it just sits at Rooting... and nothing is happening.

Edit: Nevermind, I tried a few more times and eventually everything worked fine.

Glad to see you got it. Mine went through without a hitch. Now just need to figure everything else out.


Jul 3, 2009
I've used his walkthroughs to root gingerbread, unroot it, and root ICS....redonkulously easy and no problems! thanks!


Senior Member
Dec 21, 2010
Thank you! I greatly appreciate this simple rooting method!

I was able to successfully root my Droid Razr Maxx running ICS.
Your video walk thru was great, and I love the fact you had it
available to download and watch as a file instead of streamed.

I used the Mac version on my iMac.

Best Regards,


Sent from my Motorola Xoom tablet running Jellybean using XDA-Developers app.

Edit: I have the US Verizon version.


Senior Member
Oct 27, 2010
Flashing official firmware under Mac

Hi all
Could someone explain please how to flash official Moto files using Mac?
I found script named "fastboot-mac" here but it cannot detect connected device ("Waiting for device" message in Terminal). Any ideas guys?
BTW adb-mac script from the same zip package (OP) works just fine as expected.
For instance:
./adb-mac shell
works while
./fastboot-mac reboot-bootloader
doesn't work.


Senior Member
Dec 23, 2010
Hi! Thanks for the Root! My first try I downloaded the windows only files and failed to root. The second time I downloaded the files for all three OS's and it worked fine. Not sure what made the difference but thought i'd mention. Thanks again!


Senior Member
Jan 20, 2012
Rio de Janeiro - RJ
Device: Motorola Razr XT910

Firmware: 672.180.41.XT910.Retail.en.EU

File downloaded: DroidRazrRoot.com_ICS.zip (md5: ABB27D728D718FFEF60AFA36E531FE73)

- Device disconnected
- Enabled "USB Debugging" under Developer Options
- Connected to my PC (WinXP SP3 + Latest Motorola Device Manager)
- Changed the USB mode from Mass Storage to MTP
- Started the app and went to get a cup of coffee
- Got back, noticed some failed messages
- Process finished
- Went to check my phone and Super SU was there

Thanks a lot, bro!




Senior Member
Oct 24, 2012
I am trying to us this to root my droid RAZR for Verizon on ICS I have tried multiple things to get it to root and nothing works. My debug is on. My unknown sources is checked. My mtp is set to mtp. And still nothing. My Mac nor my windows recognized the phone. Neither Odin or heimdall. What is going on here when I use your root tool it's say cannot find device. Help?¿

Sent from my SCH-I535 using xda app-developers app
  • Like
Reactions: bunnybash

Top Liked Posts

  • There are no posts matching your filters.
  • 52

    For ICS, here's NOOB-PROOF, FAIL-PROOF, video tutorials for Windows, Mac and Linux:

    Windows Droid Razr ICS Root

    Mac Droid Razr ICS Root

    Linux Droid Razr ICS Root

    Download Rooting files (for all Windows, Mac, and Linux!)

    All exploit credits goto XDA user DJrBliss Dan Rosenberg! and no one else.

    =========BELOW IS FOR Android 2.3.6==================================
    Here's root + recovery for Win Mac and Linux on Gingerbread Android 2.3.6 (should work on all Gingerbread)

    Sorry YouTube terminated my account, you can still see step-by-step photos here on my site.

    Download for Windows:

    Download Mac/Linux: (DO ./run.sh in terminal)

    Drivers for Windows:

    =========BELOW IS OLD==================================
    I simply modified the original here and re-wrote it for Linux and Mac.

    Video tutorial:

    No drivers needed for Mac and Linux!

    Download files here:

    Open up a terminal in your computer and use cd command to browse to the DroidRazrRootMacLinux directory:

    cd Downloads/DroidRazrRootMacLinux

    For Linux, type:

    sh runmelinux.sh


    sudo sh runmelinux.sh

    For Mac, type:

    sh runmemac.sh

    That's it!

    =========ABOVE IS OLD==================================
    Hi...sorry for the noob-ish question, but when I type this command into my Mac terminal, I get the following error message:

    -bash: cd: Downloads/DroidRazrRootMacLinux: No such file or directory

    Now, the downloaded file is DEFINITELY in my Downloads folder, so I'm not sure what I'm doing wrong. I was able to follow directions pretty well when I rooted my Thunderbolt using the terminal and some adb commands. Do you have any thoughts you might want to share? I appreciate your help.

    ---------- Post added at 11:38 PM ---------- Previous post was at 11:24 PM ----------

    Never mind. I don't mind admitting I'm an idiot. I went ahead and unzipped the downloaded file and all is right with the world. I'm the proud owner of a rooted Razr. Thanks for your work on this, and thanks for sharing.
    This won't work for GSM Razr right?

    Sent from my XT910 using xda premium

    I think this work on all razor.

    Sent from my XT910 using Tapatalk
    You can unroot just by going to the SuperSU app and then go to the settings, and choose “Full unroot”. Its very easy and the whole process of rooting and unrooting takes a maximum of 10 minutes.:victory:
    ROOT for Android ICS 4.0.4

    How do we root 4.0.4?

    Take this


    1.Device via MTP mode connect to your PC and USB debugging (Settings / developer options) on.
    2.unpack Zip File and Start "DroidRazrRoot404.bat"
    3.Take a Tea :silly: