• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROOT] SuperSU

Search This thread

canemaxx

Senior Member
Aug 23, 2012
541
59
Wilder,VT
Samsung Galaxy S21 Ultra
Yeah. I'm booting and rooting like a champ with NDE63P. Heck, I'm even able to revert back to NDE63P after NDE63X and NDE63V (tried them both. They both booted, but bootlooped after "fastboot boot boot-to-root.img"). I've tried all of this from within the platform tools folder, from within the fastboot_adb_pixel folder, and even the C:\adb folder. None work with NDE63X or V. Looks like I'm going to have to wait for next month's release, and try again. Thanks for all of you guys' help.
Which was the previous image for Verizon from october?
 

TheAltruistic

Senior Member
Dec 31, 2012
156
30
New York
If you're ambitious like me and updated to a November security OTA, you attempted to root, and are stuck in a bootloop without a backup or easily able to roll back to the earlier update you can just adb sideload the same update again to knock yourself out of the bootloop without having to flash anything.
Of course you won't have root and will just have to wait till Chainfire posts an updated version.
 

g4Nk

Senior Member
Aug 25, 2011
113
15
So, I've been trying to follow along the best that I can, but I'm still a little confused. I just sideloaded V and would like to install the ElementalX kernel. The instructions for the installation require boot-to-root, but won't that cause a soft brick?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 192
    This thread was originally for Pixel-specific rooting instructions, but by now the SuperSU ZIP and TWRP are fully supported:

    - Fastboot boot TWRP
    - Install latest SuperSU ZIP (v2.79-SR3 at the time of writing)

    Note that at this time I recommend against fastboot flashing TWRP. With the Pixel's new partition layout, the recovery files are inside the boot partition, and so is SuperSU. If you flash both, SuperSU's internal boot image backup will not be of the original boot image, but of TWRP. This means that neither the 'full unroot' option in SuperSU, nor incremental OTA update through FlashFire, will work as expected.

    OR

    - Use CF-Auto-Root for Pixel (not released at the time of writing, but should be released soon)
    30
    Chain fire was your tester able to verify if the system UI issue was fixed? Just curious I have yet to experience it my self and was just currently below 15%

    Yes, the 15% issue is fixed. Release probably later today or tomorrow. Have some other bugs to fix as well.
    27
    Fanboys just admit that the you can't install RC1 fresh and the op is misleads users to try that route. Dev gave instructions thant don't work. I think it was not tested, however, just flash twrp RC1 and SU5 and the dev assumed it world work. No problem, but many of us wasted hours trying to prove an assumption... Maybe we need SU6? Update: I forgot to say I was trying to root, too. So yes, I can install RC1 but can't root. Srry, dev and those I rubbed the wrong way. My bad.

    The instructions worked at that release time (weeks ago), it's not my fault TWRP was updated a few days ago in an incompatible way. Nor is it Dees_Troy's fault - it's just how things turned out.

    There will be an update to SuperSU to fix this. In the mean time, just use alpha2 instead of rc1.

    Or, you could continue being a complete asshat, in which case, please get the hell out of my thread (and/or off my planet).