Root the Nexus with ROM Links *Updated*

Search This thread


Senior Member
Aug 24, 2009
Samsung Galaxy S20
Root the Nexus with ROM Links *Updated*

1. This does void your warranty.
2. The root image auto installs the superusers permission app
3. I am in no way responsible for anything that goes wrong.
4. Once you unlock the bootloader it does a factory reset on your phone.
5. I don't mind people posting this tutorial on their sites for others to see and use but I do ask that I'm at least given credit for my work.

1. Download fastboot and adb files:

2. Extract to a folder and Open a command window in that folder by holding down your shift key and right clicking anywhere in the window and select open command prompt here

3. Then with your phone turned off hold the power and trackball to access the bootloader.

3b. Type this command to make sure your phone is connected and reconized. "fastboot.exe devices"

4. Once in the bootloader type this command in your command prompt "fastboot.exe oem unlock"

6. Follow what that sceen says.

7. Flash Amons RA Recovery Image from here

---------------Now to root your phone.---------------

1. Once you've flashed the recovery image turn your phone off.

2. Then power on by holding power button and trackball then tap the power button to access the bootloader.

3. From there use your volume keys to go down to recovery and hit power button again to access the recovery console.

4. Enjoy rooted phone

---------------Now to Flash a Radio and a Rom---------------
1-Download Radio(s):

RADIO UPDATE - (from ERE27 update)

Original Radio image (from ERD79) in an

2. Download a Rom:
A-[ROM] Enomther's TheOfficial Nexus1
B-[ROM] CyanogenMod
C-[ROM]MoDaCo Custom ROM with Desire/Sense
D-MoDaCo Enhanced ROM

2. put both the radio and update zips on your sdcard

3. power down your phone

4. Using the volume down key and power button to get to bootloader/recovery option screen
4a Use volume key to scroll and power button to pick

5. Go to flash zip from sdcard

6. Flash radio update zip first

7. After that is complete and you've restarted when it told you to do so.
7a. In to wipe menu and wipe phone.

8. Flash Rom zip

9. To get root again simply reflash the (instructions above.


    1 MB · Views: 15,800
Last edited by a moderator:
Followings are instructions for OSX or any *nix platform.
Android SDK is nice to have but not needed.
You can download the Android SDK here.

I take no responsibility for what you do to your phone or your computer.

Step 1. Download the file from above post and unzip the file to your desktop.
Step 2. Open Terminal.
Step 3. Go to the folder that you zipped.

cd ~
cd Desktop/ <enter>
cd 1.1-nexusone-superboot/ <enter>

step 3. Load into fastboot on your phone.
<option 1> first power off, then power on while holding down the trackball.
<option 2>You can also hold down volume down while powering on and then select fastboot and press power.

step 4. Make sure fastboot can connect to your device.

./fastboot-mac devices <enter>

if you can see the serial number of the phone with fastboot next to it, you are good. If not, repeat step 3.

step 5. Enter the following in your terminal screen
./fastboot-mac oem unlock (if you are on a mac)
./fastboot-linux oem unlock (if you are on a linux based machine)

step 6. If you do not want to void warranty or if you have not save your settings and contact etc, do not press yes. Save those first.
Follow instructions on screen. (use the volume up/down to switch and power to select).
Phone will reboot with unlock icon on the bottom of the X logo. Kiss your original setup goodby.

step 7. Enter the follow command:
./fastboot-mac flash boot nexusone.superboot.1.1.img <for mac>
./fastboot-linux flash boot nexusone.superboot.1.1.img <for linux>

step 8. Reboot phone by pressing volume down and pressing power. You are done!
Last edited:


Senior Member
Jan 3, 2009
If nobody else gives it a try by the time mine arrives tomorrow, I will root my device and then see if I can't reverse it for the sake of warranty preservation.

Glad we are already at this step on Day 2 :)


Senior Member
Dec 13, 2006
I did this and I can't see protected apps on the market anymore.. anyone else experience this issue?

A way to check is to try to find Twidroid on the market or really any paid app


Jul 28, 2009
Baltimore md
i think i'll wait until there is a reason to root the phone other then saying its rooted when there's a feature or ROM i can add that's useful like multi touch then ill root my phone.dont get me wrong i got this phone to root it but theres no point rite now


Senior Member
Jul 19, 2009
I'm getting mine in the mail tomorrow :). I'm not going to root it right away though.. just in case something goes wrong ):


Senior Member
Aug 24, 2009
Samsung Galaxy S20
my permisson app doesnt freeze for me but what you can do is remove it and use something like astro to go to your phones root dir theres a folder in there called superroot with the apk for it so you can reinstall it.


Retired Recognized Developer
Nov 5, 2008
Paid Market Apps

I had a feeling, and it seems to have been confirmed, that rooting will not allow me to download paid apps. I know that this was an issue when the G1 was first rooted and it was "fixed." Can someone confirm this issue? This is a big one for me.

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I did everything as suggested here but it Nexus Torch still doesn't have SU permissions. When Torch opens SU, it stops responding.

    I had this problem too, I just keep relaunching the app until finally it worked! Make sure when you slelect Allow on the superuser permission that you check the little box!
    Do this, boot to fastboot and flash recovery
    fastboot flash recovery recovery.img
    Or whatever you named recovery
    No don't reboot with cmd, just from phone choose bootloader,
    Then choose recovery, I think your OK installed ROM may be overwriting recovery at reboot

    Sent from my Nexus 7 using xda premium
    using windows cmd.

    here im pasting total commonds i got when i tried to root fone.

    "Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>cd C:\Personal\Softwares\Android tools\ADB tools

    C:\Personal\Softwares\Android tools\ADB tools>fastboot.exe devices
    'fastboot.exe' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Personal\Softwares\Android tools\ADB tools>fastboot.exe devices

    C:\Personal\Softwares\Android tools\ADB tools>fastboot.exe oem unlock
    < waiting for device >
    ... INFOErasing userdata...
    FAILED (status read failed (Too many links))

    C:\Personal\Softwares\Android tools\ADB tools>fastboot flash recovery recovery-c
    sending 'recovery' (3476 KB)... OKAY
    writing 'recovery'... OKAY

    C:\Personal\Softwares\Android tools\ADB tools>fastboot reboot

    C:\Personal\Softwares\Android tools\ADB tools>fastboot flash recovery recovery-c
    sending 'recovery' (3476 KB)... OKAY
    writing 'recovery'... OKAY

    C:\Personal\Softwares\Android tools\ADB tools>fastboot reboot

    C:\Personal\Softwares\Android tools\ADB tools>fastboot bootloader
    usage: fastboot [ <option> ] <command>

    update <filename> reflash device from
    flashall flash boot + recovery + system
    flash <partition> [ <filename> ] write a file to a flash partition
    erase <partition> erase a flash partition
    getvar <variable> display a bootloader variable
    boot <kernel> [ <ramdisk> ] download and boot kernel
    flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
    devices list all connected devices
    reboot reboot device normally
    reboot-bootloader reboot device into bootloader

    -w erase userdata and cache
    -s <serial number> specify device serial number
    -p <product> specify product name
    -c <cmdline> override kernel commandline
    -i <vendor id> specify a custom USB vendor id
    -b <base_addr> specify a custom kernel base address"

    i got bootloaderunlocked.. it showing *****unlocked******* in the HBOOT..

    here is ma HBOOT menu.

    MI CROP-0c15
    jun 14 2010,12:02:27


    <VOL UP> to previous item
    <VOL down> to next item
    <POWER> to select item


    Why are you using a HTC Hero Recovery? I see that the recovery you are trying to flash is recovery-clockwork-

    Download the N1's recovery here:
    and try to flash again.

    I presume your bootloader is unlocked. So goto bootloader and execute the command to flash the recovery. Let me know how it goes.
    Try a different browser, or try amonara recovery

    Sent from my Nexus One using xda app-developers app