Development [ROOT] [TWRP] [KERNEL] [GSI] for SM-A127f (a12s)

Search This thread

Cherubabayao.

New member
Sep 9, 2022
4
0
To Unlock Bootloader
1. On phone developer options in settings allow OEM unlocking and enable usb debugging by moving both
sliders RIGHT

If you don't see the OEM unlock
-Disable Auto System Update
-Then disable Automatic date and time (Found in General Management) > then set the time back 14 days
- Connect to the internet
-Go to software update then check for update and wait a long time till it registers the device on server
-Once it's registered the OEM Unlock should be visible in the Developer Options

then connect phone to PC
2. Reboot into download mode by holding down both Vol up and Vol down
(You might need to long press vol up to unlock bootloader)

then press vol up to continue
Won't go into download mode
 

physwizz

Senior Member
Sep 16, 2013
3,655
819
Sydney
Won't go into download mode
To Escape the Black Screen of Death or Bootloop

To boot to RECOVERY MODE

Method 1
First connect phone to the PC for 30 minutes
Hold all 3 keys and release volume down when it buzzes.

Method 2
1. Plug in USB cable to PC
2. Hold down all 3 buttons on phone.
3. When it buzzes release volume down and plug in USB cable to phone.

Then restore your backup or install a ROM

To boot to DOWNLOAD MODE

Method 1
First connect phone to the PC for 30 minutes
Hold all 3 keys and release power when it buzzes.

Method 2
1. Plug in USB cable to PC
2. Hold down all 3 buttons on phone.
3. When it buzzes release power button and plug in USB cable to phone.

Then use Odin to flash official firmware.

@physwizz
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I can now totally confirm that the afaneh92's TWRP image, as well as edward0181's, does not work on the Vietnam-made SM-A127F/DSN: I've rooted it, installed TWRP app, flashed the recovery.img from the app and rebooted into recovery using adb. I'm still getting just endless reboots. So this time the experiment was clean and the "wrong key pressed at wrong time" factor was completely excluded. I'm just curious why any stock firmware and the stock recovery tools works just fine? I've already tried many different country-specific versions from that list and they all flash and work perfectly.

    P.S.: By the way, I've built the latest Magisk from the git master and it works great, so no patched version needed.
    2
    Thanks physwizz! With these new recoveries I finally got TWRP booting! I've formatted data okay, have the sdcard accessible after that and a reboot, but now the next problem: a lot of "Unable to find partition for path '/system_root'" messages. And indeed, there is no "system_root" partition entry in fstab. Also the "Mount system partition read-only" checkbox in the Mount section is unresponsive and remains always checked. Any ideas?
    Agh, finally, I found combination, that works for me.
    I have spent days and physwizz hours PMing with me to double, triple check, if I missed some point. It still remain mysterious, why steps leads to different results, as a novice, I can just speculate, if there is some tiny important difference between A127F/DS and A127F/DSN. Or, well.... what about starting "Stock ROM" we are different.

    But there have been some clues.
    Afaneh92's TWRP, it can boot for me, but there has been two things that stink for me. Select Storage - shown Internal storage 0MB capacity and unmountable Data partition, that even if it reports 0MB size, cannot as an empty be backuped, for example. Reboots after proper steps (Format data) leads to slow bootlooping (10mins, I guess Android factory reset trying to finish with some bug in the end).

    Newest TWRP - that one reported lasttime, Srilanka user, it can in some point (physwizz remount command) starts to report Storage size, even Data partition, but installing multidisabler didnt worked for me, leads to Cannot install zip file error. So, not surprise, after data format and reboot, it lead to nothing, well I can just speculate it that un-disabled encryption. Physwizz advice to remount solves part of red colors anout system root.

    I combine those TWRP, using both for part of the job.
    1. Rebooted to Afaneh92 TWRP,
    2. run remount command
    3. run multidisable twice
    4. Reboot directly to download mode
    5. flash SriLankas TWPR, and boot it
    6. Remount command, Format data
    7. Reboot

    voila, system starts, initiate standard default process. Srilankas TWRP can backup all partition I want (including /data). All done.

    I have no idea, if this procedure will help others and will work in other conditions, thats the task for you guys, much much advanced than me. I have just some unclear imagination, whats those steps are about, but there has to be something unfinished with afanehs twrp, that prevent it to work OK in some conditions (hardware, original but regional stock rom)

    Let others know, if it worked for ya.
    HzK
    1
    Root Method

    Twrp and Kernel

    Latest twrp



    Root Method in post#2
    afaneh92 TWRP in post #2
    GSIs in post#3
    Kernel Version 2 & 3 in post #5
    Kernel version 4 in post #11
    Install kernel without TWRP in post#21
    TWRP (new) in post#6
    Skyhawk recovery (new) in post #22
    Orange Fox (new) post #24

    Note
    All of these procedures have been tested on the a127f with u2 baseband
    They will probably all work on the m127f as well.


    @physwizz

    Recoveries for U2 baseband - Working


    Recoveries for U3 baseband - Still being tested

    All recoveries contain physwizz Kernel
    1
    Installing a GSI

    1. Unzip img file
    2. Backup boot, data and super from TWRP.
    Wipe data from twrp
    3. Install IMG.
    4. Install my kernel
    5. Reboot

    I have installed lineages and pixel experience

    List of GSIs


    @physwizz
    1
    Thanks! I finally got the TWRP on my SM-A127F, though I cannot perform the last step: I get errors "Failed to mount '/data' (Invalid argument)" and "Failed to mount '/keyrefuge' (Invalid argument)". Any ideas?

    UPD: not sure if it's OK, but I changed /data filesystem to ext4 and it worked well.
    Can you post, how exactly you did it (changed to ext4)
    Based on your mention, I tried TWRP, WIPE, Advanced wipe, Change or repair filesystem, Change, to EXT4. No luck.