• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Root with Magisk Working

Status
Not open for further replies.
Search This thread

cursixx

Senior Member
Nov 4, 2013
78
39
I was able to root my pixel 4 xl using the latest Magisk canary build of the manager 7.4.0-121afbed

Hopefully you have already unlocked your bootloader but if not do that and it will reset your data

Download the factory image and extract boot.img
Patch boot.img with Magisk Manager
flash magisk_patched.img with fastboot flash boot magisk_patched.img

Thanks you @topjohnwu
 
Last edited:

eg1122

Senior Member
Oct 5, 2009
2,337
2,992
Roma, Tx
Google Pixel 6 Pro
Yep, just finished rooting and activating my Google Pay. Looking good so far.

Only thing to hope for now is TWRP and some custom ROMs, even though the only thing left that I use would be center clock and network speed in the status bar.


If you willing to do Xposed and gravitybox, then center clock and network speed is possible already.
 

Attachments

  • Screenshot_20191024-221900.jpg
    Screenshot_20191024-221900.jpg
    257.1 KB · Views: 2,313
Uh oh.... Freaking out here.

Wont boot properly. Followed all instructions in the other thread. It takes me back to fastboot mode repeatedly, with the error underneath "Boot slot: a", saying "Enter reason: error booting boot.img". I unlocked the bootloader before doing anything. Tried going into rescue mode, but it just takes me back to fastboot mode.

What do? How fix?

Halp!


NEVER MIND! Worked it out. On my initial flash of the patched file, I mistyped 'patched' as 'patchad'. Idiot mistake. Works perfectly! :victory:
 
Last edited:
Status
Not open for further replies.

Top Liked Posts