Root & Xposed on WW_17.1810.1910.73 & Update WW_17.1810.1911.110

Search This thread

MystikMan97130

Senior Member
Aug 5, 2012
152
46
Lyon 69009
www.facebook.com
Hello i found a little way for have root & and working xposed with no bug on last firmware WW_17.1810.1910.73 & WW_17.1810.1911.110
Stock Recovery

You need adb drviers and unlocked ZenFone 6 on WW_17.1810.1910.73 or WW_17.1810.1911.110

First install last Magisk Manager

Open setting of Magisk and add custom update channel https://github.com/solohsu/magisk_files#custom-update-channel

Download ZenFone6RootXposed-10.73.img or ZenFone6RootXposed-11.110 (i have add stock boot11.110.img, we will need it for next update)
http://www.mediafire.com/folder/skzceszqu8d3j/AsusZenFone6

Now reboot device to bootloader
Code:
adb reboot bootloader
And boot with ZenFone6RootXposed-10.73.img or ZenFone6RootXposed-11.110 (not flash it, your device have a chance to bootloop)
Code:
fastboot boot ZenFone6RootXposed-10.73.img
Code:
fastboot boot ZenFone6RootXposed-11.110.img

The devices reboot automaticly

Go to Magisk and install Magisk, choose direct install

Reboot and Enjoy root

if you want Xposed flash it with magisk :

Riru Core
I use YAHFA
Android 10 ElderDrivers Xposed
And the manager
Xposed Installer
 

Attachments

  • Screenshot_20191201-124900954.png
    Screenshot_20191201-124900954.png
    102.9 KB · Views: 768
  • Screenshot_20191201-124726444.png
    Screenshot_20191201-124726444.png
    138.4 KB · Views: 762
  • Screenshot_20191201-124738937.png
    Screenshot_20191201-124738937.png
    118.3 KB · Views: 764
  • Screenshot_20191201-124828477.png
    Screenshot_20191201-124828477.png
    232.8 KB · Views: 729
  • Screenshot_20191222-140800726.jpg
    Screenshot_20191222-140800726.jpg
    126.8 KB · Views: 506
  • Screenshot_20191222-140833346.jpg
    Screenshot_20191222-140833346.jpg
    209.8 KB · Views: 481
  • Screenshot_20191222-140848328.jpg
    Screenshot_20191222-140848328.jpg
    174.5 KB · Views: 460
  • Screenshot_20191222-140916943.jpg
    Screenshot_20191222-140916943.jpg
    172.7 KB · Views: 465
Last edited:

hdsporty50

Member
Mar 5, 2006
6
0
Good morning

I have tried several times root for Android 10
The Magisk part works smoothly, but the Xposed part never works, producing a bootloop

I have extracted the boot and applied magisk, loaded the Riru Core module, but when loading ElderDrivers, the phone stays in bootloop

Do you know what the reason may be?
 

fiinix

Retired Recognized Developer
Oct 9, 2010
570
224
28
Stockholm
Works splendid, great guide!
Tried to use Sandhook first, but ended up with YAHFA instead due some xposed problems (xposed not detected).

Had an old version of Android 9, so i first upgraded it to "UL-ASUS_I01WD-ASUS-16.1220.1909.194-1.1.1" (only supported upgrade path - 9 to 10), then to "UL-ASUS_I01WD-ASUS-17.1810.1910.73-1.1.1-user" (your specified .73)
- Later patching with your img

Thanks :)
 

hdsporty50

Member
Mar 5, 2006
6
0
it is impossible

Starting with .73 stock

at the moment I install Riru Yahfa, following the manual, it does not start again, unless install the official boot
the device stays on the Zenfone boot screen without doing anything else

I have tried the version supplied by Magisk, I don't know if you have tried another version
 
Last edited:

baster72

Senior Member
Feb 18, 2009
251
38
Why will we need the stock boot for the next update? We can't make menully update after root? I just want to make root not install xposed.

Sent from my ASUS_I01WD using Tapatalk
 

joesa

Senior Member
Dec 12, 2005
138
15
los mochis
thanks a lot, this a really easy way to get root, but i have a little issue, i had my phone with NO pin code or fingerprint before using this method, and now if i want to ad a pin, password or gesture it simply does not get saved, every time i do the procedure to set the pin it does like if i did nothing, anyone has this issue, or know how to fix it, is there a problem if i hard reset?
any help will be good
 

Rom1995

Member
Jul 5, 2012
15
3
In the latest build .110 ctsprofile is false while basicintegrity is true. Is it due to the root or the rom has not been signed by google?
 

MystikMan97130

Senior Member
Aug 5, 2012
152
46
Lyon 69009
www.facebook.com
Why will we need the stock boot for the next update? We can't make menully update after root? I just want to make root not install xposed.

Sent from my ASUS_I01WD using Tapatalk

just flash ZenFone6RootXposed-10.73 or ZenFone6RootXposed-11.110 and you willl have it

Good morning

I have tried several times root for Android 10
The Magisk part works smoothly, but the Xposed part never works, producing a bootloop

I have extracted the boot and applied magisk, loaded the Riru Core module, but when loading ElderDrivers, the phone stays in bootloop

Do you know what the reason may be?

it is impossible

Starting with .73 stock

at the moment I install Riru Yahfa, following the manual, it does not start again, unless install the official boot
the device stays on the Zenfone boot screen without doing anything else

I have tried the version supplied by Magisk, I don't know if you have tried another version




Don't flash Xposed using Magisk Download, flash it manualy :

EdXposed v0.4.6.0_beta

You will always get bootloop with v0.4.5.1_beta

_______________________________________

UPDATE for 11.110

flash boot.10.73.img for update safe
And do the same with 11.110 files.
Don't forget to add custom update channel in Magisk
And use v0.4.6.0_beta for xposed
 

joesa

Senior Member
Dec 12, 2005
138
15
los mochis
Hi everyone, I hope somebody can help me out to solve an issue I just got with my zenfone,
After using an advise from DaConcho for getting back screen lock after unlocking bootloader I got in another situation.

I followed the instructions from the post and everything was going fine, I boot thought adb with the provided patched boot for Q .110 and that far no issues , when I open magisk manager to download magisk from the alternative source magisk manager prompt to complete the installation downloading some necessary files, not the magisk version, just said some files, and I click yes, then it installed something and reboot, phone started fine, but when I wanted to start the process again I found out that I loose PC connectivity.
I have no connection at all, even if I manually boot in bootloader I can't connect to PC, so no adb commands,
Please can someone help
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone