Root XT910 Jelly Bean (EASY way)

Search This thread


Senior Member
Nov 9, 2010
I don't know, as I'm not a developer, but of course I wouldn't want to use a method that installs a malaware on my pc/phone, even if I'm able to clean it afterwards. And btw, this tutorial works flawlessly, it's very easy to use:

just a couple of notes which aren't expressed clearly in the tutorial (or they can be missed). you need to have:

- all (mobile and debugging) RAZR drivers installed on PC (install Motorola Device Manager and connect your phone to PC using MTP method & debugging turned on to install them) prior to using this method
- both PC and phone must be connected to the same wi-fi
- when pressing the ctrl+s to check the usb connection, i had a XT785 and no XT910: remove the 785 and add one 910 by using the icons on the right of the window
Last edited:


Senior Member
Sep 20, 2012
Google Pixel 4 XL
I don't know, as I'm not a developer, but of course I wouldn't want to use a method that installs a malaware on my pc/phone, even if I'm able to clean it afterwards. And btw, the following tutorial (click on the arrow in the quote to get the original post) works flawlessly, it's very easy to use:

Are you referring to this root process that your saying installs malware? Here is the link.

Sent from my XT910 using XDA Premium 4 mobile app


Senior Member
Nov 9, 2010
well, the exe inside the root process you posted is version 1.5.0, while the malaware one is in version 1.6.0 of the software.

I don't know if the malaware was inserted only in 1.6.0 or if it is present also in earlier versions (e.g. in 1.5.0), but I would ask if someone with more skills could check the 1.5.0 just to be sure.
Last edited:


Senior Member
Nov 9, 2010
Well the link from your original post and dtrail refers to a app called rootmanager.

And in my reference post to a threat refers to a app called rootmaster.

So are you sure these two different root processes are actually one in the same?

Sent from my XT910 using XDA Premium 4 mobile app

i edited my reply a few times while you quoted me :p please check it again :)

basically, it's the same exe with different version and name. we are sure that 1.6.0 has a malaware, but we have no confirmation 1.5.0 has it as well. but it is very possible this could be.
Last edited:
  • Like
Reactions: Crumplet


Senior Member
Nov 14, 2012
ok, I have tried this on 3 different XT910 with 4.0.4 and it doesnt work.

It does push exploit and install SU, but when I try to open SU, it says, the biaries are not installed and there is an error, contact developer.

and I am giving up on this


Senior Member
Feb 19, 2013
This method only works with JELLY BEAN 4.1.2

There's another method with just one click to root 4.0.4 Ice cream sandwich

Sent from my XT910 using xda premium


Senior Member
Sep 17, 2013

First, thanks to the author for this magnificent tool! I was able to root my umts RAZR within a couple of minutes!

However I too had the issue some of you have - the empty Host IP field. After some tries I resolved it, and I think I can give some hints that might also work for you.

In order to work properly, the VM needs to communicate with your phone both through USB and through the network (remote storage), and the phone must be able to connect to the VM (the VM cannot be behind a NAT, looking from the phone's perspective).

To communicate through the network, the VM needs to have access to the outside network (through the host's network connection). Now the field's name is somewhat misleading. It's not the host's (your computer's) IP address, but the VM's (guest's) IP address, and it is set up to obtain automatically through DHCP (you can't set it manually). To be able to do that, the VM must be configured in the VirtualBox settings (network) to have one network card, and that card must be set to mode bridged. Only this mode will work, because only this one allows other devices to connect to the VM (the VM is treated like another computer besides the one you're running it from). If you select the NAT option, the VM will obtain an IP, but will not function properly, because your phone will not be able to connect to it directly. (In NAT mode the VM can reach the outside network, but the network cannot reach the VM).

Next, the thing I have discovered, is that the VM cannot connect to a wireless network. Perhaps this is due to lack of proper drivers in the VM, that has been made as small as possible. So when you select the bridged network in the VirtualBox's settings and you choose a wireless card for that - it will not work! You have to use a wired network card, and connect your host machine with a cable to your router (using that particular card, if you have more than one). And the router must provide DHCP addressing to the clients, so that the VM can get one. Only then the VM will obtain the correct IP address, and you will be able to create the necessary remote storage on your phone, using that address.

To sum it up, in the VirtualBox machine settings set the following:
1. A network interface that is connected to the router by wire (not WiFi).
2. Set it's mode to bridged.
3. Enable DHCP server on your router.

After that it should work (at least the network part).


Senior Member
Nov 27, 2011
Port Orchard, WA
Im getting this error. Does anyone know how to fix this issue?



Recognized Contributor / XDA Welcome Team
Sep 21, 2011
South Dakota
Motorola Droid X
Amazon Fire
Notice: A New Q & A thread has been created in the Q&A, Help & Troubleshooting Sub-Forum.
Posts from members with less than 10 posts will automatically be posted there.
Please check it out, and see if you can help out someone with a question about this Topic


Senior Member
Aug 7, 2010
Hello, just got this phone to play with when my mother in law upgraded to the Turbo.

Does this method work for my phone?
It's running 4.1.2, build number 9.8.20-72_VZW-16-5

I don't know if an update was installed that might make this not work.



New member
Sep 30, 2014
It does work!

Worked fine for me, have to try several times util got smb server connection, save my day. :good:

Top Liked Posts

  • There are no posts matching your filters.
  • 61
    I apologize if this has already been mentioned elsewhere, I did skim through the main posts and perform a search for the general topic. This root method is basicly just djrbliss' over @ except it was massively simplified by another user named marty45714. So essentially this is technically now a method to root xt910 using windows! And its SUPER simple, especially for non Linux users like myself. Here is a direct quote of his post:


    I spent the weekend working on something really lightweight to get this done easily, and I've finally got it working and ready.
    Using Oracle VirtualBox with a Tiny Core Linux VM, I've managed to get this down to a 46 MB download.
    Everything is automatic... helps the user get connected to SMB, then helps with getting connected with USB debugging before running the exploit.
    I spent most of the entire weekend tweaking with Tiny Core Linux to get this ready. Please share. Where's the best place to start a new thread to get the word out about this?

    Here are the steps:

    1) Install Sun VirtualBox on your Windows PC. [EDIT: Link ---> <--- Provided my MichelBFR, aint he swell? ;)]

    2) Download the VirtualBox .ova file here: [EDIT: Link dead, see below]

    3) Import the .ova file into VirtualBox. (Click "File" then "Import Appliance".)

    4) Start the imported VM in VirtualBox (Click the big "Start" Button. It has a green arrow icon.)

    5) Follow the instructions on the Linux console."

    I also apologize for not coding links etc, I am not an advanced forum user. I just really wanted to share this with anyone who may not have come across this as of yet. If any of you need any further assistance I can try to help as I have successfully used this method and I know absolutely nothing about linux. Enjoy!

    EDIT: New link uploaded for step #2 <---- Thanks MichelBFR!!! [LINK UPDATED]
    ****** NEW TUTORIAL ******

    MichelBFR has gone the extra mile and simplified this process even further on page three, check it out! ======>

    For quick results, follow these steps: (moderators, please put this tutorial in the main post to help the others. Thanks)

    1 - Download the Virtual Box from Oracle - Choose the version that suits to your OS:
    2 - Download the .ova file to use with Virtual Box:!ZtRmDITb!Cg6dEwem_N4FKzJDUOvWQjtQoLoN2Ip7UcupGCyVL18

    It's mandatory to have access to a wireless connection between your phone and your PC. You can also use other methods, but I really don't know if they are effective.

    Download and install the Virtual Box, giving all the authorizations to install some virtual adapters. After doing it, import the "Root_Bionic_JB.ova" using CTRL + I as the screens below (mine is in portuguese-BR, but you'll understand):




    Then, press CTRL + S to enable the Virtual Box to detect your phone using the USB Port:


    Now, you're ready to begin. Press Start:



    Be sure that your phone is connected as Media Device (MTP) and the debugging mode is enabled. Then, follow the path as the screens below and insert the IP configuration which appears at the Virtual Box screen:




    Now, see if you phone will show the following screen:


    If positive, press enter at the Virtual Box screen and see if it will change, saying that your device is detected. Then, connect your phone to your PC using a USB cable and verify if the Virtual Box will detect it:



    If positive, you will need to press enter and follow the process at the screen, as above. Once your phone vibrates, press enter and wait till the next step. Press enter again to reboot.

    Congratulations. Now you have a Razr (Maxx) with Jelly Bean rooted.
    Yes I had the same issue happen to me, I forgot to mention it. Thanks for clarifying and posting screens. Glad it worked for you!

    No problem.

    But I forgot to mention another detail about the USB detection. You need to enable the Razr in the Virtual Box config before. Press CTRL + S and do as the screen:


    Then the Virtual Box will detect your phone and continue the root process.
    Well, I'm trying to apply the root on my Razr Maxx, but idk I did something wrong. The process seems to be frozen after the usb connection verification.

    Edit: I found the problem. The Virtual Box isn't recognizing the Razr at the USB port. Apparently, the system is conflicting with another request in the same device.

    Edit2: OMG!!! Rooted the phone in 30 seconds!


    After all the process:

    Hey thx for the screens
    But i really dont know about the smb process, i need put some ips in the phone or where?

    Enviado desde mi XT910 usando Tapatalk 2

    I'm taking some screens of my phone trying to show you how to connect with the Virtual Box.

    It's simple. You will fill the login fields with the info provided by the Virtual Box.