Root XT910 Jelly Bean (EASY way)

Search This thread

fabianomf

Member
Jul 24, 2012
41
12
48
goiania
All of it worked well on windows 7 host...

Hi buddy.

These steps worked fine on Windows 7 x64 host, but not on Windows 8 x64 host.

Would you have a solution for this?

On w8x64 host seems it will work fine, but it stops the process on "waiting for phone to be connected to USB..."

It seems (I don't remember for sure) that the name of usb device appears diferently that it appears on Windows 7 host.

Now it appears this way:

"scsi 6:0:0:0: CD-ROM Motorola XT910 0000 PQ: 0 ANSI: 2"

Any clue?
 

shubdya4u

Senior Member
Feb 3, 2013
114
11
Failed to attach the USB device Motorola XT910 [0216] to the virtual machine Linux Minimal.

USB device 'Motorola XT910' with UUID {715efc06-91e2-487c-8a68-463de46fe420} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

Guys can you help me !?

It's stuck at daemons started sucesfully ! :(
Installed all drivers , usb debug on !

Did you got any solutions??

Me also stuck at the same point
 

fabianomf

Member
Jul 24, 2012
41
12
48
goiania
Nevermind... I've forgot to check USB debugging... Rooted again with avatar 3.0.3 rocking!

Sent from my XT910 using xda app-developers app
 

misterfamilyguy

Senior Member
Aug 4, 2010
55
10
works

Hit thanks buttons.
Confirmed working in windows 8, MUST be using usb 2.0. I had to unplug my keyboard for one, but once i did it auto found and and new message displayed.
 

M4rt1n94

Senior Member
May 5, 2012
187
436
Stuttgart
Link down :(

Hey guys, i think the Link of step 2 is down (mediafire-link)
Can someone pls reupload this file ?
Thanks in advance!

-----------------------------------------------------------------------------------
On page 16 is a working link, soory, but can someone pls put this link on the mainpost?
For not having asking people for his link in future ;)
 
Last edited:

fabianomf

Member
Jul 24, 2012
41
12
48
goiania
MisterFamilyGuy

Buddy, where is this thanks button on xda app?

Sent from my XT910 using xda app-developers app

---------- Post added at 11:58 PM ---------- Previous post was at 11:48 PM ----------

I saw it. We just have to click on the thread to appear a menu with the button... Oh boy... :eek:

Sent from my XT910 using xda app-developers app
 

danygarss

Senior Member
Mar 4, 2011
53
16
Madrid
Here is a mirror for the OVA file. I just rooted my CDMA Razr with it.

http://d-h.st/Z4B

Hey guys, i think the Link of step 2 is down (mediafire-link)
Can someone pls reupload this file ?
Thanks in advance!

-----------------------------------------------------------------------------------
On page 16 is a working link, soory, but can someone pls put this link on the mainpost?
For not having asking people for his link in future ;)

there is it, havent tried it yet. Please, post it in OP, i've been searching for long through this post to find a working link lol thanks!
 
  • Like
Reactions: drutort

drutort

Senior Member
Apr 28, 2007
265
3
AZ
I had the same problem you got to change the setting in internet protocol 4 (properties) and change it to automatic.

Step by step right click (right coner) on wireless connection / open network and sharin connection/ click vitrual box host-only connections and a window should open then hit properties and then you should see protocol 4 click it then properties and make the option obtain automatically and run the program again it should work


IF THIS HELPED HIT THE THanks button
<<<<<<< :D

---------- Post added at 01:05 AM ---------- Previous post was at 01:02 AM ----------



here you goo
Step by step:
right click (right coner) on wireless connection /
open network and sharin connection/
click vitrual box host-only connections
and a window should open then hit properties and then you should see protocol 4 click it then properties and make the option obtain automatically and run the program again it should work


IF THIS HELPED HIT THE THanks button
<<<<<<< :D


Yes I noticed that the virtual b ox host-only network, had an ip there, but if you have different ip or network mask, so it would never get a proper IP, as quoted above, people have to put on auto or configure an IP that is setup on there LAN, most routers would be with 192.168.1.x this one had 192.168.56.1 or something like that. which would never work, some might have 192.168.0.x or 192.168.100.1.x? Just check your LAN setup in the router what you have :)

Now my question is, the IP that we are to connect is we are connecting to the virtual box IP? not the computer IP that the virtual box is on?

:confused:
 

goldfinsh

Member
Apr 26, 2010
39
3
Hi all,

I hope you can help. I did all the steps and connected through wifi. Install VB, enbale USB debugging, MTP on cellphone. I imported the ova file then connected the xt910 and made sure it is added in the filter alone. then I start the process untill I am asked to enter the IP, domain name etc...The problem is my xt910 always fails at the "add storage" connect step. I tried the tether solution and still have the same error.
 

Mickyvai

Senior Member
Dec 26, 2010
147
58
Hi, I followed the exact steps and everything went good, the phone rebooted and the Superuser app was installed but...

...the phone is NOT rooted! when I cick on the superuser app it says it must update the su binary but fails at doing that. I checked with rootchecker but it says the phone is not rooted.

Any clues?


EDIT: resolved: in virtualbox is mandatory to UNCHECK "RAZR XT875" from the USB peripherals.
 
Last edited:

kosh2thamax

Member
Nov 15, 2010
45
24
Sorry but which right corner?
I mean, of which window?

When I run the VM with the "Linux minimal" machine I see only "Network Adapter" in the lower right corner and I see no sharing connection or other (I am on a Mac notebook).

????

Ah mine is windows....and its usually at the bottom corner of the start menu...for at least windows...Oh this based on a wireless connection vs Lan...not sure if that actually make a difference ...i don't think that it should...but just wanted to clarify ...sorry i couldn't help beyond this point good luck :)
 
Hello Guys,

I have been trying since 2 days to root my phone but no luck.
I managed to add remote storage in my device but the process gets struck up at "Daemon tools starting up"

in USB devices when i try to select the phone i get the below error.

""Failed to attach the USB device Motorola XT910 [0216] to the virtual machine Linux Minimal.

USB device 'Motorola XT910' with UUID {4ac4ff4c-e316-4e6d-bfdb-040eb4ced331} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}


I even installed the new drivers too. i a using Win XP SP3
Regards,
Shirdesh

---------- Post added at 12:13 AM ---------- Previous post was at 12:08 AM ----------

 

dtrail1

Senior Member
Oct 7, 2011
4,806
7,866
Frankfurt
Hello Guys,

I have been trying since 2 days to root my phone but no luck.
I managed to add remote storage in my device but the process gets struck up at "Daemon tools starting up"

in USB devices when i try to select the phone i get the below error.

""Failed to attach the USB device Motorola XT910 [0216] to the virtual machine Linux Minimal.

USB device 'Motorola XT910' with UUID {4ac4ff4c-e316-4e6d-bfdb-040eb4ced331} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}


I even installed the new drivers too. i a using Win XP SP3
Regards,
Shirdesh

---------- Post added at 12:13 AM ---------- Previous post was at 12:08 AM ----------


Make sure you remove ALL USB devices from the VM driver list first (before booting the vm) , then install them and plug in the phone. Driver will work then.

But there is a MUCH easier way to root: user the Chinese" Root Manager", it's only one click. There is a thread with it somewhere in here...

Gesendet von meinem XT910 mit Tapatalk 4
 

ksaplostra

Senior Member
May 10, 2010
192
7
why am i getting stuck at daemon tool started successfully?
everything goes as dedcribed but as soon as daemon tool starts,it stays there...
Btw i have DT installed on my PC too,should i remove it?
ok so i removed DT from my pc,rebooted but still...im stuk atr daemon tools started...
 
Last edited:

Ficus*

Senior Member
Nov 9, 2010
81
10
  • Like
Reactions: Crumplet

Crumplet

Senior Member
Sep 20, 2012
582
129
Google Pixel 4 XL
So from what read it adds crap the pc which can be cleaned by using cleaner and clean the registry, and check and uninstall any out the ordinary programs and check your drive for any malicious files and run spybot search.

Now what about the phone? If someone used it what should they do? Will a factory reset work? Or do I have to do a full rsd wipe in order to make sure my phone is OK and secure?

Seems people in the other tread was more concerned about what it did to their phones.
Sent from my XT910 using XDA Premium 4 mobile app
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 61
    I apologize if this has already been mentioned elsewhere, I did skim through the main posts and perform a search for the general topic. This root method is basicly just djrbliss' over @ droidrzr.com except it was massively simplified by another user named marty45714. So essentially this is technically now a method to root xt910 using windows! And its SUPER simple, especially for non Linux users like myself. Here is a direct quote of his post:

    "Moderator,

    I spent the weekend working on something really lightweight to get this done easily, and I've finally got it working and ready.
    Using Oracle VirtualBox with a Tiny Core Linux VM, I've managed to get this down to a 46 MB download.
    Everything is automatic... helps the user get connected to SMB, then helps with getting connected with USB debugging before running the exploit.
    I spent most of the entire weekend tweaking with Tiny Core Linux to get this ready. Please share. Where's the best place to start a new thread to get the word out about this?


    Here are the steps:

    1) Install Sun VirtualBox on your Windows PC. [EDIT: Link ---> https://www.virtualbox.org/wiki/Downloads <--- Provided my MichelBFR, aint he swell? ;)]

    2) Download the VirtualBox .ova file here:
    dl.dropboxusercontent.com/s/bb53ayj5c3nd5ie/Root_Bionic_JB.ova?token_hash=AAGSOYfPuDXTur_e9qlYl2JRERovPyfMwe-2xNzHXg4Lxg&dl=1 [EDIT: Link dead, see below]

    3) Import the .ova file into VirtualBox. (Click "File" then "Import Appliance".)

    4) Start the imported VM in VirtualBox (Click the big "Start" Button. It has a green arrow icon.)

    5) Follow the instructions on the Linux console."

    I also apologize for not coding links etc, I am not an advanced forum user. I just really wanted to share this with anyone who may not have come across this as of yet. If any of you need any further assistance I can try to help as I have successfully used this method and I know absolutely nothing about linux. Enjoy!

    EDIT: New link uploaded for step #2 http://www.mediafire.com/download.php?84f3hkx11bpl3fc <---- Thanks MichelBFR!!! [LINK UPDATED]
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    ****** NEW TUTORIAL ******

    MichelBFR has gone the extra mile and simplified this process even further on page three, check it out! ======> http://forum.xda-developers.com/showpost.php?p=40901777&postcount=30
    60
    Tutorial

    For quick results, follow these steps: (moderators, please put this tutorial in the main post to help the others. Thanks)

    1 - Download the Virtual Box from Oracle - Choose the version that suits to your OS: https://www.virtualbox.org/wiki/Downloads
    2 - Download the .ova file to use with Virtual Box: https://mega.co.nz/#!ZtRmDITb!Cg6dEwem_N4FKzJDUOvWQjtQoLoN2Ip7UcupGCyVL18

    It's mandatory to have access to a wireless connection between your phone and your PC. You can also use other methods, but I really don't know if they are effective.

    Download and install the Virtual Box, giving all the authorizations to install some virtual adapters. After doing it, import the "Root_Bionic_JB.ova" using CTRL + I as the screens below (mine is in portuguese-BR, but you'll understand):

    root1.png


    root2.PNG


    root3.png


    Then, press CTRL + S to enable the Virtual Box to detect your phone using the USB Port:

    root5.png


    Now, you're ready to begin. Press Start:

    root4.png


    rootrazrmaxx.png


    Be sure that your phone is connected as Media Device (MTP) and the debugging mode is enabled. Then, follow the path as the screens below and insert the IP configuration which appears at the Virtual Box screen:

    59591126.png


    17161006.png


    34432921.png


    Now, see if you phone will show the following screen:

    screenshot2013043009165.png


    If positive, press enter at the Virtual Box screen and see if it will change, saying that your device is detected. Then, connect your phone to your PC using a USB cable and verify if the Virtual Box will detect it:

    rootrazrmaxx5.png


    rootrazrmaxx2.png


    If positive, you will need to press enter and follow the process at the screen, as above. Once your phone vibrates, press enter and wait till the next step. Press enter again to reboot.

    Congratulations. Now you have a Razr (Maxx) with Jelly Bean rooted.
    4
    Yes I had the same issue happen to me, I forgot to mention it. Thanks for clarifying and posting screens. Glad it worked for you!

    No problem.

    But I forgot to mention another detail about the USB detection. You need to enable the Razr in the Virtual Box config before. Press CTRL + S and do as the screen:

    root5.png


    Then the Virtual Box will detect your phone and continue the root process.
    3
    Well, I'm trying to apply the root on my Razr Maxx, but idk I did something wrong. The process seems to be frozen after the usb connection verification.

    Edit: I found the problem. The Virtual Box isn't recognizing the Razr at the USB port. Apparently, the system is conflicting with another request in the same device.

    Edit2: OMG!!! Rooted the phone in 30 seconds!

    rootrazrmaxx.png


    After all the process:

    rootrazrmaxx2.png
    3
    Hey thx for the screens
    But i really dont know about the smb process, i need put some ips in the phone or where?

    Enviado desde mi XT910 usando Tapatalk 2

    I'm taking some screens of my phone trying to show you how to connect with the Virtual Box.

    It's simple. You will fill the login fields with the info provided by the Virtual Box.