• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Rooted G7 Play: Forgot pattern lock, can't factory reset either

Search This thread
I searched and didn't see anything that relates to my specific problem.

I have a 1952-4 that I rooted per instructions on here (Magisk). I dropped it and broke the screen about 9 months ago and just fixed it today...and I can't remember my pattern. I'm up to 50 tries, so now I have to wait 120 seconds before it lets me try the next one.

Since the root process requires you to reboot recovery for root, doing that just sends it to the normal lock screen. When I hit Vol Down/Power, my options on the bootloader screen are:
-Start
-Restart Bootloader
-Recovery Mode (restarts it, sends to lockscreen)
-Power Off
-Factory Mode (restarts, sends to lockscreen)
-Barcodes
-BP Tools (restarts, back to lockscreen)
-QCOM (restarts, back to lockscreen)
-Bootloader Logs
-Switch Tools Mode (enables/disables "Tool Mode Config" option on the bootloader screen)

My computer beeps the "something USB has been plugged in" chime when I connect it, but it doesn't pull up in File Explorer (unless it's off, but just shows that a USB drive has been connected but won't pull up anything when I click on it), nor can I connect through ADB. It's not a cable/USB port issue either as ADB finds my Note 8 when I plug it in and check via "adb devices."

Can't wipe it via Find my Phone either because it's been 270 days since my account pinged the phone, so it just shows up as "Android" device.

Any suggestions on how to either get my computer/ADB to recognize it (with root) so I can just delete the lock database, or how I can factory reset it? Am I forgetting a reboot option?

Thanks in advance.
 

sd_shadow

Recognized Contributor
Sep 21, 2011
18,199
2
8,746
South Dakota
goo.gl
Motorola Droid X
Moto X4
I searched and didn't see anything that relates to my specific problem.

I have a 1952-4 that I rooted per instructions on here (Magisk). I dropped it and broke the screen about 9 months ago and just fixed it today...and I can't remember my pattern. I'm up to 50 tries, so now I have to wait 120 seconds before it lets me try the next one.

Since the root process requires you to reboot recovery for root, doing that just sends it to the normal lock screen. When I hit Vol Down/Power, my options on the bootloader screen are:
-Start
-Restart Bootloader
-Recovery Mode (restarts it, sends to lockscreen)
-Power Off
-Factory Mode (restarts, sends to lockscreen)
-Barcodes
-BP Tools (restarts, back to lockscreen)
-QCOM (restarts, back to lockscreen)
-Bootloader Logs
-Switch Tools Mode (enables/disables "Tool Mode Config" option on the bootloader screen)

My computer beeps the "something USB has been plugged in" chime when I connect it, but it doesn't pull up in File Explorer (unless it's off, but just shows that a USB drive has been connected but won't pull up anything when I click on it), nor can I connect through ADB. It's not a cable/USB port issue either as ADB finds my Note 8 when I plug it in and check via "adb devices."

Can't wipe it via Find my Phone either because it's been 270 days since my account pinged the phone, so it just shows up as "Android" device.

Any suggestions on how to either get my computer/ADB to recognize it (with root) so I can just delete the lock database, or how I can factory reset it? Am I forgetting a reboot option?

Thanks in advance.
In Bootloader
factory reset with
Code:
fastboot -w
fastboot reboot
 
Yeah. It should remember this phone, since I used this computer to root it when I first got it a year and a half ago.

I used a different cable and got it to pick up the phone (as an unknown device) in Windows but NOT ADB, and the phone to realize it was connected (see last line on phone screen) but they're not talking.

If I boot it all the way up, either regular or recovery (root), it doesn't show at all on my computer.

Like I said, I'd be fine with wiping it, but can't even get to that option.
 

Attachments

  • 20210330_202624_compress71.jpg
    20210330_202624_compress71.jpg
    226.5 KB · Views: 8
I got a new cable. My USB ports are not labeled, and my Moto drivers reinstalled.

After rebooting to the recovery screen, I plugged it in and apparently I have fastboot. I checked the bootloader logs and it says:

AP Fastboot Flash Mode (Secure)
Fastboot Reason: Volume down key pressed
USB connected

Windows doesn't pick up anything connected by USB. I can't restart to get root because then adb doesn't pick up the phone either because of the screenlock preventing me from hitting ok to trust my computer.

I'm asking the following because I can't find answers: Can you delete the screen lock file with the only bridge being fastboot, not adb. How can I do a factory reset if rebooting to recovery is our normal way of turnin gon the device with root access? Or would reflashing something work?

command line commands are a perishable skill and it's been a couple years since I did this stuff.

Thanks in advance.
 
To recap, I either need to be able to get into the directory to delete the pattern lock, or factory reset the phone.

I've tried the pattern lock 79 times, which means I have to wait 300+ seconds between tries. I think an error is causing that though.

Fastboot is my only option at this point as far as using commands goes. Rebooting recovery just reboots it with root permissions, but neither adb or Windows 10 picks it up. Using a brand new factory cord and tried every USB port on my computer, even the USB-C to USB-C. But I can't find anywhere that shows how to get into the directory using fastboot.

In Device Manager, I've been getting an error with Android ADB Interface (The device cannot start; Code 10). I uninstalled, reinstalled various drivers, killed adb.exe, etc., Still happening.

HOWEVER, Motorola ADB Interface is working just fine and goes away when I unplug my phone, returns when I plug it in. Only when it's in recovery/fastboot mode though.

I got into Safe Mode, but computer won't pick it up.

I can't get into Field Test Mode. I did reboot it into something else. I don't know what, but the screen was off and the home button was illuminated. EDL mode? I don't know. Neither my computer or adb read that anything was attached, and i can't figure out how I did it.

I also tried sideloading some pattern lock removers, but apparently you can't do that in fastboot.

Thoughts?
 
Just to close this out with a solution: I had forgotten that in order to get to the recovery menu, you have to hold the buttons when you reboot recovery. Didn't realize that until I was rooting my Moto e6.

Factory reset complete. No more pattern lock. Though since I've now tried rooting it 4 times with 4 different images and have not succeeded even though I had root before all this, I wish I could have realized the above and possibly gotten in and deleted the gesture.

Lesson learned.
 

onefstfoknv6

Member
Mar 16, 2009
10
0
Volume up button and power button
Just found this. Timing is everything apparently.

  1. Press and hold the Volume Down and Power buttons simultaneously until the Android Recovery screen appears.
  2. Press the Volume Down button to navigate to Recovery.
  3. With Recovery displayed, press the Power button.
  4. When you see the 'Droid' with 'No Command,' hold Power and tap Volume Up just once and immediately release both buttons.
  5. Scroll to wipe data/factory reset by pressing the Volume Down button
  6. Press the Power button.
  7. Scroll to YES by pressing the Volume Down button.
  8. Press the Power button.
  9. The 'phone will wipe all contents.
  10. Press the Power button.
  11. The 'phone will now reboot to the initial setup screen.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Install the moto drivers. If that doesn't work then make sure your using a usb2 port and not a usb3 port as its a known issue with moto phones.