How To Guide Rooting Zenfone 9 with Magisk

Search This thread

Thecurse21

Member
May 28, 2013
45
10
Varna
I've read somebody said if we are rooted then we can't use OTA packages. Is that true?

Also, my system update still tells me I'm up to date on Android 12. Is it because I'm rooted?

Thanks
Yes once you unlock the bootloader the phone no longer will receive updates automatically you'll have to download them from the Asus support page and put them in the root of the storage and a update message will show up.
 
  • Like
Reactions: c19932
What's the process to update after rooting? I know OTA's are no longer an option.
Download the Update from Asus, put it in root/home dir. You will get an update available message (maybe you have to reboot). After update is finished do not reboot! Launch magisk and Install it to inactive slot (after ota). Then you can hit reboot in magisk.
 
  • Like
Reactions: c19932

lostsupper

New member
Jun 19, 2016
1
0
Can anyone explain how to install the Asus USB drivers in the original post?

EDIT: Figured it out. Had to try a different usb port.
 
Last edited:

FriedMusubi

New member
Jan 21, 2023
1
0
Does anyone have drivers that will work for rooting? I tried using the drivers provided by xanker, but those are not working for me for whatever reason.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Guide has been reworked to be more clear and based on comments.

    [Part One]
    • Backup Data
    • Update phone to latest version

    [Part Two]



    • Extract the Payload Dumper GUI zip file, as well as the UL-ASUS Firmware zip file​

    • Run the Payload Dumper GUI program in the unzipped folder. A file explorer window will pop up; open the unzipped UL-ASUS Firmware folder and select the payload.bin file. Another file explorer window will pop up; select the UL-ASUS Firmware folder if not already selected, then click select folder in the bottom right.​

    • Click Dump on the Payload Dumper GUI Application. The files will be output to the UL-ASUS Firmware folder.​

    [Part Three]
    • Download Magisk and install onto phone via APK. https://magiskmanager.com/downloading-magisk-manager/
    • Plug phone into computer and allow file transfer.
    • Within the UL-ASUS Firmware folder there will be a boot.img file. Move this file onto the phone.
    • Open the Magisk application and follow image below, select the boot.img to patch

    Magisk-Patch-Boot-Image.jpg



    • A file will be output with magisk. Move this file back onto the PC, and rename to boot.img

    [Part Four]

    [Part Five]
    • Download Minimal ADB and extract files https://androidfilehost.com/?fid=962187416754459552
    • Move Boot.img file into Minimal ADB extracted folder.
    • Put Zenfone into recovery mode and connect to PC. Recovery mode can be achieved by turning off the phone and then powering on whilst holding the volume up button. Release when the ASUS logo pops on screen.
    • Run cmd-here.exe in the Minimal ADB folder; a command window will open
    • As a test run the command listed below and it should output a device fastboot devices
    • If that test succeeded run the final command to flash, fastboot flash boot boot.img
    3
    @BreadNoose Thanks for the write-up!!!

    I just got the phone 2 days ago and have been trying to follow your steps but without success. I keep having issues with fastboot (I've probably spent 6+ hours on it; I also have a 9-5 job haha). The following are things I've tried:

    *Btw, OEM unlock is not showing in Developers options. Download unlock app and I think my OEM is unlocked but in recovery it says "Yes" next to Bootloader thing.

    -ADB works fine.
    -Download Platform from Google.
    -Tried ADB minimal from xda also.
    -I tried three laptops, two windows 11 and the other windows 10. None of them recognize fastboot.
    - When I go to device manager I see Asus phone listed with that yellow triangle sign and when I try to update the driver it either says drivers up to date or if I manually try to update it says some other error.
    - Try different cables.
    - I even disabled the driver signature in the restart menu but no success.
    -I tried using Asus 8 drivers thinking that would help but nothing.

    I wonder if it's just the Asus 9 driver that's the issue? What am I missing??? 😭😭😭


    Any idea?

    Thanks for any help you can provide.
    Had the same Problem, you have to use this driver:
    2
    I'm pretty sure you'll need to enable the deny list (Zygisk). Could you give that a try and report back?
    Thanks. I ended up adding play service to magiskhide and it worked fine
    2
    Well, on the first reboot, after the app starts with unlocking process, the wiping console is displayed for about 1 second and phone is restarted after.

    There isn't any OEM unlocking option in developer options.

    EDIT:
    I just downloaded the latest firmware's zip into the root folder on phone's internal memory, executed firmware update, and retried
    unlocking now works without any problems
    2
    Thanks for this guide - I can't wait to get my ZenPhone, & root it on day 1 ;)

    A couple quick questions about updating after root has been applied:

    1) The Asus download site says about the Unlock Device App: "The software updates will not be available to the Changed Product, and the digital content in the Changed Product may no longer be used." This pretty clearly sounds like they're saying that once you've unlocked it, you can no longer apply software updates? Surely that can't be the case, right? Can someone pls clarify what this means?

    2) Assuming that the device can still be updated, how does that work exactly? I just let the device install over-the-air updates as usual, at which point it will be un-rooted, & I just repeat the steps above to re-root (i.e. download the corresponding new img file from Asus, extract boot.img, patch with Magisk, & flash it with fastboot again)?

    3) One response from @williamcll above said "you need the a/b retain module", but Google doesn't turn up any results. What does "a/b retain module" refer to?

    Thanks all in advance :)
    1)Haven't test it out yet but if it still have OTA it will unroot your iPhone on update.
    2)Downalod the ROM from Asus' website and install locally
    3)Oh wait nevermind I forgot that there's no TWRP yet for ZF9. After you install the update DO NOT REBOOT. Go into magisk, click install and select install to inactive slot.
    I was thinking of the TWRP retention module that make sure TWRP doesn't get deleted after an update.