RootMy.TV: v2.0 Released!

Search This thread

Syntax_Error_

Member
Feb 21, 2020
30
5
On LG EG9109 with softwareversion 04.06.40 this happens:
No luck with rooting.
 

Attachments

  • IMG_20220504_152144.jpg
    IMG_20220504_152144.jpg
    667.5 KB · Views: 127
Dec 6, 2010
19
2
Android Wear
The only real reason I want to root my LG OLED65C1PUB TV is to be able to turn off the Fireworks/Clock&Weather Screensaver. I have a Plex App which has a wonderful movie art screensaver but the LG screensaver keeps interrupting it so I want to be able to turn it off.

Can anyone confirm that the LG screensaver can be turned off if the TV is rooted?
 

TheDoctorZ

Member
Dec 3, 2011
6
1
Process seems to work on my 65 CX, but I don’t get the second reboot prompt to install homebrew app. FW 4.35.20
 

Attachments

  • 8F22F171-C1CC-448C-A16D-B7844F48D71E.jpeg
    8F22F171-C1CC-448C-A16D-B7844F48D71E.jpeg
    1,008.1 KB · Views: 59

LLP42

Member
Mar 15, 2021
21
8
With the just released firmware update for the 2021 OLED TV models, the last model without a fix has also received an update that fixes the corresponding security vulnerability.

Thus, the method used by RootMy.TV to gain root privileges should no longer work on any of LG's OLED TVs (2019-2022) if they have the most recent firmware version. Note that installing apps via RootMy.TV may still work.
 
  • Like
Reactions: Mother_Teresa

LLP42

Member
Mar 15, 2021
21
8
I have a C1 that's on firmware 03.35.16. I want to know if anyone has the same model on a more recent firmware and can still root.
As described before, the underlying security issue of RootMy.TV was fixed for the C1 with firmware v03.30.06, the latest publicly released version is v03.30.20. So no, you can no longer use RootMy.TV to gain root privileges with those versions until someone finds a new vulnerability.

It also sounds like you're on an older engineering firmware version.
I.e. you cannot install a new firmware version anyway until the next official version number exceeds your current version number. At least not without special tools that allow you to "downgrade" your firmware.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    rmtv.png

    RootMyTV is a user-friendly exploit for rooting/jailbreaking LG webOS smart TVs.

    Website: RootMy.TV
    GitHub: https://github.com/RootMyTV/RootMyTV.github.io

    For further details, and a full writeup, please check out the GitHub repo.

    TL;DR; If you want root on any* current WebOS LG TV, do not install updates for the time being, and wait patiently. If you're a developer or researcher, read the latest update below.

    *The exploit requires "ThinQ" support, which seems to only be available on TVs running WebOS 4.0+. I will update this when we know more about which versions support it.


    RootMy.TV is an 0-click (kinda) web-to-root exploit for WebOS.

    Website (placeholder): RootMy.TV
    GitHub (placeholder): github.com/DavidBuchanan314/RootMyTV

    After this bug in Download Manager was published (which, on its own, allows rooting the WebOS emulator), I was motivated to find new bugs which can be combined with it, to get root on actual TVs.

    Given the relatively severe impact of this exploit chain, its publication will have to wait at least until LG makes official patches available for the Download Manager bug. After that, I will be publishing the exploit, along with a full writeup.

    During my research, I received invaluable advice and information from members of the openlgtv Discord server - I definitely couldn't have done this without them. Please join us, if you would like to assist with testing the exploit etc. in the hopefully-near future: https://discord.gg/9sqAgHVRhP

    Update 2021/02/15:
    LG claims to have fixed the Download Manager bug, but they haven't really. To motivate LG to actually patch the bug, I will be disclosing my exploit chain to them under a 30-day public disclosure deadline - after which, I will be publishing the exploit here. Assuming I send my disclosure to LG email tonight, that sets the RootMyTV "release date" at 2021/03/19.

    Update 2021/03/18:
    The release date is now 2021/03/21 - I have a few things I need to finish up...

    Update 2021/03/23:
    Sorry for the delays...
    I am attaching a bare-bones vulnerability report and PoC for the exploit, which is enough to get you root. This "pre-release" is intended for developers and researchers. If you're not a developer or researcher, please be wait for the "full" release, which will hopefully arrive in the coming weeks. The final release will be more user friendly, and include a "Homebrew Channel". If you would like to contribute to development of the Homebrew ecosystem, please visit us on Discord.

    Some notes/disclaimers about the exploit: (READ FIRST!!!)

    - This will void your warranty, don't blame me if anything goes wrong etc. etc.

    - Amazon's "google play store" link, described in the writeup, is currently broken. As a workaround, you can search for "google search" on Amazon, Click the top result, Click "developer info", then click the link to Google's privacy policy. From there, you can click the menu icon in the top-right and continue with the rest of the instructions.

    - Something I forgot to mention in the report - you must update the value of the "HOST_PREFIX" variable in index.html, to point to your local webserver.

    - If you were previously using Developer Mode, then overwriting `start-devmode.sh` will have broken devmode features like `ares-install`, and the jailed sshd. You can fix this by putting the old `start-devmode.sh` back again, with some edits.

    - For some TVs that don't have the ThinQ login page, you can access an equivalent page via "Account Management" in the settings. This doesn't work on my TV (the amazon link opens in the web browser), but apparently it works on some models/versions.

    - The current version of the exploit will give you a root telnet server, accessible on the default port (23), without authentication.
    7
    If someone can use this to make a custom firmware that adds back in the 120hz black frame insertion to the LG C9 (and maybe even older models) that would be amazing. LG removed the feature last minute despite it showing up in C9 reviews samples, but it did make it into the CX as OLED motion low and mid. I remember in some old interviews hearing that the feature is all algorithm based and could be added into older OLED TVs but they never did.

    You're in luck. Just this week a user at AVSForum reported that you could enable Motion Pro on the C9/E9 with a simple command on the tv. The only disadvantage was that you need to execute this command with root privileges. Now that is where this thread comes in.
    I've managed to get root access to my C9 and have executed the command and it works! Motion Pro low, medium and high is available and works at 120Hz.

    This is the command that you need to execute:

    Code:
    luna-send -n 1 -f "luna://com.webos.service.config/setConfigs" '{ "configs": { "tv.model.motionProMode": "OLED Motion Pro" } }'
    3
    If you are having trouble connecting to certain websites or using Plex or Emby on your TV, it may be because the services are using digital certificates signed by the new LetsEncrypt Certificate Authority cert, and LG have not updated the TV’s certificate trust store to include this new cert and remove the old expired one.

    If your TV is rooted, then you can use this shell script to fix thIs: https://github.com/tf318/lg
    2
    Using com.webos.app.iot-thirdparty-login in webOS 4.9.1-53409 for this exploit doesn't seem to work anymore, because the app now seems to open all links in the web browser app instead of its own instance. No matter which link I tested, they all open the external web browser.

    Update:
    The underlying issue still exists though and I managed to use a slightly different method but the same privilege escalation method to get in anyways.

    Perhaps you might share the approach you found so others don't struggle helplessly?

    I had the same problem. After getting to the Amazon log in page, all links mentioned above opened in the web browser instead of within the ThinQ app. Eventually I tried entering non existent credentials into the Amazon login form, then after being prompted to enter a captcha, I again entered invalid credentials a second time. When shown the login form a third time I clicked the bottom link (can't remember what it was - maybe privacy or forgot password or similar) and this time the link opened within the ThinkQ app rather than an external browser, and I could then follow the rest of the exploit successfully.
    2
    If there really is a "0-click" exploit as promised, these steps become unnecessary.

    Until then, anyone who knows the ropes should have no problem finding the way I mentioned. At least when you take a closer look at the source code of com.webos.app.iot-thirdparty-login. And if you have problems with this, you should probably leave this method alone anyway.

    That's why I won't post any more details about it - at least for now.
    What gibberish.

    I provided a way forward to others in my response. I followed it and it worked, so I shared it.

    You simply turned up with no useful information, just to say "hey your instructions no longer work. I found a way round it. Not going to share". It would seem you're posting on entirely the wrong forum.