How To Guide Run an GSI on your Mi Pad 5

Search This thread

BiG_FooT

Senior Member
Nov 17, 2012
513
214
Rotterdam area

Paddy1401

Member
Dec 7, 2020
17
5
Could be interesting as A12 base stock ROM and then add GSI A12 on top of it:

New MIUI Public Beta Recovery update available!
Device: Xiaomi Pad 5 China (nabu)
Version: V13.0.0.1.45.DEV | 12.0
Release Date: 2022-07-08
Filesize: 4.0 GB
MD5:
Code:
Unknown
Download: Here

Link to the original post (and credits)
Post in thread '[MIUI Updates Tracker] Xiaomi Pad 5 (nabu)' https://forum.xda-developers.com/t/miui-updates-tracker-xiaomi-pad-5-nabu.4328591/post-87125007
How can I install this dev rom ? I have unlocked Bootloader already but afraid of hardbrick
 

kanon75

New member
Aug 28, 2021
4
0
Hi all, i install latest China Fastboot rom, i download V13.0.0.1.45.DEV.zip and i put into Mi Pad 5, update, 3 dots, choose update package, select zip file, getting info......and"Cant verify update, rom package dont match"... what my mistake?
Thank you

edit: bootloader is unlock ;)
 

hackslash

Recognized Contributor
Feb 20, 2015
1,284
1,559
24
Islamabad
Redmi K20 Pro
OnePlus 10 Pro
Hi all, i install latest China Fastboot rom, i download V13.0.0.1.45.DEV.zip and i put into Mi Pad 5, update, 3 dots, choose update package, select zip file, getting info......and"Cant verify update, rom package dont match"... what my mistake?
Thank you

edit: bootloader is unlock ;)
Install Magisk on the current ROM and install the Magisk module attached.
This will bypass the OTA verification check allowing you to install the update via System Updater.
 

Attachments

  • 渡MIUI13模块1.2.zip
    2.1 KB · Views: 60

krvrian

Member
Mar 20, 2019
11
0
Question, if I want to install A12 GSI from global miui 13 (A11), do i have to install the A11 GSI first or can i go straight to A12?
 

Askalik

New member
Feb 26, 2022
3
1
I am trying to install latest pe plus with magisk and follow these steps: download patched boot.img, flash it through command fastboot flash boot boot.img, reboot to system, seeing magisk installed, fastboot again, install vbmeta, reboot, then these 3 commands:
fastboot delete-logical-partition product
fastboot delete-logical-partition product_a
fastboot delete-logical-partition product_b
after that install pe plus through fastboot flash system system.img and has bootloop
What i did wrong? It is not my first attempt, without magisk gsi was installed ok, but with that it is always bootloop
 
  • Like
Reactions: szewc1

anr120991

Member
Jan 19, 2012
9
0
How do I get rid of this persistence dock icon? I can't seem to find the menu for it.
 

Attachments

  • Screenshot_20220717-063829_Lawnchair.png
    Screenshot_20220717-063829_Lawnchair.png
    2.6 MB · Views: 150

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    my full ungoogled LeOS-19.1 (Android 12L) works perfect on Nabu.
    see https://leos.gsi.de or join https://t.me/LeOS_Support
  • 8
    To run an GSI on your Mi pad 5 :
    Unlock bootloader

    Download an arm64 AB gsi: https://forum.xda-developers.com/f/treble-enabled-device-development-a-ab-roms.7260/
    I used system-roar-arm64-ab-vndklite-vanilla.img by Phh
    Download vbmeta.img from google

    Reboot to fastboot
    Open an cmd:

    fastboot flash vbmeta vbmeta.img

    fastboot reboot fastboot

    fastboot flash system system-roar-arm64-ab-vndklite-vanilla.img

    fastboot reboot recovery

    Make an factory reset

    Reboot
    6
    I made a LSPosed module to fix the taskbar in PixelExperience. You can also hide the taskbar pill (optional).

    ...

    I have made the module into a Magisk module (implemented using Resource Overlay). LSPosed is not required anymore. Enjoy : )

    You can use the module to fix the taskbar height in PixelExperience. You can also use it to hide the taskbar pill in PE and other ROMs.

    Download: https://github.com/Coxxs/hide-tablet-taskbar/releases
    5
    I can report that I am on a non-vndklite version of PE(plus)11 GSI (PixelExperience_Plus_arm64-ab-11.0-20211011-UNOFFICIAL.img.xz) (not that I understand what vndk is). And it seems to be working surpringly very well!!... except for the pen, of course! The pen is recognised as 'Xiaomi Smart Pen' as an input device according to DevCheck Pro app (and I got the same info on this app with stock MIUI). The buttons on the pen work as forward/backward keys... but still no input function on the touch screen. But other than that, the GSI has been working without a crash for about a couple of hours. The best of all I've tried so far! Surely, too good to be true...

    Some tweaks were necessary: as I said before, I installed 2 Magisk modules for stuttering audio (GSI Audio Stutter Fix - Mi NOTE 10 Lite (toco).zip) & totally broken bluetooth audio (Note9Taudio.zip):
    But the 2nd module might not be necessary if you follow the Phh Treble Settings the person on the 2nd link is suggesting.

    I used Migrate to copy all my apps. Some google apps (gmail, g-map, g-drive) weren't copied, so I had to install them manually.. and they're working fine. Other google apps (incl google play services & google play store) were installed fine and have been functioning well so far. I didn't install Magisk Gapps etc separately.

    In case you're starting out, I've tried the following GSIs in the last few days, but none of them worked (I came from MIUI CN 12.5.8 for Pad 5 Pro 5G):
    PixelExperience_Plus_arm64-ab-vndklite-11.0-20211011-UNOFFICIAL.img.xz
    PixelExperience_arm64-ab-vndklite-12.0-20211121-UNOFFICIAL.img.xz
    PixelExperience_arm64-ab-12.0-20211121-UNOFFICIAL.img.xz
    https://github.com/phhusson/treble_.../system-roar-arm64-ab-vndklite-vanilla.img.xz

    Oh someone mentioned the refresh rate. I can't find how to set it on Settings on PE11 GSI, so probably it's not changeable? I've tried Display Checker app, and it looks like mine is at 60Hz. I don't play games so it's acceptable for me. But if anyone knows how to change it to 120Hz, it would be good to know!

    I want to thank the OP who first brought this to our attention. I'd never tried GSIs (always spoilt with good custom or stock roms). Fingers crossed for my current GSI!
    4
    These settings were already enabled.
    I now disabled it and unpaired the headset, then reboot.
    Enabling the settings reboot,then pair the headset still no working Bluetooth audio.
    In the selection of the audio device if I select the headset it won't change to the headset and if I try to increase the volume of the headset it will always jump back to zero.
    Do not enable "Use alternate audio policy" in Qualcomm features (just make sure, that would create that bug)
    Misc features -> "Disable audio effects" and "Force-disable a2dp offload" and i would not enable the bluetooth workaround mediathek (works for me without that setting)
    4
    Please do a review about this Gsi in YouTube