• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RUU][Firmware][Stock Rooted ROM]Sprint HTC One M9 | 4.27.651.4 | Updated 4.13.17

Search This thread


Recognized Developer / Recognized Contributor
Jun 11, 2007
Here we have a collection of RUUs, firmware, untouched system backups, and stock rooted ROMs...

Latest RUU












*credit to @Rydah805 for the 1.32.651.17 RUU

Rename to 0PJAIMG.zip, copy to sd card, boot into download mode, it should scan card & prompt to install

***NOTE*** S-ON users can ONLY flash signed firmware!!!


4.27.651.4 Signed Firmware from OTA, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=457095661767155280

4.27.651.4 Modified Firmware from RUU, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=817550096634761570

4.27.651.4 Modified Firmware from RUU, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=745425885120723749

4.27.651.4 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=817550096634761569

Previous Firmware

3.41.651.41 Modified Firmware from RUU, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=385035244224405571

3.41.651.41 Modified Firmware from RUU, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=385035244224405569

3.41.651.41 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=385035244224405570

3.41.651.31 Modified Firmware from RUU, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=385035244224398913

3.41.651.31 Modified Firmware from RUU, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=529152257862681927

3.41.651.31 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=385035244224398912

3.41.651.21 Modified Firmware from RUU, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=529152257862669390

3.41.651.21 Modified Firmware from RUU, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=529152257862669389

3.41.651.21 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=529152257862669388

3.41.651.13 Signed Firmware from OTA for S-ON users(fastboot flashable): https://www.androidfilehost.com/?fid=24651430732238190

3.41.651.13 Modified Firmware from OTA, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=24651430732238219

3.41.651.13 Modified Firmware from OTA, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=24651430732238218

3.41.651.13 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=24686680535467780

3.41.651.4 Full Signed Firmware from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=24407100847294492

3.41.651.4 Modified Firmware from OTA, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=24407100847294493

3.41.651.4 Modified Firmware from OTA, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=24407100847294494

2.11.651.19 Full Firmware from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347811177

2.11.651.19 Modified Firmware from OTA, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347811176

2.11.651.19 Modified Firmware from OTA, removed recovery & boot (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347811175

2.11.651.19 Radio only from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347811174

2.6.651.11 Full Firmware from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347767489

2.6.651.11 Modified Firmware from OTA, removed recovery (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347770518

2.6.651.11 Modified Firmware from OTA, removed recovery & aboot (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347767490

2.6.651.11 Radio only from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=24052804347767491

1.32.651.30 Full Firmware from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=95916177934554030

1.32.651.30 Modified Firmware from OTA, removed recovery & aboot (fastboot flashable): https://www.androidfilehost.com/?fid=95916177934554191

1.32.651.30 Radio only from OTA (fastboot flashable): https://www.androidfilehost.com/?fid=95916177934554197

1.32.651.17 Full Firmware from RUU (fastboot flashable): https://www.androidfilehost.com/?fid=95916177934552130

1.32.651.17 Radio only from RUU (fastboot flashable):

*credit to @deakelem for the .17 radio zip, thx!

Flash Firmware via bootloader (requires micro sd card)....

-rename firmware to 0PJAIMG.zip
-copy 0PJAIMG.zip to ext_sd card
-boot into bootloader or download mode
-it will scan your ext_sd card, then ask if you want to start the update
-press volume up & let it do it's thing...

Flash Firmware via fastboot, no ext sd card needed...

-rename firmware to firmware.zip
-copy firmware.zip to your sdk folder
-boot into bootloader or download mode
-plug in usb
-select fastboot option (screen should say fastboot usb)
-type fastboot oem rebootRUU
-when u see the black screen w/ HTC, type fastboot flash zip firmware.zip
-when it's done, type fastboot reboot







Stock Rooted ROMs

Before flashing this Stock Rooted ROM or making any system change, make sure you have done a clean SYSTEM IMG BACKUP using TWRP or newer!!! See post# 2 for more information.

Stock Rooted 3.41.651.41 ROM


-SuperSu & BusyBox added

Previous Stock Rooted ROMs

XDA:DevDB Information
[RUU][Firmware][Stock Rooted ROM][Stock Backup]Sprint HTC One M9 | 1.32.651.17, ROM for the Sprint HTC One (M9)

OMJ, chas123, benny3
ROM OS Version: 7.x Nougat

Version Information
Status: Stable
Stable Release Date: 2015-04-05

Created 2015-04-05
Last Updated 2017-08-02


Recognized Developer / Recognized Contributor
Jun 11, 2007

here is a nice batch tool from @Sneakyghost I edited for Sprint...(Tasker_1.2.8.bat was edited, and stock Sprint recovery added).

original thread can be found from HERE, go give him a thanks!

Extract to folder & run Tasker_1.2.8.bat

DOWNLOAD Android_Tasker_1.2.8_Sprint_M9


The "Android_Tasker" Batch Tool - a thing i am using for myself since 2012 and which i am sharing just because i have it. It is neither good nor special, but its the way i work and people who follow the instructions here might find it easier to use the same setup as we do.
It also has the "FUU" method included - details on that method will be added at a later stage. We do not consider the FUU a good option to flash Firmware anymore because we realized that getting away from ADB and Fastboot with toolkits makes troubleshooting harder at a later stage - people relying entirely on toolkits and tools will mostly not understand what is happening and helping there is much harder.

Since everything i do basically works out of the C:\Android\com path, all my zipped-up stuff extracts to that location. The FUU and the Task-Batch-Script both work from that location. This is simply to enable easier and faster creation of new zip’s if they all use the same base structure.
If you prefer to work from a different location. you can specify a different path in the installer. However, the batch scripts do not adjust automatically, which means if you use another path, you might need to open up the scripts in an editor and adjust some paths manually.


MD5: 84A4968A9C698FA328A6C13DCB1D764F​

The installer is just a simple WinRAR self extracting archive - there is NOTHING BAD in there i swear! Open it with WinRAR 5 and look inside. You will see if you don't trust me.


  • 1.2.8
  • Splash1 converter works now. Flashing Splash1 now needs a reboot to Bootloader - it's not working in Download Mode! (limited DD support on the M9 and general flashing system changes).
  • Swapped out recoveries for newer versions.
  • Finally added the complete file set from RUU - the newest M9 RUU. ADB and Fastboot are identical to the previous version from Llabtoofer though.
  • Screenrecord removed - can’t be bothered figuring out why it doesn’t work anymore. Probably SELinux and general Android 5.x security like with the screenshot function. Not really needed either. There are other solutions.
  • Swapped out recoveries for newer versions.
  • Swapped out ADB and Fastboot for a newer pack (thanks @LlabTooFeR) - now this Tool is fully M9 compatible and even flashes large RUU.zips.
  • Changed everything to M9 files and methods. I HOPE I didn't oversee anything. Please test carefully!
  • Added stock_recovery_1.32.401.8.img
  • Added TWRP Recovery fixed version from Captain_Throwback SOURCE Post #2 Beta version
  • Added original HIMA Splash1 - S-OFF phones only!

Previous versions:
  • 1.2.5
  • Added TWRP Recovery from Captain_Throwback (All M8 devices)
  • Fixed Recovery Screenshot option (20)
  • Added newer RUU structure ( - from 4.16.1540.8 Dev Edition RUU)
  • Added Stock Recovery 4.16.401.10.img (WWE)
  • Changed the License and SFX texts again (Installer) - never happy with it.
  • Fixed some serious crap nobody reported. I just found out myself.
  • Added Stock Recovery 4.16.1540.8 (sorry still don't have the WWE recovery, but i guess they are identical)
  • Added TWRP from the M8 tree of Dees_Troy.
  • Added Stock Recovery3.28.401.7
  • Added Microsoft's vcredist_x86_2008_SP1.exe to the installer because the ARUWizard is build on the x86 Visual Studio 2008 runtime. This resolves the "side-by-side configuration" error.
  • Added 3.28.401.6 stock recovery and splash
  • Added newer RUU structure (doesn't do any difference though, just keeping it up to date)
  • Added TWRP (it still has slight issues with MTP which will be fixed soon but for now, this is good enough)
  • Changed a few lines in the script (minor, cosmetical stuff)
  • Updated the INFO PDF (option 24)

Known Issues:

  • Kernel Flashing needs fixing - can only work in fastboot now due to SELinux and related crap.
  • The partition Dumper is not correctly working, probably also due to SELinux.

Anyone used to like @squabbi's fully GUI based toolkit? He's picked it up on the M9 as well - maybe you like GUI better than commandline. Then head over here: http://forum.xda-developers.com/showpost.php?p=59949972&postcount=1
Last edited:


Recognized Developer / Recognized Contributor
Jun 11, 2007

*IMPORTANT INFO* taken from this thread!!!

Frequently Asked Questions (FAQ)
1. Why is this device different than my previous HTC device?
  • With the M9, HTC has moved to a block-based OTA system. This means that even mounting system as read-write (as TWRP typically does during startup checks) will nullify the device's ability to take an OTA. Any other changes to the system partition will also cause an OTA to fail (even if that check is removed from the OTA zip) due to "unexpected contents."
2. Which version of TWRP am I supposed to use?
  • Right now, the latest official version ( is the best version to use.
3. Why is there a "System" backup option and a "System Image" backup option now?
  • The "System" option is the standard tar backup. The "System Image" option is only relevant if your system is unmodified. This allows you to make a fully stock backup that can be restored later to take an OTA.
    • NOTE: If you are using a FAT32-formatted card, a "System Image" backup will fail, due to the 4GB file limit on that format. For a successful System Image backup, NTFS or exFAT-formatted storage must be used (either SD card or USB-OTG)
4. How am I supposed to root?
  • If you would only like to root via SuperSU, after making a stock backup, flash the BETA version of SuperSU posted here which properly mounts system, even when TWRP has it mounted read-only.
5. I tried to install x ROM, but it won't boot. Should I use TWRP to flash it?
  • No, you shouldn't. You should use the version of TWRP recommended above. If the ROM updater-script is done properly, even if your device has system mounted read-only, the ROM should still flash fine. If your ROM chef/team has chosen to mount the partitions some other way, then you may have to mount system manually in order for the ROM to flash successfully. This can be done in the Mount menu, by unchecking the "Mount system as read-only" box and then checking the box next to System to mount it. The very act of booting will change the system checksum, making it impossible to get a fully stock backup.
6. So what's the proper procedure to root without breaking OTA?
  • There is no way to take an OTA after you root. However, prior to rooting, you can take a fully untouched system image backup with TWRP, which can be used to restore a fully stock system to the device in order to take an OTA.
7. How do I backup stock recovery prior to flashing TWRP?
  • You can't. The "fastboot boot" command appears to be disabled on the M9's ABOOT, so TWRP must be fastboot flashed over stock recovery. The firmware zip included in the OTA will include a usable stock recovery image. That can be extracted and flashed after stock system is restored so that the OTA can be applied.
8. How do I restore stock system so that I can accept an OTA?
  • Check the "Mount system as read-only" box in the Mount menu.
  • Restore stock "System Image" backup (This will only work if you've made a System Image backup prior to making any modifications to /system). As of the official version, it is no longer necessary to fastboot flash the stock system image.
    • NOTE: If you made a stock system backup with one of the Beta TWRP versions, you will have to rename the backup file in the backup folder manually from "system.emmc.win" to "system_image.emmc.win" for the new official TWRP to see it as a "System Image" backup rather than a "System" backup. Otherwise, you'll get an error that the backup can't be restored because system is read-only.
  • Fastboot flash stock recovery (fastboot flash recovery recovery_signed.img)
    • NOTE: It is also possible to restore stock recovery via the TWRP GUI. Rename the stock recovery file to "recovery.emmc.win" and place in the backup folder with the stock system image. Recovery will then show as a restore option. MAKE SURE YOU REALLY WANT TO DO THIS, AS TWRP WILL BE GONE WHEN YOU REBOOT OUT OF RECOVERY!!
  • Reboot to system, install OTA.
9. What if I have an RUU? Do I need to worry about all this OTA nonsense?
  • Not if you don't care about losing all your data. If you're S-ON and have an RUU available for your exact variant (model ID and CID must match) and software number (main version must be the same or newer), then you can get back to a fully stock state by relocking (fastboot oem lock) and flashing an RUU. However, if you'd prefer to take an OTA to keep your data intact, the method stated above is how to do so. Or, you can just run a custom ROM and wait for your ROM chef to update their ROM to the latest software (though you'll still have to find a way to update your firmware if you're not S-OFF)
10. After I go through all this and successfully apply an OTA, how do I make sure I have a clean starting point again?
  • After the OTA is applied and TWRP is flashed, it will once again detect an untouched system, which will mount system read-only and allow you to make a fully stock backup and start the process over again, this time with the new base.
11. How do I get that new stock theme from the Screenshots tab?
12. What if I'm unlocked but unrooted and don't have access to a computer? How can I install TWRP?

Hima-Specific Peculiarities/Issues
  • IT IS NOT RECOMMENDED TO USE ANY VERSION OF TWRP PRIOR TO The previous version(s) mount system read-write and will break the system checksum on initialization, making it impossible to get a fully stock system backup.
  • As of TWRP, in order to preserve system intergrity to complete a fully stock system backup, system is mounted as read-only. Starting with the official TWRP, TWRP will detect whether system is unmodified and give you the option to leave it as read-only or mount it read-write. The box to select/deselect this option is in the "Mount" menu.
Current TWRP "bugs" for Hima
  • One cannot simply flash zips larger than 2GB (upstream bug)
  • Battery may read 66% when booting into recovery (plugging into USB appears to correct this issue)
  • Touch may occasionally stop working when using AROMA (may be related to device overheating)

Beta Versions
These versions will include fixes not currently merged into the official source. The new beta naming convention with always start with the official base, followed by author (in this case, me) and beta version. This should help to eliminate some of the version number confusion of previous betas.

Beta Changelog:
[SIZE="2"]Includes all official & [URL="http://forum.xda-developers.com/one-m9/orig-development/recovery-twrp-touch-recovery-t3066720/post61580654"] test build[/URL] patches, and the following additional patch(es):[/SIZE]
[*][URL=https://gerrit.omnirom.org/12728][WIP] gui: stock theme rework[/URL]
[*][URL=https://gerrit.omnirom.org/14003]Update CUSTOM_LUN_FILE from AOSP USB config[/URL]
[*][URL=https://gerrit.omnirom.org/14002]Update path for libcryptfs_hw to proper variable[/URL]
[*][URL=https://gerrit.omnirom.org/14009]Properly set sys.usb.config when ums is enabled.[/URL]
[*][URL=https://gerrit.omnirom.org/13971]Add seclabel to recovery service[/URL]
[*][URL=https://gerrit.omnirom.org/11756]Allow devices to override USB init[/URL][/LIST]

Older Beta versions (current official version is newer):
[SIZE="1"]Includes all CPTB-B1 patches, and the following additional patch(es):[/SIZE]
[*][URL="https://gerrit.omnirom.org/13818"]Fix ORS scripts displaying an error after completing[/URL][/LIST]

[SIZE="1"]Includes the following patches not yet merged to the official:[/SIZE]
[*][URL=https://gerrit.omnirom.org/12728][WIP] gui: stock theme rework[/URL]
[*][URL="https://gerrit.omnirom.org/13746"]minuitwrp: fix crash when taking a screenshot.[/URL]
[*][URL="https://gerrit.omnirom.org/13747"]partition: recreate tw_internal_path(/data/media/0), after wipe media from data or format /data.[/URL]
[*][URL="https://gerrit.omnirom.org/13793"]Fix system read only behavior during boot[/URL][/LIST]

Device specific page on our website

Download link to current and past versions
Last edited:


Recognized Developer / Recognized Contributor
Jun 11, 2007
For some strange reason my dialer does not work i cannot receive calls nor make them

same here with the dialer

I'll have to test it when I get the chance...not sure why it wouldn't work, as it's stock from dump

Do changes to the /system partition persist a reboot with this or do we need to wait for S-OFF for that?

not sure, I'll have to test this too, may need to wait for s-off


Senior Member
Feb 26, 2008
I have the same issue too. However I did not have this issue with the stock unrooted version. I had to go back to my backup to get the phone working again.

Top Liked Posts