s pen not writing and working on screen properly (please help me if you can)

Search This thread

omidr7

Senior Member
Dec 11, 2013
79
57
Amol
I just bought a galaxy note 9 for about 3 days. it came with android pie preinstalled, from day one I had one very annoying problem with my s pen. Whenever I insert my s pen into the phone for more than 2 hours or so, after removing the s pen for writing, the s pen doesn’t write and work on screen for about 1 to 4 minutes and the screen doesn’t recognize the s pen but after that everything goes back to normal.
I should mention that I tried rebooting the phone, clearing the cache partition, factory resetting the phone and resetting the s pen remote and also I turn off the s pen remote function but none of these method worked for me. (I should point out that the s pen remote function works fine) I kept s pen out of the phone for about 12 hours and then test the s pen on screen and it was perfectly working fine and I also tried with my note 4’s s pen on note 9 screen and the writing was without a problem. I feel that my note 4 s pen is way better than the note 9 s pen and also the pressure sensitivity of note 4 s pen on note9 screen is better for example I had to press very hard on screen with note 9 s pen to get the same line thickness that I can create with note 4 s pen with much less pressure.
In short whenever I keep my s pen in the phone for more than two hours the s pen doesn’t write on screen and completely hangs for 1 to 4 minutes and then works normal.
Please somebody help me because my phone doesn’t have a warranty and I don’t want to stuck with this problem after coming from legendary note 4.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Sounds like a hardware problem to me. The spen slot sounds faulty. You need to borrow another note 9 spen to test.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone